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Priming the Pump—Stage II
Modeling and mapping concentration with fire response networks

By Mike Price, Entrada/San Juan, Inc. 

The article “Priming the Pump—Preparing 
data for concentration modeling with ArcGIS 
Network Analyst 9.2” published in the July–
September 2007 issue of ArcUser magazine 
showed how the ArcGIS Network Analyst 
9.2 extension was used to create four- and 
eight-minute travel areas for seven existing 
and three proposed fire stations in Fire Dis-
trict (FD) 37 that were located in and near the 
city of Kent in southern King County in Wash-
ington state. In the last section of this tutorial, 
10 eight-minute polygon footprints were cre-
ated for all stations. 
 This exercise picks up where the last exer-
cise left off and shows how to build grids of 
each station’s footprint that will be used to as-
sess the concentration and effective response 
force (ERF) for the seven existing stations. 
After reviewing capabilities of the existing 
stations, the next step will be to add the three 
proposed stations. 
 Although readers who completed the first 
half of this exercise could continue to use those 
datasets, it is better to use the data prepared 
for this exercise. This new data will also be 
used in upcoming national training sponsored 
by ESRI and the National Alliance for Public 
Safety GIS. To review modeling networks 
with the ArcGIS Network Analyst extension 
and distribution and concentration metrics, re-
fer to the previous article.

Getting Starting
Download the sample dataset from the ArcUser 
Online Web site (www.esri.com/arcuser). Un-
zip the archive at or near the root directory of 
a local drive to create a folder called FD37_3. 
Explore the date in ArcCatalog and notice that 
there are still three subfolders named GRD-
Files, Models, and SHPFiles. The GRDFiles 
and SHPFiles folders each contain a subfolder 
called WASP83NF. SHPFiles contains many 
shapefiles and layer files while GRDFiles con-
tains only one clipping grid.
 The Models folder contains new scripted 
models that will be used to prepare data and 
calculate and map concentration. The FD 37 
8 Minute Grids model and two toolbox sub-
sets contain models that build concentration 
and ERF for existing stations and two of the 
proposed sites. These Standard of Response 
Coverage (SOC) tools will be loaded into an 
ArcMap document.
 For those who completed the first exer-

Open the FD37_SOC3.mxd file from the 
sample dataset and make sure the ArcGIS 
Spatial Analyst extension is available and its 
toolbar is visible. 

Before loading SOC custom tools, change 
the document properties so geoprocessing 
operation outputs will be overwritten and 
added to the display. 

cise, the shapefiles and layer files in SHPFiles\
WASP83NF will look familiar. Carefully 
study the 10 station footprint polygons. Each 
polygon name begins with the letter “S.” In 
the previous exercise, the fire station attributes 
were joined to the 8 Minute Network Analyst 
polygons and exported to preserve the join and 
named S_71_8 through S_WA_8. These travel 
footprints will be used to model the effective 
eight-minute coverage for all existing and pro-
posed stations. It is important to retain these 
shapefile names because they will be called by 
procedures in the SOC models.

Modeling in ArcMap
Start an ArcMap session and verify that the 
ArcGIS Spatial Analyst extension is avail-
able. Navigate to the FD37_3 folder and load 
FD37_SOC3.xmd. Switch to Layout View and 
inspect the map. The FD 37 model includes 
seven existing stations (71–77) and three pro-
posed stations (78; 79; and 407 Washington, 
WA). Make the layers for Squads, Chief Of-
ficers, Ladders, Engines, and Personnel vis-
ible. View the stacked symbology and col-
ored labels indicating the available apparatus 

and staff for stations existing and proposed. 
Table 1 summarizes this information.
 Compare the information in the table with 
the Fire Stations attribute table. Fields E_01, 
E_02, L_01, BC01, and S_01 list the available 
apparatus at each station. The STAFF_T field 
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Station Status Engine Ladder BC Squad Total Staff SOC Code

71 Existing E 71 S 71 5 1

72 Existing E 72 3 1

73 Existing E 73 S 73 4 1

74 Existing L 74 BC 1 S 74 6 110

75 Existing E 75 3 1

76 Existing E 76 3 1

77 Existing E 77 3 1

78 Proposed E 78 3 1

79 Proposed E 79 3 1

WA Proposed E 70 BC 2 S 70 6 101

What You Will Need
•  ArcGIS Desktop 9.2
•  ArcGIS Spatial Analyst 9.2
•  Sample dataset downloaded from
     www.esri.com/arcuser
•  A zipping utility such as WinZip

Table 1: Apparatus and personnel assignments for existing and proposed stations

Set the Current Workspace and Scratch 
Workspace in the Environment Settings 
dialog box.

On the Raster tab of the Environment Settings 
dialog box, set the Cell Size to Same as Layer 
Clipping Grid. 

Continued on page 48

lists each station’s available response person-
nel that will be used to calculate ERF. Look at 
the table’s SOC Code column, which contains 
a three-digit numeric code that represents ap-
paratus availability. In this code, “1” represents 
available engines, “10” indicates ladders, and 
the “100” counts the battalion chiefs. This nu-
meric coding is a key to this model. Maximize 
the mapping area by switching back to Data 
View.

Preparing the Modeling Environment
Before loading the custom SOC tools, make 
sure the ArcMap document will use relative 
data paths when searching for and storing 
data. ModelBuilder will streamline the work-
flow but it requires a specific environment and 
particular operating rules. The next steps are 
very important so follow them carefully.
1. Choose File > Document Properties and 
click the Data Source Options button. In the 
next dialog box, click the radio button next to 
Store relative path names to data sources. 
2. Next, tell ModelBuilder to overwrite the 
products of earlier calculations—because 
building and testing the model will most likely 
require several iterations—by clicking Tools 
in the ArcMap menu and selecting Options.
3. Locate the Geoprocessing tab and inspect 
its contents. In the General area, place a check 
in the Overwrite the outputs of geoprocessing 
options box. (Note: It may be necessary to dis-
able file overwriting later.)
4. In the Display/Temporary Data area, check 
Add the results of geoprocessing options to 

the display. Uncheck the box next to Results 
are temporary by default.
5. Open ArcToolbox by clicking the 
ArcToolbox icon and place it immediately to 
the right of the Table of Contents.
6. Access the model’s Environment by right-
clicking in an empty area of ArcToolbox and 
clicking Environments. Open the General 
Settings drop-down, click on the button with 
the folder icon, and change the Current Work-
space and Scratch Workspace by browsing to 
..\FD37_3\GRDFiles\WASP83NF.
7. Scroll further in the Environment dialog 
box and use the Extent drop-down to set the 
analysis extent to Same as Layer Clipping 
Grid. Minimize the Environment Settings.
8. Click on Raster Analysis Settings and set 
Cell Size to Same as Layer Clipping Grid. No-
tice that our model cells will be 50 feet, the 
approximate width of a four-lane city street. 
Click OK to apply changes.

Loading and Inspecting
a Custom SOC Toolbox
Now load a custom toolbox that contains utili-
ties to process the 10 station travel polygons 
and calculate concentration and ERF.
1. Right-click on the ArcToolbox header and 
select Add Toolbox and navigate to\FD37_3\
Models and load SOC Tools. Open all tools in 
the SOC Tools and study their names.
2. Float the cursor over the tool names to re-
veal the entire name. SOC Tools contains one 
model named FD 37 8 Minute Grids that will 
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Load the SOC Tools toolbox, which contains two toolsets: Concentration Grids and Effective 
Response Force Grids. 

Priming the Pump—Stage II
Continued from page 47

be run first to process the travel areas.
3. Two toolsets, Concentration Grids and Ef-
fective Response Force Grids, each contain 
three models to assess existing stations and 
two proposed scenarios.
4. Right-click the FD 37 8 Minute Grids tool-
set and select Edit (not Open) from the con-
text menu. Use View > Zoom > Full Extent 
to display the entire model. Count the execut-
able lines. This model processes 10 travel area 
polygons by first converting them to single 
stacked grids and then reclassifying them. 
Once reclassified, these grids will display a 
value of 1 for all cells traversed within eight 
minutes and 0 for cells not reached in eight  
minutes.
5. Double-click on Polygon to Raster 10 and 
inspect the inputs and outputs for this opera-
tion. This step converts the Washington Sta-
tion’s travel area to a grid with the polygon’s 
FID (Feature ID) value in all traversed cells, 
while setting all untraveled cells to Null. 
Check Output Raster Dataset to verify that the 
intermediate grid is stored in ..\FD37_3\GRD-
Files\WASP83NF as a permanent grid named 
Temp1_WA_8. Click Cancel to close.
6. Double-click and inspect Reclassify 10. 
This step reclassifies the Temp1 grid, assign-
ing a value of 1 to all FID values of 0 through 
99. It reassigns all 0 to all NoData cells and 
saves the reclassified grid as rc_wa_8.
7. Click Cancel to close again and save the 
project.
 This model creates 10 individual grids, us-
ing names and locations that may be edited by 
a user. When modeling SOC for fire agencies, 
these outputs can be expanded, contracted, and 
renamed to accommodate actual station counts 
and names. 

Building Individual 8 Minute Travel Grids
The next operation is the most tedious one in 
this model, but it is easy with ModelBuilder. If 
ModelBuilder was not used, each grid would 
have to be created individually. For a large city 
or a county, this could mean converting and 
reclassifying as many as 50 footprints.
1. With FD 37 8 Minute Grids model open, 
choose Model > Run Entire Model from the 
menu. 
2. Watch as 20 separate processes run and 
the 10 reclassified grids appear in the Table 
of Contents (TOC). Depending on processing 
and disk access speed, it can take up to five 
minutes to run. 
3. When the model finishes running, close it. 
It is not necessary to save any changes to the 
FD 37 8 Minute Grids model.
4. Individually inspect each reclassified grid. 
Do they look reasonable (i.e., do they contain 

Right-click on the FD 37 8 Minute Grids in the 
Concentration Grids toolset and select Edit. 

only 0 and 1 values)? 
5. Shift-click to select all grids and group 
them into a single TOC object. Name it 8 Min-
ute Travel Grid Group. Contract legends for 
individual grids and make the master group 
not visible. If necessary, move the group to the 
bottom of the TOC, just above the Clipping 
Polygon.
6. Save the project.

Defining and Modeling
Full Concentration
With individual travel footprints in the TOC, 
the next step is calculating concentration and 
ERF. 
1. In the Concentration Grids toolset, right-
click FD 37 Concentration, Existing Stations 
and select Edit.
2. Double-click the Single Output process to 
open the Single Output Map Algebra dialog 
box. Study the simple calculation and notice 
how it multiplies all existing station grids by 
the appropriate battlion chief (BC), ladder, and 
engine SOC Code listed in Table 1. All Map 
Algebra expressions are stored in a text docu-
ment as ..\FD37_3\Models\Scenarios1.txt. 
Most existing stations contain one engine with 
an SOC Code of 1. Station 74 includes a BC 
and a ladder; its Code is 110. All factored grids 
are summed, and the resulting grid is stored as 
CONC_E. Cancel back to the model and run 
it. Close the model when finished and save 
again.

3. Close the Single Output Map Algebra dia-
log box and run the model.
4. Inspect the resulting grid. Existing station 
values range from 0 to 114. A Full Concen-
tration requires that one chief officer, one lad-
der, and three engines all be on scene in less 
than eight minutes from time of departure. 
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Double-click on the Single Output process to 
open the Single Output Map Algebra dialog 
box to inspect the calculation it performs.

Apply the Full Concentration Layer file to symbolize the output of the FD 37 8 Minute Grids 
tool.

Run the tools for the two additional scenarios and apply the Full Concentration Layer file to the 
resulting grids.

Therefore, the lowest model code for Full Con-
centration is 113. All lower values fall short of 
the required force. Rather than creating a new 
legend for this grid, apply the standard legend 
from the Concentration.lyr file included in the 
sample dataset. 
5. Load the Concentration symbology 
by right-clicking on conc_e and opening 
Properties.
6. Click the Symbology tab and change the 
Show: type from Unique Values to Classified 
(this is very important). 
7. Click Import, browse to ..\FD37_3\
GRDFiles\LYRFiles, and select Full Concen-
tration.LYR. 
8. In the General tab, rename this grid to Con-
centration, Existing Stations. 
 This legend is customized for Fire District 
37. Notice that the legend accommodates up to 
two BCs and maps areas accessed by three to 
five or more engines. Since the model does not 
include a second ladder, only one is mapped. 
Green colors show that full concentration is 
now achieved in much of the Kent City area, 
but there are some gaps. Save the project.
 Repeat the process for proposed stations. 
Run FD 37 Concentration; Existing with 78, 
79 model; apply the Full Concentration.lyr file 
to the output; and rename the FD 37 Concen-
tration, Existing with 78, 79. Follow the same 
steps with the Concentration, Existing with 78, 
79, WA model. Arrange the grids in a group of 
three with 78, 79, WA and Existing on the bot-
tom. 
1. Select all three new grid layers by clicking 
and holding down the Control key. 
2. Right-click on any layer and choose Group 
from the context menu to create a Group 
Layer.
3. Name the Group Layer Concentration Grid 
Group. Save again.
 Station 78 brings one engine and three staff 
on line; Station 79 adds another engine and 
three staff members. The WA Station, added in 

the second proposal, includes an engine, a bat-
talion chief, and six staff. Do you agree with 
the improvements? What is the effect of add-
ing a second BC at the WA Station? Now let’s 
count the Response Force. Minimize and turn 
off all groups.

Mapping Effective Response Force
Now it is time to run the models for ERF. Re-
turn to the SOC Tools and expand the Effec-
tive Response Force Grids toolset.

Continued on page 50
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After running the ERF tools and symbolizing the outputs, switch to Layout view.

Priming the Pump—Stage II
Continued from page 49

1. Click Edit (not Open) for the FD 37 ERF, 
Existing Stations model. 
2. Double-click on Single Output and notice 
that this Map Algebra expression multiplies 
each station grid by the number of available 
firefighters before adding them together. The 
resulting grid is named EFF_E. 
3. Close the Map Algebra dialog box, run the 
model, and inspect the results. The output grid 
shows that as many as 21 firefighters may be 
available in various model areas. 
4. In the TOC, rename this layer ERF, Exist-
ing Stations and import symbology from Ef-
fective Response Force.lyr. Notice that the 
graduated color scheme, transitioning from 
red to green, accommodates up to 30 firefight-
ers. Save the document. 
5. Run the Existing Stations, 78 and 79, and 
Existing Stations, 78, 79, and WA and apply 
the Layer file to each. 
6. Create a layer group of all three grids and 
name it ERF Grid Group. 
7. Save the project and switch to Layout 
View.

Summary 
Now pretend that you must make a presenta-
tion to the district that demonstrates and jus-
tifies the addition of two, and possibly three, 
stations. This exercise created eight-minute 
travel grids for 10 existing and proposed sta-
tions and modeled concentration for one exist-
ing station and two proposed ones. ERF was 
also modeled for all scenarios.
 This training dataset is adapted from ac-
tual Fire District 37 data. It has been modified 
slightly for training use. Fire District 37 has 
actually modeled nearly 20 different deploy-
ment and personnel scenarios using these sta-
tions and others, too. At FD 37, fire preven-
tion professionals experiment with different 
apparatus and staffing scenarios, weighting 
them against changing values at risk, cost, and 
deployment timetables. The staff also experi-
ments with different travel times to achieve 
optimum concentration effect. 
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