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1.0 Introduction 

Arc Hydro consists of a data model, toolset, and workflows developed over the years to support 
specific geographic information system (GIS) implementations in water resources. The initial 
implementation of Arc Hydro was in 2002 with the data model, Arc Hydro book published by 
Esri Press, and a set of about 30 tools. Since then, Arc Hydro has been used in many projects, 
and in the process, new tools and workflows have been developed. There are more than 300 Arc 
Hydro tools now, and they continue to be expanded based on work in specific implementations. 
The bulk of the Arc Hydro tools are developed within the ArcMap environment.  

Arc Hydro tools are being transitioned to the ArcGIS Pro platform, and some of the tools are 
now fully operational in ArcGIS Pro.  

The document Arc Hydro: Project Development Best Practices captures what works well 
when implementing Arc Hydro projects. You must read it before continuing with this 
document. 

ArcGIS Pro has a default way in which it organizes data and project folders. This structure can 
be leveraged to support Arc Hydro (AH) best practices for data and folder organization (section 
4.2 in the Arc Hydro: Project Development Best Practices document). Remember that one of the 
key elements of a successful Arc Hydro implementation is the use of data (both raster and 
vector) in a consistent and appropriate spatial reference and organizing it in the same project 
database. 

This document describes different alternatives for Arc Hydro Pro new project startup through a 
series of examples. Note that these are not the only ways to do it, so feel free to experiment and 
come up with the approach that works best for you. 

1.1 Document History 

Table 1. Document Revision History 

Version Description Date 

1 First Version 8/2019 
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2.0 Arc Hydro Pro Project Startup Alternatives  

This document describes different alternatives for Arc Hydro Pro new project startup. To 
demonstrate the alternatives, several projects will be initiated and the results will be examined. 
The folder C:\CurrWork\ArcHydro\Tests\ProStartup is used for presenting the startup 
alternatives. 

2.1 Starting the Project With no Initial Data 

This is the alternative in which no initial data for Arc Hydro processing have been organized yet. 

1. Start ArcGIS Pro and click on the New Map template. 

2. Specify the name of the new project and the folder in which to create it. Check the box to 
create a new folder for this project. The specified project name should follow Arc Hydro 
rules for project naming (short, no spaces, no special characters, etc.). In this case, we are 
naming the project BaseAHProject and using C:\CurrWork\ArcHydro\Tests\ProStartup 
as the parent folder. 

 

3. Click OK to generate the project. 
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The following standard ArcGIS Pro project structure is created: 

 

This is very similar to the regular Arc Hydro recommended structure. Note that while the project 
geodatabase has been created, it does not have a feature dataset with a particular spatial reference 
defined. The next steps should be performed to make the initial ArcGIS Pro structure consistent 
with the recommended AH project structure. 

4. Create the folder Layers within the ArcGIS Pro project folder 
(C:\CurrWork\ArcHydro\Tests\ProStartup\BaseAHProject\Layers). This folder is to be 
used to store all raster data (if any) for the project. 

5. Create a feature dataset called Layers in the project geodatabase 
(BaseAHProject.gdb\Layers). Make sure you specify the proper spatial reference when 
creating the feature dataset—it needs to match the spatial reference of any rasters that 
will be used in the analyses. 

6. Copy any raster and/or vector data into the Layers folder/feature dataset. Make sure you 
apply the proper spatial reference transformation if needed (vector data will be 
automatically transformed as they are copied/imported into the feature dataset, but you 
have to pay special attention to the raster data). 

• In this example, a raster, filsmc, is copied into the Layers folder and then the 
HydroEdge feature class is imported into the Layers feature dataset. 
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The final Catalog structure after these steps should look like the recommended Arc Hydro 10.x 
project structure: 

 

Note that the default ArcGIS Pro project startup will also create an empty toolbox that can be 
used for any locally developed (project-specific) tools. 

2.2 Starting the Project with Arc Hydro doing some configuration 

Some Arc Hydro tools generate required data structures (e.g., a geodatabase) if there is not one 
already present. This use case presents a workflow that you can follow when you know that AH 
tools will create the necessary geodatabase data structures. The example here uses AH terrain 
processing steps. The tools that generate vector data from the rasters will use an existing target 
geodatabase or—if one does not exist already—create one. 

The starting point for this scenario is an existing folder structure with the raster data that will be 
used in the AH tools that will generate the required vector data structures (so the initial raster 
data exists but the vector data do not). The existing folder found at 
C:\CurrWork\ArcHydro\Tests\ProStartup\StarterAHProject has a subfolder, Layers, with rasters 
inside to be used in the analyses. A Catalog view looks like: 

 

Once this structure is in place, perform the following steps: 

1. Start ArcGIS Pro and select new Map template. 

2. Specify the name of the new project and the folder in which to create it. Keep the Create 
a new folder for this project check box unchecked. The specified project name should 
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match the name of the folder in which the project will be saved. In this case, we are 
naming the project StarterAHProject and placing it into the 
C:\CurrWork\ArcHydro\Tests\ProStartup\StarterAHProject folder. 

 

3. Click OK to generate the project. 

 

The following standard ArcGIS Pro project structure is created: 

 

Note that while the project geodatabase is created, it does not have a feature dataset with a 
particular spatial reference defined. Perform the next steps to make the initial ArcGIS Pro 
structure consistent with the recommended AH project structure: 

4. Add to the map the layers that will be used for processing. In this case, we will add the 
raster cat40k from the Layers folder (which is now conveniently in the Folders project 
structure in ArcGIS Pro). 

5. Open the Arc Hydro tool that generates an output feature class—in this example, the 
Catchment Polygon Processing tool. 

• Once the user interface for the tool opens and you select the input layer(s), the 
default output will be populated. Inspect the location of the output layer. In this 
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case, the output will be pointing to an existing geodatabase, but a feature dataset 
that does not (that is OK). 

 

6. Run the tool. 

7. Inspect the geodatabase. 

• The Feature dataset was created, and the tool's output feature class was stored in 
it. 

• The spatial reference of the feature dataset matches the spatial reference of the 
input raster used in the function. 

The final Catalog structure after these steps should look like the recommended Arc Hydro 10.x 
project structure: 
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2.3 Leveraging an Existing Arc Hydro Dataset 

Often, already processed AH data will be available as a starting point for an ArcGIS Pro project 
(especially as you transition from the Arc Hydro 10.x platform to ArcGIS Pro). This use case 
examines a situation in which data are available but an ArcMap project is not. A typical AH data 
structure might look like the one below. In this example, the AHFullData folder contains the 
Layers folder with all the rasters and the AHFullData.gdb file with vector and tabular AH data. 

 

When creating a new ArcGIS Pro project, there are several elements that get created (default 
folder, geodatabase, and toolbox). By default, they have the same name as the ArcGIS Pro 
project name. We want to create an ArcGIS Pro project with the same name as an existing 
geodatabase, but this will cause a conflict, so we have to apply a workaround. Two approaches 
are presented: 

1. Renaming the existing geodatabase 

2. Repointing the defaults 

 

2.3.1 Renaming the Existing Geodatabase 

To mobilize this data structure in ArcGIS Pro, use the following procedure: 

1. Before starting ArcGIS Pro, open the target project folder in file manager (e.g., 
"C:\CurrWork\ArcHydro\Tests\ProStartup\AHFullData") and rename the existing 
geodatabase to something else (e.g., change AHFullData.gdb to AHFullData111.gdb). 

2. Start ArcGIS Pro and select new Map template. 
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3. Specify the name of the new project and the folder in which to create it. Keep the Create 
a new folder for this project check box unchecked. The specified project name should 
match the name of the folder in which the project will be saved. In this case, we are 
naming the project AHFullData and placing it into 
C:\CurrWork\ArcHydro\Tests\ProStartup\AHFullData folder. 

 

4. Click OK to generate the project. 

5. Close the ArcGIS Pro project. 

6. Open the file manager and inspect the project folder. Several new folders and files 
appear. 

a. Delete the newly created project geodatabase (e.g., AHFullData.gdb). 

b. Give the old geodatabase its original name (e.g., change the name 
AHFullData111.gdb back to AHFullData.gdb). 

7. Open ArcGIS Pro and the project you just saved. Inspect the data structure. Everything 
should be pointing to the right sources. 
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2.3.2 Repointing the Defaults 

This approach is a bit more in keeping with ArcGIS Pro and does not require renaming the 
geodatabase at the file manager level, but it involves more steps. 

1. Start ArcGIS Pro and select new Map template. 

2. Specify the name of the new project and the folder in which to create it. Keep the Create 
a new folder for this project check box unchecked. Note that the specified project name 
can be anything except for the name of the folder in which the project will be saved. In 
this case, we are naming the project MyProject and placing it into the folder at 
C:\CurrWork\ArcHydro\Tests\ProStartup\AHFullDataA2. 
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3. Click on "Project → Save As" (main ArcGIS Pro tab). 

4. Specify the name of the new project and the folder in which to create it. This time the 
specified project name should match the name of the folder in which the project will be 
saved. In this case, we are naming the project AHFullDataA2 and placing it into the 
folder at C:\CurrWork\ArcHydro\Tests\ProStartup\ AHFullDataA2. 

 

5. Copy the default toolbox, change its name to match the name of the project, and put it 
into the project folder (e.g., copy MyProject.tbx and then rename as AHFullDataA2.tbx). 

6. Add that toolbox to the ArcGIS Pro project Toolboxes. 

7. The ArcGIS Pro catalog should look like this: 
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8. Click on Project → Options → Current Settings (on the main ArcGIS Pro tab). 

9. Repoint the Default geodatabase and the Default toolbox to the appropriate entities (e.g., 
AHFullDataA2.gdb and AHFullDataA2.tbx). The form should look like this: 
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10. Click OK to apply changes, then click Save to save the project. 

11. Use the catalog view to inspect changes. 

12. Delete all references to MyProject (aprx, tbx, or gdb) 

 

2.4 Leveraging an Existing Arc Hydro Dataset and 10.x Project 

Often, as you transition from the Arc Hydro 10.x platform to ArcGIS Pro, already-processed AH 
data and the 10.x ArcMap project (mxd) will be available as a starting point. A typical AH data 
structure might look like the one below. In the example, the AHFullProject folder contains the 
Layers folder with all the rasters, the AHFullProject.gdb folder with vector and tabular AH data, 
and the AHFullProject.mxd ArcMap project. 
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1. Start ArcGIS Pro and select new Map template. 

2. Specify the name of the new project and the folder in which to create it. Keep the Create 
a new folder for this project check box unchecked. Note that the specified project name 
can be anything except the name of the folder in which the project will be saved. In this 
case, we are naming the project MyProject and placing it into the folder at 
C:\CurrWork\ArcHydro\Tests\ProStartup\AHFullProject. 

 

3. Click on "Insert → Import Map" (main ArcGIS Pro tab). 

4. Navigate to the existing ArcMap .mxd file you need to import (in this case 
C:\CurrWork\ArcHydro\Tests\ProStartup\AHFullProject\AHFullProject.mxd) and click 
OK. 
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5. Click Project → Save As (from the main ArcGIS Pro tab). 

6. Specify the name of the new project and the folder in which to create it. The specified 
project name should match the name of the folder in which the project will be saved. In 
this case, we are naming the project AHFullProject and placing it into the folder at 
C:\CurrWork\ArcHydro\Tests\ProStartup\ AHFullProject. 

 

7. Copy the default toolbox, change its name to match the name of the project, and put it 
into the project folder (e.g., copy MyProject.tbx and then rename as AHFullProject.tbx). 

8. Add that toolbox to the ArcGIS Pro project Toolboxes. 

9. The ArcGIS Pro catalog should look like this: 
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10. Click Project → Options → Current Settings (from the main ArcGIS Pro tab). 

11. Repoint the Default geodatabase and Default toolbox to the appropriate entities (e.g., 
AHFullProject.gdb and AHFullProject.tbx). The form should look like this: 
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12. Click OK to apply changes and click Save to save the project. 

13. Use the catalog view to inspect changes. 

14. Delete all references to MyProject (e.g., .tbx, .gdb, and .aprx files—these might have to 
be deleted from the file manager). 
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