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Lesson 6:
DEM-Based Terrain Modeling

Lesson Goal:  Lean how to output a grid 
theme that can be used to generate a 
thematic two-dimensional map, compute an 
attractive hillshaded map, and create a con-
tour line theme and TIN, and produce a 3D 
scene.

What You Will Need:  A Pentium class PC with 
64 MB of RAM (minimum) and 100 MB of free 
hard drive space, ArcView GIS 3.1 or higher, the 
ArcView 3D Analyst and ArcView Spatial Analyst 
extensions, WinZip, and an Internet connection. 

Data and/or Utilities:  No utilites required. 
This lesson uses a conversion utility and sample 
extension that come with ArcView GIS. Get 
sample data from the Cornell University’s Geo-
spatial Information Repository.

This article describes how to use sample 
1:24,000-scale 7.5’ digital elevation model (DEM) data 
files to perform two-dimensional and three-dimen-
sional modeling in ArcView GIS with the ArcView Spa-
tial Analyst and ArcView 3D Analyst extensions. 

USGS 7.5’ DEM, a raster data set containing ele-
vation information, has 10 x 10 meter data spacing. 
After converting the data, it can be easily imported into 
ArcView GIS. Terrain models constructed from eleva-
tion data can be used for a variety of purposes includ-
ing line-of-sight forecasting, slope and aspect determi-
nation, surface runoff pattern analysis, and drainage 
basin delineation.

DEM data at this scale is particularly useful 
because each data set provides the same large-scale 
coverage as a standard USGS 1:24,000-scale quad 
map. Details regarding available coverages and pro-
cedures for ordering DEM data sets can be obtained 
at the USGS Web site. This project uses a DEM file 
downloaded from a source that provides converted 
7.5’ DEM coverages of New York State at no cost. 

Downloading and Converting DEM Data
Locating and downloading the sample data set is the 
first step in this project. 
1.  Create a new folder named DEMWORK to hold 

downloaded data files. 
2.  Visit ArcUser Online for links to Cornell University’s 

Geospatial Information Repository (CUGIR). Visi-
tors to this site can select a 7.5’ quad to download 
by graphically choosing it from a clickable map of 
New York State. 

3. Use the map’s reference grid to locate and click 
on quad S 29 (Homer), the northwest quad in 
Cortland County. This brings up a page showing 
the zipped USGS DEM files for this quad. Select 
and download 29elu.Z and S29hya.e00.Z to the 
DEMWORK folder. 29elu.Z is a UNIX-compressed 
USGS ASCII file that is 2,443 KB. S29hya.e00.Z is 
the hydrography file associated with this quad. 

4. After closing the browser, go to My Computer and 
open the DEMWORK folder. This folder should 
now contain both downloaded files. Because 
29elu.Z is a UNIX-compressed file, use the WinZip 
decompression utility with the Classic option to 

Select data for this project from the CUGIR 
site’s clickable map.
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extract the file. The decompressed file should be 9,225 KB. 
Rename it HOMER.dem.

5. Unzip s29hya.e00.Z, the hydrography coverage, and rename it 
s29hya.e00. Use the IMPORT71 utility that comes with ArcView 
GIS to format the file so it can be used. IMPORT71 is a stand-
alone program that converts an ARC/INFO interchange file cre-
ated on any other operating system into an ARC/INFO Version 
7.x coverage or grid. IMPORT71 appears as a program item 
in the ArcView GIS program group. If it is not in the program 
group, it should be found with the ArcView GIS programs in 
the bin32 subdirectory. To run IMPORT71, double click the 
IMPORT71 program item in the ArcView GIS program group to 
display the dialog box.

Create a Thematic Map in Two Dimensions
The downloaded and prepared data can now be used for two-
dimensional modeling.
1. Start ArcView GIS, load ArcView Spatial Analyst, create a new 

project, and open a view. 
2. Choose Import Data Source from the File menu. If Import Data 

Source is not available from the File menu, load the ArcView 
Spatial Analyst extension. Select USGS DEM as the file type 
and click on OK. 

3. HOMER.dem should appear in the list of Import USGS DEM 
files. Select it and click on OK. 

4. The Output Grid box appears with the default grid name 
imgrd1 (if this is the first output grid generated in this session). 
Rename the output grid HOMERS29. Allow the file to be placed 
in the Temp directory and click OK. Be patient while ArcView 
GIS calculates the new grid. 

5. When the Import Data Source HOMERS29 box appears, click 
Yes to add the new theme to the view. Now save the project 
with the name HOMERDEM by choosing File, then Save Proj-
ect As. 
Maximize the view and make the HOMERS29 theme active 

and visible. Use the Open Theme Table button to open and exam-
ine the file structure. Select the column titled Value and click on the 
Sort Ascending button. The elevation values in this column should 
range between 329 and 587 meters. 

Make the HOMERS29 theme active and double click its legend 
to open the Legend Editor. Select Graduated Color as the Legend 
Type and choose Value as the Classification Field. Click the Clas-
sify button, set the number of classes to 10, and click OK. Type 
in the elevation ranges in the Value column of the Legend Editor, 
beginning with 320−350. Each range should span 30 meters. The 
last range should be 590−620. There are several ways to enhance 
the HOMERS29 theme to better visualize the data. A hillshade 
theme and a contour map can be created, and finally, the hydrogra-
phy coverage can be added to the view.

The Import71 utility converts ArcInfo inter-
change files (.e00) into a form ArcView GIS 
can use.

Performance Strategy

Steps for reducing the size of the area 
modeled by clipping the contour line 
theme are described in an appendix   
“What to Do if Your Computer Chokes,” 
at the end of this tutorial. Learn how to 
create a custom theme that can speed 
navigation and improve refresh rates. 
Even if the computer used for modeling 
is sufficiently robust to render a large 
model, working with a smaller model 
while learning these techniques might 
be a good idea.
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Creating a Hillshade
Choose Compute Hillshade from the Suface menu. In the Compute 
Hillshade dialog box, set the Azimuth at 95 and leave the Altitude 
at the default value, click OK, and wait while the Hillshade of 
HOMERS29 theme is created. Make it the only active theme and 
display it.

Generate a Contour Line Theme
The grid theme used to create the hillshade theme can also be 
used to create a contour line theme.
1. Make HOMERS29 the active theme and choose Create Con-

tours from the Surface menu. 
2. In the Contour Parameters dialog box, set the Contour Interval 

to 10, leave the Base Contour set to 0, and click OK. Display 
the Contours of HOMERS29 theme. 

3. Add the hydrography coverage, 29hya, as a theme in the view 
and display it. The view should now look like Figure 2. Save 
the project again.
Now examine the model. Note the rounded hills and partially 

filled valleys. This is a glacially sculptured landscape. During the 
last Ice Age, valleys in this area were filled with glaciers more 
than 300 meters deep. At the end of this period, outwash condi-
tions created an abundance of sand and gravel deposits. The 
quad northeast of the Homer quad, the Tully quad, maps an area 
that includes the Tully terminal moraine. Drainage from the area 
mapped by the Homer quad flows to the south, eventually joining 
the Susquehanna River. The Finger Lakes are located west of this 
area. The southern ends of these lakes are blocked by substantial 
moraines, and drainage from these lakes flows northward to Lake 
Ontario. 

Creating a Topography TIN
The Contours of HOMERS29 theme created in the previous proce-
dure can now be used to build a TIN. Consider limiting the size of 
this theme using the techiques described in the an appendix “What 
to Do if Your Computer Chokes,” at the end of this tutorial.
1. Make the Contours of HOMERS29 theme active, choose 

Create TIN from Features from the Surface menu. Make sure 
ArcView 3D Analyst is loaded.

2.  In the Create New TIN dialog box, set Height Source to 
Contour, Input As to Mass Points, leave Value set to <none>, 
and click OK. Additional information on TIN creation options is 
available by clicking on the Help button in the dialog box. 

3. The Output TIN Name dialog box opens. Name the new theme 
HOMERTIN, allow it to be saved to the Temp directory, and 
click OK. The progress bar at the bottom of the view shows 
the rate of TIN creation. Be very patient. When the TIN is 
complete, its legend will appear in the view. 

4. Modify the appearance of the TIN by double clicking on the 
legend for the TIN theme to invoke the TIN Legend Editor. 

The grid theme used to create the hill-
shade theme can also be used to create a 
contour line theme.

The Contours of HOMERS29 theme cre-
ated in the previous procedure can now 
be used to build a TIN.
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ArcView GIS Tip

Leave a small portion of the 
associated 2D View visible 
underneath the 3D legend 
window so that you can 
easily move between views. 
Use the Theme Clipboard to 
copy a theme from a 2D 
View to a 3D View.

5. In the TIN Legend Editor, click the Edit button in the Faces 
section to edit the elevation range. Use the Classify button to 
change the number of classes to 10, and set the ranges at 
30-meter intervals to match HOMERS29.

6. Use Terrain Elevation #1 for the color ramp. Remember to click 
on Apply before closing each Legend Editor window.

7. Turn off the Contours of HOMERS29 theme. Make the 
HOMERTIN theme active and turn it on. Triangulated polygons 
will slowly build in the view until it looks like Figure 3. 

Modeling Two-Dimensional Data in a 3D Scene
The TIN just constructed can be used in ArcView 3D Analyst to 
create a 3D Scene. 
1. Make sure ArcView 3D Analyst is loaded and make the project 

window active.
2. Click on the 3D Scenes icon, located at the bottom of the proj-

ect window below Scripts, then click the New button. Two win-
dows open the 3D Scene-Viewer window and the 3D Legend 
window. Neither window can be minimized, but both can be 
resized and moved. Size and position both windows so that the 
two-dimensional view with the TIN theme is accessible.

3. From the 3D Scene menu choose Properties to open the 3D 
Scene Properties window. Set Map Units to meters, Vertical 
Exaggeration to 3, and the Background Color to light blue. Set 
Sun Azimuth to 95 and Sun Altitude to 45. Click on OK.

4. Make the two-dimensional view active and make HOMERTIN 
the only active theme. Turn it off. Choose Edit, then Copy 
Themes. Make the 3D Scene-Viewer the active window, and 
choose Paste from the Edit menu. 

5. Use the same procedure to copy the hydrography theme to the 
3D Scene-Viewer. To convert the hydrography theme to a 3D 
shapefile, make it active and select Convert to 3D Shapefile 
from the Theme menu. In the first dialog box select Surface 
for Get Z Values From, and in the second dialog box use 
HOMERTIN for Choose Theme to Use as Surface. Name the 
new theme s29hyd3D and add it to the view. Choose 3D 
Properties from the Theme menu to set the Offset Heights 
option to 5.

6. Before starting the 3D rendering process, set the theme draw-
ing priorities to a simpler hydrography scene when navigating. 
Make the hydrography theme active, choose Theme, then 3D 
Properties to invoke the 3D Properties dialog box. Click the 
Advanced button to bring up the Advanced 3D Properties 
dialog box. Uncheck the second box next to Draw Theme 
When Not Interacting. Exit both dialog boxes by clicking OK.

7. Because the Homer 3D Scene is more detailed, use the oppo-
site Advanced setting for it. Make Homer 3D the active theme, 
choose Theme, then 3D Properties, click on the Advanced 
button, check the Draw Theme When Not Interacting box, and 
uncheck the Draw Theme When Interacting box. 

The TIN constructed in the previous step can 
be used in ArcView 3D Analyst to create a 3D 
Scene.
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8. Make both themes active and start the three-dimensional rendering process by turning on the 
hydrography theme. When it is displayed, turn on the HOMERTIN theme. The process will take 
several minutes. Be patient.  After admiring this model, turn the 3D themes off and save the 
project. 

Summary
These steps show how to produce very attractive and highly detailed three-dimensional terrain models 
with minimum effort. The USGS 7.5’ DEM data files used in this tutorial, available from the Cornell 
University Web site, provide a good start in working with DEM data for two- and three-dimensional 
This lesson is based on an article written by Dr. David Miller of State University of New York College at Cortland. This 
article originally appeared in the July–September 1999 issue of ArcUser magazine.

Appendix:  What to Do if Your Computer Chokes
Converting and rendering data in three dimensions seriously tests the graphic performance limits of 
most computers. Reboot the system and reload the project if the computer hangs up. If it proceeds at 
an excruciatingly slow rate, do not save the project after copying the TIN file to the 3D Scene. Close the 
project without saving the changes and then reload. Either of these actions will return the project to its 
status at the point just after the contour theme was created. To make this process manageable, reduce 
the size of the area modeled by clipping a portion of the contours theme. 
1. Make the Contours of HOMERS29 theme active. Select New Theme from the View menu. 
2. In the New Theme dialog box, specify Polygon for feature type and click OK.
3. Save the new theme to the DEMWORK directory with the name HOMERCUT. 
4. Click on the Draw Rectangle button and create a rectangle near the center of the contours theme. 
5. From the Theme menu choose Stop Editing. Select Yes in the Stop Editing dialog box. The 

HOMERCUT theme consists of one rectangular feature.

6. Click on the Clear Selected Features button and drag 
the Contours of HOMERS29 theme to the top of the 
legend. 

7. In the File menu choose Extensions and turn on the 
GeoProcessing extension. In the View menu click on the 
GeoProcessing Wizard. 

8. In the GeoProcessing window choose the Clip One 
Theme Based on Another option and click on Next.

9. In the dialog box use Contours of HOMERS29 for the 
input theme to clip and use HOMERCUT for the overlay 
theme. The output file should be named HOMERCLIP 
and placed in the DEMWORK directory.

10. Use the same procedure to clip the hydrology coverage. 
Now click on Finish.
The reduced area HOMERCLIP theme appears in the 

legend and can be used to create a topography TIN as 
described in the main article. Use the name HOMER-
CLIPTIN for this smaller theme, which can be used to com-
plete the tasks necessary to open a 3D view. 

Use the GeoProcessing extension, 
available under the View menu, to 
clip a portion of the contour theme.


