
44   ArcUser  July–September 2004          www.esri.com

Deriving Subset Volumes 
 With Grid Masks
By Mike Price, Entrada/San Juan, Inc.

Editor s̓ note: This is the second in a two-part 
series on modeling ore bodies. The first part, 
“Modeling Bauxite Thickness and Volumes in 
ArcGIS” ran in the April–June 2004 issue of 
ArcUser. Readers who worked this first tutorial 
can use the final map document as a starting 
point for this tutorial. However, the sample data-
set includes a map document that can be used to 
start this tutorial. 

The previous exercise used the cut/fill function-
ality in the ArcGIS Spatial Analyst or ArcGIS 
3D Analyst extension to calculate total tonnage 
for Jamaican bauxite pods. Surface ownership in 
the bauxite mining areas is complex, and it is of-
ten not possible to establish the surface and min-
eral ownership of an entire pod. The Jamaican 
bauxite industry is very mature and is character-
ized by declining reserves, lower grades, and an 
extensive rural population living in the mining ar-
eas. To guide property acquisition and mine plan-
ning, engineers and land managers must develop 
and share resource information that summarizes 
both owned and nonowned tonnage.
 This exercise will continue to assess the thick-
ness and tonnage of a small area of a mining lease 
using the tonnage calculations developed in the 
previous exercise. By creating and applying grid 
masks, resource categories can be defined. The 
cut/fill volumetric derivatives will be converted 
to shapefiles, shapefiles will be combined, and 
bauxite resources will be calculated with respect 
to ownership. 
 This exercise teaches techniques for 
• Constructing complex grid masks identifying 
separate ownership
• Deriving multiple volumes by repeated 
cut/fill
• Converting multiple cut/fill grids to polygon 
 shapefiles
• Joining tabular data to shapefiles
• Coding and merging shapefiles
• Calculating tonnage and average thickness 
 by ownership in a single shapefile table

Getting Started
For readers that completed the “Modeling Baux-
ite Thickness and Volumes in ArcGIS” tutorial, 
start ArcMap and reopen jamaica1.mxd, the map 
document created by the exercise. Alternatively, 
unzip the sample dataset using WinZip, start 
ArcMap, and open jamaica1.mxd. In either case, 
choose File > Save As and save jamaica1.mxd as 
jamaica2.mxd. Perform some Table of Contents 

After opening jamaica1.mxd and renaming it jamaica_2.mxd, rename layers in the TOC.

(TOC) cleanup by renaming layers as suggested 
in Figure 1. Color ramps can also be modified if 
desired.

Determining Bauxite Tonnage by Owner
The Ownership Parcels layer will play a key role 
in this new analysis. Two mask grids, created in 
this step, will constrain volumetric calculations 
to owned and nonowned resources. These grids 
use a cell value of zero to mark off locations by 
ownership. Before building these grids, choose 
Spatial Analyst > Options in the Spatial Analyst 
toolbar and verify that the Working directory has 
been set to \Jamaica\GRDFiles\JA_1880\ and the 
Analysis extent and Cell size are Same as Layer 
Clipping Grid. If not, apply these parameters and 
save the project.

Original Layer Name New Layer Name

cf01a Total Bauxite Resources

totalres TotalResources-Joined Polygons

cf01 TotalResources-Cut/Fill

clipgrd1 ClippingGrid

Figure 1: Rename layers

 There are several different ways to create 
masks for owned and nonowned areas, but one of 
the easiest methods is to select parcels of one type 
and convert the selected parcels to a grid with a 
value of zero. Next, select nonowned parcels and 
convert this selection to another grid also with a 
value of zero. Follow these steps to create these 
masks.
1. After creating both masks, right-click on the 
Ownership Parcels layer in the TOC and choose 
Open Attribute Table from the context menu. 
Observe the Status, StatusCode, and MaskValue 
fields. Notice that the MaskValue field contains a 
value of zero for all records. 
2. In the attribute table, choose Options > Select 
by Attributes. In the dialog box, choose Create a 
New Selection as Method and create the expres-
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What You Will Need
•  ArcGIS 8.3 (ArcView, ArcEditor, or ArcInfo license)
•  ArcGIS Spatial Analyst or ArcGIS 3D Analyst extension
•  The sample dataset downloaded from the ArcUser 
 Online Web site
•  An unzipping utility such as WinZip

Select the owned parcels and con-
vert the features to a raster. 

sion “STATUS” = “Owned”. Close the table and 
retain the selection set. 
3. In the Spatial Analyst toolbar, click the drop-
down and choose Convert > Features to Raster. 
In the Features to Raster dialog box, verify that 
Input Features has been set to Ownership Parcels, 
the MaskValue is set to Field, and save the Output 
Raster to \Jamaica\GRDFiles\JA_1880\. Name 
the output raster ownmask1 and click OK. Watch 
the mask build and load into the project.
4. To create a nonowned mask, reopen the Own-
ership Parcels table, click Options in the table, 
and choose Switch Selection. Follow the same 
steps described for creating the owned mask with 
one exception. Use the expression “STATUS” = 
“Not Owned.” Name the second mask grid non-
mask1. 
5. Compare each mask to the Ownership Parcels 
and confirm that each mask contains only cell val-
ues of zero and that the cells correspond with the 
proper ownership status. In the Layer Properties 
dialog box, rename ownmask1 to Owned Mask 
and nonmask1 to Non-owned Mask. If problems 
occur, remove the suspect mask from the project 
and build it again. Save the project.

Determining Volume Subsets by Cut/Fill
Next calculate volume subsets. The first tutorial 
developed a naming convention for cut/fill grids, 
DBF output tables, and the polygon shapefile con-
verted from the cut/fill grid. The Total Resources 
cut/fill grid was named cf01, the DBF output file 
was named cf01.dbf, and the converted shapefile 
was named cf01a.shp. 
 In processing two ownership types, the same 
procedure will be performed twice. The new 
Owned Resource Cut/Fill grid will be named 
cf02, its output table cf02.dbf, and its converted 
shapefile cf02a.shp. The Nonowned Resource 

After generating cut/fill rasters for owned and nonowned parcels, sort and inspect the attribute 
tables for both layers.

grid will be called cf03, the DBF file called 
cf03.dbf, and the converted shapefile called 
cf03a.shp. Store the grids in \Jamaica\GRD-
Files\JA_1880. Create a new directory, \Jamaica\ 
DBFFiles, and place the DBF tables in it. Save 
the shapefiles to \Jamaica\SHPFiles\JA_1880.
 The 10-foot thickness grid created in the last 
tutorial contains values in feet for bauxite in the 
mapped ore bodies. Cells outside of ore bodies 
contain No Data. Each mask grid contains zero 
values over owned and nonowned polygons. This 
step will calculate two volumes using the cut/fill 

function.
1. Click the Spatial Analyst toolbar drop-down 
and choose Surface Analysis > Cut/Fill. In the 
Cut/Fill dialog box, specify Thickness Grid as 
the Before Surface and Owned Mask as the Af-
ter Surface. Leave Z Factor and Output Cell Size 
unchanged. Save the output raster to \Jamaica\
GRDFiles\JA_1880\, name it cf02, and click OK. 
The cut/fill grid will be calculated and loaded into 
the Data Frame. Rename this layer Owned Re-
sources.

Continued on page 46
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2. Repeat the process for Non-owned Resources 
using Non-owned Mask as the After Surface. 
Name the output raster cf03 and rename the layer 
Non-owned Resources-Cut/Fill. 
3. Inspect both cut/fill attribute tables. Right-click 
the Volume field and select Sort Descending from 
the context menu. The blue features represent Net 
Loss, reported in positive values, and the red fea-
tures show zero volume. The Net Loss values, 
reported in cubic feet, represent the volume of 
bauxite resource contained in each pod, subdi-
vided by ownership.

Exporting and Editing Cut/Fill Tables
The next step will export the cut/fill tables, code 
the records by ownership, convert grid areas to 
shapefiles, and join volume and area data to the 
shapefiles. After merging the owned and non-
owned shapes, the tonnage and average thickness 
will be calculated. Although this sounds like a lot 
of work, it follows a logical work flow.
1. Open the Attribute Table for Owned Resourc-
es-Cut/Fill, click Options, and select Export. Ex-
port All Records to \Jamaica\SHPFiles\JA_1880\
cf02.dbf. Add the new table to the current map.
2. Repeat the procedure for Non-owned Re-
sources-Cut/Fill, exporting all records to \Jamai-
ca\SHPFiles\JA_1880\cf02.dbf. 
3. Open each DBF table. In the table, click Op-
tions and choose Add Field. Add a new field 
called Status and set the field Type to Text and 
the Precision to 20. Right-click the Status field 
and choose Calculate Values. Use the field cal-
culator to populate the Status field in cf02.dbf 
with Owned and the same field in cf03.dbf with 
Not Owned. 

Converting Cut/Fill Grid Areas 
to Polygon Shapefiles
Now the cut/fill grids can be converted to shape-
files.
1. In the Spatial Analyst toolbar, click the drop-
down and choose Convert > Raster to Features. 
Select Owned Resources-Cut/Fill as the Input 
Raster, Value as Field, and \Jamaica\SHPFiles\
JA_1880\cf02a.shp for Output Features. Remem-
ber to include the letter a in the output shapefile s̓ 
name and save it in the SHPFiles directory. Do 
not mix shapefiles and grids in the same folder, 
and remember to uncheck the Generalize Lines 
box! By not generalizing, the exact cut/fill grid 
boundaries will be respected by the process. 
Click OK. 
2. Repeat this procedure for Non-owned Re-
sources-Cut/Fill and save the resulting shapefile 
as cf03.shp. 
3. These shapefiles will be merged into a mas-
ter set and removed from the project. Open each 
shapefile s̓ Attribute Table and observe the GRID-
CODE field. These values correspond with re-
cords coded by VALUE in cf02.dbf and cf03.dbf. 

Deriving Subset Volumes With Grid Masks
Continued from page 45

Use the Field Calculator to populate the new STATUS field in both cut/fill raster attribute tables.

These fields will be used to join cf02.dbf to 
cf02a.shp and cf03.dbf to cf03a.shp.

Joining Tabular Data, 
Merging Shapefile Subsets
In the TOC, right-click cf02a.shp and choose 
Joins and Relates > Join. In the Join Table dialog 
box, base the join on the GRIDCODE field. The 
table to join from is cf02.dbf, and the field in the 
table to base the join on is VALUE. Repeat this 
procedure for cf03a.shp and cf03.dbf. For more 
information on joins, see the ArcGIS Desktop 
online help. 
 The two bauxite resource subsets, Owned 
Resources and Non-owned Resources, could be 
kept separate, but since they have been coded by 
ownership status and both have the same table 
structure, they can be merged into one master 
set before calculating tonnage and average thick-
ness.
1. From the ArcMap menu, choose Tools > Geo-
Processing Wizard. Click the radio button next 
to Merge layers together and click Next. Select 
cf02a-Polygon and cf03a-Polygon as the layers 
to merge, use the fields from either set, and spec-
ify \Jamaica\SHPFiles\JA_1880\ownerres.shp as 
the output shapefile. Click Finish and watch the 
merged shapefile load into the TOC. 
2. Rename the shapefile Owned and Non-owned 
Bauxite Resources. Remove cf02a.shp and 
cf03a.shp from the TOC and save the project.

Calculating Total Tonnage
and Average Thickness
Before calculating tonnage and average thickness 

Use the GeoProcessing Wizard to merge the 
owned and nonowned parcel layers.

for owned and nonowned bauxite, add fields for 
these calculations. 
1. Open the Owned Bauxite Resources attri-
bute table, click the Options menu, and use Add 
Field to add two fields, DMT and Avgthick. In 
the dialog box, apply the parameters listed in 
Figures 2 and 3. Repeat this process with the 
Non-owned Bauxite Resources attribute table. 
Note that bauxite tonnage is reported in Dry Met-
ric Tons (DMT) and that one cubic foot of bauxite 
weighs 0.0410 DMT. 
2. When all fields have been added, right-click 
the name of each field, choose Calculate Values 
from the context menu, and use the formulas in 
Figure 4 to calculate DMT and average thick-
ness. 
3. To verify the work done thus far, compare 
the new ownership tonnage with the original 
resources calculated in the first exercise. Right-
click the DMT field and choose Statistics. Com-
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Figure 3: Average Thickness field

Name AvgThick

Type Float

Field Properties, 
Precision

6

Field Properties, Scale 2

Figure 2: Dry Metric Tons field 

Name DMT

Type Float

Field Properties, 
Precision

12

Field Properties, Scale 2

pare the numbers just calculated with the original 
statistical summary of DMTs in Total Bauxite 
Resources. 
 In the first exercise, 388,909.60 DMTs were 
derived. The new calculations should show 
388,860.40 for Owned and Non-owned bauxite. 
This difference of less than 50 DMT is insignifi-
cant. If the numbers are correct, save the project. 
If not, check the naming conventions and calcula-
tions and tabular joins performed. 

Dry Metric Tons
DMT = [Volume] * 0.0410

Average Thickness
AvgThick = [Volume] / [Area]

Figure 4: Formulas for field calculations

Some Tests
Now the property department, mine planners, 
and equipment schedulers for the fictional mining 
company in this exercise have some useful data 
to work with. The owned and nonowned total 
bauxite resource is slightly under 400,000 DMTs, 
and it closely agrees with the original estimate. 
 Now experiment with this new data and cre-
ate queries that a mining engineer or a land agent 
might perform. First, identify the owned large 
tonnage resource and summarize those tons. As-
sume that 5,000 DMTs, and an average thickness 
of 10 feet or more, is the minimum body that will 
be mined. This query will include three items—
parcel ownership, DMT greater than 5,000, and 
average thickness that is greater than 10 feet. 
1. Open the attribute table for Owned and Non-
owned Bauxite Resources, click Options, and 
choose Select by Attributes. Create the query in 
Figure 5 and click Apply. In the table frame, click 
the Selected Records button. Four owned regions 
should be identified. Right-click the DMT field and 
choose Statistics. This will list total economic ton-

“Status” = “Owned” AND “DMT” >=5000 AND “AvgThick” >=10

Figure 5: Identify owned resource tonnage
.

“Status” = ʻNot Ownedʼ AND “DMT” >=5000 AND “AvgThick” >=10

Figure 6: Summarize nonowned but mineable resources

nage. This should identify less than 55,000 DMTs, 
and each region will be part of a larger pod.
2. The next step will calculate high tonnage re-
sources that are not presently owned, especially 
resources that are part of a larger partially owned 
pod. Using a similar query, shown in Figure 6, 
summarize the nonowned resources that can be 
mined. If enough nonowned bauxite near owned 
bauxite is located, the land department might 
want to negotiate with the surface owners. The 
query in Figure 6 returns five areas, totaling over 
212,500 DMTs. This is encouraging!
3. Finally, modify the query to select all areas that 
contain at least 5,000 DMTs and average at least 
10 feet thick. This query returns nine regions, 
containing more than 267,000 DMTs. Lower-
ing the average thickness to five feet and running 
this modified version of the query in Figure 5 
identifies economically break-even areas. This 
query returns 13 areas that contain more than 
370,000 DMTs. 
 Remember that the total resource includes 
some 390,000 DMTs. If the rights to mine all 
parcels were acquired and worked carefully, 
more than 90 percent of the bauxite could be re-
covered. In truth, mining decisions are a bit more 
complicated than this, but these queries demon-
strate how ownership subsets might be used by 
planners and engineers.

Summary
Though most readers are not bauxite miners, this 
cut/fill procedure can be used in many areas of 
study. This method has been used to calculate 
wildland fuel loads, rainfall amounts by water-

shed, and volumes of sediment retention ponds. 
Readers who develop other uses for this tech-
nique are invited to e-mail the author and share 
them. Contact 
Mike Price, President and 
Natural Resources GIS Specialist
Entrada/San Juan, Inc.
Moab, Utah
E-mail: mike_price@frontiernet.net
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After 
calculating 
tonnage, 
view the 
statistics for 
Total Bauxite 
Resources.

The final query identifies the economically 
break-even areas.


