
Spatial Adjustment Tools: The Tutorial 

In this exercise, you will perform some spatial adjustment and data management 
operations data to be used in analysis and to make the database cohesive and effi-
cient. 

Step 1: Convert the street centerlines for a new subdivision from an AutoCAD draw-
ing exchange file (dxf) drawing to a new feature class in the Redlands Streets 
layer.

Step 2: Add displacement links to the new subdivision streets using a Control Points 
file.

Step 3: Transform the data to real world coordinates by using the Spatial Adjust-
ment tools in ArcMap to transform the new subdivision streets from digitizer 
units to Universal Transverse Mercator (UTM) Zone 11 so that they will match the 
existing streets.

Step 4: Use the Spatial Adjustment tools on stream data layers to perform an edge 
snap operation that will align features in two adjacent layers.

Step 5: Transfer attributes between these newly aligned adjacent stream layers.

Step 1: Convert CAD file to geodatabase feature class

Each CAD drawing has two entries in the ArcCatalog tree, a CAD dataset that repre-
sents all the layers in the drawingpoint, line, polygon, and annotationand a CAD 
drawing This exercise will use the CAD dataset.

1. Download the sample data from the ArcUser Online Web site. Create a folder 
called tutorial and unzip the archive using WinZip. 

2. Start ArcCatalog. Navigate to the tutorial folder. Right-click on sub_digunits.dxf 
and choose Properties. Click on the Spatial Reference tab. Notice there is no pro-
jection information associated with this file and the values for the CAD dataset 
extents are very small because represent the digitizer unitsin this case inches. 
Click OK to dismiss the CAD Feature Dataset Properties dialog box.

3. Right-click on sub_digunits.dxf and choose Export > CAD to Geodatabase from 
the context menu. 

What You Will Need

• ArcGIS 8.2 (ArcInfo or ArcEditor 
licenses)

• Sample dataset download from the 
ArcUser Online Web site

• An unzipping utility such as 
WinZIP
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Figure 1: Export the sub_dignunits.dxf to 
the RedSA_GDB geodatabase using the CAD 
to Geodatabase utility in ArcCatalog.
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4. In the CAD to Geodatabase dialog box, confirm that Polyline is selected. Under 
Output Geodatabase, click on the browse button and navigate to the RedSA_
GDB geodatabase and click Open. For Enter the name of the new feature class:, 
type sub_dig_temp. Do not close the dialog box. The CAD to Geodatabase dialog 
box should look like Figure 1, shown on the previous page.

You will import the spatial reference information from the Streets feature class in 
the RedSA_GDB geodatabase. However, you will need to adjust the spatial extents 
(i.e., X/Y Domain) for this new feature class to contain the area for both the street 
centerlines in digitizer units and the UTM streets. 

1. Click the Change Settings button. On the Spatial reference tab, click the Change 
button. 

2. Click the Import button to import a coordinate system for the new feature class. 

3. Browse to the Streets feature class in the RedSA_GDB geodatabase. Click Add. 
Notice that the coordinate system is updated in the Spatial Reference Properties 
window. Do not close the dialog box.

The extents for the Streets feature class have been copied for the minimum and 
maximum X and Y values. The sub_dig_temp features fall outside this range. For the 
transformation process to be successful, the X/Y domain or extents must cover the 
coordinate values where the features currently fall and the coordinate values where 
they will be moved. The minimum X and Y values need to be altered to account for 
the subdivision features’ currentl location. 

1. Still in the Spatial Reference Properties dialog box, click on the X/Y Domain tab. 
Type 0 for both the Min X and Min Y. The X/Y Domain values should match those 
shown in Figure 2. 

2. Click OK to dismiss the Spatial Reference Properties dialog. Click OK to dismiss 
the Output settings dialog. Click OK on the CAD to Geodatabase dialog.

3. The new subdivision’s streets have now been added to the RedSA_GDB geodata-
base. In ArcCatalog, preview the sub_dig_temp feature class.

Step 2: Add displacement links

The streets in sub_dig_temp are still in digitizer units and need to be shifted in coor-
dinate space to match the Streets feature class.

1. Start ArcMap and open a new empty map. In ArcCatalog, drag the Streets fea-
ture class from the RedSA_GDB into the ArcMap document. Add the sub_dig_
temp feature class. If you get a warning that the data is missing spatial reference 
information, click OK. 

2. Because the sub_dig_temp features are in digitizer units, they are not visible at 
the current ArcMap extent. Double-click on the symbol for sub_dig_temp in the 
Table of Contents to bring up the Symbol Selector dialog box. 

Figure 2: Adjust the values in the X/Y 
Domain dialog box to match the illus-
tration.
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3. Change the symbol to Highway Ramp which has a default color of red and a 
width of 1.70. This will make it easy to identify the new subdivision’s streets once 
they are transformed to match the Streets data. 

4. Right-click on sub_dig_temp and click Zoom To Layer. 

To use the Spatial Adjustment tools, you must begin an editing session. If neces-
sary, open the Editor toolbar by choosing View Toolbars > Editor. Also open the Spa-
tial Adjustment toolbar by clicking on View > Toolbars > Spatial Adjustment. 

1. On the Editor toolbar, choose Editor > Start Editing. On the Spatial Adjustment 
toolbar, choose Spatial Adjustment > Set Adjust Data. 

2. Click the radio button next to All features in these layers: and uncheck the 
Streets layer. The dialog should match Figure 3. Click OK. 

3. Choose Spatial Adjustment > Adjustment Methods > Transformation–Affine. 

The algorithm used in the Affine transformation requires at least four displace-
ment links. Displacement links define the source and destination coordinates for the 
transformation. Displacement links can be added manually or loaded through a links 
file. A links file, which is a tab-delimited text file, contains both the source and desti-
nation coordinates for each displacement link. Alternatively, a Control Points file that 
contains the coordinates for the destination points can be used to manually add the 
source points. 

The destination coordinates for street intersections and ends in sub_dig_temp are 
already known and have been stored in a Control Point file. You will use this text file 
to manually create displacement links. However, first you will set up the snapping 
environment for snapping the control points to the street centerlines.

1. Click Editor > Snapping , and turn on End Snapping for the sub_dig_temp layer. 
Close the Snapping Environment window. 

2. Click Spatial Adjustment > Links > Open Control Points File. 

3. Browse to the tutorial folder and select SubGCP.txt. Click Open. 

This text file contains the destination coordinates that will be added to the 
ArcMap display. There are six coordinate pairs listed in the file. The ID number for 
each destination point matches an ID for one of the source end points of a street fea-
ture in the street feature class as illustrated in Figure 4. 

1. Right-click on the X or Y Destination value for the control point for ID number 1 
and click Add Link. 

2. Move the mouse into the ArcMap display area. You will be able to see the dis-
placement link reaching from outside the display area. 

3. Snap to the end of the street for source point 1 as shown in Figure 5.

FIgure 3:  After starting an Editing session, 
choose the data that will be adjusted. 

FIgure 4:  The IDs for the control  points 
correspond to the end points of the 
street features. 
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4. Click the Refresh View button located on the lower left side of the map canvas. 
The created displacement link is displayed and the ID 1 is removed from the Con-
trol Point file displayed in ArcMap. 

5. Add the rest of the displacement links in the same manner based on the end 
points shown in Figure 4. 

6. Click the Refresh View button to show all six displacement links. 

You can view both the source and destination coordinates for the links and the 
root mean square (RMS) error for each link in the adjustment by viewing the Link 
Table. If any link does not have an acceptable RMS value, it can be modified or 
deleted. 

1. On the Spatial Adjustment toolbar, choose Link > View Link Table. All the dis-
placement links have values less than 0.5, which is acceptable for this data.

2. Link number 4 has a little higher RMS error than the other links. Right-click on it 
in the Link Table and choose Delete Link. 

3. Notice how the overall value for RMS error drops slightly. Close the Link Table. 

Step 3: Transform the data to real world coordinates  

1. From the Spatial Adjustment toolbar, click Spatial Adjustment > Adjust. The 
sub_dig_temp features should disappear from the display area because they have 
been transformed to match the other streets.

2. Right-click on the Streets layer in the TOC and click Zoom To Layer. You will be 
able to see the bright red streets of the new subdivision added to a city block in 
the center-east of the streets layer.

3. Zoom in on the new streets. Set the Selectable Layer so that only sub_dig_temp 
is selectable by choosing Selection > Set Selectable Layers and turning off the 
Streets layer.

4. To locate all streets on the same layer, select all the features in sub_dig_temp. 
Choose Edit > Copy or Ctrl+C to copy the selected features to the clipboard. 

5. In the Editor toolbar, set the Target layer to Streets. Click Paste or Ctrl+V to paste 
the features into the Streets layer.

6. Choose Editor > Stop editing from the Editor toolbar. Remove both Streets and 
su_dig_temp layers from the Table of Contents.

Step 4: Edge Snap Two Layers

You may often find it necessary to align two layers whose borders are slightly out of 
alignment. The edge snap, the most basic of the spatial adjustment methods, takes 
care of this problem. The next exercise uses data about streams. Click on the Add 

Figure 5: Right-click on the control point for 
ID number 1 and choose Add Link. Move the 
mouse into the ArcMap display area and the 
displacement link reaches from outside.

Figure 6:  Choose Link > View Link Table from 
the Spatial Adjustment toolbar to view the 
RMS values.
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Data button and navigate to the tutorial folder. Add the stream_west and stream_
east shapefiles to the map. Change the layer symbology as shown in Figure 7. Loca-
tions for colors in the palette are given in parenthesis.

Layer Attribute Value

stream_west color Malachite Green (5th row, 8th column)

stream_west line width 2.00

stream_east color Electron Gold (3rd row, 4th column)

stream_east line width 2.00 

Figure7: Layer symbology

Notice that the stream features on the two layers don’t align, and one has a slight 
overlap. The difference is approximately 50 meters and could be the result of digitiz-
ing error or other source data distortion. You will set up the initial spatial adjustment 
environment and then add Displacement Links. To work more efficiently, you will use  
the Magnifier window which will eliminate most of the panning and zooming associ-
ated with making these edits.

1. Start an Editing session. In the Editor toolbar, set the Snapping Environment to 
Ends for both layers. 

2. Choose Spatial Adjustment > Set Adjust Data. In the Choose Input For Adjust-
ment dialog, choose All features in these layers. Uncheck the stream_east layer 
and click OK. 

3. Choose Spatial Adjustment > Adjustment Methods > Edge Snap. 

4. Choose Window > Magnifier to open a magnifier window and drag the window 
to the top (northernmost) stream edge gap. Right-click on the Magnification 
window title bar, select Properties , and change the zoom factor to 600 percent.

5. On the Spatial Adjustment toolbar, select the New Displacement Link tool. Use 
this tool to link the eastern ends of the stream_west line features (shown in 
green)to the western ends of the appropriate stream_east line features (shown 
in gold) as shown in Figure 8. Add displacement links for the other two gaps, 
leaving the magnifier window over the southernmost stream. 

6. Choose Spatial Adjustment > Adjust. Notice that the default Edge Snap method 
simply moved the overlapping line from the last vertex of stream_west to the dis-

Figure 8: Use the New Displancement Link tool 
to link the eastern end of a stream_west fea-
ture to the wesern end of the corresponding  
stream_east feature. 
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placement link on stream_east. It is unlikely that the stream makes such a distinct 
linear change. Choose Edit > Undo Adjust. The stream_west line features will 
return to their original positions and the displacement links will reappear. 

7. Click Spatial Adjustment > Options. Under the General tab, confirm that Edge 
Snap is the selected Adjustment method. Click on the Options button and select 
Edge Snap if necessary and make sure Smooth is selected for Method. Click OK to 
close both dialog boxes. 

8. Perform the Adjust function a second time. Notice the difference in the Edge 
Snap result. Choosing the Smooth option for the Edge Snap method changed the 
number of vertices altered by the adjustment. The Line option moves the line 
feature from just the last vertex, while the Smooth option spreads the change 
throughout all the vertices of the feature. Because you earlier used Set Adjust 
Data to select the stream_west layer only, those are the only features altered. 
Save your edits 

Step 5: Transfer Attributes

Now that you have aligned the features from stream_west to those in stream_east, 
you need to update the more accurate attribute values from stream_east to stream_
west. The stream_west layer does not contain attribute values for either the Name 
or CFCC fields. By using the Attribute transfer tool, you will accurately and quickly 
update the values for stream_west.

1. Change the Snapping Environment. Check Edge snap for both stream layers and 
uncheck End snap. Close the Snapping Environment window.

2. Choose Spatial Adjustment > Attribute Transfer Mapping. 

3. Under Source Layer, select stream_east. Under Target Layer, select stream_west. 
Notice that the fields for each individual layer appear in the window below. The 
two layers have three of the four fields in common.

4. Click the Auto Match button. The three fields names present in both layers 
appear in the Matched Fields panel. Select the remaining Name and StreamName 
fields by clicking on each once. Notice that the Add button becomes active. Click 
the Add button. The Name and StreamName field values will be matched during 
your attribute transfer process. 

5. Make sure that the Transfer Geometry box at the bottom left corner is NOT 
checked. Click OK. 

6. Click on the Attribute Transfer tool, located at the end of the Spatial Adjustment 
toolbar. Select the uppermost river in the stream_east layer by clicking once. You 
will see it flash, and the cursor will have a link anchored to your selected seg-
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ment. 

7. Move the cursor left to the edge-snapped stream_west feature and click once. 
You will see the river flash once. In the Table of Contents, right-click on the 
stream_west layer and select Open Attribute Table. You will see that the Name 
and CFCC columns now contain updated information. 

8. Repeat the Attribute Transfer for the remaining two edge-snapped streams. The 
column values will be updated automatically. Close the Attribute Table. Choose 
Editor > Stop Editing and save your edits. 

Conclusion

These data management operations are vital for maintaining the spatial accuracy of 
data. In this exercise, you learned how to convert a CAD drawing file into a geodata-
base feature class and how to transform the digitizer units of the converted CAD file 
into real world coordinates using the Spatial Adjustment tools in ArcMap. You also 
updated and corrected less accurate spatial data and attribute information by using 
two spatial adjustment toolsEdge Snap and Attribute Transfer.


