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The 3D virtual city is emerging as an essential 
GIS tool for visualization and analysis in the 
urban environment—from placing a proposed 
building construction in the context of its sur-
roundings to conducting analyses in three di-
mensions such as line-of-sight or 3D volumet-
ric shadows. The multipatch, Esri’s native 3D 
feature type, is a key element whether work-
ing in ArcGlobe or ArcScene. ArcGIS 10 in-
troduces a host of new 3D data management 
and analysis capabilities that enhance 3D 
analysis.
 This exercise walks the reader through the 
process of creating and adding texture to a 
3D multipatch feature. It uses a geometrically 
simple urban feature—a freeway overpass in 
downtown Philadelphia—and starts with a 
polygon and some high-resolution aerial im-
agery. The workflow outlined will familiarize 
the reader with tools in ArcGIS 10 for import-
ing, exporting, and placing different types of 
3D features.
 It’s assumed that the reader is familiar with 
ArcGIS Desktop applications and the ArcGIS 
3D Analyst extension, including ArcGlobe. 
Some familiarity with Google SketchUp may 
also be helpful. To complete this exercise, the 
following software and data are required
 ArcGIS 10 with the 3D Analyst and Spatial 

Analyst extensions
 Google SketchUp 8 (free version available 

at sketchup.google.com/download/)
 Multipatch Overpass data .zip file on  

ArcGIS.com (bit.ly/ep5a2s)
The 16-step workflow is organized into four 
sections:
1. Extruding an overpass polygon and exporting 

it as a 3D multipatch feature from ArcGlobe
2. Extracting aerial imagery to use as a sur-

face texture 
3. Applying the extracted imagery to the 

overpass in SketchUp
4. Importing the newly textured overpass 

back into ArcGlobe

Supporting Data

Folder Item Description

Maps and GDBs overpass.3dd the arcGlobe document for viewing 
the overpass content in 3D

overpass.gdb a geodatabase containing high-
resolution imagery, polygon, and 
multipatch overpass features used in 
the workflow

3D Models coLLaDa (*.dae) 
models 

a folder containing untextured 
(before) and textured (after) 3D 
overpass models in coLLaDa 
format.

the folder and files in the Multipatch overpass ZIP file. Note: The Overpass.gdb 
in Maps and GDBs folder includes the overpass feature in various stages of the 
construction process, so more advanced users can skip some portions of the 
workflow if desired.

Figure 1: this exercise shows how to correct this sampling error, commonly seen in 
high-resolution DeMs in urban environments. 
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software and Data

Exercise Overview
This exercise starts with an overpass feature 
that has been poorly captured by the existing 
1-meter (m) digital elevation model (DEM) 
for downtown Philadelphia as shown in Fig-
ure 1. This type sampling error is commonly 
seen in high-resolution DEMs in urban en-
vironments that show overlapping roadways 
and structures of different elevations. Lower-
resolution DEMs, by comparison, just make 
features look flat. One approach to correcting 
this situation might be to edit the DEM or add 
a patch to raise that road and create a flat sur-
face. Although this fixes the elevation of the 
overpass road, it creates an impenetrable wall 
in the underlying expressway.
 Instead of editing the DEM, this tutorial 
will show how to create a simple but realistic-
looking overpass as a 3D multipatch feature 
that spans the gap and has a void space under-
neath. This process requires a polygon file and 
a swatch of high-resolution imagery. Sketch-
Up will be used to apply imagery to the top of 
the 3D overpass model. 

Section 1: Create a 3D Multipatch from 
an Extruded Polygon
1. The first step is to create a polygon feature 
using ArcMap in universal transverse Mer-
cator (UTM) Zone 18N. Later, this polygon 
will be extruded to create a 3D volume for 
the overpass. After adding the imagery file in 
the Overpass geodatabase to an ArcMap docu-
ment, create a simple rectangular shape and 
ensure that there are small areas of overlap 
at each end of the overpass. (The completed 
polygon feature is overpass_ply and is includ-
ed in Overpass.gdb.)
2. Close ArcMap and open the ArcGlobe 
Overpass.3dd file. Add the polygon feature 
just created. By default, the polygon will drape 

Figure 2: add the polygon feature created in arcMap to overpass.3dd. 

Figure 3: By default, the polygon will drape over the globe surface like a blanket.
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over the globe surface like a blanket. Ensure 
that the polygon completely spans the road-
way below as well as part of the elevated road 
surface on each end so there are no gaps when 
the polygon is extruded to 3D.
3. To correctly place the elevation of the 
overpass once it's extruded, sample the value 
of the DEM on each end of the roadway (as 
indicated by the ovals shown in Figure 4). Use 
the Identify tool to sample the elevation, with 
1-m DEM specified as the Identify from layer. 
Both sides of the overpass will have an eleva-
tion value of about 41 feet.
4. To set the elevation of the overpass poly-
gon, open the Layer Properties > Elevation 
tab and select the Floating without a surface 
option. Input a constant offset value for the 
desired elevation in the text box in the lower 
right side of the Layer Properties dialog box 
as shown in Figure 5. The DEM is 41 feet (this 
is pretty close to 12 meters), and this height 
bridges the gap well.
5. With the base elevation determined, an ex-
trusion of 2 m is applied. To ensure that the top 
of the overpass matches the road surface on 
each side, use either an elevation of 12 meters 

Creating and Texturing Multipatch Features
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Figure 4: to determine the elevation of the overpass once it’s extruded, sample the 
value of the DeM on each end of the roadway (as indicated by the ovals).

Figure 5: set the elevation under Layer Properties.

and a -2 extrusion or an elevation of 10 meters 
and a +2 extrusion. 
6. Next, use the Layer 3D To Feature Class 
tool in the 3D Analyst toolbox to convert the 
extruded 3D polygon to a multipatch feature. 
(Use overpass_mp to skip this step.)
7. Now the 3D multipatch feature needs to be 
converted to a COLLADA format file so that 
it can be imported into SketchUp to apply the 
imagery. This is done using the Multipatch To 
COLLADA tool in the Conversion toolbox, 
which outputs the COLLADA file to a speci-
fied folder.

Section 2: Extract Surface Imagery
8. Use the Extract By Mask tool in the Spatial 
Analyst toolbox to extract imagery for the top 
of the overpass. The parameters for this tool 
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include the imagery swatch as the input raster 
and the overpass polygon as the feature mask. 
(The imagery_extract file can be used to skip 
this step.)
9. Next, convert this extracted imagery to 
PNG format using the Copy Raster tool in the 
Data Management toolbox. The input raster is 
imagery_extract, the output raster is imagery 
is PNG and the pixel type is 8-bit unsigned. 

Section 3: Apply Surface Imagery and 
Color to the 3D Overpass in SketchUp
10. Open SketchUp and use File > Import to 
import the COLLADA model (*.dae) saved in 
Step 7. Use the Select tool to select the model, 
then right-click and select the Explode option.
11. Activate just the top face of the overpass 

Figure 7: use the 
extract By Mask 

tool in the spatial 
analyst toolbox to 

extract imagery 
for the top of the 

overpass.

Figure 8: In 
sketchup, use 
the select tool to 
select the model, 
then right-click and 
select explode.

Continued on page  12

Figure 6: use the Layer 3D to Feature class tool to convert the extruded 3D polygon (left) to a multipatch feature (right).

with the Select tool. Use File > Import, select 
the *.png file type, then navigate to the PNG 
imagery exported in Step 9. With the Use as 
texture option enabled, roughly place the im-
age on the top face (don’t worry about the ex-
act placement for now).
12. With the top face still selected, finely ad-
just the position of the imagery by choosing 
Edit > Face > Texture > Position. Four pins 
will appear at each corner of the image. Move 
each pin to the four edges of the overpass and 
stretch the imagery until it fits.
13. With the imagery in place, use the Paint 
Bucket tool to apply color to the sides and bot-
tom of the overpass. (Color_C15 in the Mate-
rials palate roughly matches the color of the 



12   ArcUser  Winter 2011 esri.com

Our MS GIS Program is designed for an audience of professionals seeking to
improve their knowledge of the analysis and management of geographic

information. We offer both a full-time and a part-time residential program. Within the
University’s interdisciplinary learning environment, students have an unparalleled
opportunity to interact personally not only with University faculty, staff, and students
from other programs, but also with the many talented professionals at the world’s
leading GIS company, ESRI, located in close proximity to the University.

The University of Redlands, founded in 1907, is a fully-accredited, liberal arts and
sciences university. This intensive, international learning environment ensures a global
context of relevance to students from around the world. Graduates of this program
can become GIS practitioners prepared for positions such as project managers,
applications specialists, and applications software development team members.

For information call (909) 748-8128 or visit
www.msgis.redlands.edu

Master of Science in GIS

at the University of Redlands

Figure 9: Move the four pins to the edges of the overpass and stretch the imagery to fit.
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concrete.)
14. Once the imagery has been added and 
painted, export the model (File > Export > 
3D Model) back to a COLLADA file, which 
will then be used to replace the untextured 
multipatch in the ArcGlobe document. [Note: 
SketchUp version 6 format may be used in 
place of COLLADA for this step (File > Save 
As > SketchUp Version 6).]

Section 4: Importing the Textured  
Overpass Back into ArcGlobe
15. In ArcGlobe, begin a 3D editing session. 
Use the Edit Placement tool on the 3D Edi-
tor toolbar to select the overpass. While the 
overpass is selected, use the Replace with 
Model function in the 3D Editor toolbar and 
navigate to the COLLADA(or SketchUp) file 
saved in Step 14. (A textured COLLADA file 
is also provided in the 3D Models directory 
in the ZIP file.) After the file is selected, save 
the edits. The newly textured overpass will ap-
pear in place of the untextured version (The 
textured multipatch supplied in the Overpass.
gdb is overpass_mp feature.)
16. As a final touch, add shadow underneath 
the overpass to mask the duplicate imag-
ery on the expressway below. A copy of the 

Figure 10: use the Paint 
Bucket to color the sides and 
bottom of the overpass.
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Figure 11: use the edit Placement tool and the replace with Model function in the 
3D editor toolbar to add the coLLaDa (or sketchup) file.

but the techniques for feature extrusion, mul-
tipatch creation, and texturing can be applied 
to create complicated 3D structures such as 
bridges, houses, or high-rises. If just 3D anal-
ysis is the goal, skip the texturing steps and 
see the ArcGIS Resource Center help topic 
“Obtaining elevation information for build-
ing footprints” to learn how to quickly create 
a city’s worth of 3D multipatch buildings from 
footprint polygons with height attributes.
 Visit the 3D GIS Resource Center (bit.ly/
a0vnDp) and 3D GIS blog (bit.ly/g5J6xq) for 
tips on working with and analyzing 3D data in 
ArcGIS, and video demonstrations highlight-
ing the different types of analysis possible in 
ArcGIS 10, such as volumetric shadow analy-
sis over time, 3D feature extraction from Li-
DAR, and 3D viewshed analysis. Download 
additional 3D templates and workflows from 
the 3D Template Gallery. The 3D City: Phila-
delphia template is particularly useful for those 
new to virtual cities in ArcGlobe. It includes a 
collection of highly detailed 3D building mod-
els, vegetation, and street furniture for down-
town Philadelphia, Pennsylvania.

Figure 12: Now 
compare the overpass 
in these before (left) 
and after (right) 
images.

original overpass polygon was adjusted to 
be slightly narrower on each side so that the 
shadow doesn’t appear on the upper road 
surface edges. (Use shadow_ply in the Over-
pass geodatabase.) An 80 percent black fill 
is applied (CMYK=0,0,0,80) along with a 
10 percent transparency. The finished product, 

compared with the original image, is shown in 
Figure 12.

Conclusion
This exercise outlined the basic steps and tools 
needed to create a textured 3D multipatch fea-
ture in ArcGIS 10. The workflow is simple, 


