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Creating Custom Formats With  
 ArcGIS Data Interoperability Extension

This tutorial uses the ArcGIS Data Interoper-
ability extension to create a custom import tool 
and a custom format for making GPS data held 
in comma separated value (CSV) files directly 
usable by ArcGIS. It requires an ArcGIS Data 
Interoperability extension license as well as 
ArcGIS 9 Desktop with an ArcView, ArcEditor, 
or ArcInfo license.

What Is ArcGIS Desktop
Interoperability Extension?
Based on Safe Software s̓ Feature Manipula-
tion Engine (FME) technology, ArcGIS Data 
Interoperability extension is a set of integrated 
tools that enhances the ability of ArcGIS to 
work directly with data in a multitude of for-
mats. This new extension enables users to per-
form the three key tasks necessary for seamless 
interoperability: direct read, format translation, 
and data model transformation.

What Is a Custom Format?
Custom formats are one of the most powerful 
capabilities of the ArcGIS Data Interoperability 
extension. A custom format creates a view, or 
skin of the data, so it can be used in a highly 
productive manner without physically being 
translated into a new format. When a custom 
format is used, no copy of the original data is 
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In the CSV Input Settings dialog box, check the 
box next to Field Names On First Line to indi-
cate the first row will contain attribute names 
and the rest of the CSV file columns will con-
tain data.

Workbench is a graphic environment for creating data model transformations. 

made. Consequently, if the original data chang-
es, there is no need to perform the translation 
process again. 
 A custom format consists of a set of data 
model transformations that is applied to data 
while it is being read from its native format and 
before it is presented to ArcGIS for display or 
analysis. Once a custom format is defined, it 
can be used just like any other format supported 
by ArcGIS to read any appropriately structured 
source data. For example, custom formats can 
be created and applied to CAD data to auto-
matically decode information stored in graphic 
attributes, such as line color or thickness, and 
turn it into meaningful attributes that can be di-
rectly used in ArcGIS. Additionally, as in this 
example, a custom format can create graphics 
and attributes from unstructured data. 

Getting Started
Before starting this tutorial, download the 
sample dataset from the ArcUser Online Web 
site and use WinZip to open the archive. If 

you do not have the ArcGIS Data Interoper-
ability extension, purchase or obtain a free 
30-day evaluation version from www.esri.com/
datainteroperability. Read the installation guide 
before installing the extension. 
 Once the ArcGIS Data Interoperability ex-
tension has been installed and licensed, enable 
it within ArcCatalog by choosing Tools > Ex-
tensions. Check the box beside Data Interoper-
ability. Access to data in a number of nonna-
tive formats becomes available immediately 
through both the ArcCatalog tree and Interop-
erability Connections node. The Data Interop-
erability Tools toolbox provides access to the 
Quick Import and Quick Export tools that can 
be used to move data directly between ArcGIS 
and a number of formats.
1. If the ArcToolbox window is not visible in 
ArcCatalog, add it by clicking the Show/Hide 
ArcToolbox Window button.
2. Add the Data Interoperability Tools toolbox 
if it is not visible. Right-click on ArcToolbox 
in the Toolbox pane and select Add Toolbox. 
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What You Will Need
•  ArcGIS Data Interoperability extension
•  ArcGIS 9 (ArcView, ArcEditor, or ArcInfo license)
•  Sample data downloaded from ArcUser Online
•  An unzipping utility such as WinZip

Browse to Toolboxes, then to System Toolbox-
es, and then select Data Interoperability Tools. 

Setting Up a User Toolbox
In this tutorial, you will be creating a custom 
import tool. Because custom tools cannot be 
added to system toolboxes, a new user toolbox 
must be created. 
1. Right-click on the ArcToolbox node from 
within the Toolbox pane. 
2. Select New Toolbox from the context menu. 
3. Rename the new toolbox to My Interoper-
ability Tools.

Creating the Custom Import Tool
The first step in creating a custom format is to 
create a custom import tool. A custom import 
tool is used to bring data into a personal geo-
database from a format external to ArcGIS by 
applying data transformations to the data before 
it is written. Custom formats are always based 
on custom imports.
 In this tutorial, road data collected by a field 
technician using a GPS must be turned into 
something usable by ArcGIS. The road data 
points, stored in a CSV file, have a location 
along with a key identifying the road to which 
it belongs. The attributes of the road are stored 
in a database table with the same key value. The 
transformations necessary to build the road net-
work (complete with attributes) from the GPS 
survey points and the associated database can 
be defined using the custom import tool. 

Reading the CSV File
1. Right-click the My Interoperability Tools 
toolbox and select New > Custom Data Import 
Tool. In the Custom Data Import Tool Wizard, 
click Next to continue. 
2. When prompted to Select Source Format, 
click the Browse button to display the Formats 
Gallery, and double-click Comma Separated 
Value. This selects the format, closes the For-
mats Gallery, and populates the Source Format 
field in the wizard. Click Next.
3. When prompted to Locate Sample Source 
Data, click the Browse button and navigate to 
the location of the sample dataset. In this ex-
ample, the source CSV file has a .gps extension. 
Set the Files of Type to All Files, and double-
click the file major_roads.gps.
4. Click the Settings button to display the CSV 
Input Settings box. Since the first line of the CSV 
file contains field names, not geometry values, 
check the box beside Field Names on First Line. 

The Workbench canvas will display the source feature type connected to the destination feature.

5. Click OK to accept the settings, dismiss the 
settings box, and return to the wizard. 
6. Click Next and then click Finish. Work-
bench, the graphic environment for creating 
data model transformations, will start, and the 
Custom Import Tool template will be ready for 
editing. The Workbench canvas will display the 
source feature type connected to the destination 
feature.

Constructing Linear Topology
From x,y Coordinates
The first step in constructing linear topology 
from GPS data points is to create point geom-
etry from text attributes. Workbench transform-
ers needed for these operations can be located 
quickly by using the Search box. 
1. Click the Gallery tab at the bottom of the 
Navigator pane on the lower right side of the 
Workbench interface. Type 2DPointReplacer in 
the Search box and press Return, or click the 
Find button. The 2DPointReplacer transformer 
appears in the Search Results folder. 
2. Drag the 2DPointReplacer transformer from 
the Search Results folder to the canvas between 
the source and destination feature types.
3. Right-click the 2DPointReplacer transform-
er on the canvas, and choose Insert Before from 
the context menu. Accept the default selection 
in the window that appears, and click Next. 
The transformer will be connected between the 
source and destination feature types.
4. The 2DPointReplacer transformer displays 
a red exclamation point on its Property button, 
indicating that required information is needed. 
Click the 2DPointReplacer transformer Proper-
ties button to display the 2DPointReplacer Pa-
rameters dialog box.
5. In the X Value field, select the x attribute 
from the drop-down list; in the Y Value field, 

select the y attribute from the drop-down list. 
Click OK. Notice that the Properties button has 
changed to an ellipsis, indicating the transform-
er has the information it needs for operation. 
6. The 2DPointReplacer converts table features 
with no geometry into spatial features with 
point geometry. To verify this, select Tools > 
Route to Visualizer and then click the Run but-
ton (a triangular green button on the standard 
toolbar) to execute the custom import. When 
Route to Visualizer is set, output features are 
not sent to the destination feature types and are 
routed instead to the Visualizer. After viewing 
the points, minimize the Visualizer window.
7. The second step in constructing linear topol-
ogy is to create road lines from the GPS points. 
Type a PointConnector into the Search box 
on the Gallery tab and press Return. Drag the 
PointConnector transformer from the Naviga-
tor Pane to a spot on the canvas between the 
2DPointReplacer and the MAJOR_ROADS 
destination feature type. Right-click on it, 
choose Insert Before from the context menu, 
choose MAJOR_ROADS, and click Next. For 
Select Out Port, select POINTCONNECTOR: 
LINE and click Finish. On 2DPointReplacer, 
click on the green triangle next to POINT and 
drag it to the INPUT triangle for PointConnec-
tor.  The PointConnector connects points in the 
order it receives them. 
8. In this example, each GPS point has an 
identifier that links it to its road. Click the 
PointConnector properties button and set the 
Connection Break Attribute to road_id. This 
instructs the PointConnector to begin a new 
road feature every time the value of road_id 
changes. Click OK.
9. Click the Run button (or press F5) to verify 
that linear topology is being created. Minimize 

Continued on page 50
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the Visualizer window after viewing the lines 
created by PointConnector.

Joining Database Attributes
to the Road Lines
Now that features with linear geometry have 
been constructed, the next step is to attach attri-
butes for each road to the geometry. The Joiner 
transformer queries a database to retrieve the at-
tributes associated with a feature. One or more 
feature attributes (foreign keys) are joined to 
one or more columns (primary keys) in a table 
in the database, and the values for the matching 
table row(s) are added as feature attributes.
1. Use the Search box on the Gallery tab to find 
a Joiner transformer. Drag a Joiner transformer 
to an area between the PointConnector and the 
MAJOR_ROADS destination feature type. 
Right-click on the Joiner transformer, choose 
Insert Before, and choose MAJOR_ROADS. 
2. Click on the Joiner transformer properties but-
ton to initiate the Joiner Parameter wizard. Click 
Next to continue past the Welcome screen. 
3. When prompted to Specify External Data-
base, select the Microsoft Access file (*.MDB) 
from the Type drop-down list. Click the File 
Browse button and double-click the file road_
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When prompted to Match Keys, pair the prima-
ry key from the database with its corresponding 
feature attribute.

After constructing linear geometry and adding 
database attributes, the schema of the MAJOR_
ROADS is no longer current. The next step is to 
define the schema for the geodatabase feature 
class that will contain the road line.

attrs.mdb. Leave the Username and Password 
fields blank. Click Next.
4. When prompted to Identify Database Keys, 
specify ROAD_ID as the database field to use 
as primary key and click the > button to move it 
into the Keys text box. Click Next.
5. When prompted to Match Keys, pair the pri-
mary key from the database (ROAD_ID) with 
its corresponding feature attribute (road_id) by 
highlighting both and clicking the > button to 
commit the selection. Click Next.
6. When prompted to Select Database Columns, 
click the >> button to add all the database col-
umns to the feature attributes. Click Next.
7. Click Next for succeeding wizard panes to ac-
cept the defaults, and click Finish to close the wiz-
ard. 
8. Click the Run button to test the custom im-
port tool. View the results in Visualizer, and 
select one of the features to verify that the da-
tabase attributes are now available. Close the 
Visualizer window.

Defining the Destination Feature Type
The Custom Data Import Tool wizard created 
the MAJOR_ROADS destination feature to 
match the feature type from the source CSV 
file. With the linear geometry constructed and 
database attributes added, the schema of the 
MAJOR_ROADS destination feature is no 
longer current so the next step is to define the 
schema for the geodatabase feature class that 
will contain the road lines.
1. Right-click the MAJOR_ROADS destina-
tion feature and click Delete. 
2. Choose Destination Data > Import Feature 
Type Definitions to display the Import Destina-
tion Feature Types dialog box.
3. In the Format field, choose Microsoft Access 
Database (Attributes Only). In the Dataset field, 
click the browse button and navigate to the lo-
cation of the sample dataset. Double-click on 
road_attrs.mdb.
4. Click OK to close the Import Destination 
Feature Types dialog box and display the Select 

Feature Types to Load dialog box. Click OK to 
accept the default settings and dismiss the Se-
lect Feature Types to Load dialog box. 
5. Expand the major_roads destination feature 
type to verify that the attribute schema has been 
imported from the database. 
6. Click the major_roads destination feature 
properties button, and choose geodb_polyline 
from the Allowed geometries drop-down menu. 
Click OK.
7. Connect the JOINED output from the Joiner 
transformer to the major_roads destination fea-
ture type.
8. Choose Save from the File menu to save 
your Custom Import Tool, but leave the Work-
bench window open.
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Specifying the Coordinate System
There is no coordinate system information 
available with the source CSV file. However, 
ArcGIS Data Interoperability extension can be 
used to attach a coordinate system to the data. 
1. Click the Workspace tab in the Workbench 
Navigator panel and expand the major_roads 
[CSV] node and then the Parameters node.
2. Double-click the Coordinate System node to 
bring up the Edit Coordinate Systems dialog box. 
3. Click the Browse button to bring up the 
Spatial Reference Properties dialog box and 
click Select. Browse to: Projected Coordinate 
Systems > State Plane > NAD 1983 (Feet) > 
NAD 1983 StatePlane Texas Central FIPS 4203 
(Feet).prj. Click the Add button to confirm the 
selection. Click OK to dismiss the Spatial Ref-
erence Properties dialog box.
4. The selected coordinate system will be 
shown in the Edit Coordinate Systems dialog 
box. Click OK.

5. Choose Save from the File menu to save the 
custom import tool, but leave the Workbench 
window open.
 The custom import tool is now complete and 
can be used anywhere in the ArcGIS geoprocess-
ing framework (for example, in ModelBuilder) 
to import the GPS points as linear features into 
a staging personal geodatabase.

Creating a Custom Format
When the custom import tool is run, it creates 
a restructured copy of the original roads data 
in a personal geodatabase. If the original data 
were to change, the import would have to be 
rerun to ensure that the most recent version of 
the data was used.
 To use the data in a meaningful way without 
taking ownership, a custom format can be cre-
ated from a custom import tool. The resulting 
custom format can be applied to any source GPS 
road data files on an as-needed basis, to ensure 

the data being used is always up-to-date. Once 
a custom import tool is created, it is simple to 
turn it into a custom format. 
1. Choose File > Export As Custom Format to 
display the Set Custom Format Name and De-
scription dialog box. 
2. In the New Custom Format Name field, en-
ter GPS_Survey_Roads. In the New Custom 
Format Description field, enter GPS Survey 
Roads. Click OK to bring up a new Workbench 
window with the title GPS_Survey_Roads.
3. The next step is to associate the Custom For-
mat with files that have a .gps extension so the 
transformations will be applied automatically 
to all .gps files. Click the Workspace tab in the 
Workbench Navigator panel. Expand the ma-
jor_roads [CSV] node and then the Parameters 
node. Right-click on the Source CSV file, and 
choose Edit Parameter Prompt to bring up the 
Edit Parameter Prompt dialog box.

Continued on page 52
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4. If the existing Parameter Prompt does not al-
ready read, type the line below in the box. 

Source CSV Files(s)

The File Type Filter indicates the fi le extension 
with which this custom format will be associ-
ated. It consists of a description and a fi lter, 
separated by a | character. Delete the existing 
File Type Filter, and carefully type the follow-
ing statement.

GPS_Files(*.gps)|*.gps|All_
Files(*.*)|*.*.

In the Associate Format with Filter fi eld, choose 
Yes from the drop-down menu. 
5. Click OK to close the dialog box, and then 
save and exit GPS_Survey_Roads workbench. 
Save and close the Custom Import Tool work-
bench.

Using the Custom Format
The GPS Roads Custom Format is ready for use.
1. Restart ArcCatalog to refresh the list of fi le 
associations.

Creating Custom Formats With 
ArcGIS Data Interoperability Extension
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2. In the Catalog tree, browse to the location 
of the sample dataset and expand major_roads.
gps. Select the major_roads Interoperability 
Feature Class, and click the Preview tab to view 
the roads.
3. Click the Metadata tab and then the Spatial 
tab to verify that the data is in the correct coor-
dinate system.
 The GPS Roads Custom Format, like 
any format supported by the ArcGIS Data 
Interoperability extension, can now be used 
with ArcGIS including the geoprocessing 
framework.

Conclusion
The ArcGIS Data Interoperability extension pro-
vides a variety of ways to access data in ArcGIS. 
The data model transformation capabilities can 
be used to create Custom Import Tools, which 
transform data as it is brought into personal 
geodatabases so it is ready to use. Alternately, 
custom formats may be created to directly read 
and transform data on the fl y to make it highly 
usable within ArcGIS without taking owner-
ship of it. For more information about using the 
Custom Import and Custom Format tools in a 

CAD environment, see the online ArcGIS Data 
Interoperability tutorial at the ESRI Web site at 
www.esri.com/datainteroperability. 

About the Author
Tyson Haverkort is a product specialist at Safe 
Software. He is a graduate of the College of 
Geographic Sciences and the British Columbia 
Institute of Technology and has worked at Safe 
Software since 1999. Safe Software, located 
near Vancouver, British Columbia, Canada, 
and ESRI jointly developed the ArcGIS Data 
Interoperability extension.

Instantly re-create symbology 
when reusing data. All the 
information for symbolizing the 
data in an ArcMap layer can be 
saved as a separate ArcGIS layer 
(.lyr) fi le. Create a .lyr fi le by right-
clicking on the data layer and 
choosing Save as Layer File. Make 
it easy to reuse these fi les by 
providing descriptive fi le names 
and saving layer fi les in a separate 
folder. 
 Layer fi les reference source 
data based on the Data Source 
Options settings specifi ed for the 
source map. Change the default 
setting from full to relative before 
saving the .lyr fi le by choosing File 
> Map Properties, clicking on Data 
Source Options, and selecting 
relative paths.
 Import symbology by opening 
Layer Properties for the target 
data layer and clicking the Import 
button on the Symbology tab. 
Raster, proportional, chart, dot 
density, and multivariate symbols 
cannot be imported from .lyr 
fi les. Use these symbology types 
by adding the .lyr fi le to the map 
document. If the referenced data 
does not reside in the map, set 
the data source by right-clicking 
on the .lyr fi le and choosing Layer 
properties, click on the Source 
tab, and click the Set Data Source 
button.

Reuse Symbology 
With .lyr Files
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