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Leverage Data Investments
 With ArcGIS Extension 
By Katie Clift, ESRI Technical Marketing Specialist

What You Will Need
•  ArcGIS 9 with Service Pack 1
    (ArcView, ArcEditor, or ArcInfo license)
•  ArcGIS Data Interoperability extension, installed
•  Sample data downloaded from ArcUser Online

Good spatial data is the foundation of any mean-
ingful geographic analysis. Individual depart-
ments in an organization may use GIS software 
from different vendors but still need to work 
together and optimize the organization s̓ data 
investments. Data sharing used to mean spend-
ing valuable time converting source datasets 
across formats to perform data visualization, 
analysis, or mapping tasks. The ArcGIS Data 
Interoperability extension has largely eliminat-
ed these challenges.
 While ArcGIS supports direct read for 
a variety of data formats, the ArcGIS Data 
Interoperability extension, based on Safe Soft-
ware s̓ Feature Manipulation Engine (FME) 
technology and incorporating Safe Software s̓ 
extensive knowledge of spatial data formats, 

The Formats Gallery, which shows all the data formats supported for direct read and data import

This tutorial uses data in five formats that will 
be incorporated in an analysis operation using 
the ArcGIS Data Interoperability extension. By 
creating an Interoperability Data Connection, a 
directory of CAD files will be read as one spatial 
dataset and used as input for a geoprocessing 
model.

greatly expands support for spatial data formats 
from many vendors. It adds direct read capabil-
ity for 70 more spatial formats and the ability to 
export more than 50 spatial formats. With this ex-
tension, many more datasets can easily be added 
to maps or included in geographic analysis. 

Tutorial Overview
This tutorial introduces the ArcGIS Data 
Interoperability extension and uses data in five 
formats. The data will be displayed in ArcMap 
using direct read capability. By creating an 
Interoperability Data Connection, a directory of 
CAD files will be read as one spatial dataset and 
used as input for a geoprocessing model.

Setting Up the Project
The ArcGIS Data Interoperability extension 
should be installed before starting this tutorial. 
This extension can be purchased and download-
ed online. A complete evaluation copy is also 
available online and can be converted later to 
a full license.
1. Once installed, enable the extension in both 
ArcMap and ArcCatalog by choosing Tools > 
Extensions from the menu and checking the box 
next to Data Interoperability. Unlike many other 
ArcGIS extensions, the Data Interoperability ex-
tension does not have a toolbar but does add the 
Data Interoperability Toolbox to ArcToolbox.
2. Visit the ArcUser Online Web site at www.
esri.com/arcuser and download the archive con-
taining the sample dataset. Create a folder for 
the project called data_interop and unzip the 
archive into it.

3. The sample dataset includes a map document 
called DataInteropTutorial.mxd. Start ArcMap 
and open this document.
4. Choose Tools > Options from the main menu 
and check the Geoprocessing environment. 
In the Options dialog box, click on the Geo-
processing tab. Under the Display/Temporary 
Data, make sure the boxes next to Add Results 
of Geoprocessing Operations to the Display and 
Results Are Temporary by Default are checked.

Examining Data Layers
Click on the Source tab in the table of contents 
in ArcMap. The City Boundary, Rivers, and 
Recreational Areas data layers are sourced from 
personal geodatabase feature classes. However, 
data for the Highways data layer is stored in a 
Geomedia Access warehouse. If DataInterop-
Tutorial.mxd is installed in a different directory 
than the sample data, a red exclamation mark 
next to this layer indicates the link to the source 
data is broken. Steps 1 through 3 will repair the 
link. If the link is not broken, skip to step 4.
1. ESRI personal geodatabases and Geomedia 
Access warehouses are both stored in Micro-
soft Access databases. Choose Tools > Options. 
Select the Data Interoperability tab on the Op-
tions dialog box. Make sure the box next to Ex-
amine .mdb Files for Geomedia Warehouses is 
checked. Click OK.
2. Right-click on the Highways data layer and 
choose Properties. In the Properties dialog 
box, click the Source tab and click the Set Data 
Source button.

Continued on page 46
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3. Navigate to the Geomedia Access warehouse. 
Select the Highways line dataset. Notice that 
the data type shown is Interoperability Feature 
Class. Click OK.
4. Right-click on the Highways layer and choose 
Label Features to display labels using attribute 
table values. Save the map document.

Directly Use Interoperability
Data Sources
With the ArcGIS Data Interoperability exten-
sion, ArcGIS can add many non-ArcGIS data-
sets directly to a map using the same procedure 
employed when adding native ArcGIS datasets.
1. Click the Add Data button, navigate to the His-
toricDistrict.gml dataset in the \data\GML folder. 
Double click to expand this dataset and add the 
HistoricDistrict Polygon layer from this GML 
Version 2.x dataset. Click OK to ignore the Miss-
ing Projection Information message box.
2. Symbolize the HistoricDistrict dataset by 
importing the HistoricDistrict.lyr file from 
\LayerFiles\. Right-click on the layer, click on 
the Display tab, and change the layer transpar-
ency to 50 percent. Turn off the HistoricDistrict 
polygons.
3. Click the Add Data button, navigate to the 
\data\MapInfo\SchoolDistricts.TAB. Expand 
the SchoolDistricts.tab and add the SchoolDis-
trict Polygon from the dataset. Again, click OK 
to ignore the Missing Projection Information 
message box.
4. Symbolize the SchoolDistricts Polygon data 
by adding the file SchoolDistricts Polygon .lyr 
file. Turn off the SchoolDistricts Polygon data. 
Save the map document. 

Configure an Interoperability Connection
In ArcCatalog, Interoperability Connections can 
be configured to specify connection properties 
for non-ArcGIS datasets. Configuring a connec-
tion can assign spatial reference information so 
ArcMap can reproject the data on the fly or cre-
ate a single dataset from a group of tiled CAD 
files. This section describes the process used for 
configuring an Interoperability Connection that 
will read specific CAD file properties for an in-
put dataset. 
1. Open ArcCatalog. Navigate to lots_DGN in 
the Data folder. Preview one of these DGN files 
in ArcCatalog. 
2. Scroll down the table of contents and expand 
the Interoperability Connections node. Double-
click on Add Interoperability Connection.
3. In the Interoperability Connections dialog 
box, click the … button next to the Format 
drop-down list to display the Formats Gallery, 
which shows all of the data formats supported 
for direct read and data import. Many of these 
formats are also available for data export. Se-
lect the MicroStation Design format by double-
clicking on it.

This model in ModelBuilder uses Geomedia Access warehouse, MapInfo TAB files, and MicroStation 
CAD files as input data for an analysis.

4. Click the … button next to the Dataset text 
box. Navigate to lots_DGN in the Data direc-
tory. Hold down the Shift key and click to select 
all the DGN files as input. Click Open.
5. Click the Settings… button to access format 
specific configuration settings. For this tutorial, 
accept the default values.
6. Click the … button next to the Coordinate 
System text box. The standard ArcGIS Spatial 
Reference dialog box appears. On the Spatial 
Reference dialog box, click the Import button 
and navigate to the RecAreas feature class in the 
DataInteropTutorial.mdb personal geodatabase 
in the data folder. Assigning the Spatial Refer-
ence will allow ArcMap to perform on-the-fly 
projection on the Interoperability dataset. When 
finished, click OK twice to exit all dialog box-
es.
7. To preview the Interoperability Connection 
in ArcCatalog, expand the new connection and 
select the 1Polygon feature class. Click on the 
Preview tab in ArcCatalog s̓ right pane. A win-
dow will appear that shows the indexing prog-
ress. Features are indexed to a file on disk to 
free memory and improve performance. A tiled 
parcels dataset will appear when indexing is 
complete. 
8. Choose View > Refresh or press F5 to update 
the Interoperability Connection information in 
the ArcCatalog tree. Initially, the Interoperabil-
ity Connection will show all possible configura-
tions as read from the source dataset. After in-
dexing the features and refreshing the Catalog 
tree, the Interoperability Connection will only 
show populated feature classes. 
9. Click the Add Data button in ArcMap, navi-
gate to the newly configured Interoperability 
dataset, and click to expand it. Select 1 Poly-
gon and add it to the map. 1 Polygon can also 
be dragged and dropped from the Interoper-

ability Connection to ArcMap. Save the map 
document.

Using Interoperability
Datasets in a Model
Integration with the geoprocessing environment 
is twofold—as non-ArcGIS datasets that are di-
rectly read and as data sources that are directly 
incorporated into geoprocessing models as in-
put feature classes. This functionality allows re-
peated execution of geoprocessing work flows 
when updated results are required and/or a non-
ArcGIS dataset has changed even if the dataset 
was edited in its native software package.
 In this section, selections will be performed 
on the Geomedia Access warehouse data (High-
ways), MapInfo TAB files (SchoolDistricts 
polygons), and the CAD polygon layers (DGN 
Lots). 
 If the ArcToolbox window is not already 
open, open it. Navigate to data\DataInteropTu-
torial.mdb and add the DataInteropTutorial tool-
box, right-click on ArcToolbox and choose Add 
Toolbox. This toolbox contains two models, one 
for users with an ArcEditor or ArcView license 
and the other for users with an ArcInfo license. 

ArcEditor or ArcView License Users
1. Choose Selection > Select by Attributes from 
the main menu. In the Select by Attributes dia-
log box, choose Highways (Geomedia) as the 
layer and create the expression “NAME” = ʻUS 
HWY 301ʼ. Click Apply.
2. Choose Selection > Select by Location. Check 
the box next to 1 Polygon and choose Intersect. 
Select Highway (Geomedia) as the other layer 
and make sure Use Selected Features and Use a 
Buffer to the Features of Highways (Geomedia) 
are checked. Make the buffer 150 feet. 
3. Expand the DataInteropTutorial toolbox. 
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The model output was exported to GML 
using the Quick Export tool and added 
back to the map.

Right-click on the SelectParcels_ArcEditor_ 
ArcView tool and choose Edit.
4. Run the model by clicking the Play button or 
selecting Model > Run Entire Model.

ArcInfo Users
1. With this license, the selection steps are in-
corporated into the Geoprocessing model. Ex-

pand the DataInteropTutorial toolbox. Right-
click on the SelectParcels_ArcInfo tool and  
choose Edit.
2. Click the Play button to run the model or 
select Model > Run Entire Model from the 
ModelBuilder menu. 
 Notice that the results of this simple analysis 
have been added to ArcMap as a feature class 

called LargeParcelsNear301. These features 
have been selected from the 1 Polygon parcels 
(DGN) dataset based on proximity to US Hwy 
301 using the Geomedia Highways feature class 
and SHAPE_Area > 200,000 ft2. The results of 
this analysis can be exported into non-ArcGIS 
formats.

Export Model Results
to Non-ArcGIS Formats
The ArcGIS Data Interoperability extension adds 
the Data Interoperability Toolbox to the geopro-
cessing environment. This toolbox contains two 
tools—Quick Import and Quick Export. These 
quick tools require limited input from the user 
to import or export data. More detailed import 
or export functionality is also available with this 
extension. The user can create custom import, 
export, and data transformation tools. In addi-
tion, export functionality could be incorporated 
into a geoprocessing model.
1. In ArcToolbox, expand the Data Interoper-
ability Tools toolbox and double-click the Quick 
Export tool. 
2. In the dialog box, select LargeParcelsNear301 
for the input layer. 
3. Click the … button to access the Output 
Data Destination dialog box. Click the … but-
ton next to the Format text box and select GML 
Version 2.x from the list.
4. Click the … button next to the Dataset text box 
to specify the output destination as \data\output 
and the file name as LargeParcelsNear301.
5. Add the converted data to ArcMap. While 
most formats can be read directly without 
configuring an Interoperability Connection in 
ArcCatalog, some export formats require an In-
teroperability Connection. 

Conclusion
Geographic analysis and mapping are data de-
pendent activities. Converting data to and from 
proprietary formats can be repetitive and time 
consuming, but with the ArcGIS Data Interoper-
ability extension, ArcGIS can directly use data 
in a wide variety of vector data formats. This 
extension provides impressive data import and 
export functionality that can be automated in 
using the geoprocessing work flow. For infor-
mation on using this extension to create custom 
formats and tools, see the accompanying article, 
“Creating Custom Formats With ArcGIS Data 
Interoperability Extension.” For more informa-
tion about this extension, visit www.esri.com/ 
datainteroperability. 
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