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The Dilemma at the Border
  Registering Vector Data Across Datums
By Mike Price, ESRI
As I work with GIS professionals in earth 
science, natural resources, public safety, and 
other fields in the United States and around 
the world, one of the most common and dis-
concerting complaints that I hear is “My data 
is not quite lining up! It is off by just a few 
meters.”
 Data mismatch can stem from many factors 
including incompatible projections, inconsis-
tent map units, and different plotting scales. 
Differences in the relative age of data sets may 
mean differences in data collection methods 
and accuracy. The improper application of a 
datum to a data set is an increasingly common 
and very important cause of data alignment 
problems. 
 Datum issues are some of the least under-
stood and most troublesome reasons why data 
sets may not align properly. Datum differences 
in geographic or projected space are often 
not identified until significant problems arise 
that require considerable money and effort to 
resolve.
 This tutorial will familiarize GIS profes-
sionals with the importance of datums and 
demonstrate methods for identifying and fixing 
datum differences. An accompanying article 
“Datums—Who Needs ’Em Anyway?” pro-
vides an overview of datum development and 
use. Coincidentally, while researching this arti-
cle, I received a request for assistance from the 
El Centro Sector office of the United States 
Border Patrol. Two similar sets of street data, 
one from the El Centro Sector office and 
another from the San Diego Sector office, were 
not aligning. Data in different datums proved 

 ArcView GIS and ArcInfo 8 ship with a 
five CD–ROM data set called ESRI Data & 
Maps. For this exercise, make sure you have 
the 1999, not the 1998, version of this set. The 
needed files are located on Disc 3, “Western 
United States (by State).” These files are also 
available as a separate self-extracting zipped 

The U.S. Border Patrol uses GIS to assist with rescue efforts. 

tems including two data sets in unknown coor-
dinate systems. Creating a data framework to 
manage different data sets is important. Before 
downloading, copying, or unzipping any files, 
set up the following directory structure.
1. Open Windows Explorer and create a direc-

tory named BrdrPtrl at or near the root 
directory on your hard drive.

2. Under this directory, create a subdirectory 
named SHPFiles. Inside of SHPFiles, 
create four subdirectories named LatLon27, 
LatLon83, Unknown, and UTM27z11.

3. Download sample data from the ArcUser 
Online Web site and place the files in the 
subdirectories as shown in Figure 1. 

Create a directory structure to organize files.

file on the ArcUser Online Web site accompa-
nying the online version of this article. These 
files contain 1:100,000-scale data describing 
roads in the State of California. If you are 
using the data from the CD–ROM, navigate 
to \the westusa\ca folder and locate seven files 
with a “cards” prefix that make up this data 
set. If you are using the downloaded data set, 
simply extract the files into the UTM27z11 
subdirectory previously created.
 In addition to the familiar .shp (shape), 
.shx (shape index), and .dbf (dBASE) files, 
this data set contains .avl (legend) .sbn (spa-
tial bin), .sbx (spatial bin index), and .prj (pro-
jection data) files. Left click cards.prj to select 
it. This file contains projection information for 
the California roads data. Projection informa-
tion is provided for all data sets on the 1999 
version of ESRI Data & Maps CD–ROMs.
 To view the projection information con-
tained in cards.prj, hold down the Shift key 
and right click on the file name to bring up 
a context menu. Select Open With from the 
menu list, scroll down and select WordPad, 
and click OK. Stretch the WordPad window 
across the screen. The new one-line projec-
tion file format shown below is used by the 
ArcView Projection Utility and ArcInfo 8 and 
contains information on projection, datum, 
spheroid, prime meridian, units of measure, 
and y-shift.

to be the source of the problem. The El Centro 
Sector street data was built using the North 
American Datum of 1927 (NAD27) while 
the San Diego Sector uses street centerline 
data created using North American Datum of 
1983 (NAD83). These offices have generously 
allowed me to use their data.

Setting Up the Project Environment
In this exercise, we will manage and use data 
registered in several projected coordinate sys-
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GEOGCS[“GCS_North_American_1983”,

DATUM[“D_North_American_1983”,SPHEROID

[“GRS_1980”,6378137,298.257222101]],

PRIMEM[“Greenwich”,0],

UNIT[“Degree”,0.0174532

925199433]]

 This file confirms that the California 
roads data is stored in geographic coordinates 
(latitude/longitude) using NAD83. If you are 
using the data from the CD–ROM, it is not 
necessary to copy this file, but if you are using 
the downloaded version, place this file in the 
LatLon83 folder.

Setting Up the Project
With the data organized, the next step is to 
create a new ArcView GIS project with four 
views. Start ArcView GIS, create four new 
views, and choose View > Properties to rename 
them with the names shown in Figure 2. Choose 
Windows > Tile to tile these four empty views 
in the ArcView GIS window.
 Load shapefile data into three of the views 
as shown in Figure 3. Don’t worry about load-
ing data in 3. Lat Long NAD27 yet. In 2. Lat 
Long NAD83, turn on the Clippol1 theme and 
zoom in on the El Centro, California, area. 
Turn on the cards.shp theme. Because a legend 
(.avl) file called cards.avl was saved in the 
same location, a prebuilt legend for cards.shp 
will automatically be applied. Now is a great 
time to do some project housekeeping. Choose 
File > Set Working Directory and set the 
default data path to \BrdrPtrl\SHPFiles. Name 
the project Border01 and save it in the BrdrPtrl 
folder.

Understanding Our Data
Select 1. Unknown Projection, Datum. To keep 
the screen proportioned for this project, use 

the maximize button to expand the view so 
that it fills the screen. Choose View > Proper-
ties and verify that map units are set to deci-
mal degrees and distance units are in meters. 
Double click on the Street2k theme in the 
legend. Use the Legend Editor to change the 
legend to a unique value color scheme that 
contrasts with the colors in the prebuilt legend 
for the Street10 theme.
 Take a careful look at the Street10 and 
Street2k themes. Even at a scale of 1:100,000 
there are significant differences between these 
two shapefiles. Zoom both themes so that 
downtown El Centro is at a 1:5,000 scale. 
Locate the same feature in both themes and 
use the Measure tool to determine the east–
west offset between the two data sets. This 
offset should be approximately 77 meters or 
about one-half of a city block. This is just 
what the El Centro Border Patrol GIS analysts 
saw—a data offset caused by the application 
of two different datums. The Border Patrol 
needed to merge these data sets and map at 
parcel level scale so a discrepancy this large 
was unacceptable.
 To determine the datum for the Street10 
and Street2k data, let’s compare these data 
sets with data in a known projected coordi-
nate system. Copy the Street10 and Street2k 
theme from 1. Unknown Projection, Datum 
to 2. Lat Long NAD83. Select both themes 
and use Edit > Copy Themes, make the 2. Lat 
Long NAD83 view active, and choose Edit > 
Paste to add both themes to the 2. Lat Long 
NAD83 view. 
 This view already contains the ESRI sample 
data for this area that is registered in geographic 
coordinates in NAD83. Turn the Street10 and 
Street2k themes on and off individually and 
change the scale by zooming out to 1:100,000 
and into 1:24,000. Notice that the Street10 

Choose Windows > Tile to tile four empty views 
in the ArcView GIS window then add themes to 
first, second, and fourth view. 

Using the measuring tool reveals that the two 
themes are about 77 meters offset from each 
other. 

While Street10 theme aligns quite well with 
Card.shp, the Street2k theme shows a half 
block east–west offset. Do not stare at this for 
too long—it can be very hard on your eyes!

Continued on page 34
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theme aligns quite well with the known set, 
Card.shp, while the Street2k theme shows a 
half block east–west offset. Do not stare at 
this for too long—it can be very hard on your 
eyes!
 After viewing these themes at both 
1:100,000 to 1:24,000 scales, you can reason-
ably conclude that the Street10 data is reg-
istered in geographic NAD83 space, while 
Street2k is not. Since the Street10 data has 
been identified as being in geographic NAD83, 
use Windows Explorer to save the Street10 
files in the \LatLon83 directory as Street10. 
Determining the datum of Street2k will require 
a little detective work. Some ways for finding 
out projection and datum information might 
include reading a metadata file or calling the 
data provider. After learning that Street2k is an 
older data set registered in geographic NAD27 
space, there are two choices—order a replace-
ment data set in NAD83 or use the ArcView 
Projection Utility to reregister the data in 
NAD83. Before reprojecting this data set, use 
Edit > Cut Themes to remove the Street2k 
theme from 2. Lat Long NAD83 and use Edit 
> Paste to add it to 3. Lat Long NAD27.

Reregistering with the
ArcView Projection Utility
The ArcView Projection Utility will be used to 
associate the Street2k theme with the NAD83 
datum. 
1. Choose File > Extensions to load the Pro-

jection Utility Wizard extension. Start 
the Projection Utility by choosing File > 
ArcView Projection Utility and wait as it 
loads.

2. In the Projection Wizard, select Street2k as 
the shapefile to reregister. Notice that the 
coordinate system shown for this data is 
unknown because there is no projection 
(.prj) file for this data set. One will be 
created soon. 

3. Click the Next button to go to Step 2. In the 
Step 2 panel, check the Show Advanced 
Options box to display four tabs—
Name, Parameters, Datum, and Ellip-
soid. Click on the Name tab and verify 
that the ArcView Projection Utility has 
recognized Street2k as being in GSC-
NORTH_AMERICAN_1927 [4267] and 
that units are set to degrees. To specify 
a new datum for Street2k, click on 
the Datum tab and choose select 
NAD27_to_NAD83_NADCON as the 
Geographic Transformation type. Click 
Next to continue. A dialog asks if you 
want to save this new coordinate system 
information. Click Yes to create a pro-
jection file and store it in the Unknown 
directory.

The Dilemma at the Border
Continued from page 33

4. In Step 3, choose Geographic as coor-
dinate system type and select 
GCS_NORTH_American_1983 [4269] as 
the Name and Degrees [9102] as the 
units. The datum transformation rules are 
set, so click Next to continue. 

5. Step 4 asks for a location for the reregis-
tered data. Save the new shapefile to the 
\SHPFiles\LatLon83 directory and name 

Street2k is an older data set registered in geographic NAD27. Before reprojecting this data set, 
cut it from 2. Lat Long NAD83 and paste to 3. Lat Long NAD27.

After reprojecting Street2K, inspect the summary page and verify that the parameters are correct. 

it Street2k. The same name can be used 
because the new shapefile will be stored 
in a different directory. Click Save, then 
Next to continue.

6. Review the Projection Utility Summary. 
Verify that the input geographic transfor-
mation and the new file name and loca-
tion are correct. If not, use the Back 
button to move back through the process 
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If correctly registered, the 
newly reprojected Street2k 
theme should sit right on 
top of Street10 in 2. Lat 
Long NAD83.

and fix any errors. Print this page and 
save it for future reference.

7. When everything is correct, click Finish 
to complete the process. When finished, 
ArcView GIS will ask if you want to add 
the new data to a view. Click Yes and 
navigate to SHPFiles\LatLon83 subdirec-
tory, select the Street2k theme and add it 
to 2. Lat Long NAD83 view.

8. Maximize 2. Lat Long NAD83 and notice 
that the new Street2k shapefile is turned 
off, on top of the Table of Contents, 
and its legend is a Single Symbol type. 
Double click on the Street2k theme and 
use the Legend Editor to choose a color 
that contrasts with the Street10 theme 
streets. Turn the Street2k theme on.

 If correctly registered, Street2k should sit 
right on top of Street10 in 2. Lat Long NAD83. 
Zoom in and see how these themes align now. 
Your boss at the Border Patrol is sure to be 
pleased with your results—the Street10 and 
Street2k data sets are now registered in the 
same datum.

A Bigger Challenge
Now for the data loaded in the 4. UTM 
NAD27, Zone 11 view. This data is from 
the United States Geological Survey (USGS) 
EROS Web site and includes 1:100,000-scale 
digital line graph (DLG) roads data registered 
in a Universal Transverse Mercator (UTM), 
a nongeographic space, using NAD27. Your 
mission is to get this data to line up with 
themes in the 2. Lat Long NAD83 view. Try 
this one when you have plenty of time to con-

centrate.
 Here is a hint: Reproject the usgs100k 
theme to geographic coordinates in NAD27 
and add it to the 3. Lat Long NAD27 view. 
Reregister the geographic NAD27 data to geo-
graphic NAD 83 in the 2. Lat Long NAD83 
view. If you do this correctly, you should 
see a close, though not exact, alignment of 
both Street themes and the USGS DLG roads 
theme. If you do this, you are a true Projection 
and Datum Wizard.

Summary
Once the Border Patrol El Centro Sector office 
realized the two Street data sets were built 
using two different datums, they obtained a 
NAD83 data set to replace the one in NAD27. 
As GIS users become more sophisticated and 
use data from a variety of sources, differences 
in data set datums will become more of an 
issue. With a better understanding of datum 
and projection issues, you can identify and 
correct issues caused by something as small as 
“just a few meters.”


