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Modeling the Wildland/Urban Interface
By Mike Price, Entrada/San Juan

Complex vegetation types and the highly 
variable topography on which our forests 
grow present special management challenges. 
These wildland fuel managers have combined 
many years of study and practical observation 
with spatial technology to create classification 
systems for forest fuels and topography that 
gauge fire hazard. The National Fire Protection 
Association’s NFPA1144—Standard for 
Protection of Life and Property from Wildfire 
addresses the relationship of slope and fuels 
so that the fire hazards around homes located 
at the Wildland/Urban Interface (WUI) can be 
assessed.
 This exercise uses a small portion of the 
Firewise Communities workshop dataset to 
create a slope/fuel hazard model in ArcGIS 
using limited data input—just digital elevation 
model (DEM) data and a local vegetation 
shapefile. To enhance the model, roads and 
hydrography data from the U.S. Census 
Bureau’s TIGER files are also included, 
together with data on historic fires.

Getting Started
After downloading the sample data from the 
ArcUser Online Web site, unzip the archive 
and it will create the directory structure shown 
in Figure 1.
1. Open an ArcMap session, and choose 

Tools > Extensions and enable the 
ArcGIS Spatial Analyst extension. 
Choose View > Toolbars and toggle on 
the Spatial Analyst toolbar.

Figure 1: Directory structure for exercise data

This exercise creates a slope/fuel hazard 
model in ArcGIS using just digital elevation 
model (DEM) data and a local vegetation 
shapefile as input for the analysis. The 
model is enhanced by adding roads and 
hydrography data from the U.S. Census 
Bureau’s TIGER files and historic fire data.

Creating a hillshade will aid in visualizing 
topography using the 30-meter DEM, 
topogr30.

2. Click the Add Data button and navigate 
to \FireModl\GRDFiles to load topogr30, 
the 30-meter DEM of the study area. 
A message box warns that projection 
information is not available for this layer. 
Click OK to dismiss it.

3. Right-click on topogr30, choose 
Properties, click on the Symbology tab, 
and choose an appropriate color ramp. 
Save the map document as FireMod1.mxd. 
When inspecting the DEM, note that 
regional drainage trends from north to 
south and that elevation varies between 
approximately 900 to 3,700 feet. Before 
continuing, let’s establish the extent and 
some parameters ArcGIS Spatial Analyst 
will use for the model.

4. In the Spatial Analyst toolbar, choose 
Spatial Analyst > Options. In the Options 

dialog box, click on the General tab and 
set the working directory to \FireModl\
GRDFiles.

5. Click on the Extent tab and set the extent 
to Same as Layer “topogr30”. Click on 
the Cell Size tab and set the cell size to 
Same as Layer “topogr30”. 

6. Click on the General tab again and set 
topogr30 as the Analysis Mask. Leave all 
other parameters unchanged. Click OK 
twice to save and apply these changes.
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What You Will Need
• ArcGIS 8.x (ArcInfo, ArcEditor, or ArcView license)
• ArcGIS Spatial Analyst extension
• Sample data from the ArcUser Online Web site
 (www.esri.com/arcuser)
• An unzipping utility such as WinZip

After duplicating the 
vegetation shapefile, apply 
ArcView 3 legends to 
thematically map these layers.

7. Choose File > Map Properties and in the 
Map Properties dialog box, add some 
descriptive text that documents this 
map. Click on the Data Source Options 
button in the lower right corner. Click 
the radio button next to Store Relative 
Path Names, and click OK twice to retain 
these changes and close the dialog box. 

 Now the map can easily be moved to 
another drive or computer because setting 
data sources to relative paths allows ArcMap 

to automatically find all relevant data from a 
new location.

Creating a Hillshade
A hillshade will aid in visualizing the 
topography of this area.
1. Choose Spatial Analyst > Surface 

Analysis > Hillshade from the Spatial 
Analyst toolbar. 

2. Verify that topogr30 is the input surface 
and leave azimuth at 315 and altitude 

at 45 so that the sun will shine from 
the northwest, creating shadows on the 
southeast side of ridges. Save the output 
raster as Hlshgr30. Click OK to create 
a hillshade, which loads in the Table of 
Contents above the DEM. 

3. Right-click on Hlshgr30 and select 
Properties. Click the Display tab, and set 
Transparent to 50 percent. Now you can 
really visualize this major north–south 
drainage and its many tributaries.

Modeling Fuels From Vegetation Data
It’s time to load the vegetation shapefile and 
assess the fuel aspects of the model. Click the 
Add Data button and navigate to the \FuelModl\
SHPFiles directory and add vegepol1. Right-
click on vegepol1 and choose Open Attribute 
Table. The fields in this table include Holland 
Description (HOLLANDTEX) and the Fire 
Behavior Officer (FBO) Fuel Model Codes 
(FBOMODEL). 
 The FBO codes will be used to classify 
the hazard associated with type of fuels. The 
vegetation types and associated FBO ratings 
are summarized in the table that is included 
with the sample dataset. Remember that the 
data for this training model is generalized 
to represent conditions that could be found 
throughout the United States. Do not use 
these classifications as a guide! Seasonal 
variation and poor forest health can push fuels 
into a higher hazard class. Consult a local 
forest management professional for detailed 
information on fuel model classes that apply 
to your area. A couple of legends that were 
originally created in ArcView 3.x have been 
included in the sample dataset. They will be 
used to code vegetation by name and FBO fuel 
class.
1. Before importing these legends, make a 

duplicate copy of this layer. Right-click 
on vegepol1 and select Copy. Right-click 
on Data Frame (i.e., default name Layers) 
and select Paste Layer. 

2. Right-click on the new layer and choose 
Properties. Click on the General tab 
and rename this layer vegepol2. Drag 
vegepol1 to a position just below the 
partially transparent Hlshgr30. 

3. Import a thematic legend for the 
vegepol1 layer by right-clicking on 
its name and selecting Properties. 
Click on the Symbology tab. Click 
on the Import button. In the Import 
Symbology dialog box, click on the 
radio button next to Import Symbology 

Continued on page 48
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Definition from an ArcView 3 Legend 
File (*.avl): and use the browse button 
to navigate to Vegepol1.avl, located 
in \FireModl\SHPFiles. In the Import 
Symbology Matching dialog box, assign 
the HOLLANDTEX value field to 
Vegepol1.avl and click OK.

4. Repeat the process with the vegepol2 
layer. Use the Vegepol2.avl, assign 
FBOMODEL as the value field, and click 
OK. Save the map document.

Deriving Topographic Slope in Percent
With the 30-meter DEM, the slope of this 
area can be calculated, modeled, and related 
to potential fire severity and rate of spread. 
The NFPA 1144 standard uses percent slope, 
classified in ranges, to assign risk points to 
structures within 300 feet of these areas. 
Table 1 shows the values that will be used 
to reclassify the slope generated from the
30-meter DEM and assign hazard points based 
on steepness. After creating a percent slope grid 
and then classifying it, the NFPA 1144 Hazard 
Points can be applied to each grid cell.
1. In the Spatial Analyst toolbar, choose 

topogr30 from the drop-down Layer 
box. Choose Spatial Analyst > Surface 
Analysis > Slope. 

2. In the Slope dialog box, click the 
radio button for Percent, set Output to 
\FireModl\GRDFiles\, and permanently 
name the output sloppct1. Click OK to 
create slope.

Apply a red–yellow–green color 
ramp to the slope percentage grid 
that is generated from topogr30.

3. Drag sloppct1 below the hillshade and 
vegetation layers. Make the sloppct and 
the Hlshgr30 visible. Right-click on 
sloppct and choose Properties. 

4. Click on the Symbology tab and choose 
Create a Stretched (continuous) legend for 
slope, and apply a green–yellow–red color 
ramp. Slope values for this dataset should 
range from 0 to slightly more than 100. If the 
range is lower, delete the grid and rebuild it. 
This time, be careful to specify percent rather 
than degrees. Save the map document.

5. Classify the slope grid by assigning the 
point values specified in the NFPA 1144 
standard. In the Spatial Analyst toolbar, 
set sloppct1 as the active layer. Choose 
Spatial Analyst > Reclassify. 

6. In the Reclassify dialog box, click on the 
first field in the Old Values column and 
type 0 – 10. Don’t omit a space before 
and after the hyphen! Click the New 
Value field and type 1 if necessary. 

7. Continue in the same manner creating 
four more ranges for higher slope 
hazards, and assign the corresponding 
NFPA hazard points as shown in Table 1. 
Use the Delete Entries button to remove 
any unnecessary ranges. Name the output 
raster slopcls1 and click OK to continue. 

8. To visualize slope hazard, place the 
newly classified grid just below Hlshgr30 
and make those the only visible layers. 
Create a custom yellow–orange–dark red 
legend to show increasing slope hazard. 

Gridding Vegetation
and Classifying Fuel Hazard
Vegepol1 was duplicated so that it could 
be used to generate the two grids that will 
display vegetation type and FBO fuel type 
classifications. After FBO values are gridded, 
they can be reclassified to assign fuel hazard 
points established in NFPA 1144. Table 1 
summarizes these vegetation types as FBO 
fuel classes and Table 2 relates FBO fuel 
classes to the NFPA 1144 fuel hazard points.
1. To create the first grids, choose Spatial 

Analyst > Convert > Features to Raster. 
In the Features to Raster dialog box, 
set vegepol1 as the input feature, 
HOLLANDTEX as the field to grid, and 
vegegrd1 as the output raster. Click OK. 
After the new grid is added to the map, 
move it to a spot just below the bottom 
vegetation shapefile.

2. Repeat this process to create an FBO 
fuel type grid by selecting FBOMODEL 
as the grid field, and name the output 
raster vegegrd2. Move this grid to a 
position just above vegegrd1. Notice 
that the initial legend for each grid is a 
value grid. Open the attribute table for 
both, and verify that vegegrd1 contains 
the HOLLANDTEX field and vegegrd2 
contains the Value field. 

 Now for a slick trick! The prebuilt 
layer files that were included in the sample 
dataset will properly symbolize these grids. 
Click the Add Data button and navigate to 

Reclassify the slope percentage grid 
(sloppct1) on the value field using the fields 
in Table 2.
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Table 1: Classification of 
topography and assigned 
hazard points based on 
steepness

Old Value
(min–max slope in percent) 

New Value
(NFPA Hazard Points)

0 – 10 1

10 – 20 4

20 – 30 7

30 – 40 8

40 – 999 10

No Data No Data

Table 2: 
Reclassification 
values to relate 
FBO fuel 
classes to the 
NFPA 1144 fuel 
hazard points

Old Values
(FBO Fuel Codes)

New Values
(NFPA Hazard Points)

NFPA Class Fuel Description

0 0 Non Fuel Water, urban, agricultural, riparian (seasonal)

1;2;3 5 Light Grasses, forbs, saw grass, and tundra

5;6;7;8;9 10 Medium Light brush and small trees

4;10 20 Heavy Dense brush, timber, and hardwoods

11;12;13 25 Slash Timber harvesting residue

No Data No Data N/A N/A

Table 3: 
Descriptive layer 
names

File Name Descriptive Name

topogrd30 Topo Grid 30 M

sloppct Slope Percent

Hlshgr30 Hillshade Topo Grid 30 M

slopcls1 Reclassified Slope NFPA 1144

vegepol1 Vegetation Poly, Raw

vegepol2 Vegetation Poly, Fuels

vegegrd1 Vegetation Grid, Raw

vegegrd2 Vegetation Grid, Fuels

fuelcls1 Reclassified 

owner1 Ownership Poly

hostfire Historic Fires Poly

tgr_lkh TIGER Hydrography Line

tgr_lka TIGER Transportation Line

\FireModl\LYRFiles\, and add the FBO Fuel 
Grid and Vegetation Grid layer files. If the 
vegetation grids were properly created, 
named, and stored, they will be reloaded with 
appropriate legends. If the Layer files do not 
load properly, carefully review the file and 
directory naming conventions used. 
 When inspecting the newly symbolized 
vegetation grids, notice that vegetation in 
drainage bottoms is often classified as Light 
while fuels on hillsides are typically classified 
as Medium with pockets of eucalyptus and 
chamise chaparral rated as Heavy fuels.

Reclassifying FBO Types to Hazard Points
The next step uses the FBO fuel types to 
determine NFPA 1144 hazard points. Make 
vegegrd2 the target layer in the Spatial 
Analyst toolbar, and choose Spatial Analyst > 
Reclassify. In the Reclassify dialog box, click 
the Unique button and type 0 (zero) as the 
first old value and 0 as a new value. Complete 
the dialog using the values shown in Table 2. 
Use semicolons (;) between numbers rather 
than commas, delete any unused entries, and 
leave No Data unchanged. Specify fuelcls1 as 
the output raster and click OK. Place fuelclsl 
below the vegetation polygons and create a 
color legend for it. Save the map.

Modeling Slope and 
Fuel Hazards With NFPA 1144
Before continuing, this is a great time to 
customize the model by adding data layers 
that help orient the user and providing more 
meaningful layer names.

1. Use the layer files supplied with the 
sample dataset to quickly enhance the 
model with predefined legends. Click 
the Add Data button, navigate to the 
\FireModl\LYRFiles subdirectory, and 
add layer files for TIGER Transportation, 
TIGER Hydrography, Ownership, and 
Historic Fires.

2. Right-click on layers listed in Table 3 
and choose Properties. In the Properties 
dialog box, click on the General tab and 
rename each layer by combining the file 
name with the descriptive name in the 
second column of Table 3.

 One more grid calculation is needed 
to create a composite slope/fuel model.
NFPA 1144 standards provide a numeric scale 
for assessing wildland fire risk and hazard 
severity. Two important pieces of information 
are the kind of vegetation located within
300 feet of structures and slope within 300 feet 
of structures. As shown in Tables 1 and 2, points 
are assigned for increasing severity of both items. 
Fuel hazard classes vary from 5 for light fuels to 
25 for timber harvest slash. Topography points 
vary from 1 to 10. By summing the reclassified 
slope (slopcls1) and reclassified vegetation 

Continued on page 50
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Use the Raster Calculator to summarize the 
NFPA 1144 Hazard Points, the fuelcls1 and 
slopcls1 layers. 

Modeling the Wildland/Urban Interface
Continued from page 49

grids (vegegrd1 and vegegrd2), ArcMap will 
be able to calculate and display the slope/fuel 
hazard in the model.
1. Choose Spatial Analyst > Raster 

Calculator from the Spatial Analyst 
toolbar. Enter the formula either by typing 
or by choosing layers and operators. 
[Reclassified Fuels NFPA 1144 
fuelcls1] + [Reclassified 
Slope NFPA 1144 slopcls1]

2. Click Evaluate to create a new grid that 
sums slope fuel hazards. Grid values for 
this region should vary between 1 and 
30; 35 is the absolute maximum. Save 
it as a permanent grid by right-clicking 
on the new grid’s name and choosing 
Make Permanent. Name the grid slopfuel 
and place it in the \FireModl\GRDFiles 
directory. Path and name are critical now, 
so be precise! 

3. Click Add Data and navigate to
\FireModl\LYRFiles. Add the Slope Fuel 
Grid.lyr file and position it just below 
Hillshade Topo Grid 30 M, and make it 
visible. Save the map one more time!

Sit back to admire and explore a sophisticated 
slope/fuel model. Identify areas where 
wildland fire hazard is least and where it is 
greatest. Turn on the Historic Fires layer and 
compare it with the changes in vegetation and 
slope. Look for roads that serve as firefighter 
access routes and life breaks.

Summary
This exercise used a 30-meter DEM and a 
vegetation shapefile to create a realistic slope/
fuel hazard model for the WUI. The slope grid, 
generated from the DEM, was classified based 
on NFPA 1144. Vegetation types were assigned 
an FBO Fuel Model number by a wildfire fuels 
specialist, and these fuel model rankings were 
used to create a fuel hazard grid. The fuel 
hazard grid was also classified using the NFPA 
1144 standard. After summing both classified 
grids, slope/fuel hazard can be assessed. The 
safest locations to build residences can be 
determined. Past fire extents can be assessed 
and fire suppression opportunities explored. 
Although this exercise was developed from 
actual data, the fuel rankings applied should 
not be used to assess hazards. For more 
information on the WUI, visit the Firewise 
Web site at www.firewise.org.

For more information, contact

Mike Price, Principal
Entrada/San Juan
E-mail: mike_price@frontiernet.net

Apply a custom yellow–orange–dark red legend 
to the reclassified slope layer (slopcls1) to show 
the slope hazard.

Reclassify the FBO fuel types to determine 
NFPA 1144 Hazard Points based on the 
information in Table 3. 

Customize the model by adding TIGER 
Transportation, TIGER Hydrography, Ownership, 
and Historic Fires layers and providing meaningful 
names for all the layers. 


