What You Will Need

ArcGIS 8.2 (ArcView, ArcEditor, or Arclnfo license)
ArcGIS Spatial Analyst extension

Sample data from the ArcUser Online Web site
(www.esri.com/arcuser)

An unzipping utility such as WinZip

Suitability Analysis With

Raster Data

By Chris Wayne, ESRI-Olympia

This exercise, the first of a two-part series, will
teach you how to work with raster layers using
the ArcGIS Spatial Analyst extension. You
will be creating and converting grid layers to
prepare them for input into an analysis model.
Then you will run a model to determine
potential sites for a new landfill.

In this tutorial, you will prepare and
model data that will help a fictional county
use GIS to identify suitable sites for a new
landfill. These sites will be chosen based
on the characteristics of the land, water, and
soils in the county. The tutorial sample data
came from the Montana Natural Resources
Information System (NRIS) and is public
access data. However, this data has been
modified for purposes of this exercise, and
you should not use it for anything other than
this exercise. To acquire real data, go to the
NRIS Web site (nris.state.mt.us). The site
provides data so that additional factors, such
as wilderness areas or population centers, can
be considered in your analysis.

Notes on Working With Grids

Grids are actually collections of files within
several folders in a directory. Never move,
rename, copy, delete, or otherwise alter grids
in Windows Explorer—always use ArcCatalog.
Grid names must be less than 11 characters,
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and the name of any grid folder, shapefile,
table, or other file should not contain spaces
or any character other than a letter, number,
or underscore.

Setting Up the Data

After downloading the sample dataset from
ArcUser  Online  (wWww.esri.com/arcuser),
create a folder on your computer called
landfill and unzip the archive into it. The
archive creates subfolders named If analysis
and Results. The If_analysis folder has several
subfolders. The Results folder will be used
to store the results of all the analysis steps.
Inspect the contents of these folders in both
ArcCatalog and Windows Explorer before
starting the exercise.

Define the Study Area

In this section you will use the Options dialog
box in ArcGIS Spatial Analyst to save steps
while processing data for the analysis. The
raster data analysis generates a lot of new
grids. The cell size and map extent must be
specified for each new grid. Instead of doing
this for each grid individually, you can set
a default cell size and extent in the Options
dialog box. This will also help maintain
consistency in the data that you create.

1. Start an ArcMap session. Enable the
Spatial Analyst extension. This is a two-
step process. Choose Tools > Extensions
from the menu and check the box next
to Spatial Analyst. Next, choose View >
Toolbars and check Spatial Analyst on.
The Spatial Analyst toolbar will appear.
You can leave it floating or dock it.

2. Open landfill_analysis.mxd in the
landfilNIf_analysis\ subfolder. From the
Spatial Analyst toolbar, choose Options.
In the Options dialog box, click on
the General tab and set the Working
directory to landfil\If _analysis\analysis.
Click OK but do not close the Options
dialog box.

3. The analysis extent sets the
x,y coordinates for all the grid operations.
Although the extent can be specified by
using another layer, the intersection or
union of layers, or manually entering
x,y coordinates, the analysis extent will
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always be a rectangle. However, an
analysis mask, which works in much the
same way, can use only a layer as a mask
but uses the actual shape of the layer
instead of a rectangular envelope. This
exercise will use an analysis mask. Still
on the General tab of the Options dialog
box, select county_bnd from the drop-
down box next to Analysis mask. Read
the Analysis Coordinate System section
of the dialog box but do not modify it.
4. Click on the Extent tab. Select Same as
Layer county_bnd from the drop-down
box. Click on the Cell Size tab and select
As Specified Below from the drop-down
box, and enter 1000 in the Cell Size box.
Click OK and save the map document.

Make a Slope Map

The elevation layer is a continuous surface of
values. Information can be derived from this
surface, such as hillshading, contour lines,
and slope, which indicates the rate of change.
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Slope

will be a relevant factor in siting the

landfill because the topography of an area is
an important consideration for excavation.

1.

Make the elevation layer visible. In
the Spatial Analyst toolbar, choose
Surface Analysis > Slope. Set Input
surface as Elevation and Output
measurement as Percent. Accept the
rest of the defaults (i.e., Z Factor 1,
Output Cell Size 1000, Output raster:
<Temporary>). A new layer, with the
same shape as the county outline, will
be created. Its values (rounded) should
range from 0.07 to 28.51.

Right-click on the Slope of Elevation
layer and choose Properties. In
the Properties dialog box, click on
the Source tab. This grid layer is
a continuous (i.e., floating point),
temporary dataset. Click on the
Extent, Display, and Symbology tabs
to explore the grid’s properties before
closing the Properties dialog box.

WWW.esri.com

3. Because this grid will be needed for
future analysis, convert it from a
temporary grid to a permanent one.
Right-click on Slope of Elevation and
choose Make Permanent. Save the file
as slopemap in the landfill \If_analysis\
d_analysis\ subdirectory.

To demonstrate the effect of the analysis
mask, choose Spatial Analyst > Options
and click on the General tab. Change the
Analysis mask to None. Running the slope
and hillshade operations as previously
described will produce an output grid that
has the same extent as the county’s bounding
box but does not honor the actual shape of the
county. Change the Analysis mask back to
county_bnd, and delete the temporary rasters
just created.

Creating Buffers for Analysis

Figure 1 shows all the layers needed for
this analysis as they should appear in the
Table of Contents. The distance from both
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Generate a multiringed buffer around the
streams using the Buffer Wizard.

Layer Visible | Legend
landfills No Show
streams Yes Show
county_bnd No Hide
elevation No Hide
Slope of elevation | No Hide
Coverclass No Hide

Figure 1: Layers

streams and existing landfills will also be a
factor for siting the new landfill. The core
functionality in ArcGIS contains a Buffer
Wizard that simplifies the process of creating
buffers. Although many existing landfills have
been built right on riverbanks, this is a less
acceptable practice today so distance from a
waterway will be one of the criteria used in
selecting a site. Make the Streams layer active

Continued on page 56
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Suitability Analysis With Raster Data

Continued from page 55
Panel Action
1 Buffer the streams layer.
’ Make sure distance units are set to kilometers. Choose As Multiple Buffer Rings, and make four rings with one
kilometer between each ring.
3 Choose Yes to dissolve barriers between buffers. Save the buffer in a new layer as a new shapefile in landfill\If_

analysis\d_analysis\ and accept the default name, Buffer_of_streams.shp.

Figure 2: Choices for Buffer Wizard

and Choose Tools > Buffer Wizard from the
menu. Use the parameters for each panel in the
wizard shown in Figure 2 to build the Stream
buffer. Buffering may take a few minutes to
perform so be patient. Click the Help button
for additional information if necessary.

The stream buffer layer will be added to
the map. Examine the layer’s attribute table
by right-clicking on the layer in the Table of
Contents and choosing Open Attribute Table.
What fields does the table have? How many
records does it contain? Close the table, and
make the layer invisible.

A feature class (whether stored in a
geodatabase or as a shapefile) has different
data structures than a grid. A feature class
layer must be converted to a grid before
Spatial Analyst can perform analysis on it.
Choose Spatial Analyst > Convert > Features
to Raster. Select Buffer_of_streams.shp as the
input layer and ToBufDist as the field. Save
this grid as landfillNf analysis\d_analysis\
buff_temp, and click OK.

A new floating point grid is added to the
map. Confirm this by right-clicking on the
layer, choosing Properties, and clicking on
the Source tab. Because an analysis mask was
applied to this layer, the county_bnd layer
defines the shape of this grid not the streams
or the buffer shapefile.

There are two types of grid layers —floating
and integer. Floating point grids represent
continuous data, such as elevation, store
numbers with decimal places, and don’t have
attribute tables because the possible number of
unique cell values is too large. Buff temp is
a floating point grid. To avoid problems later
in the analysis, use the Raster Calculator to
change buff_temp to an integer grid.

1. From the Spatial Analyst toolbar,
choose Raster Calculator. In the text
box, type the following statement,
making sure there is a space
between int and the parentheses:
int ([Buff_templ)

2. Click on Evaluate, and a new grid is
created and added to the map. Right-
click on this new layer, choose Make
Permanent, and save it as strmbuff
in the landfill\if_analysis\d_analysis\

56 ArcUser April-June 2003

% landfill_analysis.mx»d - Arc™Map - ArcInfo

J File Edit Wew Insert Selection Tools ‘Window Help

=B x|

B

J Spatial Analyst = ‘ Layer |elevatiom

1:1,864,440 s | g | &l add Features o TIN. .. ‘ k? |

|IDER&| & PRBX |0~

Bl £ Gallatin County = ‘
=l O Buffer_of _streams
Buffer Distance
m0.00-1.00
I 1.00-2.00
[[z.00-3.00
[13.00-4.00
B O landfils

N
El M streams

B O counky_bnd

- YR AR S ¥ Rl ANoyS]

]
El & buff_temp
Yalue

[]1 - 1.333333333
[]1.333333334 - 1. 666666667
[ 1 BEEBREEES - 2
[]2.000000001 - 2.333333333
[7]2.333333334 - Z.666666667
[ 2. GEEBEEEEE - 3 =l

Display I Source

+
B

|
[~

=R

| |455646.06 5354600 Meters | %

Change the floating point grid to an integer one using the Raster Calculator.

subdirectory.

3. Right-click on the strmbuff layer
and choose Properties. Click on the
General tab to change the name to
Stream Buffers. Make it invisible.

4. Delete buff temp and buffer_of
streams.shp from the Table of
Contents, and save the map.

Calculate Distance From

Existing Landfills

Next, you will use Spatial Analyst to calculate
the distance of every cell from the location of
open landfills in the county.

1. Verify that the landfills layer is at the
top of the Table of Contents, and make
it visible.

2. To work only with open landfills,
choose Selection > Select by
Attributes from the menu, and in
the Select by Attributes dialog box,
set Landfills as the layer, choose to
create a new selection, and use the
query builder to create the expression

“STATUS” = ‘0’. Click Apply. Three
landfills should be selected.

In the Spatial Analyst toolbar, choose
Distance > Straight Line and set
Landfills as the Distance To: layer.
Accept the rest of the defaults. Click
OK. Setting a maximum distance is
not necessary because the analysis
mask will define the search area.

A new raster layer is created. Move
the new grid below the landfill layer so
both layers are visible. The new layer
should be the shape of the county. The
values in this grid represent meters
from any given point to the nearest
open landfill.

Right-click on this layer and choose
Make Permanent. Save it as sl_dist
(i.e., straight-line distance) in landfill\
If_analysis\d_analysis\. Right-click on
the layer again, choose Properties, and
rename the layer sl_dist. Save the map.
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Add a Soil Drainage Grid

Soils data is important to include in landfill
siting analysis because this data often
indicates wetlands, rock depth, and drainage.
Click on the Add Data button, and navigate to
landfill>\If_analysis\d_analysis\ and add the
soildrain.lyr layer to the map. This grid has
already been converted from a polygon feature
class to a grid. The original polygon feature
dataset was included in the sample dataset and
can be found in landfilNIf_analysis\d_gallatin\
county_data.mdb\soils.

Prepare for Analysis

The last phase in this tutorial will prepare
the project data for the analysis that will be
performed in the second part of this exercise.

1. Right-click on the Data Frame, choose
Properties from the context menu,
and click the General tab. Change the
name of the Data Frame from Gallatin
County to Suitability Analysis.

2. Right-click on the Suitability Analysis
Data Frame and choose New Group
Layer from the context menu. Right-
click on the New Group Layer, choose
Properties, click the General tab, and
change the name to Final Proposal.

3. Drag the landfills, county_bnd, and
Slope of elevation layers into the Final
Proposal group layer and make this
group layer invisible.

4. Delete the streams
layers.

5. Activate Suitability Analysis. This
Data Frame should have the layers

and elevation
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Use ArcGIS Spatial Analyst to
calculate the distance of every cell
from the location of open landfills in
the county.
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listed in Figure 3 and be listed in
the Table of Contents in the order
shown. Hide all the legends for these
layers. The Final Proposal group layer
provides background data. All other
layers will be used for suitability
analysis.
6. Save the map document now.

Layer Visible
sl_dist Yes
soildrain Yes
Stream Buffers Yes
Coverclass No
Final Proposal No

Figure 3: Table of Contents

Overview of the Model

Most of the model design process—
determining the relevant factors, getting data
for these factors, and documenting the entire
process in a flowchart—has been done for
you. The procedures in this tutorial made
the data usable for analysis. The second
part of this tutorial, to be published in the
July—September 2003 issue of ArcUser, will
cover reclassifying each of the five suitability
factors on a scale of one to five and creating a
new integer grid for each factor. Combining
all of these grids will generate a ranking for
each cell for landfill suitability. The combined
grid, reclassified on the same one to five scale,
will take all three factors deemed important to
the new landfill site into consideration.
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