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Spatial modeling technology is growing like wildfire within the emergency management com-
munity. In areas of the United States where the population has expanded to abut natural areas, 
the risk of wildland fire is great. The term Wildland/Urban Interface (WUI) is used to describe 
these areas. Special mitigation and response strategies have been developed to manage risk in 
these areas. The National Fire Protection Association (NFPA) has developed a set of standards 
for evaluating risk in developing areas threatened by wildfire.

This article presents a portion of very simple wildfire risk model. It shows how to use the 
ModelBuilder interface of ArcView Spatial Analyst 2 to model just two of the many factors 
that influence wildfire risk—slope and fuel. Together, these two factors make up one of the 
criteria specified in the NFPA 299 Standards for Protection of Life and Property from Wildfire. 
A realistic model of wildfire risk would use complex data that would include a very detailed 
breakdown of the vegetation into fuel classes and would model both slope and aspect. Addi-
tional data on weather history, the locations of structures, fire history, access, the evacuation 
routes available, and other factors that might affect fire ignition and spread would also be 
incorporated in the model. 

ModelBuilder uses wizards to guide the user through the steps required for developing grid 
data using DEM to Grid, Vector to Grid, and Point Interpolation processes. In this exercise, 
digital elevation model (DEM) data and vector files will be converted to grid data and assigned 
a fire risk value and percentage of influence. When run, the model will generate a map show-
ing overall fire hazard risk. Though very complex models can be created rapidly, this example 
demonstrates the basic procedures used to add data and processes, set model parameters, run 
the model, and output a map. One of the strengths of ModelBuilder is that smaller models can 
be combined into larger models for performing very complex analysis. 

Getting Started
1. Visit the ArcUser Online Web site to download firemodl.zip, the sample data set for 

this tutorial. 
2. Using Windows Explorer or another file management system, create a directory called 

firemodl and unzip the sample data using Winzip or a similar file unzipping utility.
3. Start ArcView GIS. Choose File>Extensions and check the box next to the Model-

Builder extension. 
4. Open a new project and view. Do not add data to the project.
5. Choose View>Properties and change the map and distance units to meters.

The extent of the theme and the cell size can 
be set for the entire project through the project 
defaults. 



Special

Data conversion processing options that can be 
assigned to a function include Vector to Grid, DEM 
to Grid, and Point Interpolation. 

The extent of the theme and the cell size can be set 
for the entire project through the model defaults.

Add Vegetation and Study Area Themes
1. Click the Add Themes button, making sure the Data Source is set to Feature 

Data Source. Navigate to the firemodel directory and add the vegetation.shp and 
studyarea.shp files to the view. 

2. In the view Table of Contents, click on the studyarea.shp theme and drag it to the top.
3. Click the check boxes for the studyarea.shp and vegetation.shp themes to draw them. 

A higher fire risk value is associated with certain types of vegetation. The study area theme 
limits the extent of the output themes created by the erosion model. The wildfire risk model 
will be built in the ModelBuilder window.

Start ModelBuilder and Set Defaults
1. In the View menu, choose Model>Start ModelBuilder. 
2. From the ModelBuilder interface, choose Model>Model Defaults. Default settings are 

automatically applied to all processes in a model but can be overidden. 
3. Click on the Extent tab. Click on the Extent of This Theme option and choose 

studyarea.shp from the drop-down box. Click on Apply to Entire Model. 
4. Click the Cell Size tab. Click the This Cell Size option and type in 30. Click on Apply 

to Entire Model and then OK to exit the dialog box. The model will now create new themes 
with a cell size of 30 meters.

Add a DEM to Grid Data 
Conversion Process
The DEM to Grid conversion process converts a DEM file to an elevation grid theme that can 
be used to calculate slope data. 
1. Choose Add Process>Data Conversion>DEM to Grid. The DEM Conversion wizard 

opens. Read the introductory panel and click Next. 
2. In the next panel, click on the Browse button to locate and select the elevation.dem file 

in the firemodl folder and click Next. 
3. This panel is used to define the properties of the output grid theme. The legend table 

determines how values in the output theme will be grouped in the output theme legend. 
Accept the default legend and click Next.

4. In the next panel, choose Green Monochromatic as the output color scheme and click 
Next.

5. The default extent for this model was set to the Study Area theme using the Model 
Defaults option, so click Next. 

6. In the next panel, click Next to accept the default cell size of 30 meters that was set 
using Model Defaults. 

7. In the documentation panel in the next panel type “This process converts DEM data 
to an elevation grid that will later be converted to slope data.” in the Comments text 
box and click Next.

8. In the next panel, type “Elevation Grid” for the theme name. Because these are grid 
files, use the DOS file naming convention and limit file names to eight characters. Name 
the DEM conversion output file elevgrd. Click Finish. A DEM conversion process is 
added to the fire hazard model. The process has nodes with property sheets that allow 
you to access the process properties entered using the wizard. Note that the process does 
not run or create the grid theme after exiting the wizard. 

9. Choose File>Save and save the model to the firemodl directory.

Add and Define a Vector
Conversion Process
The DEM to Grid process was added using a wizard, but processes can be added by dragging 
and dropping nodes on the model window. Node properties are set using property sheets that 
look like wizard panels but are not sequential. Using this method, a Vector conversion process 
will be added to the model so that the vegetation shapefile can be converted to a grid theme 
and overlaid with a slope grid derived from the elevation grid. 
1. Click the Add Data button in the ModelBuilder interface. This button has a blue 

Vegetation data from shapefiles and elevation 
data derived from a DEM can easily be added 
to the model. 

Data conversion processing options that can be 
assigned to a function include Vector to Grid, 
DEM to Grid, and Point Interpolation. 
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Converts a point, line, or polygon theme to an integer grid
Converts a digital elevation model file to a floating-point grid
Converts a point theme to a floating-point grid

Groups the values in a grid theme into new classes and assigns
   them new values
Converts a floating-point elevation grid to a contour line theme
Converts a floating-point elevation grid to a slope grid
Converts a floating-point elevation grid to an aspect grid
Converts a floating-point elevation grid to a hillshade grid

Reclassifies all cells within a specified distance from
   a feature into a single buffer zone
Multiplies the values of two or more input themes by influence factors,
   then adds the values to produce an output grid
Reclassifies the cell values of two or more input themes to a common
   scale, then multiplies the reclassified values by influence factors
   and adds the values to produce an output grid

Description

Vector to integer grid
DEM to floating-point grid
Point interpolation

Reclassification

Contour
Slope
Aspect
Hillshade

Buffer zones

Additive overlay

Weighted overlay

Function

Data conversion

Reclassification
Terrain

Distance

Overlay

Spatial Operation
Category Spatial Operations

in ModelBuilder

The Weighted Overlay process combines 
different types of data by assigning eval-
uation scale values and the amount of 
influence to the values in each theme.

The Fuel/Slope Hazard model combines 
derived vegetation and slope data through a 
Weighted Overlay process.

rectangle icon. Click anywhere inside the model window to place a Data node. 
2. Pass the cursor over the ModelBuilder buttons to access the Tool Tips and locate the 

Add Function button. Click on it. Click inside the model window to the right of the Data 
node to place the oval Function and rectangular Derived Data nodes. 

3. Locate and click the Add Connection button. Drag a line between the Data and Function 
nodes. 

4. Click the Auto Layout button to arrange the layout. If necessary, click the Full View button 
to make the model fit in the window. The next steps define the properties of the Vector 
conversion process just specified.

5. Right-click on the Data node and choose Theme from the context menu. The Data node 
changes to a Theme node. Right-click on the new Theme node and choose Properties. In 
the Project Theme property sheet, type “Vegetation” as the project data name and select 
vegetation.shp from the drop-down box next to Choose input theme. Choose vegtype as 
the input field. Click OK. The Theme node name changes to Vegetation. 

6. Right-click on the Function node and choose Data Conversion>Vector to Grid from the 
context menu. The function changes to a Vector Conversion and the Derived Data node 
changes to Vector Conversion Map. 

7. Right-click the Vector Conversion node and click Properties. In the output file, each cell 
corresponding to a particular vegetation type stores the associated Class Value. This table 
shows those values. Click OK. 

8. Right-click the Vector Grid node and choose Properties. Select the Output Theme and type 
“Vegetation Grid” for theme name and veggrid for file name. Click OK. Click on the Save 
button in the ModelBuilder interface.

The Vector conversion process will now create a grid theme from the vegetation shapefile. The 
next step will be to create a Slope process. 

Create and Define a Slope Process
The rate of elevation change or slope is one of the factors that affects the hazard associated 
with fire in an area. Along with aspect, it affects the speed at which a fire will spread and the 
accessibility of an area to firefighters. Elevation data can be used to derive slope. The Eleva-
tion Grid output theme from the DEM conversion process will be used as the input theme to 
the Slope process. 
1. Click the Zoom Out button once to make room for a new process. Click the Add 

Function button and click inside the model window to add a Function node and its 
connected Derived Data node to the model. 

2. Right-click the Function node and select Terrain>Slope from the context menu. The 
Function name changes to Slope and the Derived Data node changes to Slope Map. 

3. The Slope wizard will be used to define the properties for the Slope process. The input 
data for this process is the output theme from the DEM conversion process, Elevation 
Grid. The wizard automatically connects the Slope and DEM conversion processes. 

4. Right-click on the Slope node and choose Wizard from the context menu. Click Next 
after reading the introductory panel. 

5. In the input panel, choose Elevation Grid as the input theme. Click Next. 
6. In the method panel, select Percent as the method for calculating slope and click Next. 
7. In the output theme type panel, choose discrete as the grid theme. The Slope process 

output can be a continuous grid theme of slope values or a discrete grid theme of 
slope classes. The Weighted Overlay process used to combine slope and vegetation data 
requires discrete grid themes. Click Next. 

8. In the classification panel, slope classes can be customized by editing the table. Click 
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Next to accept the default classifications.
9. In the color scheme panel, accept the default color scheme of red monochromatic and 

click Next. 
10. The extent was previously set to Studyarea.shp, so click Next. 
11. The cell size was also set to 30 meters by the model default. Click Next. 
12. In the documentation panel, select the Comments tab and type “This process converts 

elevation data into slope data.” in the text box and click Next. 
13. In the output theme panel, type “Slope Grid” for theme name and slopegrid for file 

name. Click Finish to exit the wizard. Maximize the ModelBuilder window. 
The Slope function is automatically connected to its input data, Elevation Grid. The vegetation 
and slope data can now be combined in a Weighted Overlay process. 

Define an Evaluation Scale
The Weighted Overlay process combines slope and vegetation data to assess the overall fire 
hazard. Because these themes do not contain similar data, the values in each theme must be 
converted to a common value scale. The common scale for this model will assign a value of 1 
to areas with the lowest wildfire potential and 3 to areas with the highest wildfire potential. The 
Weighted Overlay table will be used to define the input themes, their weights, and the scale 
values of each input in each theme.
1. From the Add Process menu, choose Overlay > Weighted Overlay from the menu. Read 

the introductory panel and click Next. 
2. In the evaluation scale panel, the predefined evaluation scale is set to 1 to 3. Accept 

this scale and click Next. 
3. In the Weighted Overlay table panel, choose Add Theme to open the Theme and Field 

dialog box. Click the input theme dropdown arrow and choose Slope Grid. Leave the 
input field dropdown list set to Value, the field that contains the slope values. Click OK. 

4. The Slope Grid theme is added to the Weighted Overlay table. 
5. On the Weighted Overlay panel, click Add Theme again. In the Theme and Field dialog 

box, choose Vegetation Grid as the input theme and leave Value as the input field. 
Click OK. 

6. Scroll to the bottom of the Weighted Overlay table to see that the Vegetation theme 
has been added. 

Set Influence Factors and
Assign Evaluation Scale Values
In the Weighted Overlay table, the Percent Influence field (%Inf) is used to assign the influ-
ence each theme has on the fire hazard assessment. In this model, slope will be deemed a more 
important factor in fire hazard than vegetation type. 
1. Click in the %Inf field next to the Slope Grid theme. Type 75. Now 75 percent of the fire 

hazard value for the output theme will be determined by the slope. 
2. Scroll down to the Vegetation Grid theme. Click in the %Inf field and type 25. 
3. The Sum of Influences field at the bottom of the panel now equals 100 percent. 

The Scale Value field assigns fire hazard potential (from 1 to 3) to slope or vegetation data. 
A special value, Restricted, is used for areas where no data is available or there is a body of 
water. 
1. For the Slope Grid theme, the fire hazard potential increases as the slope increases. Click 

in each cell of the Scale Value field and type the numbers shown in Figure 1. Choose the 
input values from the drop-down lists in each cell.

2. For the Vegetation Grid theme, set the scale values as shown in Figure 2. Barren areas 
have very low fire potential and water bodies have no fire potential. Forested areas 
have fire potential based on the ignition characteristics of each type of vegetation. Click 
Next. 

With each theme’s overall influence set and each slope and vegetation category ranked, this 
information can be overlaid into a single fire hazard theme. 

Modeling Fire Hazard
Page 4



Modeling Fire Hazard

The elevation grid derived from the DEM data is con-
verted to slope data using the Slope process.

Changing the evaluation scale and rerunning the 
model lets the user change the amount of risk assigned 
to various factors in the model. In the new version of 
the model, a much smaller area is colored dark red. 

The areas colored dark red are the areas of highest 
fuel/slope hazard. 

Define Properties for the
 Output Theme
1. Restricted areas have a light red default color. Change these areas of no data and water 

to gray. 
2. On the color scheme panel, double-click on the Restricted color in the Color field. The 

Color dialog box opens. In the Basic colors palette, click on a shade of gray and click 
OK. The color of the Restricted class changes to gray. Click Next to continue. 

3. In the extent panel, the extent of the output theme is already set to Studyarea.shp. Click 
Next. 

4. In the cell size panel, the cell size of the output theme is set to 30 meters. Click Next. 
5. In the documentation panel, select the Comments tab and type “This process determines 

the fire hazard by combining slope and vegetation data.” in the text box. Click Next. 
6. In the output theme panel, click in the Theme Name text box and type “Fuel Slope 

Hazard”. Click in the File Name text box and type “hazard”. 
7. Click Finish to add the process to the model. Click the Full View button. The input themes 

have been connected automatically to the Weighted Overlay process. 
8. Click Save. 

This very simple fire hazard model is complete. It converts an elevation DEM file to an eleva-
tion grid theme and the elevation theme to a slope theme. It converts a vegetation theme to a 
vegetation grid theme. Slope and vegetation types are ranked on a fire hazard evaluation scale. 
Finally, these themes are given weights and combined to create an overall fuel slope hazard 
value based on a uniform scale of 1 to 3. These fire hazard values become the values of the 
cells in the output theme. 

Save and Run the Model
The entire model can be run, or just selected processes within the model. Right-clicking a 
function node and choosing Run causes only the process to which the node belongs and any 
dependent processes to run. 
1. Right-click the Slope function node and click Run. 
2. After the process runs, the Slope Grid theme and the Elevation Grid theme are created 

in the view. 
3. Because the Slope process is dependent on the DEM conversion process, both of these 

processes run and are now marked with drop shadows in the ModelBuilder window. 
4. Return to the ModelBuilder window and click the Run button to run the entire model. 

The Elevation Grid, Vegetation Grid, and Fuel Slope Hazard themes are created in the 
view. In the model window, all nodes have drop shadows, indicating that the entire model 
has been run. 

Analyze Results and Modify Model
After looking at the Fuel Slope Hazard theme created by the model, you might decide to 
modify some of the fire hazard values. Because all the properties are saved in the model, you 
can adjust properties and rerun the model to get new results. 
1. In the ModelBuilder window, right-click the Weighted Overlay function node. Click on 

Properties to open the Weighted Overlay property sheet. 
2. Select the Overlay Table tab and scroll down to the Slope theme. Change the Scale Value 

for Value 4 to 1 and the Scales Values for Values 7 and 8 to 2. Click OK. 
3. Click the Run button. 
4. A new version of the Fuel Slope Hazard theme overwrites the old one. The new theme 

has more light red areas and fewer dark red areas, indicating lower overall fire hazard 
than the previous version. 

Exit ModelBuilder
1. In the ModelBuilder window choose  File > Exit and click Yes to save changes 
 to the current model document. 
2. In ArcView GIS, choose File > Close  All and File > Close Project. Click Yes to 
 save changes to the project.

After completing this exercise, you can appreciate how easy it is to convert and add data, incorporate 
analysis functions, and modify the resulting model to rapidly examine many “what-if” scenarios. 
For more information on ArcView Spatial Analyst 2 with ModelBuilder, visit the ESRI Web site 
(www.esri.com/software/arcview/extensions/spatext.html).
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