
What You Will Need
• ArcGIS (ArcInfo, ArcEditor, or ArcView license)
• ArcGIS Spatial Analyst extension or ArcGIS 3D Analyst extension
• Sample data downloaded from the ArcUser Online Web site
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By Mike Price, ESRI 

Deriving Volumes

This tutorial describes techniques for deriv-
ing volumetric data that were developed for a 
water assessment project in North Dakota that 
needed to calculate the amount of silt depos-
ited on a lake bottom. See the accompanying 
article, “Project Inspires New Approach to 
Volumetric Calculations,” to learn more about 
how these techniques were developed.
 Download the zipped dataset for this exer-
cise, PowersLk.zip, from the ArcUser Online 
Web site and use WinZip or a similar utility to 
extract the files into the root directory of the 
drive that will be used for this project. The 
zipped file will build appropriate subdirecto-
ries for the data.

Previewing Data in ArcCatalog
Open ArcCatalog, navigate to the PowersLk 
directory that was just created when the sam-
ple data was unzipped. Expand the PowerLk 
folder to examine the contents of the GRDFiles 

and SHPFile folders. Both folders contain a 
subdirectory named NDSP83NF. The naming 
convention used for this folder indicates the 
projection and datum applied to the data and, 
in this case, denotes data in North Dakota State 
Plane NAD83 North feet. 
 Select one of the shapefiles and click on 
the Metadata tab to view information on the 
projection, datum, and units. Scroll to the sec-
tion on spatial reference information. Notice 
that the projected coordinate system is custom. 
Review the parameters for North Dakota State 
Plane North which uses a Lambert Conformal 
Conic projection.
 Because the silt volume will be calculated 
in Imperial units (cubic yards and short tons), 
the model will measure easting, northing, and 
elevation values directly in feet. Click the Pre-
view tab and take a look at the geography and 
table views of each shapefile. Preview the layer 
files and notice that prebuilt thematic legends 
have been included and are stored within the 
layer set. View the original field data contained 
in the attribute table for Lake Samples Point 
shapefile.

Thickness Modeling in ArcMap
1. Open ArcMap and arrange the ArcCatalog 
and ArcMap windows so that both are ac-
cessible. Load the ArcGIS Spatial Analyst 
extension or ArcGIS 3D Analyst extension by 
choosing Tools > Extensions. Display the ex-
tension toolbar by choosing View > Toolbars.
2. In ArcCatalog, individually select all the 
files in both NDSP83NF folders and drag and 
drop them into ArcMap. Arrange the layers in 
the Table of Contents so that point layers are 
top, followed by polygon and grid layers. 
3. When done, close ArcCatalog and maxi-
mize ArcMap. Save the new ArcMap document 
in the PowersLk directory as PowersLk.mxd.

Exploring the Sample Data
Right-click on the Silt Thickness Merge Point 
layer and choose Open Attribute Table. Scroll 
to the right and inspect the fields named SILT-

With ArcGIS Spatial Analyst

Inspect the unzipped files in ArcCatalog.

THKFT and DATA_TYPE. Right-click on the 
SILTTHKFT header and choose Sort Descend-
ing. DATA_TYPE shows the three types of 
thickness data used in this exercise—transect, 
interpolated, and lake edge data. 
 The data includes good quality, well-dis-
tributed silt thickness points and lake edge 
point data that show zero thickness. Tran-
sect data was collected by the North Dakota 
Department of Health by dropping a probe 
through ice and measuring the distance to the 
top of soft silt and the depth to the consolidated 
gravel.
 Health department scientists, using profiles 
and other known information, estimated the 
interpolated points. The author created the lake 
edge points by converting the Powers Lake 
polygon to vertex points and assigning these 
points zero value for all depths.
 The distance to the top of soft sediment 
(WDEPT_FT) directly provides the wa-
ter depth. Subtracting depth to top of soft 
sediment from depth to consolidated gravels 
(LBDEPT_FT) yields silt thickness (SILTTH-
KFT). Let’s investigate the silt thickness. 
1. In the Silt Thickness Merge Point table, 
choose Options > Select By Attributes. In the 
SELECT FROM dialog window, create the 
expression DATA_TYPE <> Lake Edge. Ap-
ply this query. Click the Show Selected button 
to show the subset which should contain 159 
select records from a total of 577 records. 
2. Right-click on the SILTTHKFT column 
header and sort the selected records in de-
scending order. Right-click again onto the 
SILTTHKFT column header and choose Sta-
tistics to view a histogram and statistics for the 
selected attributes. The thickness values, away 
from the lake edge, range from 0.08 to 5.75 
feet.
3. Close the statistics dialog box, click the 
Show All button and choose Options > Clear 
Selection. Save the project.
 Next comes the tricky part—creating a 
thickness grid representing varying thickness 
of the silt throughout the lake. To simplify 

Tip: Available extensions can be quickly 
activated by right-clicking on an empty 
toolbar area.
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this exercise, the silthik grid file was carefully 
constructed using the ArcGIS Geostatistical 
Analyst extension. The silthik and its layer 
file, Silt Thickness Grid, are included in the 
sample data.
1. Make the Silt Thickness Grid and the Silt 
Thickness Merge Point the only visible layers, 
and zoom into any northern part of Powers 
Lake. 
2. Select the Identify tool and click anywhere 
inside the lake. In the Identify Results window, 
reset Layers to <Visible Layers>.
3. Use the Identify tool to query on several 
thickness points and verify that Silt Thickness 
Grid and the Silt Thickness Merge Point have 
similar values. 
4. The next step is to contour the thick-
ness set. Locate the Spatial Analyst toolbar 
and verify Silt Thickness Grid is the target 
layer. From the Spatial Analyst menu, choose 
Surface Analysis > Contour. In the Contour 
dialog box, set Contour Interval to 0.5 feet, 
leave Base Contour at 0 and Z factor at 1, and 
set Output Features to \PowersLk\SHPFiles\
NDSP83NF\ and name it ThickCon.shp. The 
Contour layer is automatically loaded in the 
map. Create a thematic legend for the contour 
layer and save the map document. Our model 
is certainly getting colorful! 

Deriving Volumes from 
Thickness Data With Cut/Fill
It’s time to get analytical. The Department of 
Health wants to calculate silt volumes in many 
lakes and ponds in western North Dakota. It is 
fairly easy for the Health Department to collect 
thickness data, especially in winter, when the 
lakes are frozen. Traditionally, volumes are 
calculated using a procedure called cut/fill. 
This process requires multiple topographic 
surfaces. The Before surface is subtracted from 

the After surface. To fully analyze lake bot-
tom sediment volume would require carefully 
constructing at least two elevation surfaces and 
performing  traditional cut/fill operation. 
 A little creative thinking led to a slightly 
different solution. What if all the cells in the 
mask grid were assigned a value of zero and 
then the mask grid was used with the Silt 
Thickness Grid to perform a cut/fill opera-
tion? Isn’t a volume just a first derivative of a 
thickness grid against a zero surface? Experi-
menting with careful thickness gridding and 
using the lake edge points made it possible to 
force model edges to approach zero thickness. 
Creating a grid of the lake polygon further con-
strained (masked) the model. Sounds too much 
like calculus, but let’s give it a try! Functional-
ity in the ArcGIS Spatial Analyst extension can 
help build the zero lake grid.
1. Set the working directory by choosing 
Options from the Spatial Analyst toolbar 
menu and click on the General tab. Specify 
\PowersLk\GRDFiles\NDSP83NF as the 
Working Directory.
2. Still in the Options dialog box, click on the 
Extent tab and set the extent to Same as Layer 
Silt Thickness Grid. Click on the Cell Size tab 
and set Analysis Cell Size to Same as Layer 
Silt Thickness Grid. Click Save, then OK. 
3. Reopen the Options dialog box and click 
on the Cell Size to verify that cell size is set to 
20 feet and the layer has 1,206 rows and 766 
columns.
4. In the Spatial Analyst menu choose Con-
vert > Features to Raster. In the Feature to 
Raster dialog box, select Powers Lake Poly as 
the Input features, and ID as the Field. A zero 
value has been conveniently preassigned to the 
ID field for this polygon feature. Name the 
output grid LakeGrid. Click OK.
5. LakeGrid will load into the map document. 
Move it to the bottom of the Table of Contents. 

After selecting the interpolated and transect 
values, right-click on the SILTHKFT header and 
choose Statistics in the context menu to display a 
histogram and statistics for these values. 

Generate contours for the Silt Thickness Grid 
layer using contour intervals of 0.5 feet. 

Convert the Powers Lake Poly shapefile to a 
raster file and save the new file as LakeGrid.

Use the Identify tool to verify the values are set 
to zero. This is SO important!  Right-click on 
LakeGrid in the Table of Contents and choose 
Properties to rename this grid to Lake Zero 
Grid. Save again.
6. Now for some magic! The next step is to 
use the Silt Thickness Grid against the new Lake 
Zero Grid to perform a cut/fill calculation. In the 
Spatial Analyst menu, choose Surface Analysis 
> Cut/Fill. In the Cut/Fill dialog box, set Silt 
Thickness Grid as the Before surface and Lake 
Zero Grid as the After surface. The Z factor is 
1 and keep the output cell size as 20. Leave the 
Output raster as <Temporary>. Click OK.
 This will create and load a new grid with 
gained volume (cut) as positive values, lost 
volume (fill) as negative, and a temporary 
name of cutfill#, where # is a counter specific 
to your computer. If the procedure aborts, try 
switching the Before surface to Lake Zero 
Grid, and run again. If the Before and After 
surfaces are switched, sediment cut values will 
be negative.

Continued on page 54
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Deriving Volumes With ArcGIS Spatial Analyst
Continued from page 53

Tabulating Areas and Volumes
and Calculating More Numbers
To tabulate and modify volume data will re-
quire editing the value table that resides with 
the new grid. Right-click on the name of the 
cut/fill layer and open its attribute table which 
contains five fields, including Volume and 
Area, and 21 records. Most records have small 
areas and a volume of zero representing the 
tiny portions of Powers Lake where silt was 
not measurable. To get a quick volume, right-
click on the Volume field header and choose 
Sort Descending. Hold down the Control and 
click on the two nonzero values to select them, 
click on Show Selected, and right-click on the 
Volume header and choose Statistics. Check 
out the Sum line. These calculations have de-
rived a total of 195,261,200 cubic feet of mud! 
Close the Statistics window. Choose Show 
All and Options > Clear Selection when done 
viewing these statistics.
 This is a useful value but excavation dredge 
production is measured in cubic yards per hour. 
The trucks that will haul removed material to 
a landfill are weighed in short tons. Also, it 
would be nice to know the average thickness 
of all sediment in the lake.
1. To add new fields and calculate mate-
rial units, export the CutFill table as a dBASE 
file for further editing. With the Attributes of 
Cut/Fill table open, choose Options > Export 
and save all records to \PowersLk\GRDFiles\
NDSP83NF\ as cutfill4.dbf. Click on Yes 
to add the table to the project. Click on the 
Table of Contents Source tab to view the table. 
Right-click on the Cutfill between Silt Thick-
ness Grid Lake Zero Grid layer and choose 
Make Permanent and name the grid. Save the 
project.
2. Open the exported dBASE table and add 
the new fields highlighted in Figure 1. Set the 
type, precision, and scale as indicated.
3. Start an Editing session by choosing Editor 
> Start Editing for the Editor toolbar.
4. To calculate values for each new field, 
right-click on the header for each new field and 
choose Calculate Values from the context. Use 
the formulas shown in Figure 2. When finished 
calculating values, choose Editor > Stop Edit-
ing and save the edits. Close the table.
5. Apply a tabular join to associate the 
CutFill4.dbf records back to the original Cut/
Fill table. Right-click on the Cutfill between 
the Silt Thickness GridLake Zero Grid layer 
in the Table of Contents and choose Joins and 
Relates > Joins. Use the Value field as the field 

Drag LakeGrid to the bottom of the Table of Contents after it is added to the map document.

After sorting the cut/fill attribute table, select the two nonzero values, right-click on the Volume 
header, and use statistics to view the total cubic feet of silt. 
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Joining the cutfill4.DBF 
table adds the cubic yard, 
short ton, and average 
thickness calculations.

Figure 2: Formulas to generate cubic yard and short tons values

Field Name Type Precision Scale Description

Silt_CuYds Float 12 2 Silt volume in cubic yards

Silt_Stons Float 12 2 Silt mass in short tons

AvgThk_Ft Float 7 3 Average thickness in feet

Figure 1: Fields to add to exported dBASE table

to make the join on. After verifying that the 
field in cutfill.dbf has been added to the Cutfill 
between Silt Thickness GridLake Zero Grid at-
tribute table, save the map again. 
 Notice that Powers Lake is separated into 
two subunits by a small neck containing mini-
mal sediment. The total silt volume for both 

regions of Powers Lake is 195.3 million cubic 
feet. This silt covers nearly 71 million square 
feet (or more than 1,600 acres and slightly 
more than 2.5 square miles)! The thickness for 
the larger north area averages 2.776 feet while 
the average thickness for the smaller southern 
area is 2.683 feet. These calculations work out 

to more than 7.23 million cubic yards of mate-
rial weighing nearly 12.3 million short tons 
when wet.

Summary
This exercise demonstrated several ArcGIS 
and ArcGIS Spatial Analyst extension proce-
dures, and a useful new trick, too. Powers Lake 
Water Assessment Project staff and the North 
Dakota Department of Health can now apply 
this Cut/Fill Thickness to Volume procedure to 
study Powers Lake and other water bodies in 
the northwestern part of the state. The author 
is adapting this procedure for mining and envi-
ronmental science applications.

Tip: Load a shapefile with a known 
projection and projection (PRJ) file 
into a map document first to set the 
Data Frame to that projection.
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Project Inspires New Approach to
   Volumetric Calculations

By Mike Price, ESRI
In April 2002, Ann Fritz, an environmental 
scientist at the North Dakota Department of 
Health, Division of Water Quality, contacted 
ESRI to request help with volumetric calcula-
tions of lake bottom sediment. Ann’s agency 
had collected very detailed thickness data 
but preferred not to create the multiple topo-
graphic surfaces typically required for cut/fill 
calculations. 
 The subject of the silt thickness calcula-
tions was Powers Lake, a large shallow fresh 
water lake located in Burke and Montrail 
counties in North Dakota. This lake contains a 
variety of fish—northern pike, walleye, trout, 
perch, and crappie and ice fishing is very 
popular in winter. The community of Powers 
Lake, population 408, is located at the north 
end of the lake and is approximately 150 miles 
west of Bismarck.
 In 1999, the Powers Lake Water Assess-
ment project was initiated to clean up the lake 
by reducing nitrogen and phosphorous levels 
and mitigating a blanket of silt and clay that 
has formed on the lake bottom. The goal of the 
project is to restore the lake to its condition 
during the 1960s. Guided by the North Dakota 
Department of Health, townspeople and high 

Creating a group layer lets you manage many individual layers 
as though they were a single layer. This can be very useful if you 
have data layers, such as basemap data, that you want to add to 
several maps or share with coworkers who are using the same 
data. All the layers in the group layer, as well as any customization 
to any of the layers, can be added to a new map in a single opera-
tion. Group layers also help keep data organized. For example, 
layers for streets, highways, and railroads could all be saved and 
managed as a transportation group layer. 

1. Start ArcMap and open an existing map or start a new map.

2. In the Table of Contents, click on the Display tab.

3. Right-click on the data frame and choose New Group Layer.

4. Double-click on the new group layer to bring up the Group 
Layers Properties dialog box.

5. Click on the General tab and change the name from the de-
fault name to something meaningful.

Creating Group Layers

school volunteers have extensively mapped, 
sampled, and studied the lake. Environmental 
scientists will explore the feasibility of im-
proving lake bottom habitat and estimate the 
cost of removing bottom sediment.
 A primary project objective is to under-
stand the amount and location of mud de-
posited on the lake bottom, evaluate ways to 
decrease silt influx, and test practical methods 
to remove excess silt. To better understand 
sediment distribution, survey crews using 
GPS constructed five transects across the 
lake in the winter of 2000–2001. Holes were 
drilled through surface ice on 100- to 300-foot 
centers and a depth probe was lowered into 
the water. Measurements were taken when 
the probe intersected soft sediment and again 
when the probe hit compacted gravel. The five 
transects yielded 74 measurements. The lake 
depth is less than 15 feet and mud thickness 
measurements range from 0 to 5.75 feet, with 
an average thickness of three feet. 
 However, the data collected from these 
transects was insufficient for three-dimen-
sional modeling, so additional points were 
interpolated by Health Department scientists 
using profiles and other known information 

to help develop terrain surfaces. I also created 
lake edge points by converting a polygon de-
scribing Powers Lake to vertex points and as-
signing these points zero value for all depths. 
 The Division of Water Quality needed 
a simple, straightforward procedure to use 
all this data—transect measurements, in-
terpolated points, and lake edge points—to 
generate volumetric calculations for Powers 
Lake. After a little “out of the box” thinking, 
I developed the Cut/Fill Thickness to Volume 
procedure described and demonstrated in the 
accompanying tutorial, “Deriving Volumes 
With ArcGIS Spatial Analyst.” I tested this 
procedure with other data comparing results 
obtained using good terrain surfaces and 
actual excavation data. The results were strik-
ingly similar—in fact, the results were often 
identical!
 Powers Lake Water Assessment project 
staff and the North Dakota Department of 
Health have applied the Cut/Fill Thickness to 
Volume procedure, not only to Powers Lake, 
but also to the many other lakes throughout 
the northwest part of the State. I am currently 
adapting this procedure for mining and envi-
ronmental science applications.

6. Click on the Group tab. Click on the Add button and navigate 
to the location of the data you want to add. Click on the Proper-
ties button to change the symbology for a highlighted layer. 

7. Add as many layers to the group layer as desired. Click OK 
when finished. 

8. Saving the group layer outside the map document makes 
it available for other maps. Right-click on the group layer and 
choose Save As Layer File. Name and save the file. 

 Layers that have already been added to the map can be in-
cluded in a group layer by dragging and dropping the layer to the 
group layer. A new group layer can also be created from existing 
layers by selecting the layers, right-clicking, and choosing Group 
from the context menu. Choose Properties from the same context 
menu to set symbology and rename the new group layer. 
 Group layers can also be created in ArcCatalog. Start 
ArcCatalog and select the folder that will hold the new group 
layer file. Choose File > New > Group Layer from the menu. Use 
the methods outlined in steps 4 through 7 to add layers to the 
group and set properties for those layers.


