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This ebook was designed 

specifically for DCGS-Army 

SP-1 users of ArcGIS® Pro as 

a quick-guide for explaining 

basic ArcGIS Pro functionality 

pertaining to the military 

application of GIS. This ebook 

describes specific workflows 

to assist in the streamlining of 

tasks to create, import, edit, 

and share GIS information.
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Getting Started with New 
Feature Class Layers
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1. 	 From the Map tab, in the Inquiry group, click Locate       to open 
the Locate pane.

The pane appears over the Catalog pane.

2. 	 In the Locate pane, in the Search field, type the address,  
place-name, or x,y coordinates you want to find.

As you type, suggestions appear in the drop-down menu based 
on your input. 

The suggestions are generated by locators based on your input.

3.	 To set suggestion parameters, perform the following:

• In the Locate pane, click the Options button       , and select 
Provider Settings.

•	In the Provider Settings options, check or uncheck Suggestions 
to configure, as necessary.

•	Click the Back To Locate Pane button        to return to the  
Locate tab.

4	 In the Search field, you can press Enter to search based on the 
text you enter in the search box, or you can click one of the 
suggestions to perform a search based on that text.

01
chapter

ADD POINTS by Entering Coordinate
To perform portions of this workflow, you must have access 
to a geocoding service such as XY provider, the ArcGIS World 
Geocoding Service, or a similar geocoding service available on your 
organization’s portal.

Getting Started with New Feature Class Layers in ArcGIS Pro     |  
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If the address is matched, the suggested result candidates will 
display in a list under the locator that returned them. In addition, 
they will display as labeled points on your map.
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ADD POINTS by Entering Coordinate
(with Coordinate Conversion)

For this workflow to be successful, ArcGIS Pro Intelligence must be 
installed. Once installed, the Coordinate Conversion tools and other 
Defense Tools can be utilized from either ArcGIS Pro or ArcGIS Pro 
Intelligence.

1.	 From the Map tab, in the Inquiry group, click Coordinate 
Conversion      .

2.	 In the Coordinate Conversion pane, click the Map Point Tool  
button     , and then click a location on the map.

3.	 Type coordinates in the Input text box, and press Enter.

A coordinate matching your input coordinate format is added to the list, 
and the location is displayed in the formats you set in the output table.
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IMPORT POINTS by CSV, Spreadsheet

1.	 From the Map tab, in the Layer group, click the Add Data down 
arrow, and click XY Point Data      . 

If the stand-alone table is already in the map, you can right-click it  
in the Contents pane, and click the Display XY Data button      .  
A new geoprocessing pane will appear over the Catalog pane.

2.	 In the XY Table To Point geoprocessing pane, set the following 
parameters:

•	Input Table: Your CSV or spreadsheet containing XY points

•	Output Feature Class: Name and folder location of your new 
feature class

•	X Field: Select the x-value in your table

•	Y Field: Select the y-value in your table

•	Z Field: (if applicable) Select the z-value in your table

•	Coordinate System: (if necessary) Select the coordinate system 

3.	  Click Run.

A new point feature class will be added to your map.
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CONVERT A TABLE to locations on the map
To perform this workflow, you must have access to a geocoding service 
such as XY provider, the ArcGIS World Geocoding Service, or a similar 
geocoding service available on your organization’s portal.

Add the table you want to geocode to your map.

1.	 From the Map tab, in the Layer group, click the Add Data down 
arrow, and click Data      .

2.	 In the Add Data dialog box, browse to the location of your table, 
select it, and click OK.

3.	 In the Contents pane, right-click your table, and choose  
Geocode Table.
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The Geocode Table pane contains a list of guided steps to geocode 
your table. There are six overarching steps in this workflow. The first 
step is to examine your tabular data with the address.

4.	 In the Geocode Table pane, click Start.

In STEP ONE: ABOUT YOUR TABLE, you will look at your data to 
determine how many fields in your data you want to use for geocoding.

5.	 For Input Table, confirm that the correct table is displayed in the 
text box.

6.	 Use the down arrow to answer the question regarding the number 
of fields you want to geocode in your data.

If you are unsure of the number of fields that need to be geocoded, 
click the Attribute table button      to view the table.

7.	 Click Next.

In STEP TWO: WHAT LOCATOR ARE YOU USING? you will decide 
whether to use the World Geocoding Service, a custom service from 
your organization, or a custom locator.

8.	 For Input Locator, click the down arrow to select the input locator 
you want to use for geocoding.

Locators added to the project that support batch geocoding 
automatically appear in the Input Locator drop-down menu. If you do 
not see a custom locator or custom service, or you can browse to a 
different locator by clicking the Browse button      .

Note: When using the ArcGIS World Geocoding Service, this 
operation may consume available credits.

9.	Click Next.
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In STEP THREE: MAPPING THE FIELDS IN YOUR TABLE, you will 
examine the fields in your data and the fields in your locator to see 
how they connect to each other to maximize efficiency.

10.	For each of the fields in your data that you want to use in 
geocoding, find the corresponding locator field and choose the 
appropriate data field in the drop-down menu.

The field mapping is completed automatically, but you should review 
the field mapping to ensure that you do not want to make any 
changes or map additional fields.

11.	If necessary, click the Attribute table button      to review the fields 
in your data that need to be geocoded.

12.	Click Next.

In STEP FOUR: OUTPUT, you will specify where you want your output 
feature class to be created based on the type of geocoding operation 
that will be performed.

An output location and name are assigned automatically. You have 
the option to change the output if desired.

13.	For Output, click the Browse button      , and set a new feature 
class name and location.

14.	Check Add Output To Map After Completion if you want to add 
your new feature class to the map automatically.

15.	For Preferred Location Type, choose an option from the  
available menu.
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When performing geocoding, you may be using the geocoding results 
to display on a map or perform further analysis. In this case, you 
may want to change the Preferred Location Type setting to Address 
Location so that the points represent the rooftop or parcel centroid for 
the address. The point that is displayed is closest to the center of the 
feature that represents the address. By contrast, you may be using the 
geocoding results in a routing application where you want the points 
to be located on the side of the street for better routing. In this case 
Routing Location is the better option. With this option, the point that is 
displayed is typically closer to the street and closer to where a vehicle 
would arrive at the location.

16.	Click Next.

Depending on the size of your table and the location of output, the 
operation may be time-consuming.

The final two steps are optional based on the type of data you are 
using. If your locator does not support the Country or Category setting, 
proceed to Step 20 (Click Finish).

STEP FIVE: LIMIT BY COUNTRY is an optional step. In this step, you 
can limit your search to specific countries if you are using a service that 
supports geocoding by country.

When using the World Geocoding Service or other locators that 
support multiple countries, you may want to specify that geocoding 
should only happen in specific countries. This is important because 
it can improve geocoding performance and reduce the potential for 
an address to return a false-positive match in another country. It is 
possible for an address in one country to look very similar to an address 
in another country. Geocode Table allows you to choose one or more 
countries to limit the results of the geocoding. In some cases, your 
table may contain addresses for many countries, in which case you 
should have a country field in the data and map that field in the field 
mapping section of the tool as opposed to selecting multiple countries 
in this step. Mapping a country field from the table will help to pinpoint 
the country for each record.
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The capability to limit geocoding by country is determined by the 
locator you chose and is not always available. If your locator does not 
support the Country setting, this page of the guided workflow does 
not appear.

17.	If available, choose any combination of countries from the 
displayed list.

18.	Click Next.

And finally, STEP SIX: LIMIT BY CATEGORY is another optional step. 
In this step, if you are using a service that supports geocoding based 
on categories, you can limit your search to specific categories.

You may want to limit the results of geocoding to specific categories, 
such as only address matches, because the geocoding results are 
for parcel delivery. Another example is if you know the entire table 
consists of cities, and you do not want New York to match to New 
York State or even New York County. Using this parameter limits 
matches to a specific type of location.

As with the Country setting, the capability to limit geocoding by 
category is determined by the locator you chose and is not always 
available. If your locator does not support the Category setting, this 
page of the guided workflow does not appear.

19.	If available, choose any combination of categories from the 
displayed list.

20.	Click Finish.

Now you will review all inputs in the final step of the guided workflow 
and run the Geocode Table.
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21.	Confirm that all the inputs on the 
final page of the guided workflow 
correctly display for all of the inputs 
you chose in the previous steps.

22.	Click Run.

The progress of the tool is displayed 
at the bottom of the pane.
If you selected the Add Output To 
Map option in the Output step of the 
guided workflow, the output is added 
to the map automatically.
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A line feature will have two vertices. A polyline will have multiple 
vertices. The workflow to add a line or a polyline is identical except for 
the number of vertices used to construct the feature geometry.

1.	 In the Catalog pane, expand Databases, right-click your desired 
geodatabase, point to New, and choose Feature Class.

2.	 In the Define pane, set or confirm the following parameters:

•	Name: The name of your new feature class

•	Alias: A simple to understand layer alias

•	Feature Class Type: Line

•	Geometric Properties: Ensure that both boxes are unchecked

3.	 Click Next.

4.	 In the Fields pane, click the Click Here To Add A New Field option if  
you know what attributes you want to include in your line feature class.

5.	 Click Next.

6.	 In the Spatial Reference pane, set the XY Coordinate System to  
the appropriate system for your work area, and click Next.

7.	 In the Tolerance pane, accept the default values, and click Next.

8.	 In the Resolution pane, accept the default values, and click Next.

9.	 In the Storage Configuration pane, accept the default values,  
and click Finish.

Your new feature class will automatically be added to your map.

ADD LINES
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10.	From the Edit tab, in the Features group, click Create       .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

11.	In the Create Features pane, expand the existing line feature that you 
would like to add lines to, and click the Line construction tool      .

 

When you clicked the Line construction tool, a construction toolbar 
appeared at the bottom of the map. This toolbar contains frequently 
used construction tools.
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12.	Click the map to create the first vertex.  

Note: You can also right-click on the map, click Absolute X,Y,Z…,  
and in the Absolute X,Y dialog box, type the values of a specific  
x,y location, and press Enter.

13.	Move the pointer and click the map to create the second vertex 
for a line feature.

14.	Alternatively, you can right-click and specify an x,y coordinate 
location or include the vertex using distance and direction.

15.	To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

16.	To finish the sketch and create the feature, on the construction 
toolbar, click the Finish button    , or press F2.

17.	From the Edit tab, in the Manage Edits group, click Save       .

18.	In the Save Edits dialog box, click Yes to save your edits.
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IMPORT LINE from database
IMPORT POLYLINE from database
A line feature will have two vertices. A polyline will have multiple 
vertices. The workflow to add a line or a polyline is identical except for 
the number of vertices used to construct the feature geometry.

1.	 In the Catalog pane, on the Project tab, right-click Databases, and 
select Add Database.

 

2.	 In the Select Existing Geodatabase dialog box, browse to the 
location of your geodatabase and select it.

3.	 Click OK.

4.	 In the Catalog pane, expand Databases, and from your newly 
added geodatabase, right-click the line feature class, and select 
Add To Current Map.

Note: If your geodatabase is empty, you can follow the steps above 
to add a feature class to your geodatabase.
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ADD POLYLINE
A line feature will have two vertices. A polyline will have multiple 
vertices. The workflow to add a line or a polyline is identical except for 
the number of vertices used to construct the feature geometry.

1.	 In the Catalog pane, expand Databases, right-click your desired 
geodatabase, point to New, and choose Feature Class.

2.	 In the Define pane, set or confirm the following parameters:

•	Name: The name of your new feature class

•	Alias: A simple to understand layer alias

•	Feature Class Type: Line

•	Geometric Properties: Ensure that both boxes are unchecked

3.	 Click Next.

4.	 In the Fields pane, click the Click Here To Add A New Field option 
if you know what attributes you want to include in your line feature 
class.

5.	 Click Next.

6.	 In the Spatial Reference pane, set the XY Coordinate System to the 
appropriate system for your work area, and click Next.

7.	 In the Tolerance pane, accept the default values, and click Next.

8.	 In the Resolution pane, accept the default values, and click Next.

9.	 In the Storage Configuration pane, accept the default values, and 
click Finish.

Your new feature class will automatically be added to your map.



22

03 NAVIGATING 
IN MAPS01 NEW FEATURE 

CLASS LAYERS 02 MODIFYING 
EXISTING LAYERS

10.	From the Edit tab, in the Features group, click Create       .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

11.	In the Create Features pane, expand the existing line feature that you 
would like to add lines to, and click the Line construction tool      .

 

When you clicked the Line construction tool, a construction toolbar 
appeared at the bottom of the map. This toolbar contains frequently 
used construction tools.
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12.	Click the map to create the first vertex, or right-click and specify  
an x,y location.

13.	Move the pointer and click the map to create each vertex of the 
polyline feature and sketch the remaining geometry.

14.	Alternatively, you can right-click and specify an x,y coordinate 
location or include the vertex using distance and direction.

15.	To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

16.	To finish the sketch and create the feature, on the construction 
toolbar, click the Finish button     , or press F2.

17.	From the Edit tab, in the Manage Edits group, click Save      .

18.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, right-click your desired 
geodatabase, point to New, and choose Feature Class.

2.	 In the Define pane, set or confirm the following parameters:

•	Name: The name of your new feature class

•	Alias: A simple to understand layer alias

•	Feature Class Type: Polygon

•	Geometric Properties: Ensure that both boxes are unchecked

3.	 Click Next.

4.	 In the Fields pane, click the Click Here To Add A New Field option 
if you know what attributes you want to include in your polygon 
feature class.

5.	 Click Next.

6.	 In the Spatial Reference pane, set the XY Coordinate System to the 
appropriate system for your work area, and click Next.

7.	 In the Tolerance pane, accept the default values, and click Next.

8.	 In the Resolution pane, accept the default values, and click Next.

9.	 In the Storage Configuration pane, accept the default values, and 
click Finish.

Your new feature class will automatically be added to your map.

10.	In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a polygon feature class to your map.

ADD POLYGON
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11.	From the Edit tab, in the Features group, click Create      .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

12.	In the Create Features pane, expand the existing polygon 
feature that you would like to add lines to, and click the Polygon 
construction tool      .

 

When you clicked the Polygon construction tool, a construction 
toolbar appeared at the bottom of the map. This toolbar contains 
frequently used construction tools.

 

Note: This construction toolbar is similar to the line construction 
toolbar but will create polygons with the Polygon tool selected.
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13.	Create the polygon feature using one of the following methods:

•Click the map, move the pointer, and click the map again until 
you have created your desired number of vertices.

•	In your map, right-click and use the context menu to specify  
x,y,z coordinate locations, distance, and direction.

14.	To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

15.	To finish the feature, right-click and click the Finish button     , or 
press F2.

16.	From the Edit tab, in the Manage Edits group, click Save      .

17.	 In the Save Edits dialog box, click Yes to save your edits.
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To perform this workflow, you must have access to the ArcGIS 
LocateXT extension.

1.	 From the Map tab, in the Layer group, click the Add Data down 
arrow, and click Extract Locations       .

2.	 In the Extract Locations pane, in the Output section, set the 
following parameters:

•	Name: Provide a name for the feature class.

•	Coordinate System: Set this based on the input coordinates  
of your file.

3.	 If your polygon coordinates are located in a file, click the Files and 
Folders tab and specify the items/files:

•	In the Input field, you can click Browse, and from the Add Files 
And Folders dialog box, browse to the location of your file and 
add them.

•	Alternatively, you can also drag your file directly into the Extract 
Locations pane and drop it into the Input field.

IMPORT POLYGON from text
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4.	 If your polygon coordinates can be copied/pasted from text, click 
the Text tab and type the coordinates for locations:

Use the Copy/Paste capabilities in a document, email, or web page to 
add bulk coordinates for your new polygon into the Input field.
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5.	 Click Extract. 

This will add your points to the map as a new feature class.

 

Now that you have points, you must connect them to create a new 
polygon feature class.

6.	 From the Analysis tab, in the Geoprocessing group, click Tools       . 

7.	 In the Geoprocessing pane, search for Minimum Bounding 
Geometry.

8.	 Click Minimum Bounding Geometry (Data Management Tools).
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9.	 In the Geoprocessing pane, set the following parameters:

•	Input Features: Click the down arrow, and select the feature class 
that you just created using the Extract Locations tool.

•	Output Feature Class: Provide a name and location for the new 
polygon feature class.

•	Geometry Type: Select Convex Hull .

•	Keep the remaining options on the default settings.
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10.	Click Run. 

Your new polygon feature class will automatically be added to your map.
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If you attempt to access an Excel file in ArcGIS Pro without the 
appropriate driver installed, you will receive the error   
Required Microsoft Driver Is Not Installed.

To work with Excel files in ArcGIS Pro, you must download and install 
the Microsoft Access Database Engine 2016 Redistributable  
the Microsoft Download Center.

1.	 From the Map tab, in the Layer group, click Add Data       .

2.	 In the Add Data dialog box, browse to the location of the  
Excel workbook.

3.	 Select the Excel workbook, and click OK.

4.	 In the Contents pane, click the table you want to add to the map.

5.	 Click Select.

ADD EXCEL TABLE to Map
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Alternatively, you can add an Excel table directly to your map from the 
Catalog pane.

1.	 In the Catalog pane, expand Folders, and browse to the folder 
where your Excel workbook is located.

2.	 Right-click your Excel workbook, and select Add To Current Map.

You may need to add a folder connection to access the appropriate folder.

•	In the Catalog pane, right-click Folders, and select Add Folder 
Connection.

•	In the Add Folder Connection dialog box, browse to the folder 
you wish to connect, and then click OK.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Create       .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

3.	 In the Create Features pane, expand the existing line feature that you 
would like to add lines to, and click the Line construction tool      .

 

02
chapter

ADD LINES to Existing Layer
A line feature will have two vertices. A polyline will have multiple 
vertices. The workflow to add a line or a polyline is identical except for 
the number of vertices used to construct the feature geometry.

Add or Edit Features to Existing Layers in ArcGIS Pro     |  
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When you clicked the Line construction tool, a construction toolbar 
appeared at the bottom of the map. This toolbar contains frequently 
used construction tools.

 

4.	 Click the map to create the first vertex. 

Note: You can also right-click on the map, click Absolute X,Y,Z…, and 
in the Absolute X,Y dialog box, type the values of a specific  
x,y location, and press Enter.

5.	 Move the pointer and click the map to create the second vertex 
for a line feature.

6.	 Alternatively, you can right-click and specify an x,y coordinate 
location or include the vertex using distance and direction.

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

8.	 To finish the sketch and create the feature, on the construction 
toolbar, click the Finish button     , or press F2.

Next you will save your edits.

9.	 From the Edit tab, in the Manage Edits group, click Save      .

10.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a point feature class to your map.

2.	 From the Edit tab, in the Features group, click the Create button     .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

3.	 In the Create Features pane, expand the existing point 
feature that you would like to add lines to, and click the Point 
construction tool       .

 

ADD POINTS to Existing Layer
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When you clicked the Point construction tool, a construction toolbar 
appeared at the bottom of the map. This toolbar contains frequently 
used construction tools.

 

4.	 Create one, or more, point features using one of the following 
methods:

•	Click on the map where you would like to add your new point.

•	Right-click on the map, click Absolute X,Y,Z…, and in the 
Absolute X,Y dialog box, type the values of your desired new 
point, and press Enter.

5.	 To undo an edit, on the Quick Access Toolbar, click the Undo 
button        .

6.	 When you are finished adding your point (or points), right-click 
and click the Finish button     , or press F2.

Next you will save your edits.

7.	 From the Edit tab, in the Manage Edits group, click Save      .

8.	 In the Save Edits dialog box, click Yes to save your edits.
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ADD POLYGON to Existing Layer

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a polygon feature class to your map.

2.	 From the Edit tab, in the Features group, click Create      .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

3.	 In the Create Features pane, expand the existing polygon 
feature that you would like to add lines to, and click the Polygon 
construction tool       .
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When you clicked the Polygon construction tool, a construction 
toolbar appeared at the bottom of the map. This toolbar contains 
frequently used construction tools.

 

Note: This construction toolbar is similar to the line construction 
toolbar but will create polygons with the Polygon tool selected.

4.	 Create the polygon feature using one of the following methods:

•	Click the map, move the pointer, and click the map again until 
you have created your desired number of vertices.

•	In your map, right-click and use the context menu to specify 
x,y,z coordinate locations, distance, and direction.

5.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button       .

6.	 To finish the feature, right-click and click the Finish button     ,  
or press F2.

Next you will save your edits.

7.	 From the Edit tab, in the Manage Edits group, click Save     .

8.	 In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Create     .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

3.	 In the Create Features pane, expand the existing line feature that you 
would like to add lines to, and click the Line construction tool      .

 

ADD POLYLINES to Existing Layer
A line feature will have two vertices. A polyline will have multiple vertices. 
The workflow to add a line or a polyline is identical except for the number 
of vertices used to construct the feature geometry.
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When you clicked the Line construction tool, a construction toolbar 
appeared at the bottom of the map. This toolbar contains frequently 
used construction tools.

 

4.	 Click the map to create the first vertex, or right-click and specify 
an x,y location.

5.	 Move the pointer and click the map to create each vertex of the 
polyline feature and sketch the remaining geometry.

6.	 Alternatively, you can right-click and specify x,y,z coordinate 
locations or include a vertex using distances and directions.

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button       .

8.	 To finish the sketch and create the feature, on the construction 
toolbar, click the Finish button      , or press F2.

Next you will save your edits.

9.	 From the Edit tab, in the Manage Edits group, click Save      .

10.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Modify         .

3.	 In the Modify Features pane, expand Alignment, and click Move       .

4.	 In the Modify Features pane, click Select One Or More  
Features     , and in your map, select the line feature (or features) 
that you would like to move.

Note: You can click the Select One Or More Features down arrow  
to change the selection type.

When you clicked the Move button and selected your feature, an 
editing toolbar appeared at the bottom of the map. This toolbar 
contains frequently used editing tools.

 

EDIT/MOVE LINE
A line feature will have two vertices. A polyline will have multiple vertices. 
The workflow to edit/move a line or a polyline is identical except for the 
number of vertices used to construct the feature geometry.
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5.	 In the map, pause your pointer near your selection until the move 
pointer appears      , then click and drag the feature to the new 
location on the map.

 

The line feature’s old location will appear in cyan, and the new location 
will appear as a dashed line highlighted with a large yellow dot.
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6.	 Use the tools on the toolbar to move, rotate, or scale the 
selected features.

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

8.	 To apply your changes, on the construction toolbar, click the 
Finish button      , or press F2.

Next you will save your edits.

9.	 From the Edit tab, in the Manage Edits group, click the  
Save button       .

10.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a point feature class to your map.

2.	 From the Edit tab in the Features group, click Modify        .

3.	 In the Modify Features pane, expand Alignment, and click Move     .

4.	 In the Modify Features pane, click the Select One Or More 
Features      , and in the map select the point feature (or features) 
that you would like to move.

Note: You can click the Select One Or More Features down arrow  
to change the selection type.

When you clicked the Move button and selected your feature, an 
editing toolbar appeared at the bottom of the map. This toolbar 
contains frequently used editing tools.

 

5.	 In the map, pause your pointer near your selection until the move 
pointer appears      , then click and drag the feature to the new 
location on the map.

 

EDIT/MOVE POINT(S)
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The point feature’s old location will appear in cyan, and the new 
location will appear in yellow.

6.	 Use the tools on the toolbar to move, rotate, or scale the 
selected features.

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

8.	 To apply your changes, on the construction toolbar, click the 
Finish button       , or press F2.

Next you will save your edits.

9.    From the Edit tab, in the Manage Edits group, click Save      .

10.  In the Save Edits dialog box, click Yes to save your edits.
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EDIT/MOVE POLYGON

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a polygon feature class to your map.

2.	 From the Edit tab, in the Features group, click Modify       .

3.	 In the Modify Features pane, expand Alignment, and click Move      .

4.	 In the Modify Features pane, click the Select One Or More 
Features      , and in your map select the polygon feature(s) that 
you would like to move.

Note: You can click the Select One Or More Features down arrow to 
change the selection type.

When you clicked the Move button and selected your feature, an 
editing toolbar appeared at the bottom of the map. This toolbar 
contains frequently used editing tools.
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5.	 In the map, pause your pointer near your selection until the move 
pointer appears      , then click and drag the feature to the new 
location on the map.
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The polygon feature’s old location will appear in cyan, and the new 
location will appear as a dashed outlined polygon highlighted with a 
large yellow dot at the polygon’s centroid.

6.	 Use the tools on the toolbar to move, rotate, or scale the selected 
features.

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

8.	 To apply your changes, on the construction toolbar, click the 
Finish button      , or press F2.

Next you will save your edits.

9.	 From the Edit tab, in the Manage Edits group, click Save      .

10.	In the Save Edits dialog box, click Yes to save your edits.
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EDIT/MOVE POLYLINE
A line feature will have two vertices. A polyline will have multiple vertices. 
The workflow to edit/move a line or a polyline is identical except for the 
number of vertices used to construct the feature geometry.

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Modify        .

3.	 In the Modify Features pane, expand Alignment, and click Move      .

4.	 In the Modify Features pane, click Select One Or More  
Features      , and in your map select the polyline feature  
(or features) that you would like to move.

Note: You can click the Select One Or More Features down arrow  
to change the selection type.

When you clicked the Move button and selected your feature, an 
editing toolbar appeared at the bottom of the map. This toolbar 
contains frequently used editing tools.
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5.	 In the map, pause your pointer near your selection until the move 
pointer appears      , then click and drag the feature to the new 
location on the map.
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The polyline feature’s old location will appear in cyan, and the new 
location will appear as a dashed line highlighted with a large yellow dot.

6.	 Use the tools on the toolbar to move, rotate, or scale the selected 
features.

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button         .

8.	 To apply your changes, on the construction toolbar, click the 
Finish button       , or press F2.

Next you will save your edits.

9.	 From the Edit tab, in the Manage Edits group, click Save      .

10.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 If necessary, from the Insert tab, in the Project group, click New Map.

2.	 From the Map tab, in the Navigate group, click Go To XY      .

The Go To XY Control dialog box appears at the bottom of the map. 
Initially the input coordinates are set to decimal degrees. You can 
change these to a coordinate type of your choosing.

3.	 In the Go To XY Control dialog box, click the Coordinate Type 
down arrow, and select MGRS.

 

Your input coordinate system is now set to MGRS.
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JUMP to MGRS

Navigating in Maps in ArcGIS Pro     |  
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4.	 In the coordinate field, type the MGRS coordinates.

5.	 In the Go To XY Control dialog box, click the Flash button       to 
visually identify the location.

 

A green dot will flash in your map to identify the MGRS coordinate.

6.	 In the Go To XY Control dialog box, click the Pan button        to 
center the map on this point.

Now that your map is centered on the MGRS coordinate, you can use 
the various Navigate tools to zoom to your location.

7.	 From the Map tab, in the Navigate group, click Fixed Zoom In         .

Alternatively, you can use the Explore tool to interactively pan and 
zoom to your location using your mouse controls.
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ZOOM to Specific Scale
This workflow will work for zooming to any map scale.

1.	 If necessary, from the Insert tab, in the Project group, click  
New Map       .

2.	 On the bottom left of the map, click the down arrow next to the 
map scale, and select the desired scale.



58

03 NAVIGATING 
IN MAPS01 NEW FEATURE 

CLASS LAYERS 02 MODIFYING 
EXISTING LAYERS

3.	 If the desired scale is not listed, in the scale field,  
double-click and type the desired scale and press Enter.

 

Note: When typing a scale, you can type either the full 
representative fraction (1:250,000) or the denominator (250,000).
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ZOOM to Layer

1.	 If necessary, from the Insert tab, in the Project group, click  
New Map       . 

2.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

3.	 In the Contents Pane, right-click the layer, and select  
Zoom To Layer.

The map pans and zooms to the layer.
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1.	 In the Catalog pane, expand Databases, right-click the desired 
geodatabase, point to New, and choose Mosaic Dataset.

This will open the Create Mosaic Dataset tool.

2.	 In the Geoprocessing pane, set the following parameters:

•	Output Location: This will be set to the geodatabase and 
location you selected.

•	Mosaic Dataset Name: Name of your new mosaic dataset.

•	Coordinate System: From the Coordinate System drop-down 
list, you can choose the coordinate system of any of the layers in 
your map. You can also click the Select Coordinates  
button        to add a new coordinate system if desired.

•	Product Definition: Select the type of imagery you are working 
with from the list. You can also select None if you are unsure of 
the imagery or sensor type.

•	Product Properties: This will automatically populate the fields for 
the specifications of each band based on the selected input for 
Product Definition. If you selected None or Custom, you could 
enter unique information if desired.

•	Pixel Properties: Select the bit depth for your imagery if you 
know it.

Note: For Product Definition, ArcGIS Pro supports the most common 
sensors. ArcGIS Pro will use information in the metadata of your 
imagery to intelligently manage it.

3.	 Click Run.

An empty mosaic dataset has been added to your map. Next, you will 
need to add your imagery to this mosaic dataset.

04
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CREATE MAP CATALOGS (Create Mosaic Dataset)

A mosaic dataset must exist within a geodatabase.  
You must create a new mosaic dataset before you can add rasters.

Getting Started with Mosaic Datasets in ArcGIS Pro     |  
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4.	 In the Catalog pane, expand Databases, expand your default 
geodatabase, right-click the mosaic dataset you just created, and 
choose Add Rasters.

5.	 In the Geoprocessing pane, set the following parameters:

•	Mosaic Dataset: Choose your newly created mosaic dataset.

•	Raster Type: Click the down arrow and select the same raster 
type when you created the empty mosaic dataset. (This raster 
type will be the same as the Product Definition in step 2 above.)

•	Input Data: You can select a folder, an individual raster, or a set 
of rasters.

Note: If you selected a folder, every raster of the specified raster 
type in that folder will be added to the mosaic dataset. Under the 
Advanced Input Data Options section, use the check box to include 
the subfolders.

The rest of the fields are optional and pertain to creating overviews, 
pyramids, and calculating statistics. These options are dependent on 
the type of data you have, and how you set them depends on the 
kinds of analysis you want to perform.

6.	 Click Run.
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VIEW MAP CATALOG (Images)

The mosaic dataset is ideal for managing a collection of raster data. 
You can view the mosaic dataset as a single mosaicked image; 
however, you can also view and access individual rasters within the 
mosaic dataset if necessary. There are multiple ways to do this. 

Note: Examining the mosaic dataset layers does not alter the source 
mosaic dataset.

1.	 In the Catalog pane, expand Databases, from your desired 
geodatabase, add the mosaic dataset to your map.

2.	 In the Contents pane, click the mosaic dataset layer to activate  
the Mosaic Layer contextual menus.

3.	 From the Mosaic Layer: Data tab, in the Table group,  
click Attribute Table.

4.	 Scroll through the Attribute Table to explore the mosaic  
dataset rasters.

The Attribute Table contains a list of all the raster data or images in 
your mosaic dataset. You can use this table in the same way you use any 
other table in ArcGIS Pro. You can select individual rows or columns. 
Selecting rows in your table will highlight them in the map.

The primary rasters are the source images for the mosaic dataset. 
Other datasets present are the various Overview layers. These reduced 
resolution datasets are various layers that allow for easy rendering at 
different map scales. You can visually examine more information about 
these layers by using Explore Raster Items.

5.	 From the Mosaic Layer: Data tab, in the Selection group,  
click Explore Raster Items.

6.	 In the Explore Raster Items pane, click the Inspect tab.

7.	 If necessary, expand Preview and Raster Information.

As desired, you can scroll through the various raster datasets and overview 
layers in your mosaic dataset to view the properties of each layer.



64

03 NAVIGATING 
IN MAPS01 NEW FEATURE 

CLASS LAYERS 02 MODIFYING 
EXISTING LAYERS

Sorting With Mosaic Methods

1.	 In the Catalog pane, expand Databases, from your desired 
geodatabase, add the mosaic dataset to your map.

2.	 In the Contents pane, click the mosaic dataset layer to activate 
the Mosaic Layer contextual menus.

3.	 From the Mosaic Layer: Data tab, in the Table group, click Sort. 

 

VIEW OVERLAPPING MAPS (Images)

Deciding how to resolve conflicts of overlapping imagery is a 
component of working with collections of imagery. You can set up 
rules that apply to each layer as a whole, or you can apply rules to 
only the parts of the imagery that are overlapping. First you will set 
sorting options. 
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Some of the sort methods are suited for having your collection of 
imagery (rasters) be simply a collection of imagery (rasters). You do 
not need to do any analysis; you just need to have your imagery in a 
logical order. In this case, the North-West and the None methods are 
good options.

•	North-West       : Resolves the sorting by choosing the layer 
closest to the northwest corner of the boundary.

•	None       : Orders the images in the same order as the 
attribute table.

Other sort methods can be used for zooming in and panning around 
your collection of imagery.

•	Closest To Center       : As you pan and zoom through your mosaic 
dataset, you will be looking at the images closest to the center 
of your screen. When you zoom in to a feature, the selection 
updates automatically, so you see the imagery closest to the 
feature.

•	Seamline       : When you put your collection of imagery 
together, there are a few options for identifying seamlines. They 
can be based on the footprints of the imagery or the features 
within the imagery. However your collection is set up, when 
you choose this option, it generates the seamlines, ranks your 
images based on the distance to those seamlines, and chooses 
the closest imagery. The result is a smooth transition from one 
image to the next.

A large amount of high-resolution imagery is taken from a viewing 
angle that is not directly overhead. A drawback to this is that all the 
angles are different, which can be disorienting as you pan from one 
image to another in your mosaic.

Closest To Nadir       : Selects the imagery closest to the image being 
viewed from directly overhead. Assuming that all your imagery is 
oblique, you will end up with a less abrupt transition from one scene 
to the next if you have a lot of tall features because the viewing 
angles will be fairly close together.
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Other sorting methods use different properties in the image or raster 
metadata.

•	By Attribute       : Selects imagery based on specific attributes.

•	Lock Raster       : Displays only the images you select Insert Text.

•	Closest To Viewpoint       : Imagery over an area from multiple flight 
paths stores these paths in the metadata, which allows you to view 
the imagery from many different angles so you can see your imagery 
from all sides.

•	The three remaining attribute sorting methods are preset: Least 
Cloud Cover, Oldest, and Most Recent. They and are self-explanatory.

1.	 If necessary, in the Catalog pane, expand Databases, from your 
desired geodatabase, add the mosaic dataset to your map.

2.	 In the Contents pane, click the mosaic dataset layer to activate the 
Mosaic Layer contextual menus.

Resolving Overlapping Pixels

After you have determined the method for ordering, you can fine-tune 
using the overlap options.

3.	 From the Mosaic Layer: Data tab, in the Table group, click 
Resolve Overlap.
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The first two overlap methods are based on the parameters of each 
source of rasters/images.

•	First: The images at the top of the list will be drawn first.

•	Last: The counterpart that starts at the bottom of that same list 
will be drawn last.

You can also work on the pixel level. There are different averaging and 
statistical approaches that you can take. 

•	Minimum and Maximum operators take the lowest and highest 
valued pixel of all the overlapping layers. Using this option 
means that you have no guarantee of looking at the pixels of just 
one image in the overlapping area but rather a combination of 
potential layers.

•	Blend and Mean: Averages the values of the pixels in question. 
Using either of these operators means that you may not be 
looking at pixel values from any of your layers.

•	Mean: This uses the standard averaging technique.

•	Blend: This works by giving more weight to pixels closer to 
neighboring images to produce a smoother image.

•	Sum: Adds the values of all the overlapping pixels. If you assume 
that most pixel values are relatively close to one another for each 
layer, this technique can be useful to visualize where you have 
the most layers.
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CREATE MAP CHIPS by Polygon  
(Clip Raster [Data Management])

This tool allows you to extract, or chip out, a portion of a raster dataset 
in your map based on a template extent. This tool can be used to clip a 
raster dataset, mosaic dataset, or image service layer. A raster dataset 
or mosaic dataset will be used for this workflow example. The clip 
output includes any pixels that intersect the template extent.You must 
create a new mosaic dataset before you can add rasters.

Creating Map Chips in ArcGIS Pro     |  

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a raster dataset or a mosaic dataset to your map.

2.	 From the Analysis tab in the Geoprocessing group, click Tools       .

3.	 In the Geoprocessing pane, in the search field, type Clip Raster.

4.	 In the search results, click Clip Raster (Data Management Tools).

5.	 In the Geoprocessing pane, set the following parameters:

•	Input Raster: Choose the raster dataset or mosaic dataset

•	Output Extent: (Optional): A raster dataset or feature class to 
use as the clipping extent. If a raster dataset or feature class 
is selected, the Rectangle bounding box coordinate will fill in 
automatically

Clip
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•	Rectangle: The four coordinates that define the bounding box 
of the clipping extent

•	Output Raster Dataset: The name and geodatabase location of 
your new raster dataset

•	Maintain Clipping Extent: Check this to have the new raster 
dataset columns and rows exactly match the clipping extent

Note: For Output Extent, you can use selected features within the 
map as the clipping extent. If you select a single feature in the 
feature class, check Use Input Features For Clipping Geometry to 
clip out the areas that are selected. If a feature in the feature class 
is selected but Use Input Features For Clipping Geometry is not 
checked, the output clips out the minimum bounding rectangle for 
that feature.

Note: For Rectangle, the clipped area is specified either by using 
a minimum and maximum x,y coordinates that you set, or set 
automatically by the area of an output extent file.

Note: For Output Raster Dataset, setting the output to a 
geodatabase location will automatically create a raster dataset. If 
you specify a raster format type—for instance, BIL, BIP, BMP, BSQ, 
DAT, Esri Grid, GIF, IMG, JPEG, JPEG 2000, PNG, TIFF, MRF, CRF—
you will need to set this to a folder location, not a geodatabase, and 
add the appropriate file extension.

6.	 Click Run.

Your new raster dataset chip (subset) will be added to your map.
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CREATE MAP CHIPS by Point
This workflow will result in a chip, or subset, of a raster dataset or 
mosaic dataset centered around a specific point. The first element of 
this workflow will create a new feature class of a buffered distance—
that you specify—around your point of interest. 

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a raster dataset or a mosaic dataset and a point 
feature class to your map.

2.	 From the Map tab, in the Selection group, click Select     . 

3.	 In the map, select the point you want to use to create a chip.

4.	 From the Analysis tab, in the Geoprocessing group, click Tools      .

5.	 In the Geoprocessing pane, in the search field, type Buffer.

6.	 In the search results, click Buffer (Analysis Tools).



72

03 NAVIGATING 
IN MAPS01 NEW FEATURE 

CLASS LAYERS 02 MODIFYING 
EXISTING LAYERS

7.	 In the Geoprocessing pane, set the following parameters:

•	Input Features: The point feature class with your selected point

•	Output Feature Class: Name and location of your new output 
feature class

•	Distance [Value Or Field]: Type in a distance, and select a 
distance unit of the buffer

•	Keep all other options on the default settings
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Now that you have created a new feature class around your selected 
point, you can use the buffer polygon to create a rectangle to use as 
your clip extent. The second element of this workflow will create this 
rectangle polygon.

8.	 In the Geoprocessing pane, click the Back button       .

9.	 In the search field, type Feature Envelope To Polygon, and then 
click Feature Envelope To Polygon (Data Management Tools).

10.	In the Geoprocessing pane, set the following parameters:

•	Input Features: Select the Buffer feature class previously created

•	Output Feature Class: Name and location of your new output 
feature class

•	Check the Create Multipart Features box if you have multiple 
features



74

03 NAVIGATING 
IN MAPS01 NEW FEATURE 

CLASS LAYERS 02 MODIFYING 
EXISTING LAYERS

The final element of this workflow uses your newly created 
rectangle polygon to clip your raster dataset or mosaic dataset.

11.	In the Geoprocessing pane, click the Back button        .

12.	In the search field, type Extract By Mask, and then click  
Extract By Mask (Spatial Analyst Tools).

13.	In the Geoprocessing pane, set the following parameters:

•	Input Raster Select your raster dataset or mosaic dataset

•	Input Raster Or Feature Mask Data: Select the polygon 
feature class created previously created from the Feature 
Envelope To Polygon tool

•	Output Raster: Name and location of your new output 
feature class
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The final output is a raster dataset chip (subset) of your raster 
dataset or mosaic dataset based on the distance from the point you 
specified earlier.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Create      .

The Create Features pane opens, showing each of the editable 
layers in the map. These layers are the feature templates that contain 
construction tools to create features.

3.	 In the Create Features pane, expand the existing feature that you 
would like to add arcs to, and click the Line construction tool      .

 

When you clicked the Line construction tool, a construction toolbar 
appeared at the bottom of the map. This toolbar contains frequently 
used construction tools.

06
chapter

ADD ARCS by Creating a New Feature
ADD ARCS from Database (existing feature class)

Working with Range Rings, Ellipses, and Arcs in ArcGIS Pro     |  



78

03 NAVIGATING 
IN MAPS01 NEW FEATURE 

CLASS LAYERS 02 MODIFYING 
EXISTING LAYERS

4.	 On the construction toolbar, click the Arc Segment construction  
tool       .

 

5.	 Create the start point by using one of the following methods: 

•	Click the map.

•	Right-click the map, click Absolute X,Y,Z…, and in the Absolute 
X,Y dialog box, type the values of your desired new point, and 
press Enter.

6.	 Create a second point that defines the path of the arc using one 
of the following methods: 

•	Click the map.

•	Right-click the map, click Absolute X,Y,Z…, and in the Absolute 
X,Y dialog box, type the values of your desired new point, and 
press Enter.

This action locks the path of the arc to the new point. No new point 
will be created on the map. You must create an endpoint and specify 
a radius to finish the arc segment.
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7.	 Create the endpoint and specify the radius by using one of the 
following methods:

•	Sketch the radius by moving the pointer and click the map to 
create the endpoint.

•	Press R, type the radius, press Enter, and click the map to create 
the endpoint.

•	Right-click the map, click the Circular Arc button       , specify 
the radius and other geometry values, and press Enter to close 
the dialog box and create the arc.

 

To continue creating other segments, use the tools on the 
construction toolbar. 

8.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button       .

9.	 On the construction 
toolbar, click the Finish 
button      , or press F2.

Next you will save your edits.

10.	 From the Edit tab, in the Manage Edits group, click Save       .

11.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

Because of the feature geometry of arcs, they will be part of a line 
(polyline) feature class.

2.	 From the Edit tab, in the Features group, click Modify        .

3.	 In the Modify Features pane, expand a tool category, and click a 
specific editing tool.

You can type a function into the Search field to help identify an 
appropriate tool.
 

EDIT ARCS  
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When you clicked a specific tool and selected your feature, an editing 
toolbar appeared at the bottom of the map. This toolbar contains 
frequently used editing tools for that specific tool.

4.	 In the Modify Features pane, click Select A Feature      , and  
in your map, select the feature or features you want to modify.

Once selected, the feature or features will turn cyan. The selected 
features are also listed in the Modify Features pane.

5.	 Edit the feature following the steps prescribed by the specific tool.

6.	 To finish the modification, right-click and click the Finish  
button      , or press F2.

7.	 To undo an edit, on the Quick Access Toolbar, click the Undo 
button        .

Next you will save your edits.

8.	 On the Edit tab, in the Manage Edits group, click the  
Save button       .

9.	 In the Save Edits dialog box, click Yes to save your edits.
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1.	 From the Edit tab, in the Features group, click Select       
and in the map, select the arc feature you want to delete.

Note: Press and hold Shift while making your selections to select 
more than one arc feature.

Once selected, the arc feature(s) will turn cyan.

 

2.	 Delete the selected arc feature(s) using one of the following 
methods:

•	From the Edit tab, in the Features group, click the Delete button  

•	Right-click and choose Delete  

•	Press Delete.

Next you will save your edits.

3.	 On the Edit tab, in the Manage Edits group, click Save      .

4.	 In the Save Edits dialog box, click Yes to save your edits.

 

DELETE ARCS  
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

1.	 From the Insert tab, in the Measurements group, click Distance 
and Direction     .

2.	 In the Distance and Direction pane, click the Ellipse tab.

3.	 For Units, click the down arrow to select your desired map unit.

4.	 Click the Map Point Tool button       .

5.	 In the map, click a location to designate the center point  
of the ellipse.

As you move the pointer in the map, the Center Point field updates 
automatically.

6.	 In the map, click a location to designate the orientation and vertex 
of the major axis.

Moving the pointer in the map updates the distance units of the major 
axis automatically in the Major field.

7.	 In the map, click a location to designate the vertex along the 
minor axis to complete the ellipse.

CREATE ELLIPSES INTERACTIVELY   
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Similarly, as you move the pointer in the map to specify the minor axis 
distance, the Minor field updates automatically.

Your new ellipse is added to the map. 

 
The Distance and Direction tool also created a new feature dataset 
containing several new feature classes. You can see this new feature 
dataset and the new feature classes in the Contents pane.
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You can remove ellipses if you make errors while interactively 
creating them.

8.	 In the Distance and Direction pane, click Delete Ellipses.

You can export these ellipses to a new feature class or a KMZ file.

9.	 In the Distance and Direction pane, click Export.

10.	In the Select Output dialog box, choose Feature Class/Shapefile 
or KMZ, and click OK.

11.	In the Select Output dialog box, set the location and name of 
your new feature class, shapefile, or KMZ file, and click Save.

Your new feature class will be added to your map.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and  
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

1.	 From the Insert tab, in the Measurements group, click Distance  
and Direction     .

2.	 In the Distance and Direction pane, click the Ellipse tab.

3.	 For Units, click the down arrow to select your desired map unit.

4.	 In the Center Point field, type or paste a coordinate.

5.	 In the Major field, type a value.

6.	 In the Minor field, type a value.

CREATE ELLIPSES from Copied/Pasted or
typed text (known coordinates)
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7.	 In the Angle field, type a value.
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8.	 Press Enter.

A new ellipse is created and added to the map. 

The Distance and Direction tool also created a new feature dataset 
containing several new feature classes. You can see this new feature 
dataset and the new feature classes in the Contents pane.

 

You can remove ellipses if you make errors while creating them.

9.	 In the Distance and Direction pane, click Delete Ellipses.
You can export these ellipses to a new feature class or a KMZ file.

10.	In the Distance and Direction pane, click Export.

11.	In the Select Output dialog box, choose Feature Class/Shapefile 
or KMZ, and click OK.

12.	In the Select Output dialog box, set the location and name of 
your new feature class, shapefile, or KMZ file, and click Save.

Your new feature class will be added to your map.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

1.	 From the Edit tab, in the Features group, click Select       ,  
and in your map, select the ellipse feature you want to delete.

Once selected, the ellipse will turn cyan.

 

DELETE ELLIPSES 
 

2.	 Delete the selected ellipse using one of the following methods:

•	From the Edit tab, in the Features group, click the Delete  
button     .

•	In the map, right-click, and click the Delete button     .

•	Press Delete.

Next you will save your edits.

3.	 On the Edit tab, in the Manage Edits group, click Save       .

4.	 In the Save Edits dialog box, click Yes to save your edits.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

Based on how ellipses are created using the Distance and Direction 
tools, they can be moved, but they cannot be updated or edited.  
To make changes to an ellipse you must do the following:

1.	 Delete the ellipse you would like to update.

2.	 Repeat the steps to re-create the ellipse with your updated 
specifications.

 

UPDATE/EDIT ELLIPSES 
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CREATE RANGE RINGS INTERACTIVELY 
 For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

This workflow demonstrates how to interactively create range rings by 
clicking the map.

1.	 From the Insert tab, in the Measurements group, click Distance 
and Direction     .

2.	 In the Distance and Direction pane, click the Rings tab. 

3.	 For Ring Type, click the down arrow, and choose Interactive.

4.	 Click the Map Point Tool button     .

As you move the pointer in the map, the Center Point field updates 
automatically.

5.	 In the map, click a location to designate the center point of the ring.

Moving the pointer in the map updates the distance units of the 
radius automatically.

6.	 Click the map to designate the diameter of the ring.

7.	 Add rings as necessary and double-click to finish.
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The new range rings are created and added to the map.

 

The Distance and Direction tool also created a new feature dataset 
containing several new feature classes. You can see this new feature 
dataset and the new feature classes in the Contents pane.
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You can remove range rings if you make errors while interactively 
creating them.

8.	 In the Distance and Direction pane, click Delete Rings. You can 
export these range rings to a new feature class or a KMZ file.

9.	 In the Distance and Direction pane, click Export.

10.	In the Select Output dialog box, choose Feature Class/Shapefile 
or KMZ, and click OK.

11.	In the Select Output dialog box, set the location and name of 
your new feature class, shapefile, or KMZ file, and click Save.

Your new feature class will be added to your map.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

This workflow demonstrates how to create range rings with a fixed 
number of rings at a specified distance.

1.	 From the Insert tab, in the Measurements group, click Distance 
and Direction     .

2.	 In the Distance and Direction pane, click the Rings tab. 

3.	 For Ring Type, click the down arrow, and choose Fixed.

4.	 Enter a coordinate in the Center Point text box, or click the Map 
Point Tool button       to set a center point for the ring or rings.

As you move the pointer in the map, the Center Point field updates 
automatically.

5.	 In the Number of Rings field, type the value for how many rings 
to create.

6.	 For Distance Unit, click the down arrow to select your desired 
linear unit.

7.	 In the Distance Between Rings field, type the value for how far 
apart the rings must be based on your distance units.

CREATE RANGE RINGS Using a Fixed Ring 
Number and Distance from Copied/Pasted Text 
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8.	 In the Number of Radials field, type the value for how many 
radials to create. 

 

9.	 Press Enter. 

Range rings are created and added to the map. For this example, 10 rings 
were created with three radial segments. Each ring is three meters apart.
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The Distance and Direction tool also created a new feature dataset 
containing several new feature classes. You can see this new feature 
dataset and the new feature classes in the Contents pane.

 

You can remove range rings if you make errors while creating them.

10.	In the Distance and Direction pane, click Delete Rings.

You can export these range rings to a new feature class or a KMZ file.

11.	In the Distance and Direction pane, click Export.

12.	In the Select Output dialog box, choose Feature Class/Shapefile 
or KMZ, and click OK.

13.	In the Select Output dialog box, set the location and name of 
your new feature class, shapefile, or KMZ file, and click Save.

Your new feature class will be added to your map.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

This workflow demonstrates how to create range rings based on an 
origin and set distance from that specified origin.

1.	 From the Insert tab, in the Measurements group, click Distance 
and Direction    .

2.	 In the Distance and Direction pane, click the Rings tab.

3.	 For Ring Type, click the down arrow, and choose Origin.

4.	 Enter a coordinate in the Center Point text box, or click the Map 
Point Tool button        to set a center point for the ring or rings.

As you move the pointer in the map, the Center Point field updates 
automatically.

5.	 For Distance Unit, click the down arrow to select your desired 
linear unit.

6.	 Enter a value in the Distances table to set how far the first ring 
entered will be from the origin point.

7.	 Click the Add Distance button      to add a new row to the 
Distances table.

8.	 As necessary, add additional distances.

CREATE RANGE RINGS by Distance from an 
Origin from Copied/Pasted Text 
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9.	 In the Number of Radials field, type in the value for how many 
radials to create. 

 

10.	 Press Enter.

Range rings are created and added to the map. For this example, two 
rings were created with five radial segments. The first ring is 10 meters 
from the origin and the second ring is 15 meters from the origin.
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The Distance and Direction tool also created a new feature dataset 
containing several new feature classes. You can see this new feature 
dataset and the new feature classes in the Contents pane.

 

You can remove range rings if you make errors while creating them.

11.	In the Distance and Direction pane, click Delete Rings.
You can export these range rings to a new feature class or a KMZ file.

12.	In the Distance and Direction pane, click Export.

13.	In the Select Output dialog box, choose Feature Class/Shapefile 
or KMZ, and click OK.

14.	In the Select Output dialog box, set the location and name of 
your new feature class, shapefile, or KMZ file, and click Save.

Your new feature class will be added to your map.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

This workflow demonstrates how to create range rings based on an 
origin and a distance from a previously created ring.

1.	 From the Insert tab, in the Measurements group, click Distance 
and Direction     .

2.	 In the Distance and Direction pane, click the Rings tab.

3.	 For Ring Type, click the down arrow, and choose Cumulative.

4.	 Enter a coordinate in the Center Point text box or click the Map 
Point Tool button and set a center point for the ring or rings.

As you move the pointer in the map, the Center Point field updates 
automatically.

5.	 For Distance Unit, click the down arrow to select your desired 
linear unit.

6.	 Enter a value in the Distances table to set how far the first ring will 
be from the origin point.

7.	 Click the Add Distance button to add a new row to the  
Distances table.

8.	 As necessary, add additional distances.

CREATE RANGE RINGS by Distance  
Between Rings from Copy/Pasted Text 
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When creating rings using the Cumulative option, the rings are 
created based on the order of rows in the Distances table and based 
on the previous row. For example, values in the table of 100, 350, and 
75 result in rings created at distances of 100, 450, and 525 from the 
origin.

9.	 Enter a value in the Number of Radials text box.

 

10.	Press Enter.
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Range rings are created and added to the map. For this example, two 
rings were created with three radial segments. The first ring is 10 meters 
from the origin and the second ring is 15 meters from first ring and—
because the cumulative option is selected—25 meters from the origin.

  



103Working with Range Rings, Ellipses, and Arcs in ArcGIS Pro     |  

05 06 0704 MOSAIC 
DATASETS

CREATING 
MAP CHIPS

RANGE RINGS, 
ELLIPSES, ARCS

MAP 
COORDINATES

The Distance and Direction tool also created a new feature dataset 
containing several new feature classes. You can see this new feature 
dataset and the new feature classes in the Contents pane.

 

You can remove range rings if you make errors while creating them.

11.	In the Distance and Direction pane, click Delete Rings.
You can export these range rings to a new feature class or a KMZ file.

12.	In the Distance and Direction pane, click Export.

13.	In the Select Output dialog box, choose Feature Class/Shapefile 
or KMZ, and click OK.

14.	In the Select Output dialog box, set the location and name of 
your new feature class, shapefile, or KMZ file, and click Save.

Your new feature class will be added to your map.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and other 
Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

If your point data is in the form of a CSV file or spreadsheet, import 
the points to create a new feature class (see Import point by CSV, 
Spreadsheet).

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Analysis tab, in the Geoprocessing group, click Tools      .

3.	 In the Geoprocessing pane, in the search field, type Generate 
Range Rings.

4.	 In the search results, click Generate Range Rings (Defense Tools).

5.	 In the Input Features (Center Points), click the down arrow and 
choose the point feature class.

6.	 For Range Ring Type, verify that Interval is the selected type.

CREATE RANGE RINGS from CSV, Spreadsheet, 
Database, or Features



105Working with Range Rings, Ellipses, and Arcs in ArcGIS Pro     |  

05 06 0704 MOSAIC 
DATASETS

CREATING 
MAP CHIPS

RANGE RINGS, 
ELLIPSES, ARCS

MAP 
COORDINATES

7.	 For the remaining values, set the following parameters:

•	Number of Rings: Enter values for the desired number of rings

•	Interval Between Rings: Enter values for the desired distance 
between rings based on your distance units

•	Number Of Radials: Enter values for the desired number of radials

•	Output Feature Class (Rings): Name and location of the feature 
class for the rings

•	Output Feature Class (Radials): Name and location of the feature 
class for the rings

Note: Two separate feature classes will be generated for both the 
rings and the radials.

8.	 If necessary, expand Units Options, and click the Distance Units 
down arrow to set the desired units. 
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9.	 Click Run.

Two new feature classes are created and added to the map. For this 
example, the input features included three center points. Each ring 
contains four rings, with internal rings 200 meters apart. Additionally, 
each range ring has three radial segments. 
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1.	 From the Edit tab, in the Features group, click Select      , and  
in your map, select the ring or rings you want to delete.

 

Once selected, the ellipse will turn cyan.

 

DELETE RANGE RINGS  
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2.	 Delete the selected ring feature using one of the following methods:

•	From the Edit tab, in the Features group, click the Delete  
button      .

•	In the map, right-click, and click the Delete button      .

•	Press Delete.

Next you will save your edits.

3.	 On the Edit tab, in the Manage Edits group, click Save     .

4.	 In the Save Edits dialog box, click Yes to save your edits.
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For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Distance and Direction tools and 
other Defense Tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

Based on how range rings are created using the Distance and 
Direction tools, they can be moved, but they cannot be updated or 
edited. To make changes to a range ring you must do the following:

1.	 Delete the range ring or range rings you would like to update.

2.	 Repeat the steps to re-create the range rings with your updated 
specifications.

 

UPDATE/EDIT RANGE RINGS  
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MOVE RANGE SETS by Entering Center 
Coordinate  

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Modify        .

3.	 In the Modify Features pane, expand Alignment, and click  
Move To      .

4.	 In the Modify Features pane, click Make A Selection       , and in  
the map, select the range ring feature that you would like to move.

Ensure that you click and drag the select tool over the entire range 
ring area. Once selected, the range ring will appear cyan.

Note: You can click the Make A Selection down arrow to change the 
selection type.

              

5.	 For Method, click the down-arrow, and choose Absolute.

Specify the new coordinate location.
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6.	 For Values, click the Units down arrow, and choose a unit of 
measure or coordinate system.

 

7.	 Type the new coordinate value in the appropriate field.

 

Depending on the coordinate system or units chosen, the input field 
will change. You must input the appropriate coordinate pair or unique 
coordinate, such as the MGRS coordinate in the example.

8.	 Click Move To.

The feature moves or shifts to the new location.
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   9.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

10.	To save an edit, from the Edit tab, in the Manage Edits group, 
click Save.

 
11.	To apply your changes, on the construction toolbar, click the 

Finish button      , or press F2.

Next you will save your edits.

12.	From the Edit tab, in the Manage Edits group, click Save      .

13.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Modify        .

3.	 In the Modify Features pane, expand Alignment, and click  
Move      .

4.	 In the Modify Features pane, click the Select One Or More 
Features button     , and in the map, select the range ring that  
you would like to move.

Note: You can click the Select One Or More Features down arrow to 
change the selection type.

When you clicked the Move button and selected your feature, an 
editing toolbar appeared at the bottom of the map. This toolbar 
contains frequently used editing tools.

Ensure that you click and drag the select tool over the entire range 
ring area. Once selected, the range ring will appear cyan.

 	     

MOVE SINGLE RANGE SET by Click and Drag
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5.	 In the map, pause your pointer near your selection until the move 
pointer      appears, then click and drag the feature to the new 
location on the map.

 

6.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

7.	 To apply your changes, on the construction toolbar, click the Finish 
button      , or press F2.

Next you will save your edits.

8.	 From the Edit tab, in the Manage Edits group, click Save     .

9.	 In the Save Edits dialog box, click Yes to save your edits.
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MOVE MULTIPLE RANGE SETS by Click  
and Drag

1.	 In the Catalog pane, expand Databases, and from your desired 
geodatabase, add a line feature class to your map.

2.	 From the Edit tab, in the Features group, click Modify        .

3.	 In the Modify Features pane, expand Alignment, and click Move      .

4.	 In the Modify Features pane, click Select One Or More  
Features      , and in the map, select the range ring that you  
would like to move.

5.	 To select additional range rings, press and hold Shift, and in the 
map, select another range ring.

Note: You can click the Select One Or More Features down arrow to 
change the selection type.

When you clicked the Move button and selected your feature, an 
editing toolbar appeared at the bottom of the map. This toolbar 
contains frequently used editing tools.
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Ensure that you click and drag the select tool over the entire range 
ring area. Once selected, the range ring will appear cyan.
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6.	 In the map, pause your pointer near your selection until the move 
pointer button       appears, then click and drag the feature to the 
new location on the map.

 

7.	 To undo an edit, on the Quick Access Toolbar, click the  
Undo button        .

8.	 To apply your changes, on the construction toolbar, click the 
Finish button      v, or press F2.

Next you will save your edits.

9.	 From the Edit tab, in the Manage Edits group, click Save       .

10.	In the Save Edits dialog box, click Yes to save your edits.
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1.	 From the ribbon at the top of the app, click the Project tab.

2.	 In the left pane, click Options.

3.	 In the Options dialog box, under Project, click Units.

4.	 From the Units page, expand Location Units.

5.	 Select the Coordinate format that you would like to be the default 
for your ArcGIS Pro projects.

6.	 Click OK.

7.	 In the top-left center, click the Back arrow         to return to  
your project.

CHANGE DEFAULT COORDINATE FORMAT

Working with Map Coordinates in ArcGIS Pro     |  
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CHANGE THE DISPLAYED Input Coordinate 
Format
For this workflow to be successful, ArcGIS Pro Intelligence must  
be installed. Once installed, the Coordinate Conversion tools and  
other Defense tools can be utilized from either ArcGIS Pro or  
ArcGIS Pro Intelligence.

1.	 From the Map tab, in the Inquiry group, click Coordinate  
Conversion     .

2.	 In the Coordinate Conversion pane, click the Edit Properties button     .

3.	 In the Edit Properties dialog box, for Display Coordinate  
Category, choose a format from the provided list.

4.	 Click OK.
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COPY COORDINATE by Clicking Map (Right-Click)

1.	 From the Map tab, in the Navigate group, ensure that the Explore 
tool      is selected.

2.	 In the map, right-click the desired point in Map View and choose 
Copy Coordinates.

3.	 The coordinate will be copied to your clipboard.
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CUSTOMIZE COPY COORDINATE    
For this workflow to be successful, ArcGIS Pro Intelligence must be 
installed. Once installed, the Coordinate Conversion tools and other 
Defense tools can be utilized from either ArcGIS Pro or ArcGIS Pro 
Intelligence.

1.	 From the Map tab, in the Inquiry group, click Coordinate 
Conversion      .

2.	 In the Coordinate Conversion pane, in the Output table, click the 
Add button      .

3.	 In the Add New Output Coordinate dialog box, choose a 
coordinate type from the Category list.
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4.	 Expand Advanced.

5.	 In the Advanced text box, insert or delete characters or spaces to 
change the way the coordinate is displayed.

For DD, DDM, and DMS, 0 represents a digit, whereas # represents 
a significant digit (not zero). For example, the default format for DD 
is Y0.0#####N X0.0#####E, which shows a minimum of one decimal 
point but up to six significant digits. If you have an input coordinate 
of 45.002N, 40.300W, it defaults to 45.002N, 40.3W in the output 
because there is only one significant digit. 

If you customize the formatting to Y0.0000##N X0.0000##E, the 
output will be displayed as 45.0020N, 40.30000W.
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Letters and spacing also change the display of the output 
coordinates. As another example, the default output format for MGRS 
coordinates is 11SMU4217517182. However, you can add spaces for 
added reading clarity: 11S MU 42175 17182.

If desired, you can format the output to drop the Grid 
Zone Designator by removing the letter Z, thus the output: 
MU4217517182.

6.	 In the Name field, enter a name or accept the default.

7.	 Click OK.
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Now when you select a point on the map, the new format will be 
output in the Coordinate Conversion pane.

Note: If your Input coordinate system is different from your Output 
coordinate system, for instance, your Input is MGRS and your 
Output is DD, the List will record your points in MGRS.

8.	 In the Output table, click the copy button        to copy the newly 
formatted coordinate to your clipboard.
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