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Task checklist  

 

TASK COMPLETE 

1. Deploy the Election Outreach solution 
template 

 

2. Manage election data  

3. Modify elected offices  

4. Share Election Day polling place wait times  

5. Share voting center wait times 

6. Hide election wait times 

 

7. Apply your organization’s branding 
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Overview 

State and local governments strive to improve voter participation through open 
communication and a sense of collaboration. Helping people find where they need to 
vote is inherently location based and accessing voting locations is an important aspect 
of election outreach.  
 
The Election Outreach solution template includes a collection of maps and apps that 
can be used by elections staff to educate voters and increase voter participation. This 
collection of maps and apps provides a modern way for the general public to obtain 
information about current elected officials and locate voting centers or Election Day 
polling places. The Election Outreach solution apps use geographic data typically 
managed by state and local election agencies. Election Outreach includes Election 
Data Management, which is a configuration of ArcGIS Pro used to maintain an 
inventory of electoral districts, precincts, voting centers, and polling places used by 
the Election Outreach apps. 
 

In this guide, you will learn how to configure the Election Outreach solution template 

by deploying the solution templates, using the Election Data Management ArcGIS Pro 

project, branding and configuring the My Elected Representative, Election Polling 

Places, and Voting Centers apps, and sharing election wait times with voters.  

Build skills in these areas 

• Deploying ArcGIS solution templates 

• Revising feature layer domains and views 

• Configuring web apps 

• Sharing election wait times 

What you need 

• ArcGIS Pro 2.2 or later 

• ArcGIS Online 

1.  Deploy the ArcGIS solution template  

First, you’ll install the ArcGIS Solution Deployment Tool Add-In and deploy the 

Election Outreach solution template. 
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Install the ArcGIS Solutions deployment tool 

1. Download the ArcGIS Solutions Deployment zip file. 

The Esri Downloads page opens. Note, you may need to sign in first. 

2. If necessary, close ArcGIS Pro before installing the add-in. 
3. Browse to the folder to which you downloaded the zip file and extract its contents. 
4. Double-click SolutionDeployment.esriAddinX to run the installer. 
5. Click Install Add-In. After the installation is complete, click OK. 

 

Now that you've downloaded the add-in, you can deploy ArcGIS solution templates to your 
ArcGIS organization using ArcGIS Pro. 

https://links.esri.com/download/arcgissolutiondeployment
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Deploy solution template 

Next, you’ll create a new ArcGIS Pro project and deploy the Election Outreach solution 
template to your ArcGIS organization. 

1. Open ArcGIS Pro. If necessary, sign in to your ArcGIS organization. 

Note: 

If you don't have ArcGIS Pro, you can sign up for an ArcGIS free trial. 

The start page appears. The 10 most recent projects you've worked on are listed. 

2. From New, choose Map. 
3. In the Create a New Project pane, change Name to Deploy Solutions and click OK. 

The project opens with a blank map. 

Note: 

If you already created a Deploy Solutions project, open the project. 

4. On the Share tab, in the Deploy group, click ArcGIS Solutions. 

 

The ArcGIS Solutions Deployment Tool opens in the Tasks pane. Tasks are sets of 
preconfigured steps that guide you through a workflow. The first task is to sign in to your 
organization. You've already done that, so you can skip it. 

5. Double-click the Deploy an ArcGIS Solution task. 

 

http://links.esri.com/arcgis-free-trial/
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This task contains a directory of available solution templates. The solution templates are 
organized by industry. You can also search for solution templates. 

6. In the Deploy an ArcGIS Solution task pane search bar, type Election and press Enter. 

The search returns multiple results. You'll deploy the Election Outreach solution template.  

7. Under Local Government, select Election Outreach. 

 

Note: 

If you see a check mark next to any of the solution templates, it means the solution template 
has been deployed in your organization. To deploy the solution templates, click the Options 
button and ensure that Use Existing Items in the Organization is not checked. 

  

8. For Output Folder, type Election Outreach. 
9. Click Deploy. 

The solution template deploys to your ArcGIS organization. 

10. Click Finish. 

The Tasks pane returns to the list of tasks. 
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11. Save the project. 
12. Close ArcGIS Pro. 

In this task, you downloaded and installed the ArcGIS Solution Deployment tool and 

deployed the Election Outreach solution in your ArcGIS organization. Election 

Outreach includes Election Data Management, My Elected Representative, Election 

Polling Places, and Voting Centers.  

In the next task, you will use Election Data Management to manage your election data. 

2. Manage election data 

Election Data Management includes defined tasks and instructions to load 

authoritative election data into the feature layers used by the Election Outreach apps, 

maintain key characteristics, and manage election data through election cycles. Use 

the instructions in the Election Data Management tasks to load the Election Outreach 

feature layers with election data as well as to manage that data through election 

cycles.  

1. In a browser, sign in to your ArcGIS organization. 

Note: 

If you don't have an organizational account, you can sign up for an ArcGIS free trial. 

2. At the top of the site, click Content. 
3. On the My Content tab, type Election Data Management in the search box. 
4. Under Item Type, click Maps. 
5. Click the item title Election Data Management to open the item. 
6. Click Open in ArcGIS Pro. 

The Election Data Management project opens in ArcGIS Pro. 

7. In the Catalog pane, expand Tasks and Election Data Management.  
8. Expand task group to view the Election Data Management tasks. 

Tip: 

Click each group task heading and task to view a description at the bottom of the 
Tasks pane. 

https://www.arcgis.com/home/index.html
https://www.esri.com/en-us/arcgis/trial
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9. Under Getting Started, select Understanding Election Data Management and click the 

Open Task arrow  to open the task (you can also double-click the task name). 

Review the introductory text to become familiar with the Election Outreach feature 
layers and workflow. The additional tasks include step-by-step instructions to load 
existing data, create new data, and prepare for the next election.  

Each task group includes instructional steps to populate key attributes used in the 
Election Outreach apps. Depending on your starting point, you can begin with 
different tasks. For example, if you have existing election data you want  to import into 
the Election Outreach feature layers, begin with the Load existing election data tasks.  

 

3. Modify elected offices 

My Elected Representative is a configuration of Web AppBuilder for ArcGIS used by 

the general public to determine who represents them in local, state, and federal 

elected offices. My Elected Representative includes several elected office layers 

including Mayor, County Clerk, Governor, and United State Senate. The elected 



 

 Copyright © 2019 Esri. All rights reserved.  9 
   

offices available in the app can be configured. For example, a city can deploy My 

Elected Representative and configure only local elected offices.  

Configure elected office domain values 

Review the ElectionGeography feature layer elected offices and identify an elected 
office your organization may want to add to My Elected Representative.  

1. Sign in to your ArcGIS organization. 
2. At the top of the site, click Content.  
3. On the My Content tab, under Folders, type Election Outreach in the search box.  
4. Click the Election Outreach folder.  
5. Under Item Type, click Layers. 
6. On the right side of the page, click the ElectionGeography feature layer. 
7. On the item page, click the Data tab. 
8. Click Fields. 
9. Select Electoral Districts from the Layer drop-down menu. 
10. Click the Elected Office display name.  

In the List of Values (Domain) section, review the existing categories and identify those 
that are not applicable and those that are missing. 

11. Click Edit next to List of Values (Domain). 

12. Optionally click the Delete button  to remove a category from the list, and click Save. 
13. Click Add. 
14. Type the new elected office name into the Displayed Value and Stored Value text 

boxes.  
15. Repeat steps 12-14 to add the remaining elected offices. 
16. Optionally drag the elected office names to a new location in the list to reorder them. 
17. Click Save. 

Add or delete the same elected office or offices to the ElectionGeography_public 
feature layer view. 

18. If necessary, sign in to your ArcGIS organization. 
19. At the top of the site, click Content. 
20. On the My Content tab type Election Data Management in the search box. 
21. Under Item Type, click Maps. 
22. Click the item title Election Data Management to open the item. 
23. Click Open in ArcGIS Pro. 

The Election Data Management project opens in ArcGIS Pro.  

https://www.arcgis.com/home/index.html
https://www.arcgis.com/home/index.html
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24. On the Share tab, in the Deploy group, click ArcGIS Solutions. 
25. Double-click Configure an ArcGIS Solution task.  
26. In the Configure an ArcGIS Solution step, click Next Step.  
27. In the Add Fields step, click Skip.  
28. In the Modify Domains step, click Browse next to the Input Layer or Table parameter. 

The Input Layer or Table dialog box appears. 

29. Under Portal, click My Content.  
30. Double-click the Election Outreach folder. 
31. Double-click the ElectionGeography_public feature layer view. 
32. Click Electoral Districts, and click OK. 
33. In the Field parameter, click the drop-down arrow and choose Elected Office. 
34. In the Domain section, type a new category in the Code text box and the Description 

text box. Repeat this step until all the domains that apply to your organization have 
been added. 

35. Optionally delete a domain by hovering to the left of the domain you want to delete 
and clicking remove . 

36. Optionally reposition the elected office by right-clicking to the left of the domain you 
want to move and selecting Move Uup or Move Down.  

37. Once you have finished adding or removing domains, click Run. 
38. Click Finish. 
39. Close Election Data Management and save your changes. 

Configure elected offices in the My Elected 
Representative web map 

In this task, you will configure the My Elected Representative web map to display the 
elected offices you want to display in the My Elected Representative app. 

1. If necessary, sign in to your ArcGIS organization. 
2. At the top of the site, click Content. 
3. On the My Content tab, under Folders, type Election Outreach in the search box. 
4. Type My Elected Representative in the search box. 
5. Under Item Type, click Maps. 
6. Click the item title My Elected Representative to open the item. 
7. Click Open in Map Viewer.  

The map Contents lists several preconfigured elected office map layers ranging from 
Mayor to President of the United States. Each layer is filtered using the Elected Office 
field on the Electoral Districts feature layer.   

8. To remove an unneeded elected office layer, click More Options , and click Remove. 

https://www.arcgis.com/home/index.html
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9. To add a new layer, click More Options > Copy. 

A new layer appears at the top of the Contents layer list.  

10. To update the new layer’s name, click More Options > Rename. Type the elected office 
name in the text box. Click OK.   

11. Click the Filter button  on the new layer. Click the Edit tab on the dialog box.  

An existing filter query displays Elected Office is Value. You will modify the query to 
display the desired elected office. The drop-down menu displays the values you 
configured in a previous task.  

12. Select the appropriate elected office domain value from the drop-down menu. Click 
Apply Filter.  

13. Optionally drag the layer to a new location in the Contents layer list.  

Tip: 

You can also configure existing layers using the steps above. Modify the name and 
filter of an existing layer to match your configuration needs. 

 

14. Click Save > Save to save your changes in the web map. 

Configure elected offices in the My Elected 
Representative app 

1. If necessary, sign in to your ArcGIS organization. 
2. Click Home > Contents. 
3. Type My Elected Representative in the search box. 
4. Under Item Type, click Apps. 
5. Click the item title My Elected Representative to open the item. 
6. Click Edit Application. 
7. Click the Widget tab. 
8. Click Set the widgets in this controller. 

9. Click Configure this widget  on the Find My Elected Representative widget. 
10. Select the Search Settings tab. 
11. Click Set on Select search layer(s) to configure the layers searched in the app. 

 
The Select search layer(s) dialog box configures the layers searched in the app. 
 

https://www.arcgis.com/home/index.html
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12. Ensure that the check box is selected next to each of the layers available. 
13. Click OK. 

14. Click Save to save the Web AppBuilder for ArcGIS configuration.  

4. Share Election Day polling place wait 
times on the map 

Share Election Day wait times in Election Polling Places 

Many states divide communities into geographic areas and assign registered voters to 
designated polling places based on their residential address. On Election Day, ballots 
are cast at these designated polling places and then tabulated to determine the 
winner of a political contest or proposal. Election Polling Places is a configuration of 
Web AppBuilder for ArcGIS that can be used by voters to locate their polling place 
where ballots can be cast on Election Day. 

When paired with Election Management, Election Polling Places can display Election 
Day wait times so that voters can make an informed decision about when to vote. The 
Election Polling Places web map includes a Polling Place Wait Times layer that displays 
the current wait time. To share wait times in the Election Polling Places app, you’ll use 
the included Polling Place Wait Times map layer. 

1. If necessary, sign in to your ArcGIS organization. 
2. At the top of the site, click Content. 
3. On the My Content tab, type Election Polling Places in the search box. 
4. Under the Item Type, click Maps. 
5. Click the item title Election Polling Places to open the item. 
6. Click Open in Map Viewer. 
7. Uncheck the Polling Places layer (do not remove).  
8. Check the Polling Place Wait Times layer. 

The map now displays the most recently reported wait time symbolized by the length 
of the wait reported. When an election is completed and you want to remove the wait 
times symbol, turn on the Polling Places layer, and turn off the Polling Place Wait 
Times layer. 

http://links.esri.com/localgovernment/tryit/ElectionsPollingPlaces/
http://links.esri.com/localgovernment/help/electionmanagement
https://www.arcgis.com/home/index.html
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9. Click Save > Save.  

 

5. Share voting center wait times on the 
map 

Share voting center wait times 

Voting centers are an alternative to traditional, neighborhood-based precincts. When 

a jurisdiction opts to use voting centers, voters may cast their ballots at any voting 

center in the jurisdiction, regardless of their residential address. Voting Centers is a 

configuration of Web AppBuilder for ArcGIS that  can be used by voters to locate the 

nearest voting center where ballots can be cast in person or by mail.  

When paired with Election Management, Voting Centers can display election wait 

times so that voters can make an informed decision about when to vote. The Voting 

Centers web map includes a Voting Center Wait Times layer that displays the current 

wait time. To share wait times in the Voting Centers app, you’ll use the included Voting 

Center Wait Times map layer.  

1. If necessary, sign in to your ArcGIS organization. 
2. At the top of the site, click Content. 
3. On the My Content tab type Voting Centers in the search box. 
4. Under the Item Type, click Maps. 
5. Click the item title Voting Centers to open the item. 
6. Click Open in Map Viewer. 
7. Uncheck the Voting Centers layer (do not remove).  

http://links.esri.com/localgovernment/tryit/VotingCenters/
http://links.esri.com/localgovernment/help/electionmanagement
https://www.arcgis.com/home/index.html
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1. Click Change Style . 
2. Under Select a drawing style > Location (Single Symbol), click Options. 
3. Use the Transparency slider to set the transparency level to 100%. 

 

 
 

4. Click OK. 
5. Click Done. 

 
8. Check the Voting Center Wait Times layer. 

 

The map now displays the most recently reported wait time symbolized by the length 

of the wait reported. When an election is completed and you want to remove the wait 

times symbols, turn on the Voting Centers layer and set its transparency to 0%, and 

turn off the Voting Center Wait Times layer. 

 
 

9. Click Save > Save to save your changes on the web map.  
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6. Hide election wait times 

On Election Day, the Election Polling Places app automatically displays current 

information such as the most recently reported wait time and the location’s 

operational status.  

 

In some cases, your organization might use the Election Management solution to track 

election wait times without sharing those wait times in the Election Polling Places app. 

Optionally, you can remove the wait times information. 

Remove wait times from Election Polling Places 

1. If necessary, sign in to your ArcGIS organization. 
2. At the top of the site, click Content. 
3. On the My Content tab, type Election Polling Places in the search box. 
4. Under the Item Type, click Maps. 
5. Click the item title Election Polling Places to open the item. 
6. Click Open in Map Viewer.   
7. On the Polling Places layer, click More Options > Configure Pop-up. 
8. Click the Configure button.  

http://links.esri.com/localgovernment/help/electionmanagement
https://www.arcgis.com/home/index.html
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The Custom Attribute Display window appears. 
 
Tip: 

Click the View HTML Source  button. Copy and save all the HTML syntax into a text 
editor. This will make it easier to restore wait times or discard changes. From a text 
editor, you can copy and paste the original HTML syntax into the Custom Attribute 
Display after clicking the View HTML Source button. 

9. Delete {expression/expr0} from the pop-up. Make sure the entire line is removed. The 
result looks like this:  
 

 
 

10. Click OK to close the Custom Attribute Display. 
11. Click OK to finish configuring the pop-up.  
12. Click Save > Save to save your changes to the web map. 

 
On Election Day, the pop-up now does not display wait times but continues to display 
current information such as the Today is Election Day message and operational status.  
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Remove wait times from Voting Centers 

A voting center can be open on Election Day as well as for a period prior to Election 

Day. When a voting center is open and active, the Voting Center app automatically 

displays current information such as the most recently reported wait time and the 

location’s operational status.  
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In some cases, your organization might use the Election Management solution to track 

election wait times without sharing those wait times in the Voting Centers app. 

Optionally, you can remove the wait times information. 

1. If necessary, sign in to your ArcGIS organization. 
2. At the top of the site, click Content. 
3. On the My Content tab, type Election Polling Places in the search box. 
4. Under the Item Type, click Maps. 
5. Click the item title Election Polling Places to open the item. 
6. Click Open in Map Viewer.   
7. On the Polling Places layer, click More Options > Configure Pop-up. 
8. Click the Configure button.  

 

 
 
The Custom Attribute Display window appears. Because voting centers can be open 
on Election Day only or over a period of time, you will remove wait times from two 
places in the pop-up configuration.  
 
 
 

http://links.esri.com/localgovernment/help/electionmanagement
https://www.arcgis.com/home/index.html
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Tip: 

Click the View HTML Source  button . Copy and save all the HTML syntax into a text 
editor. This will make it easier to restore wait times or discard changes. From a text 
editor, you can copy and paste the original HTML syntax into the Custom Attribute 
Display after clicking the View HTML Source button. 

9. Delete {expression/expr0} from the pop-up. Make sure the entire line is removed. The 
result looks like this:  
 

 
 

10. Scroll until {expression/expr8} is visible. 
11. Delete {expression/expr8} from the pop-up. Make sure the entire line is removed. The 

result looks like this:  
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12. Click OK to close the Custom Attribute Display. 
13. Click OK to finish configuring the pop-up.  
14. Click Save > Save to save your changes to the web map. 

 

When a voting center is open and active, the pop-up now does not display wait times 
but continues to display current information such as the This voting center is open 
message and operational status.  
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7. Apply your organization’s branding 

In this task, you will brand the My Elected Representative, Election Polling Places, and 
Voting Center apps with your organization’s unique colors and share election wait 
times with voters.  
 

Brand and configure the Election Outreach apps 

1. If necessary, sign in to your ArcGIS organization. 
2. At the top of the site, click Content. 
3. On the My Content tab type My Elected Representative in the search box. 
4. Under the Item Type, click Apps. 
5. Click the item title My Elected Representative to open the item. 
6. Click Edit Application. 
7. Brand the My Elected Representative app with unique colors. 

1. Select the Theme tab.  
2. In the Style section, select the Set Custom Color button, and click 

Custom. 
3. Select a color or click Custom to enter an RGB or hex value. Click OK. 

8. Configure the app title and other text elements. 
1. Select the Attribute tab. 

2. In the Branding section, modify the app title and subtitle. Click the  
button to use the rich text editor.  

3. Select the Widget tab.  
4. Click Set the widgets in this controller. 

5. Click Configure this widget  on the About widget. Use the rich text 
editor to modify the About text. 

6. Click OK.  
9. Click Save to save the Web AppBuilder for ArcGIS configuration.  
10. Repeat the above steps for the Election Polling Places and Voting Center apps.  

 
Tip: 

The Election Polling Places and Voting Center pop-up configurations include a banner 
to display current information (see screen shots above). Use the Custom Attribute 

Display to edit the HTML source, replacing the hex value #464646 with your 
organization’s hex value color. 

In this guide, you learned how to configure the Election Outreach solution template to 

meet your organization’s needs by adding new elected offices and configuring them 

https://www.arcgis.com/home/index.html
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in the My Elected Representative app and branding and sharing election wait times in 

both the Election Polling Places and Voting Centers apps.  
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Additional resources 

 

• State & Local Government solutions 

• Location Intelligence for Elections 

• Redistricting Tools 

 

 

https://www.esri.com/en-us/industries/state-local-government/overview
https://www.esri.com/en-us/industries/government/departments/elections
https://www.esri.com/en-us/arcgis/products/esri-redistricting/overview

