Use Geodatabase Subtypes and Attribute Domains for
Automatic Validation Tutorial
By Marnel Taggart and Mike Ridland, ESRI Educational Services
Overview

This tutorial supplements the article Use Geodatabase Subtypes and Attribute Domain for
Automatic Validation that appeared in the April-June 2000 issue of ArcUser magazine.
This article describes when and how you would use subtypes and domains to control the
integrity of new data entered in your geodatabase.
For this tutorial you will need to have ArcInfo 8.02 loaded on an Windows NT computer
with 1.2 MB of free disk space for the sample database. The sample database contains
road data for Santa Barbara, California that has been modified so it is only suitable for
completing these exercises. Please print this document so you can refer to it while
completing the tutorial.
Defining subtypes on a geodatabase feature class or table allows the attribute values stored
in one field to categorize the data and allows for automatic data entry. Domains ensure that
you may only enter legal attribute values. The following steps outline how to create
subtypes and attribute domains for a geodatabase feature class.

Gettting Started
Step 1

Download the data.

n Create a new folder that will become your working directory (e.g,. C:\tutorial).
n Down load the self extracting data file sb_gdb.exe into this directory.
n Double-click on the file to unzip the data.
This file contains the sample geodatabase, SantaBarbara.mdb.
Step 2

Start ArcCatalog, navigate to the sample data location, and preview the data.

n Start ArcCatalog.
n Navigate to the Santa Barbara geodatabase.
n Click the Roads feature class in the ArcCatalog tree.

Using Subtypes
Click the Preview tab in the right pane. View the geography or table for the Roads feature
class by choosing Geography or Table from the drop-down list next to Preview at the
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bottom of the frame. The Geography view is shown below.

You will be creating subtypes on the Roads feature class. Your subtypes coding scheme
will categorize the Roads data into four separate types without physically splitting the data
into multiple feature classes. Not only will this organize the data for display, but the
subtypes will ensure consistency when new data is added or existing data is edited.
n Right-click on the Roads feature class and choose Properties from the context menu or
double-click on the Roads feature class to bring up the Feature Class Properties dialog
box.
n Click the Fields tab.
n Scroll through the field names and note their corresponding data types.

Remember, subtypes are only permitted on Long Integer fields. Although several fields
meet the Long Integer criteria, in this exercise you will create subtypes based on the
values stored in the Class field. This field represents the type of road and has values
ranging from 1 to 4.
n Click Cancel to close the Properties dialog.
n Preview the Roads attribute table by choosing Table from the drop-down box in below
the Preview frame. This time, examine the Class field values.
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The following table shows the existing numeric Class codes and the corresponding
descriptions you will be assigning for the subtype.
Code

Description

1

Interstate Highway

2

Primary Road

3

Secondary Road

4

Ramp or Interchange

Now you will create subtypes for the Roads’ Class field.
Step 3

Create new subtypes and set their default values.

n Open the Feature Class Properties dialog box for the Roads layers by double-clicking
on the Roads layer or right-clicking on the Roads layer and choosing Properties in the
context menu. Click on the Subtypes tab in the Feature Class Properties dialog box.
n From the Subtype Field pull-down menu, choose Class.
Now you will specify the code and related description for each value stored in the Class
field.
n In the first cell under the Code heading, overwrite 0 with 1.
n In the first cell under Description, overwrite New subtype with Interstate Highway.
Notice that the Default Subtype now reads Interstate Highway. You’ll change that in just a
minute.
n Fill in the rest of the subtype values and descriptions from the table above and click the
Apply button when finished.The dialog box should resemble the illustration below.

You can choose one of the subtype codes as the default value. Newly added features will
inherit this code. You will change the default subtype since you believe you will be
adding many new Primary Roads.
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n Set the default subtype value by choosing Primary Road from the drop-down list for
Default Subtype. Click on the Apply button.
Using this dialog box it is possible to set default attribute values for each subtype. For
example, if the majority of new Secondary Roads will have two lanes and a speed limit of
35 miles per hour, these values may be set as defaults to save editing time. You will set
default values for Primary and Secondary Roads as you believe these are the most
frequently edited features.
n Click on the bar just to the left of the Primary Road in the subtype list to select the
Primary Roads subtype.
n Enterdefault values of 4 for NumLanes, 2 for TrafficFlow, and 50 for SpeedLimtthe the
selected subtype in the bottom menu list. Click on the Apply button when these values
have been entered.Next, set the default values for the Secondary Roads subtype by
clicking the bar next to it and entering 2 for NumLanes, 2 for TrafficFlow, and 35 for
SpeedLimit

n Click Apply, and then OK to dismiss the dialog box.
New Primary and Secondary Roads will automatically inherit these default values for
NumLanes, TrafficFlow, and SpeedLimit.

Step 4

View the subtypes in ArcMap.

Now that the subtypes have been defined, you will take a look at how they are displayed in
ArcMap.
n From the ArcCatalog menu, launch ArcMap.
n Add the Roads feature class from ArcCatalog by dragging and dropping it onto the
ArcMap display canvas or by choosing File > Add from the ArcMap interface or by
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pressing the AddData button and browsing for the file.
n Zoom in to the Roads layer as desired.

Notice how ArcMap automatically displays the Roads data classified by your subtypes.
Note that the Class field stores Long Integer values (e.g., 1,2,3) and the subtype translates
these codes into textual descriptions.
Double clicking on the symbols in the Table of Contents will allow you to choose
something other than ArcMap’s default symbology for the subtypes.
n Change the symbology of the subtypes if desired.
Step 5

Edit with subtypes in ArcMap.

Next, you will look at how subtypes allow for automatic data entry. When adding new
features or editing existing features in ArcMap, your data will be constrained by the
subtypes you’ve defined.
n If it is not already available, add the Editor toolbar to your ArcMap session by
choosing Tools > Editor toolbar.
n Choose Start Editing from the Editor menu on the Editor toolbar.
n If necessary, Zoom into a small portion of the display.
n Select any Primary Road.
n Click on the table icon in the Editor toolbar to open the Attribute Editor.
n Click on the value for the Class property.
Notice how descriptions rather than the numeric codes are provided as an attribute choices
in the drop down box.
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n Choose a Secondary Road for the Class attribute.
Notice that the values for NumLanes and SpeedLimit have automatically been updated to
the default values of the new subtype you set.
n Experiment with editing operations as desired.
n Choose Stop Editing from the Editor menu in the Editor Toolbar and click on No when
prompted to save your edits.
n Quit ArcMap.

Working with Domains
Step 6

Create attribute domains.

Next you will explore setting domains for the geodatabase. Recall that a domain defines a
set of legal attribute values for a field subtype code. Domains are created in ArcCatalog
and can be either coded values or ranges. Since they are a property of the geodatabase,
domains can be shared by fields in multiple tables. Now you will create several attribute
domains.
n In ArcCatalog, right-click on the Santa Barbara geodatabase and choose Properties in
the context menu to bring up the Database Properties dialog box.
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.

The Domains dialog box has three data input sections. The top section lets you add a
domain name and description. The section in the middle allows you to edit domain
properties and the bottom section lets you specify the valid attributes for a domain that
uses coded values.
Domains help when you are editing. For instance, coded value domains provide a list of
valid attribute values when you are editing inside the Attribute Editor. Range domains
ensure the your edited attributes fall within a specified range of numeric values. You will
create coded value domains for the fields NumLanes and TrafficFlow and a range domain
for SpeedLimit by using the Domains section of the Database Properties dialog box.
Click on the bar next to the first cell under Domain Name to enter the LaneNo domain
properties specified in the LaneNo domain table. Enter the information from the table in
each of the three sections of the Database Properties dialog box as indicated. Be sure to
click the Apply button to update the dialog box after the domain information is added.
Follow the same procedure to enter the domain properties for TrafficDirection and
SpeedLimit using the values shown in the Traffic Direction and SpeedLimit domain
tables. Make sure to click the bar next to the cell under Domain Name when entering the
parameters for each domain. Be sure to click the Apply button to update the dialog box
after the domain information is added. Note that since SpeedLimit uses a range rather than
coded values, the dialog box will change to provide Minimum Value and Maximum Value
fields but will omit the coded value section. Leave the Split Policy and Merge Policy
Fields with the default value.
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LaneNo Domain
Domain Name

Description

LaneNo

Number of Lanes

Domain Properties
Field Type

Long Integer

Domain Type

Coded Values

Coded Values
Code

Description

2

Two Lane

4

Four Lane

6

Six Lane

TrafficDirection Domain
Domain Name

Description

TrafficDirection

Direction of Traffic

Domain Properties
Field Type

Short Integer

Domain Type

Coded Values

Coded Values
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Code

Description

1

One Way

2

Two Way
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SpeedLimit
Domain Name

Description

SpeedLimit

Speed Limit

Domain Properties
Field Type

Long Integer

Domain Type

Range

Minimum value

5

Maximum value

70

The completed Database Properties dialog should look like the illustration above.
Step 7

Apply your domains.

In this step you will apply your new domains to the fields of the Roads data.
n In ArcCatalog, display the property sheet for the Roads feature class.
n Click the Subtypes tab.
You can set the domain for each subtype field by choosing from the list of defined
domains in the Default Values and Domains scrolling list.
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n Click on the bar to the left of the Interstate Highway subtype and apply the domains
you created in the previous section to the fields as shown in the table below.

Field Name

Domain Name

NumLanes

LaneNo

TrafficFlow

TrafficDirection

SpeedLimit

SpeedLimit

n Now apply the same domains to the other three subtypes.

n When domains have been applied to all the subtypes, click on Apply and OK.
You just applied a domain to each individual subtype. When you apply domains in this
manner, you have more flexibility in specifying which domain associates with each
subtype. If all of your subtypes have the same domains (as in our example), you can use a
shortcut. Apply the domains you created by to the entire field by using the dialog box
under the Fields tab.
Now that the domains have been applied, experiment editing with them in ArcMap.
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Step 8

Edit with the domains in ArcMap.

n Launch ArcMap. Add the Roads feature class from ArcCatalog by dragging and
dropping it onto the ArcMap display canvas or by choosing File > Add from the
ArcMap interface or by pressing the AddData button and browsing for the file.
n Open Editor toolbar if it is not available.
n Choose Editing > Start Editing from the Editor toolbar.
n Zoom in as desired.
n Use the selection tool in the Editor Toolbar to select a roads. Hold down the Shift key
to select additional roads. Open the Attribute Editor by clicking on the Table icon in the
Editor toolbar.
n Click the values for the NumLanes or TrafficFlow fields. Note that these coded value
domains list the available values.
Now experiment with the range domain for the SpeedLimit field.
n Change the SpeedLimit value to 100 by selecting the Value field and typing in 100.
Notice that ArcInfo will let you add almost any numeric value, even an invalid value. For
example, 100 is outside of the 5 to 70 miles per hour range. Now have ArcInfo check to
see if you have any invalid attributes.
n From the Editor Toolbar choose Validate Selection.
A dialog window appears telling you that your attribute is not within the acceptable range.
Any features with invalid attributes remain selected.

n Change the SpeedLimit back to a value with the range.
n Choose Editor > Validate Selection to validate the new compliant value for
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SpeedLimit.
A dialog appears telling you all features are valid.
Step 9

Adding invalid data.

You want to override coded value domains. For example, your two-lane road may
temporarily become three lanes due to a passing zone (i.e., an additional lane) along one of
the directions of travel. You would not be able to add a “3” through the Attributes Editor
dialog, but you can add this potentially invalid data by editing the table directly.
Experiment adding potentially invalid data to the table.
n With the Roads layer displayed in ArcMap, choose Start Editing from the Editor menu
in the Editor Toolbar. Select a road from the layer.
n Right-click on the Roads layer in the table of contents. From the context menu, choose
Selection > Open Table for Selected Features.
n Change the NumLanes to 3, a value outside the coded domain, then close the table.
3

n From the Editor menu, choose Save Edits and then Stop Editing.
Notice that the new value was accepted without any error notification. This means you
can concentrate on adding attributes rather than validating errors after each edit. When
you are done editing all your values, you can save time by validating all at once.
n Choose Start Editing from the Editor menu.
n Use your mouse to select your previously edited feature(s).
n Chose Editor > Validate Selection.
A dialog box identifying the offending value and valid data parameters will be displayed.
n Open the Attribute editor and make edits as needed, or you can choose to leave the
NumLanes as “3”.
ArcMap will let you save invalid data and find invalid data using the Validate Selection
menu tool. You can fix invalid data by using the Attribute Editor or by directly editing the
table.
n Quit ArcMap.
Congratulations, you have completed this tutorial. You have created and applied subtypes
and domains and seen the benefits of these validation rules.
Learn more about subtypes, domains, and the geodatabase by reading Modeling Our
World: The ESRI Guide to Geodatabase Design. This book ships with ArcInfo 8.01
software and is also available from ESRI Press. Several instructor-led training courses on
using geodatabases, What’s New in ArcInfo, Introduction to ArcInfo using ArcMap,
ArcCatalog and ArcToolbox, and Working with the Geodatabase, are offered by ESRI. For
more information about educational materials, visit www.esri.com\education.
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