Features to Go:

Field Deployable GIS
By Ty Fitzpatrick, ESRI Technical Marketing Analyst
Advancements to infrastructure management
have included the development of distributed
data management techniques. The Internet,
terminal servers, and disconnected geographic
databases are some of the strategies that
have been implemented for distributing
geographic data to decentralized locations.
Although the Internet and terminal servers are
suitable solutions for many database-driven
applications, disconnected databases are
required when persistent network connections
between databases are not available or when
creating or updating data in the ﬁeld is
necessary.
Distributed data management also
covers scenarios such as a remote ofﬁce
where dedicated network connections to a
centralized database are not practical from an
administrative or security standpoint. Using
distributed data management enables satellite
ofﬁces, subcontractors, and ﬁeld technicians
to complete independent tasks on a subset of
data from a central database with minimal
administrative impact related to synchronizing
data changes.
Distributing data, in the form of personal
geodatabases for ArcEditor (or ArcInfo) or
shapeﬁles for ArcPad, gives organizations
choices in cost and implementation style.
Furthermore, ﬁeld technicians in many
disciplines, from electric and gas companies
to environmental and government agencies,
whether using ArcEditor or ArcPad, demand
easy-to-use
applications
for
updating
centralized databases. Using a combination
of the ﬁeld-editing tools provided with
ArcGIS can meet all the requirements for
ﬁeld data collection. This article will discuss
disconnected editing and the ArcPad extraction
tools for the geodatabase that are available in
ArcGIS 8.3.
You Can Take It With You
Disconnected editing is designed for users
requiring a fully functional ArcEditor seat in
the ﬁeld for the query, analysis, and design
of geographic objects. Disconnected editing
tools extract a subset of geographic features
from a master geodatabase to a checkout
geodatabase. Disconnected editing tools are
accessed by choosing View > Toolbars > Editor
> Disconnected Editing in the main menu or
by choosing Editor > More Editing Tools >
Disconnected Editing in the Editor toolbar.
These tools check out and check in data,
manage checkouts, and extract data. Extract
data functionality is also perfect for creating
a subset of the data in the enterprise database
and copying it to a separate geodatabase that
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Select individual layers for extraction.
will not be checked back into the enterprise
database.
Using disconnected editing is simple.
Geographic and tabular data from a master
geodatabase is checked out to a checkout
geodatabase. The master geodatabase must be
an ArcSDE geodatabase, and the data checked
out must be in feature classes that are registered
as versioned. The checkout geodatabase can be
either an ArcSDE or a personal geodatabase.
The master ArcSDE geodatabase will support
multiple checkouts to personal or ArcSDE
databases. If the checkout geodatabase is
registered as versioned, it may also serve a
dual role as both a master and a checkout
geodatabase.
The Checkout Geodatabase
Map documents help to spatially deﬁne how
data is checked out from a master geodatabase.
Data can be checked out based on the extent of
the current display, the full extent of the data,
the extent of a currently selected graphic, or by
user-deﬁned coordinates. Attribute ﬁlters based
on selected sets for individual feature classes
can be used to further reﬁne the data extracted.
These techniques allow data extraction to be
tailored to speciﬁc work ﬂows.
All features in a geodatabase can be
extracted from simple features (e.g., lines,
points, polygons, annotation, and dimensions)
to more complex features (e.g., geometric
networks, topologies, and all types of
relationship classes). When features have

dependencies on other feature classes, as is the
case with geometric network and topologies,
all relative data is extracted. When extracting
features in topologies and geometric networks,
all spatial and geometric network integrity
rules are also checked out and remain intact,
and these features behave just as they do in the
master geodatabase. Because all feature types
and networks in a geodatabase are supported,
ﬁeld crews and remote ofﬁces can maintain
and query geographic data as though they were
using the master geodatabase.
Only a few steps are required to check
out data. Simply deﬁne the version for the
checkout, select the ﬁlter method for identifying
geographic objects, further reﬁne the selection
criteria based on individual feature classes if
necessary, and select a checkout geodatabase.
The checkout geodatabase will contain a
duplicate schema of the master geodatabase
for those checked out features including
feature class deﬁnitions, geometric networks,
domains, and any other geodatabase rules.
And because the data extracted from the master
geodatabase must be registered as versioned,
conﬂict detection rules are enforced when data
is checked back in. Conﬂicts are resolved in the
checkout version that was created during the
checkout process.
Optionally, a map document may be created
for each checkout. Each layer preserves the
properties contained in the map document
connected to the master geodatabase as well as
all other document settings, ensuring the ﬁeld
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Reﬁne selection criteria for the selected layers.
technician has the same experience as a user
back at the head ofﬁce.
Integrating Data Into
the Master Geodatabase
Data can be checked in using either ArcCatalog
or ArcMap. In ArcCatalog, right-click on the
database connection and select Disconnected
Editing > Checkin. In ArcMap, access the
Disconnected Editing toolbar as previously
described and click the Checkin button. Only
updates, inserts, and deletes are posted back
to the master geodatabase. These updates
are resolved against the version deﬁned for
the checkout, and reinforced by all conﬂict
detection rules during check-in.
Delta Databases
Checking in an update from a checkout
geodatabase back to the master geodatabase
can be accomplished in two ways. If a
persistent database connection is available,
changes between the master and checkout
geodatabases can be incorporated directly.
However, if a dedicated connection is not
available, in the case of satellite ofﬁces, or
where the infrastructure does not provide
enough bandwidth, only the edits (or deltas)
made to check out data can be exported to a
delta database. The delta database is smaller
and more portable than the entire checkout
database. Consequently, delta geodatabases can
be transmitted more easily than copying over
the entire checkout geodatabase.
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To create a delta database, choose Tools >
Customize from the ArcMap main menu. In the
Customize dialog box, select the Commands
tab. Highlight Disconnected Editing in the right
pane. From the left pane, drag and drop the
Export Changes button onto the Disconnected
Editing toolbar. This command, now available
from the toolbar, will create a delta database
containing only the changes created in the
checkout geodatabase.
Custom Implementations
If out-of-the-box functionality does not meet
all the needs for an organizationʼs work ﬂow,
a full application program interface (API) is
available. Larger organizations often require
tailored implementations supporting dozens of
ﬁeld crews.
To streamline this process, scripts can
be written that automatically incorporate
detached databases with the enterprise GIS.
Conﬂicts between critical features can be
trapped and piped to log ﬁles and reports for
engineers or managers to resolve at a later
date. Many code samples demonstrating these
types of implementations are available from
the ArcObjects Developer Help by choosing
Samples > Geodatabase > Disconnected
Editing.
ArcPad Extraction
In a fashion similar to disconnected editing,
ArcPadʼs extraction utilities check out a subset
of geographic features from a geodatabase.

However, these features are exported to
a workspace of shapeﬁles rather than to a
checkout geodatabase. These extraction tools
are designed for organizations that require a
low-cost solution in the ﬁeld and donʼt require
the editing capabilities of ArcEditor.
Typically, these users will perform basic
data capture and attribute manipulation in
addition to viewing and querying data on
small, handheld devices. The user experience
is similar to disconnected editing. To access
these tools, in ArcMap choose View > Toolbars
> ArcPad from the main menu.
The methodology for extracting data to
ArcPad is similar to that for disconnected
editing, but the naming conventions are an
little different. Get Data for ArcPad replaces
Checkout, Check in Data for ArcPad handles
Checkin functions, and Undo Checkout is
analogous to Manage Checkouts.
However, unlike disconnected editing, the
data extracted from the master geodatabase
can be either versioned and residing in an
ArcSDE geodatabase or data from a personal
geodatabase. This enables ArcView users to
export data to ArcPad for use in the ﬁeld. If
data is being extracted from versioned feature
classes in a geodatabase, versions will not be
created for each checkout. However, applying
the same principles designed for disconnected
editing (i.e., creation of a version for each
checkout) will reduce conﬂicts between
editors.
Checking Features Out to ArcPad
ArcPad extraction also uses the map document
to deﬁne how geodatabase objects are extracted,
and several methods are available for further
reﬁning the selection of the data that will be
exported from the master geodatabase. The
same spatial methods used with disconnected
editing—the extent of the current display, the
full extent of the data, and the extent of the
currently selected graphics, or features—are
available. Filters can also be applied by
deﬁning deﬁnition queries to individual layers.
Furthermore, only ﬁelds deﬁned as visible
in the layer properties will be extracted to
the shapeﬁles schema. The experience for
users of ArcPad with extracted features and
disconnected editing is virtually the same.
Because shapeﬁle datasets store feature data
differently than geodatabases, not all complex
feature type characteristics can be preserved.
Because shapeﬁles donʼt support complex
features (e.g., edges and junctions), they are
converted to simple feature types (e.g., lines
and points). Refer to the online help for speciﬁc
Continued on page 60
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details on data type changes during ArcPad
checkout.
An ArcPad project folder containing a map
document with symbology for each layer of the
ArcMap document is created during the checkout
process. Property pages are created for each layer
containing pull downs for all domains deﬁned in
the geodatabase.
When extracting data from a versioned
geodatabase to ArcPad, create a version of the
database for the checkout and start editing. Select
the layers and workspace that will be checked
out, and choose the ﬁlter method needed for

identifying the desired feature classes. As the last
step, deﬁne a destination folder for the exported
shapeﬁles and ArcPad project.
Checking In Features From ArcPad
Checking in data from a device using ArcPad
to the master geodatabase is just as easy as
checking it out. If the master geodatabase
is versioned, change the version to the ﬁeld
version created from the checkout and use
Checkin Edits from ArcPad toolbar in ArcMap.
Select the layers that will be incorporated back
into the master geodatabase. All edits made to
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features and their attributes will be merged
with the master geodatabase.
After the edits from ArcPad have been
incorporated into the master geodatabase,
reconciling and posting of those features with
the parent version will resolve any conﬂicts
that may have been introduced. If a personal
geodatabase is being used with ArcView, edits
will be merged with the current edit session.
Wrap-Up
For some organizations, data collection in
the ﬁeld is a fundamental aspect of their
business model. To meet these requirements,
the disconnected editing and ArcPad
extraction tools available in ArcGIS 8.3 can
help users in satellite ofﬁces or in the ﬁeld
access, update, and then reconcile data with
the master geodatabase, which provides a
more ﬂexible work ﬂow. ArcGIS not only
supports distributed data management right
out of the box but also allows for extensive
customization to serve the speciﬁc needs of
large organizations. For more information
on disconnected editing and the ArcPad
extraction utilities, refer to the online help.
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