Model GTOPO30 Data
in ArcView GIS
By Lt. Keith P. Barto, United States Navy
With contributions from Dr. David Miller, SUNY College at Cortland, Gerry Hatcher,
Monterey Bay Aquarium Research Institute, and Mike Price, ESRI
Editor’s Note: This article explains how to download the Global 30-Arc-Second
(GTOPO30) digital elevation model (DEM) data available from the U.S. Geological
Survey’s Web site. This data can be converted to grid format using ArcView GIS
with the ArcView Spatial Analyst extension. The author explains how to use the
Map Calculator in ArcView Spatial Analyst to apply several formulas that will allow
ArcView GIS to correctly recognize negative values and modify other aspects of the
data. With these adjustments made, the data can be used with the ArcView 3D Analyst
extension to create two- and three-dimensional models and export images of these
models in formats suitable for use with other programs and on the Web.

Background on the GTOPO30 Data Set
The GTOPO30 data set, completed in 1996,
was developed by the U.S. Geological Survey’s
EROS Data Center with funding or data
contributions from the National Aeronautics
and Space Administration (NASA), the United
Nations Environment Programme/Global
Resource Information Database, the U.S.
Agency for International Development, the
Instituto Nacional de Estadistica Geografica

This data set covers an area that ranges between
90 degrees north to 90 degrees south latitude
and between 180 degrees west to 180 degrees
east longtitude. The horizontal grid spacing
is 30 arc-seconds (0.008333333 degrees or
approximately 1 kilometer), resulting in a
DEM with dimensions of 21,600 rows and
43,200 columns. The horizontal coordinate
system is decimal degrees of latitude and
longitude referenced to World Geodetic System

e Informatica of Mexico, the Geographical
Survey Institute of Japan, Manaaki Whenua
Landcare Research of New Zealand, and the
Scientific Committee on Antarctic Research.
The GTOPO30 DEM raster data is primarily
derived from the Digital Terrain Elevation
Data (DTED) Level 1 data set produced by
the National Imagery and Mapping Agency
(NIMA) and ESRI’s Digital Chart of the
World.

of 1984 (WGS84). The vertical units represent
elevation in meters above mean sea level.
The elevation values range from -407 to
8,752 meters.

Choose the DEM data at
the USGS EROS Data
Center using the graphical
interface.
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Ocean areas have been masked as “no data”
and have been assigned a value of -9999. Lowlying coastal areas have an elevation of at
least 1 meter. If the ocean value is changed
from -9999 to 0, the land boundary will be
www.esri.com

Hands On

Use Compute Hillshade from the
Surface menu to create a rendered
perspective of the data.
maintained. Due to the nature of the raster
structure of the DEM, small islands in the ocean
less than approximately 1 square kilometer are
not represented.
Information on available coverages and
ordering procedures for this data can be found
on the USGS Web site. Visit ArcUser Online
for links to this site.
Downloading and Converting DEM Data
Before locating and downloading the sample
data set, create a new folder named gtopo30
with a subdirectory folder called grdfiles to
hold downloaded data files. Go to the ArcUser
Online site for links to the USGS Distributed
Active Archive Center. The site uses a graphical
interface to let visitors select tiles to download.
This exercise uses tile w100n40, which is the
second tile down and third tile over from the
left in the grid.
1. Download the w100n40 to the gtopo30
folder. If the file downloads with the
name w100n40_tar.tar, rename it
w100n40.tar.gz using Windows Explorer
or another file manager. Winzip is
required to decompress this file. Choose
Options>Configuration to make sure the
Tar Smart CF/LF Conversion option is
turned off in Winzip before extracting
this file. If this default setting is not
changed, carriage return characters may
be converted to CF/LR pairs, which will
create corrupted files.
2. Decompress the w100n40.tar.gz file into
the gtopo30 folder. This folder should
contain 11 files all beginning with
www.esri.com

3.

4.
5.

6.

7.

8.

w100n40 and ending with a variety of
extensions.
Rename the w100n40.dem to
w100n40.bil. Renaming this file allows it
to be imported as a Band Interleaved by
Line (.BIL) image file.
Launch ArcView GIS and make sure the
ArcView Spatial Analyst and ArcView
3D Analyst extensions are loaded.
Open a new project and view. Specify
an image data source and add the
w100n40.bil file to the view. Make this
theme active and display it.
Convert the image to a grid by choosing
Theme>Convert to grid from the menu.
Save the output grid to the gtopo30/
grdfiles subfolder and accept the default
name nwgrd1. Click on Yes in the dialog
box to add nwgrd1 to the current view.
Make nwgrd1 active. This grid contains
information for an area 15 degrees by
25 degrees. For most users it is advisable
to work with only a portion of this area
at any one time.
Resize the working area by choosing
Analysis>Properties from the menu. In
the Analysis Properties: View 1 dialog
box set Analysis Extent to As Specified
Below. Set Left to –100, Right to –95,
Bottom to 35, and Top to 40. The
working area will now be located in the
upper left corner of the view.
The GTOPO30 DEM is 16-bit signed
integer data in simple binary raster
format. Previous modeling articles in
ArcUser magazine used the one-degree
Continued on page 50

Winzip is required to uncompress the
GTOPO30 data files. Make sure the TAR File
Smart CF/LF Conversion option is turned off.
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Model GTOPO30 Data in ArcView GIS
Continued from page 49

Change the working area by choosing
Analysis>Properties and specifying the extent in
the dialog box.

Use the Map Calculator to apply a formula that
will make ArcView GIS interpret integer data
correctly.

The Map Calculator is also used to change
ocean mask values of -9999 to null values.
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USGS DEM data, which is provided in
ASCII format. The GTOPO30 files can
be converted to ASCII by creating a grid,
which was done in the previous step,
and applying the following formula.
Go to Analysis>Map Calculator. Select
Nwgrd1 from the list under Layers. In
the formula box enter the following
formula. Click on the Evaluate button
when finished. A new theme, Map
Calculations 1, will be added to the
theme. ([Nwgrd1] >=
32768).con([Nwgrd1] 65536, [Nwgrd1])
9. In this formula, 32,768 represents 2 to
the 15th power and 65,536 represents
2 to the 16th power. In the GTOPO30
DEM, 1 bit is used for the sign and
15 bits are used for the number. This
means 2 to the 15th power is the
maximum value that can be represented.
ArcView GIS interprets the integer data
as unsigned and uses all 16 bits for the
number, thus placing values in the range
0 to 65,536. The formula is needed so
that ArcView GIS properly recognizes
the negative values in the data. Center
the image and zoom to a comfortable
level.
10. GTOPO30 data files use the value -9999
to mask ocean areas. These values need
to be changed to null. Close and reopen
the Map Calculator. The new grid theme,
Map Calculation 1, now appears in the
Layers list. Maximize the view and make
the Map Calculation 1 theme active. In
the Map Calculator, enter the following
equation in the formula box and click on
the Evaluate button.
([Map Calculation 1] =
-9999).setnull([Map
Calculation 1])
11. Make the new theme, Map Calculation 2,
the only active and displayed theme in
the view. The map units for this new grid
are decimal degrees and the elevation is
in meters.
12. Save the project.
Constructing
Three-Dimensional Projections
Two methods for creating a rendered
perspective using an overhead view and a threedimensional terrain visualization are described
here. Both methods use functionality that is
built into ArcView Spatial Analyst or ArcView
3D Analyst.

Rendered Perspective Overhead View
This method uses the Hillshade feature
available in ArcView Spatial Analyst and
ArcView 3D Analyst to produce an overhead
view of rendered terrain.
1. With the previously created project and
view open and the Map Calculation
2 theme active, choose Analysis> Map
Calculator.
2. Enter the following formula in the formula box and click on the Evaluate
button. ([Map Calculation
2]*0.004)
3. Make the new theme, Map Calcualtor
3, active and choose Surface>Compute
Hillshade from the menu.
4. In the Compute Hillshade dialog, change
Altitude to 55 and leave Azimuth to the
default value of 315. Click on OK when
finished.
Three-Dimensional Terrain Visualization
1. With the previously created project and
view open, open a 3D Scene window
by clicking on the 3D Scene icon in the
main Project window. Position windows
for view and 3D Scene so that each can
be seen.
2. In View1, make the Map Calculation 2
theme active.
3. Choose Edit>Copy Themes from the
view menu.
4. Make the 3D Scene view active and
choose Edit>Paste.
5. Make sure the Map Calculation 2 theme
in the 3D Scene window is active.
Choose Theme>3D Properties. In the
3D Theme Properties dialog box select
Assign Base Heights by Surface and
use calc2 as the surface. Check the box
Show Shading for Features in the lower
left side of the dialog box. Click on
OK. Be patient. This process will take a
minute or two. During this process the
view window may either go blank or
be very distorted because the horizontal
component of the data is in decimal
degrees and the vertical component is in
meters.
6. Once the process is complete choose 3D
Scene>Properties. In the 3D Properties
dialog box select 1.5 from the drop-down
box next to Vertical Exaggeration Factor
and click on the Calculate then the OK
buttons. Be patient. After a short time the
GTOPO30 tile will be rendered in three
dimensions in the 3D Scene view.
www.esri.com
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Use ArcView 3D Analyst
to create a three-dimensional visualization of the
GTOPO30 data.
7.

8.

Double-click on the Map Calculation 2
theme in the 3D Scene legend to bring
up the Legend Editor. Choose Terrain
Elevation #2 from the drop-down box in
the Color Ramp selection.
Rotate to the desired perspective.
Choose 3D Scene>Properties to adjust
Sun Azimuth and Sun Elevation in the
3D Scene Properties dialog box.

Convert Three-Dimensional
Views to Images
These three-dimensional images can be saved
in JPEG or BMP format directly from ArcView
3D Analyst for use with other applications
and on Web pages. These images can also be
exported out of ArcView 3D Analyst in Virtual
Reality Modeling Language 2.0 (VRML)
format. VRML is a platform-independent
format for sharing three-dimensional files on
the Web.
Save in JPEG or BMP Format
Choose 3D Scene>Save as Image and choose
the desired file format, JPEG or BMP, from
the drop-down box. Specify the width for the
output image and the height will be scaled to
it. Provide an output file name and location.

INFO BOX
What you will need to build this model
• ArcView GIS 3.1 or higher
• ArcView Spatial Analyst 1.1 or higher
• ArcView 3D Analyst or higher
• 120 MB of free hard drive space
• Pentium class PC with 64 MB of RAM
www.esri.com

Save in VRML Format
With the desired file open in ArcView 3D
Analyst, choose File>Export to VRML 2.0.
Keep the size of export files small, or they
will not work well with Web browsers on PCs.
Cosmoplayer from Cosmo Software seems to
work the best with these files.
For more information on modeling data using
ArcView GIS and its extensions, visit the
“Terrain Modeling with ArcView GIS” section
of the ArcUser Online Web site or read
Extending ArcView GIS, available from ESRI
Press through the GIS Store.
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Disclaimer
The user assumes all responsibility for use of the sample routines as well as implementation of them to achieve the intended
results. The user is responsible for fully testing each portion of
the routine prior to relying on it. This information is offered as a
sample only, and ESRI assumes no obligation for its operation,
use, or any resultant effect in spite of this offer. This information
and these sample routines are provided on an “as is” basis, without warranty of any kind.
Please remember to back up your data prior to using
this information.
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