Suitability Analysis
With Raster Data—Part 2
By Chris Wayne, ESRI–Olympia
The tutorial “Suitability Analysis With Raster
Data” that appeared in the April–June 2003
issue of ArcUser magazine showed how to
create and convert grid layers and set up a
model for landfill site suitability analysis for
a fictional county. In this next installment,
you will use the same data to perform the
analysis and make a map showing the analysis
process.
The sample data for this exercise came
from the Montana Natural Resources
Information System (NRIS) and is public
access data. However, this data has been
modified for purposes of this exercise, and
you should not use it for anything other than
this exercise. To acquire real data, go to the
NRIS Web Site (nris.state.mt.us).
In this exercise, a continuation of the
tutorial in the previous issue of ArcUser,
you will reclassify the data for several layers
that represent relevant factors to the landfill

Figure 1: The file structure for this exercise
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analysis and use the Raster Calculator in
ArcGIS Spatial Analyst to run the model. The
sample dataset, which can be downloaded
from the ArcUser Online Web site, contains
a ready-to-go map document (.mxd file) and
data for the tutorial.
Measuring Suitability
You will reclassify each data layer on a scale
of 1 to 5, with 5 being the most suitable for
the new landfill and 1 being least suitable. In
the real world, ranking these factors could
be influenced by public input, scientific data,
economic impacts, and other criteria. For the
purpose of this exercise, the subjective values
for most factors have been decided, but you
could change them to reflect your own criteria.
You can also exclude a category from analysis
by reclassifying it as NoData.
Reclassifying Values
You will use different methods to reclassify
each layer. It will be easier to examine
each new grid that is generated during
the reclassification process if you change
each legend to graduated color and with 5
classifications based on value. Use a different
color ramp for each reclassified layer. When
reclassifying each layer, enter the new values
manually.
1. Download the sample data from the
ArcUser Online Web site. Use WinZip or a
similar utility to unpack the file. The directory
structure shown in Figure 1 will be created.
2. Open landfill_analysis.mxd, the map
document. Make sure the ArcGIS Spatial
Analyst extension is activated. Choose Tools
> Extensions and check Spatial Analyst. If the
Spatial Analyst toolbar is not visible, choose
View from the main menu and toggle it on.
3. Choose Spatial Analyst > Reclassify from
the Spatial Analyst toolbar. Choose Slope of
elevation as the input raster. In the Reclassify
dialog box, click on the Classify button and
change the Classification Method to Equal
Interval and specify 5 classes. Click OK.
4. In the Reclassify dialog box, change the
values as shown in Figure 2. This is most
easily done by changing the values in the Old
values column first, then changing the New
values column. Note: Leave a space between
each value and the dash between them in
the Old values column. When the dialog box
looks like the illustration, click OK. A new
grid called Reclass of Slope of elevation is
created.
5. Right-click on the new layer. Choose
Properties, click on the Symbology tab and

In the Reclassify dialog box, click on the
Classify button and in the Classification dialog
box, change the Classification Method to
Equal Interval and specify 5 classes. Click OK.
change the legend to Classified, specify
5 classes, and select a color ramp. Click Apply
and OK.
6. Right-click on the layer and choose Make
Permanent from the context menu. Save
the map in <YourDirectory>/lf_analysis/
d_reclass/ as slope_r1. Notice that areas with
high slope values are classified as unsuitable
because of the problems associated with
excavating on steep slopes.
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New values

0–1
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2
5
4
3
1
No Data

Figure 2: Reclassification values for Slope of
Elevation
Using a Saved Classification
The least suitable sites are those closest
to currently operating landfills. However,
landfills too far away could cause
management and maintenance headaches. In
the first tutorial, the locations of open landfills
were reclassified to measure the distance (in
meters) of every cell from all open landfills.
The output grid was saved as sl_dist.
1. In the Spatial Analyst toolbar, choose
Spatial Analyst > Reclassify. In the Reclassify
dialog box, make sl_dist the input raster.
2. Click the Load button and choose
distance_reclass from <YourDirectory>\lf_
analysis\tables\. Back in the Reclassify dialog
box, click OK. A new grid called Reclass of
sl_dist is created.
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What You Will Need
• ArcGIS 8.x (ArcInfo, ArcEditor, or ArcView license)
• ArcGIS Spatial Analyst extension
• Sample data and map document from the
ArcUser Online Web site (www.esri.com/arcuser)
• An unzipping utility such as WinZip

3. Right-click on the new layer and choose
Properties to change the legend to Graduated
Color with 5 classes as previously described.
Right-click on the layer and choose Make
Permanent from the context menu and save
the layer as distance_r1 in <YourDirectory>\
lf_analysis\d_reclass\.

Right-click
on Reclass of
sl_dist and choose
Properties to
change the legend
to graduated color
with 5 classes
as previously
described.

Add a Reclassification
Grid for Soil Drainage
In this scenario, the soil drainage has already
been reclassified for you by the geologist for
our fictional county. Click on the Add Data
button and add the soildrain_rl layer from
<YourDirectory>\lf_analysis\d_reclass\.
Right-click on this layer, choose Properties.
Click on the General tab and change the layer
name to Reclass of soildrain. If you open the
attribute tables for these layers and inspect
them, you will notice that the reclassified
layer prohibits landfills on water and rock by
reclassifying these areas as NoData.
Reclassify Stream Buffers by Unique Value
1. In the Spatial Analyst toolbar, choose
Spatial Analyst > Reclassify. In the Reclassify
dialog box, make Stream Buffers the input
raster.
2. Click the Unique button in the Reclassify
dialog box. Accept all default values except
the NoData value. Change the New Value for
NoData to 5. Areas more than four kilometers
away from any stream are the most suitable
for landfills. Areas close to streams are less
suitable. Substituting 5 for the NoData value
will eliminate areas too close to streams. Click
OK. A new grid called Reclass of Stream
Buffers is created.
3. Right-click on the new grid, choose
Properties, reclassify the legend to
5 classes, assign a color ramp, and make
it permanent. Save the file as buffers_r1 in
…<YourDirectory>\lf_analysis\d_reclass\.

Old
Value

New
Value

Devise your
own land cover
classification
scheme using
the worksheet in
Figure 3. Consider
the cultural or
financial value of
the existing land
types, the expense
of altering a land
type, and the
relative abundance
or scarcity of a land
type by looking at
the COUNT field.
Reclassify Land Cover
The land cover class is the final suitability
factor that will be considered in this analysis.
The old value for each cover class was a code

S_VALUE

COUNT

1

Deciduous/Mixed Forest

3739

2

Coniferous Forest

11904

3

Cropland

2974

4

Grassland

4880

5

Desert Shrub and Savanna

2157

6

Water

27

7

Alpine, Tundra, Barren

169

Figure 3: Reclassification worksheet
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Reason

that identified each S_VALUE (i.e., Grassland,
Cropland). You will supply new values that
reclassify Coverclass based on the suitability
scale used elsewhere in the exercise (i.e., 5 is
the most suitable and 1 is the least suitable).
1. Make the Coverclass layer visible in the
Table of Contents (TOC). Drag it to the top of
the TOC or turn off the layers above it so that
it is visible.
2. Use the worksheet in Figure 3 to figure out
the classification scheme you will use before
entering it in ArcMap. Consider the cultural
or financial value of the existing land types,
the expense of altering a land type, and the
relative abundance or scarcity of a land type
(see the COUNT field). Remember that the
final scheme will have 5 classes. Some land
cover classes may be completely unsuitable
Continued on page 44
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for landfills and should be excluded using
NoData rather than ranked.
3. After determining the classifications,
choose Spatial Analyst. Reclassify from the
Spatial Analyst toolbar. In the Reclassify dialog
box, make Coverclass the input raster. Click
the Unique button. Enter your classification
scheme. Click OK. A new grid called Reclass of
Coverclass is created.
4. Change the legend to graduated color with
5 classes, make the layer permanent, and save
it as cover_r1 in <YourDirectory>\lf_analysis\
d_reclass\.

Figure 4: First arithmetic model
[reclass of Coverclass] + [reclass of sl_dist] + [Reclass of Slope of
elevation] + [Reclass of soildrain] + [reclass of Stream Buffers]

Running the Model
Before running the model, use Notepad or
WordPad to create a new text file called
landfillmodel.txt and save it in <YourDirectory>\
lf_analysis. In this model as it is currently
configured, each grid has equal weight in the
decision making process.
Using the Raster Calculator
1. In the Spatial Analyst toolbar, choose Spatial
Analyst > Raster Calculator. In the left pane of
the Raster Calculator is a list of all the grids. The
pane is too narrow to show the complete name,
so youʼll need to scroll down and to the left to see
the entire list of grids and the full name of each
grid.
2. Double-click on the grid names and the
operators to build the statement exactly as it
is shown in Figure 4. The spacing, location
of parentheses, and the operators must match
Figure 4. Copy the statement and paste it
into landfillmodel.txt. Annotate it with “First
arithmetic model.”
3. In the Raster Calculator, click Evaluate.
A new temporary grid called Calculation will
be created. Notice that the range of values is
between 7 and 23.
4. Right-click on the new layer and choose
Properties. Click on the Symbology tab to change
the new gridʼs legend to Classified with a single
class for each value. Save the map document and
then save again as model_a23.
5. In landfillmodel.txt, write some information
about this model. Note what data went into it,
the purpose of the analysis, the cell size and
measurement units used, the geographic extent
of the model (i.e., Gallatin County, Montana),
when you ran the model, and the name of
the organization for which the model was
developed.
An Optional Activity
In the real world, certain features are more
relevant than others in a suitability model. This
can be reflected in the model by rerunning it
using weighted values for slope and soils so that
these factors will have the most influence. The
syntax will differ slightly from the arithmetic
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Use the Raster Calculator to perform a simple analysis of the data on the suitability factors.

Devise your own land cover classification scheme using the worksheet in Figure 3. Consider
the cultural or financial value of the existing land types, the expense of altering a land type,
and the relative abundance or scarcity of a land type by looking at the COUNT field.
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Figure 5: Using weighted values
(([Reclass of soildrain] * .3) + ([Reclass of Slope of elevation] * .3)
+ ([Reclass of Stream Buffers] * .2) + ([Reclass of Coverclass] * .1) +
([Reclass of sl_dist] * .1)) * 5

model. Each grid will have a decimal weight
associated with it, and the sum of the decimal
weights must be 1. Note that there are extra
parentheses in the new statement. Create the
weighting scheme shown in Figure 5 by building
this statement in the Raster Calculator, or use a
scheme of your own design.
Because the total number of factors in the
equation is 5, the sum of all the individual
calculated weights is multiplied by 5. Copy this
text and paste it in landfillmodel.txt, and annotate
it with something such as: “First weighted
model.” Click the Evaluate button and a new
Calculation layer is created. Color ramp the
legend and save the map as weighted.mxd.
Make an Analysis Process Map
A process map will show the factors that
were involved in the analysis. Currently
the map document has only one data frame
called Suitability Analysis that contains all
the reclassification grids and the final analysis
grid. To present each of the grids side-by-side
on a single map sheet will require placing each
reclassification grid in its own data frame.

In the real world, certain features are more relevant than others in a suitability model. They
can be reflected in the model by rerunning it using weighted values for slope and soils so that
these factors will have the most influence.

The Layout toolbar has many of the same zoom and pan tools as the standard toolbar, but these
tools work in layout view and allow you to move around the layout.
www.esri.com

Organizing Data With Data Frames
1. From the main menu, choose Insert > Data
Frame. A new data frame is created at the bottom
of the Table of Contents. Right-click on the new
data frame and choose Properties to rename it
Landcover Reclass.
2. Left-click the Reclass of Coverclass layer and
drag it to the Landcover Reclass data frame.
3. Right-click on the Landcover Reclass data
frame and choose Properties. In the Data Frame
Properties dialog box, click on the Source tab.
Notice that the coordinate system has already
been defined by the Reclass of Coverclass layerʼs
coordinate system.
4. Create new data frames for each
reclassification grid and the arithmetic or
weighted grids using the same process. You
should have seven data frames—the six
new data frames and the original Suitability
Analysis data frame.
5. Save the map document now.
Creating a Layout
The next step is to arrange the data frames in a
layout map that will show these factors and the
final reclassification. When a map has multiple
data frames, only one data frame is active at a
time. To activate a data frame, right-click on
it and choose Activate from the context menu.
Save your work often during the layout process
because layout elements are only stored in the
map document.
1. From the main menu, choose View >
Layout view. You now are switching from
Continued on page 46
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The final step is to display the
data frames in a layout map that
will show these factors and the
final reclassification.

map space to paper space, and the layout
toolbar appears. It has many of the same zoom
and pan tools as the standard toolbar, but these
tools work in layout view and allow you to
move around the layout.
2. In the layout, notice that the data frames
are stacked on top of each other. To fix this,
use the Zoom Out tool in the Layout toolbar
to zoom out several times until there is some
white space around the map sheet.
3. In the Table of Contents, right-click on
the Final Proposal Data Frame and choose
Activate from the context menu. A blue
dashed line and handles appear around this
data frame indicating that it is active.
4. Use the Select Elements tool on the
standard toolbar (i.e., the black arrowhead) to
grab this data frame and move it off the map
page. Right-click the data frame and choose
Properties. Click on the Size and Position
tab in the Data Frame Properties dialog box.
Change the size to 2 inches wide and 3 inches
high. Click OK. On the main toolbar, change
the scale to 3,000,000.
5. Repeat this procedure for each of the data
frames. Arrange all six data frames neatly on
the layout page. Make sure each data frame is
the same scale and same size. Arrange the data
frames so that the maps take up most of the
space on the page and the Final Analysis data
frame is in the upper left corner.
46 ArcUser July–September 2003

Making a Presentable Map
After arranging the data frames, modify the
data frames and add standard map elements.
1. Make each data frame active by rightclicking on the data frame in the Table of
Contents and choosing Activate. For each data
frame, include a legend by choosing Insert >
Legend from the main menu and following
the steps in the Legend Wizard. Keep these
legends simple because they will be small.
Modify the legend for each data frame by
right-clicking on it and choosing Properties to
access the Legend Properties dialog box and
set the display characteristics.
2. Include a title for each data frame by
choosing Insert > Title from the main menu.
Type in the name of the data frame and move
it near the data frame with the pointer tool.
Double-click on the title to set the font and
style and other properties.
3. Repeat this process for each data frame,
saving the map document after each data
frame is modified. Add elements for the entire
map layout.
� A title for the map such as “Landfill
Suitability Analysis Factors.”
� A scale bar. Only one is needed because
all the data frames should be the same
scale.
� A north arrow.
� Your name and the date the map was
printed.

4. Inspect the entire map and make any
necessary adjustments in the placement, size,
or other properties of the map elements. Save
the map before printing it.
Conclusion
Over the course of these two tutorials, you
have assembled, converted, and modified
data and created a model for determining the
best location for a landfill. The first tutorial
covered defining the study area, making
slope and buffer maps, and calculating the
distance from existing landfills. In the second
tutorial, you reclassified a variety of grid
layers based on suitability factors and created
a new integer grid for each factor. Using the
Raster Calculator, you combined these grids
to generate a ranking for each cell for landfill
suitability. The combined grid, reclassified on
the same 1 to 5 scale, takes the three factors
deemed important to the new landfill site into
consideration. Finally, you created a map
showing both the process and the results.
The ESRI Virtual Campus (campus.
esri.com) provides additional information
on spatial analysis. See Getting Started
with Surface Analysis using ArcGIS Spatial
Analyst, a workshop, and Spatial Analysis
in Agriculture: A GIS Approach and Spatial
Analysis of Geohazards using ArcGIS, two
online courses.
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