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Task Action

Giving the focus to Table of Contents Press F3

Return focus to map Press Esc

Select a layer or Data Frame Use up and down Arrow or type first letter of layer or Data Frame

Open Properties for layer or Data Frame Select item and press Enter

Activate a Data Frame Select item and press F11 or hold Alt key and click the Data Frame

Access context menu for layer or Data Frame Hold Shift and press F10 or press Application key or right-click

Collapse all layers in Data Frame Invoke context menu and choose Collapse All Layers or hold Control and click on the +/- box

Turn layers on and off Select one or more layers and press the Spacebar 

Rename layer or Data Frame Select item and press F2

Move to beginning or end of Table of Contents Press Home or End keys

Duplicate a layer in a Data Frame Hold down the Control key and drag and drop the layer

Copy and paste multiple layers in a Data Frame
Select by holding down the Control key and clicking on the layers to select them. 
Access context menu and choose Copy, then choose Paste. 

ArcGIS 9, the newest major release of ArcGIS, 
provides new functionality in many areas and 
extended capabilities for previously existing tools 
and functions. Numerous enhancements deliver 
better performance in many key areas.

• ArcGIS 9 integrates raster data in the 
geodatabase and lets users manage raster data 
using ArcCatalog. 
• The performance and scalability of the 
geodatabase in a multiuser work flow has 
improved.
• All or any part of a geodatabase can now 
be exported to an XML file for importing 
into another geodatabase or as part of a 
disconnected editing work flow. The XML 
specification will be published by ESRI, 
which will make geodatabases completely 
open and interoperable. 
• Composite address locators can now be 
defined for geocoding. 
• Two new applications, ArcGIS Engine 
and ArcGIS Server, offer new deployment 
opportunities. ArcGIS facilitates cross 
platform application deployments based on 
core ArcGIS functionality. ArcGIS Server 
deploys server-based ArcGIS services and 
applications on Intranets and the Internet.

 ArcGIS 9 also includes a completely new 
environment for geoprocessing. In ArcGIS 9, 
users can perform geoprocessing operations by 
using tool dialog boxes; through building and 

Figure 1: The directory containing the 
unzipped sample dataset 

ArcGIS 9 
 Enhancements Promote Productivity

What You Will Need
•  ArcGIS 9 (ArcView, ArcEditor, or ArcInfo license)
•  The sample dataset downloaded from 
 the ArcUser Online Web site
•  An unzipping utility such as WinZip

running interactive visual models; by running 
commands or ARC Macro Language (AML) 
scripts from the command line; by invoking 
scripts written in standard scripting languages 
such as Python, JScript, or VBScript, or by 
programming ArcObjects in Visual Basic 6, 
Visual Basic.NET, C#, or C++. 
 Another article in this issue, “Working With 
ArcGIS 9: Building a Groundwater Protection 
Model,” walks the reader through an exercise 
that uses this new geoprocessing functionality 
and demonstrates ModelBuilder, the ArcGIS 9 
visual modeling environment.

About These Exercises
In addition to these new features, significant 
improvements have been made to the usability of 
ArcGIS 9. The articles in this section highlight 
a selection of the most requested usability 
enhancements that speed common tasks by 
eliminating multiple menu choices or mouse 
clicks through employing keyboard shortcuts or  
by grouping similar functions together. Working 
through these exercises will introduce the reader 
to some of the many ways ArcGIS 9 promotes 
greater productivity and provides users with 
quicker and more flexible ways to accomplish 
common tasks such as manipulating data layers, 
navigating the Table of Contents, making 
selections, identifying features, and placing 
labels. 

 After downloading the sample dataset from 
ArcUser Online (www.esri.com/arcuser), unzip 
the file and store it locally. It contains a map 
document, New9.mxd, and data that will be used 
for all the exercises in this section. 

Quick Tips at a Glance
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Before beginning this exercise, start ArcCatalog to 
inspect the data and explore some of the changes in 
this application at version 9.
 The command for showing and hiding the 
Catalog Tree window has been moved from the 
View menu in the standard menu bar to the Window 
menu where it joins the ArcToolbox and Command 
Line controls. This centralizes the commands for 
controlling the ArcCatalog window. 
 In the Windows menu, click the ArcToolbox 
choice. At version 9, ArcToolbox has been 
incorporated into both ArcMap and ArcCatalog so 
geoprocessing tools are organized and accessible. 
Tools are organized into toolboxes, which contain 
subcategories called toolsets. Toolboxes and toolsets 
can contain scripts and models as well as tools. The 
number and kinds of tools available depend on the 
license used (i.e., ArcView, ArcEditor, or ArcInfo) 
and the extensions available.

Exploring ArcCatalog
Getting Organized With ArcToolbox
The ArcToolbox window can be dragged below 
the Catalog Tree window to expand the area for 
viewing filed contents, previews, and metadata. 
The ArcToolbox window can be reorganized, and 
custom toolboxes can be created. 
 Custom toolboxes can store frequently used 
existing tools, models, and custom scripts and 
tools. Toolboxes are saved as TBX files. Although 
the default storage location for custom toolboxes is 
the user s̓ profile directory in Windows, TBX files 
can be saved in any folder or in a geodatabase. 
 Expand the new_nine folder and notice that it 
contains a toolbox called HandyTools. Click again 
to expand the HandyTools toolbox. This custom 
toolbox contains tools for Dissolve, Merge, Clip, 
Interest, and Union, the five tools that were accessed 
using the Geoprocessing Wizard in 8.x. The Buffer 
and Multiple Ring Buffer from the Buffer Wizard 
have also been included in this toolbox. 
 Right-click the HandyTools toolbox and choose 
Add to ArcToolbox. Now HandyTools appears in 
the ArcToolbox window. Right-click on it in the 
ArcToolbox window and choose Help to see the 
documentation that was created for this toolbox. 
Note that the documentation lists where the tools in 
this toolbox can be found in the ArcGIS 9 default 
toolboxes. 
 Custom Help can be created for any new 
or existing toolbox. Documentation created for 
toolboxes can contain information on the toolbox s̓ 
author, any constraints on its use, an abstract, 
keywords, tool descriptions, illustrations, and 
links.
 Right-click the toolbox again and choose Edit 
Documentation. In the ArcToolbox Documentation 
Editor, click Keywords. On the right side of 
the dialog box, click the second line and type 
Geoprocessing Wizard. Click the Finish button to 
stop editing the documentation. 

Updating Data Sources
References to file-based data sources for map 
documents (.mxd files) and published map 
documents (.pmf files) can be updated or repaired 
from ArcCatalog. Right-click on New9.mxd and 
choose Set Data Source(s). In the dialog box, click 
the drop-down box to the select Diet Hazards Data 
Frame. Correct the reference for Diet Hazard: 
Redlands Area MrSID by clicking on it. Click 
the button to the right of the New Data Source for 
this layer, and use the Browse for Data dialog box 
to select the \Redlands\Raster\RedlandArea.sid. 
Click OK.

New Data Conversion Tools
In ArcToolbox, expand the Conversion toolbox 
to see the new conversion tools available that 
supply both import and export capabilities. Like 
all the tools in the new geoprocessing framework, 
these tools can be launched individually, run at the 
command line, used in scripts, or added to models. 
This flexible approach makes it easy to combine 
operations and create a complete work flow. 

 The new ArcView 8x Tools toolbar provides 
easy access to the ArcGIS 8.x conversion tools 
typically needed by ArcView users, although it 
is available at all license levels. Choose View > 
Toolbars > ArcView 8x Tools to display it. Many 
tools and wizards from 8.x were retained and can 
be viewed by choosing Tools > Customize from 
the menu. Make these tools readily available by 
dragging them to a new or existing toolbar. Note 
that these tools have been carried over from 
ArcGIS 8.x and do not participate in the new 
geoprocessing framework.

New Coordinate Systems
The list of available coordinate systems has been 
significantly augmented in ArcGIS 9. Support 
has been added for more than 250 additional 
geographic transformations. More than 300 new 
geographic coordinate system (i.e., .prj files) and 
nearly 1,000 projected coordinate systems have 
been added. These include Fuller, Rectified Skew 
Orthomorphic (RSO), Cube, Robinson ArcInfo, 
and an improved version of the ArcInfo Workstation 
LOCAL projection called Local Cartesian.
 In ArcToolbox, expand Data Management 
Tools > Projections and Transformations > 
Feature and click Project to access the Project 
dialog box. Click the Browse button next to the 
Output Coordinate field. In the Spatial Reference 
Properties dialog box, click Select and drill down 
through the Geographic Coordinate Systems or 
Projected Coordinate Systems folder to inspect the 
available coordinate systems.

Learn More About ArcCatalog
When finished exploring ArcCatalog, close all the 
dialog boxes. Click Help in the standard menu 
bar. This menu includes a link to the online GIS 
Dictionary at the ESRI Support Center. At the site, 
browse or query for a term. To learn more about 
new functionality in ArcGIS 9, access the ArcGIS 
Desktop Help and choose the topic “What s̓ New 
in ArcGIS Desktop 9.” Exit ArcCatalog before 
going on to the next section of this exercise. 

The new conversion tools available in 
ArcGIS 9 supply both import and export 
capabilities.

The HandyTools toolbox contains custom 
help created for this toolbox. Tools in ArcGIS 
allow creation and editing of documentation.



40   ArcUser  July–September 2004          www.esri.com

ArcGIS 9 adds new capabilities and extends 
existing functionality. This tutorial concentrates 
on usability and productivity enhancements 
relating to navigating and manipulating the 
Table of Contents, layers, group layers, and Data 
Frames; labeling features; and selecting and 
identifying features. ArcGIS 9 provides options 
for accomplishing common tasks from the 
keyboard rather than the mouse and eliminates 
drilling down through menus to execute common 
functions.

Navigating Through the 
Table of Contents
This exercise will use the sample dataset and 
map document, new9.mxd, from the previous 
exercise. 
1. Start an ArcMap session and open new9.mxd. 
Save the file as new9_finish.mxd to the same 
directory. The keyboard can be used to move the 
application focus between the Table of Contents 
and the map. Click F3 to give the focus to the 
Table of Contents so keyboard strokes will go to 
it and allow the use of keyboard shortcuts. Press 
Esc to give the focus back to the map.
2. Use the up and down arrows to select Data 
Frames or individual layers. Use the down arrow 
to select the Downtown Tree Study. Press F11 
to activate it. Alternatively, hold the Alt key and 
click on the Data Frame name to activate it.
3. Pressing the first letter of any layer or Data 
Frame will select it. If more than one layer begins 
with that letter, the selection will move down to 
the first instance. Press again to move to the next 
instance until reaching the end of the Table of 
Contents. It will then move to the top of the Table 
of Contents. Press the letter Z to select the Zoning 
Polygons layer. Press the Enter key to open the 
Layer Properties dialog box. Press Esc to close 
this dialog box.
4. Use the Home and End keys to move quickly 
to the first and last entries in the Table of Contents. 
Press Home to select the Diet Hazards Data 
Frame and F11 to activate it.
5. Context menus for any selected Data Frame or 
layer can now be accessed by holding Shift + F10 
or by pressing the Application key on a Microsoft 
compatible keyboard in addition to using a right 
mouse click.
6. Right-click on the Diet Hazard Data Frame 
and choose Collapse All Layers. Alternatively, 
hold the Control key and click on the +/- box next 
to the Data Frame to expand or collapse the layers 
in the frame.
7. Right-click on the Diet Hazard Data Frame 
again and choose Turn All Layers Off. This 
context menu can also be used to turn all the 
layers on. 
8. Select the Donut Shops layer. Hold down the 
Shift key and arrow down to select the Streets, 

Working Quickly and Easily in ArcMap

The Layer Properties dialog box features an improved dialog box for Field that makes it easy 
to see the names, aliases, types, length, precision, scale, and number format of the fields in the 
attribute table.

Install the Pause Drawing command as a button on the standard toolbar.

Downtown Boundary, and Zoning—Polygons 
layers. Hold down the Control key and press 
the Spacebar to turn all these selected layers on. 
Alternatively, hold down the Control key and 
click on any of the selected layers.

9. Move the Diet Hazard Data Frame below the 
Downtown Tree Study Data Frame by selecting it 
and dragging it to the new position. A Data Frame 
can also be copied by holding down the Control 
key and clicking and dragging the Data Frame to 
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a new position. It copies when released.
10. Copy the Streets and Zoning—Polygon 
shapefiles from the Diet Hazards Data Frame to 
the Downtown Tree Survey Data Frame. Hold 
down the Control key and click on Streets and 
Zoning—Polygons, access the context menu, and 
choose Copy. Select the Downtown Tree Survey 
Data Frame and press F11 to activate it. Access 
the context menu and choose Paste Layer(s). 
Multiple layers can also be dragged and dropped 
or copied and pasted between two ArcMap 
sessions.

Working With Layers
Layers can now be more directly manipulated 
with minimal clicks and choices. 
1. With the Streets layer selected, open the Layer 
Properties dialog box by pressing the Enter key 
or pressing F12. 
2. In the Layer Properties dialog box, click the 
Fields tab. The improved dialog box makes it 
easy to see the Primary Display Field and lists the 
names, alias, type, length, precision, scale, and 
number format. Click OK or press Esc to close 
this dialog box.
3. Press F2 and type “Redlands Streets” to 
rename the layer. 
4. Press the Spacebar to turn the layer off. Press it 
again to turn the layer on again. 
 The accompanying table “Quick Tips at a 
Glance” summarizes these shortcuts. 

Pause Drawing
The Pause Redrawing command is a great time-
saver when building a map document or refining 
a map. It is not available from the default GUI but 
can easily be added as a button or a shortcut. This 
section adds both versions. 
1. Choose Tools > Customize. Click on the 
Commands tab and select Pan/Zoom from the 
Categories pane. In the Save In drop-down, make 
sure Normal.mxt is selected so the command will 
be available in all map documents. 
2. Scroll down to Pause Redrawing and select it. 
Drag this command to a convenient location on 
the standard toolbar. Click on this button to toggle 
redrawing off and on. 
3. Still on the Commands tab, click on the 
Keyboard button. Click in the box under Press 
New Shortcut Key. Hold Alt and press S. Click 
the Assign button. Click Close twice to close the 
dialog boxes.

Getting Selective
The Selection tab in the Table of Contents now 
appears by default so selection layers can be 
set quickly. To learn more about the Selection, 
Source, or Display tabs, press F3 to give the 
Table of Contents the focus and press F1. To turn 
selectability for all layers on and off at once, hold 
down the Control key and click any check box. 
 The selection logic used by ArcMap changed. 
ArcGIS 9 differentiates between the layer state of 
0 features selected and the layer state with no set of 

selected features. ArcGIS 8.x made no distinction 
between these states. In the new geoprocessing 
framework this distinction becomes important 
because it affects whether none of the features 
or all features will be used in the next step of a 
process. 
 To illustrate the difference, make sure the 
Selection tab is displayed. Choose Selection 
> Select by Attributes, create the expression 
“NAME” = ̒ Donut Hut  ̓in the text box, and click 
Apply. This expression will return no feature 
because this name does not exist in the attribute 
table. On the Selection tab the Donut Shops 
layer will be bold and followed by “(0 features 
selected)”. In ArcGIS 8.x, layers were bold only 
if one or more features were selected. 
 Selections can still be cleared by using 
the Clear Selected Features command or by 
clicking on the map with the Select Features tool. 
However, note that if all the features in a layer 
are selected, choosing Switch Selection does not 
clear the selected set but does set the number of 
features selected to 0. 
 The list of layers from which features are 
selected can now be restricted to layers currently 
set as selectable on the Selection tab by checking 
a box in both the Select By Location and the 
Select By Attributes dialog boxes. 
 To improve performance when working 
with large datasets, the Unique Values list is no 
longer automatically populated in the Select 

Continued on page 42

The selection logic used by 
ArcMap changed. ArcGIS 9 
differentiates between the 
layer state of 0 features 
selected and the layer state 
with no set of selected 
features.
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By Attributes dialog box. Click the Get Unique 
Values button if these values are needed. 
 Queries for attribute selections can now 
be based on NULL values. NULL values are 
supported in geodatabases and in the date fields 
of shapefiles (i.e., in dBASE files) and coverages. 
The Select By Attributes dialog box now also 
automatically determines the correct format 
for date queries based on the type of data being 
queried. For more information about date fields, 
search on “SQL reference” in the index for 
ArcGIS Desktop Help. The improved SQL help 
contains an expandable list of SQL operators and 
functions.

Simplified Identify Tool
The enhancements to the Identify tool were 
driven by user suggestions. Clicking on the 
Identify tool immediately invokes the Identify 
Results window, eliminating the need to choose 
View > Identify Results from the standard menu. 
With the Identify Results window, the layer to 
identify from can be selected and this window 
can be moved so it will not obscure the area of 
interest on the map. The <Top Most Layer> is 
still the layer selected by default, but it has been 
moved to the top of the drop-down list so it is 
easily identified.
1. Activate the Downtown Tree Survey Data 
Frame. 
2. Click the Identify tool. The Identify Results 
window appears. Click the Layers drop-down 
and select Sick Tree Survey. 
3. Click on one of the trees to bring up the 
information for this feature.

Centralizing Labeling
Labeling functions have been improved and 
centralized in ArcGIS 9. The Labels tab in the 
Data Frame Properties dialog box has been 

With the Label Manager, the labeling options 
are centralized and the most commonly used 
ones can be directly accessed from a single 
dialog box.

Working Quickly and Easily in ArcMap
Continued from page 41

Clicking on the Identify tool 
immediately invokes the Identify 
Results window, eliminating the need 
to choose View > Identify Results 
from the standard menu.
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To learn more about new features in ArcGIS 9, access the ArcGIS Desktop Help and choose the topic 
“What’s New in ArcGIS Desktop 9.” It contains subheadings for ArcMap and ArcCatalog and the 
ArcGIS extensions. For users moving to ArcView 9 from ArcView 3, see the help section “Migrating 
from ArcView GIS 3 to ArcView 9.” 
 Both instructor-led and online courses are available for users transitioning to ArcGIS 9 as well as 
those new to GIS. Visit www.esri.com/training for class listings and related information. 

Learn About the Latest Enhancements in ArcGIS 9
Instructor-Led Training
The newest capabilities of ArcGIS Desktop are showcased in What’s New in ArcGIS 9. Learn 
about the new geoprocessing, command line, and modeling environments; enhancements to 
the geodatabase; advanced scripting capabilities; labeling and annotation improvements; three-
dimensional visualization and analysis with ArcGlobe; and the new functionality in the ArcGIS 
Publisher and Maplex for ArcGIS extensions.

New Web Course Teaches the Basics of ArcGIS 9
Virtual Campus Web-Based Training
To teach new GIS users who want to learn the major functionality offered by ArcGIS, Learning 
ArcGIS 9 guides users through GIS analytical processes provided with a variety of ArcGIS tools to 
solve realistic problems. This course emphasizes practical GIS skills including how to symbolize data 
for different types of maps, create and edit geographic data, perform spatial analysis, and design 
presentation quality maps.

New Web Seminar Highlights ArcGIS 9 Features
Virtual Campus Web-Based Training
Explore the new features in ArcGIS by taking the free What’s New in ArcGIS 9 training seminar. 
Learn about some of the most important new functionality including data interoperability options, 
labeling and annotation improvements, geodatabase enhancements, the geoprocessing framework, 
three-dimensional visualization tools, and new options for developers.

New Web Course Introduces the ArcGIS 9 Geoprocessing Environment
Virtual Campus Web-Based Training
Geoprocessing with ArcGIS 9 (for Arclnfo) is designed for experienced GIS and ArcGIS users who 
want to learn about the new geoprocessing environment and the geoprocessing tools and techniques 
for managing and analyzing GIS data. Course exercises show how to set up the geoprocessing 
environment, choose appropriate geoprocessing tools for a variety of tasks, prepare data for analysis, 
create models, execute analyses, and automate and refine geoprocesses using scripts.

More Ways to Learn About ArcGIS 9

replaced by the new Label Manager. In the Label 
Manager, label priority ranking and label weight 
ranking can be set. Labels can now be locked and 
unplaced labels viewed. These label functions 
can be accessed from the Labeling toolbar or the 
Data Frame context menu. 
 With the Label Manager, the labeling options 
are centralized and the most commonly used ones 
can be directly accessed from a single dialog box. 
It is no longer necessary to click the Symbol 
button to change font, size, or color for label 
text. The label field, placement properties, and 
label classes can be set directly from this dialog 
box. Scale range, label styles, and labeling by 
expression are just a click away.
 More fonts are supported by ArcGIS 9. At 
ArcGIS 8.x, only TrueType and TrueType-based 
Open Type fonts were supported. Now Type 1 
fonts, TrueType collection and MultipleMaster 
fonts, and OpenType fonts (based on TrueType, 

Type 1, and Type2CFF) are also supported. Icons 
in the font drop-down indicate the kind of font 
selected.
1. Make sure the Diet Hazard Data Frame is 
active. Choose View > Bookmarks > Donut 
Central to zoom in to the view and trigger the 
Donut Shop display. 
2. Choose View > Toolbars > Labeling to display 
the Labeling toolbar. Notice that the toolbars list 
is now alphabetized so toolbars can be quickly 
located. The toolbar list can be accessed by right-
clicking on any toolbar so toolbars can be turned 
off and on. 
3. With the Labeling toolbar open, pass the cursor 
over each button to identify its function. Click the 
Label Manager button to open its dialog box. 
4. In Label Classes tree on the left side of the 
Label Manager, highlight Default under Donut 
Shops. 
 Under the Text Symbol section, change the 

font to Arial Narrow, the point size to 8, the style 
to bold, and the color to Gray 60%. 
5. Click the Label Weight Ranking button and set 
the Feature Weight to Medium and Label Weight 
to High. These parameters control placement 
when there are conflicts between labels and 
features in the active Data Frame. 
 An optional extension, the Maplex for ArcGIS 
extension, provides high-quality cartographic 
label creation and fitting. If this extension is 
available and loaded, abbreviation dictionaries 
can be used and many additional labeling 
parameters set. 

Conclusion
These are just a few of the hundreds of 
enhancements in ArcGIS 9. Additional 
information on the new features in 
ArcGIS 9 can be found in the online help. See 
the accompanying article, “More Ways to Learn 
About ArcGIS 9,” for the online and instructor-
led courses available. 


