Slopes, Sharp Turns, and Speed
Refining Emergency Response Networks
to Accommodate Steep Slopes and Turn Rules
By Mike Price, Entrada/San Juan, Inc.
Exercises in previous ArcUser issues demonstrated how the ArcGIS Network Analyst 9.2 extension can be used to model
essential services provided by existing and proposed fire stations in King County, Washington. In this issue, the area modeled
is farther north—the city of Burnaby, British Columbia, Canada. This exercise will model optimized response areas for a fire
department that have been optimized to include time-based travel penalties for steep slopes and sharp turns.
The Slope/Turns Exercise
The challenge in this exercise is to build the
street dataset to display slope in percent for
the Burnaby Fire Department’s service area.
The department is building a new fire hall. Fire
Hall 7 will serve a large area in central and
western Burnaby. Burnaby’s irregular terrain
includes slopes of more than 15 percent. To
properly model time-based travel, a slope
correction factor for steep streets was developed

Introducing Burnaby
Originally a rural agricultural area, Burnaby,
British Columbia, received city status in 1992
and has developed into a major business,
residential, and transportation corridor
between Vancouver and British Columbia’s
Lower Mainland. With a population of 202,799
(in 2006) and an areal extent of nearly
100 kilometers, Burnaby is the third largest
urban center in the province. It is bordered
by the Burrard Inlet on the north and the
Fraser River to the south. Burnaby’s landscape
is characterized by hills, ridges, valleys, and
an alluvial plain. Elevation ranges from mean
sea level to 375 meters. Land features have
controlled and constrained development
throughout this community.
The Burnaby Fire Department serves
the entire municipal area and provides aid
response into neighboring jurisdictions.
The department staffs six fire halls, and a
new station will open soon. The first line
of response includes six first line engines,
four ladders, a command unit, rescue truck,
an equipment truck, and other specialized
equipment. The agency’s fire suppression and
administrative staff numbers 286. In 2006, the
department responded to 13,400 calls. The
Burnaby Fire Department works closely with
the city’s excellent Engineering Department to
plan and optimize service throughout the area.
Burnaby Engineering uses ArcGIS Network
Analyst to optimize response areas.

and field-tested. The slope adjustment, together
with global turn rules, was applied to posted
speed limits to calculate valid travel times and
define optimal response areas.
Getting Started
Download the zipped sample dataset for this
exercise from ArcUser Online (www.esri.com/
arcuser) and place it near the root of the drive that
houses the project. Unzip the data and explore
it in ArcGIS ArcCatalog. Note that the sample
data is contained in a file geodatabase. The
geodatabase includes a special feature dataset
named Transportation_Model that contains a
single feature class named Highways_Streets.
This feature class will support time-based
modeling. Study the geodatabase layer files
for symbolizing municipal boundaries, fire
stations, hydrants, and historic incidents and
the registered JPEG and its layer file.
This exercise will model detailed slope
derived from a large triangulated irregular
network (TIN) model. Because the actual
background TIN is too large to easily download,
a picture of hillshaded slope (Slpp_300.jpg)
will be used instead to emphasize steep areas.
Start ArcMap, open a new, blank map
document, and save it as Burnaby1.mxd.
Load the City Boundary.lyr from \Burnaby\
GDBFiles\UTM83Z10\. Check the layer’s
coordinate system and load Analysis Area.lyr,
Streets – Slope.lyr, and Fire Halls.lyr from
this same folder. Note that Streets - Slope has
been thematically symbolized. From \Burnaby\
JPGFiles\UTM83Z10\, load Slope, Percent,
Hillshade JPEG.lyr and move it to the bottom of
the table of contents (TOC). Ignore the warning
box about the spatial reference.
Preparing the Street Data
Open and inspect the attribute table for Streets
- Slope. Eight fields in this table contain zero
(0) values. Before the slope can be depicted,
values for the LENGTH_KM, MINUTES_R,
SLOPE_ABS, SLOPE_ADJ_1, MINUTES_S,
and SPEED_ADJ1 fields will be calculated.
The values for these fields will be calculated

outside an editing session. If a field requires
recalculating, simply zero out the field. Rightclick on the field header, choose the Field
Calculator, select the field name to zero out,
input “0” into the text field, and click OK.
1. Locate LENGTH_KM field and right-click
on its header. Select Calculate Geometry
to calculate length of all street segments
in kilometers. In the Calculate Geometry
dialog box, set the Property as Length,
the Coordinate System to Use Coordinate
System of the Data Frame, and Units as
Kilometers and click OK.
2. To calculate the unadjusted travel time,
right-click on MINUTES_R and choose the
Field Calculator. In the Field Calculator text
field, input the following equation and click
OK.
[Length_Km] *(60/ [SpeedZone])
3. Next use the Field Calculator to determine
the absolute slope and place that value in the
SLOPE_ABS field. Remove the previous
formula from the text field. Choose the Abs
function from the list of functions and select
the SLOPE1 field. Abs ([Slope1]) should
display in the text field. Click OK.
4. Move the table if necessary to look at the
changes these calculations have made to the
thematic display of the Streets - Slope layer.
Keep the Streets - Slope table open and save
the map document.
Calculating Slope Adjustment
1. In the Streets - Slope table, calculate slope
adjustment factor by right-clicking on the
Slope_Adj1 field header, choosing Field
Calculator, and removing the previous
formula from the text field. Input the
following equation and click OK.
1 + ([Slope1]/10)^2
Slope_Adj1 is a multiplication factor that
increases travel time for steep slopes.
Continued on page 52
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What You Will Need
• ArcGIS Desktop 9.2 (ArcInfo, ArcEditor,
or ArcView license level)
• ArcGIS Network Analyst 9.2 extension
• Sample data from ArcUser Online

(in percent)

Travel Time
Multiplier

Comments

0

1.00

Base time

1

1.01

2

1.04

3

1.09

4

1.16

5

1.25

6

1.36

7

1.49

8

1.64

9

1.81

10

2.00

11

2.21

12

2.44

13

2.69

14

2.96

15

3.25

16

3.56

17

3.89

18

4.24

19

4.61

20

5.00

21

5.41

22

5.84

23

6.29

24

6.76

25

7.25

26

7.76

27

8.29

28

8.84

29

9.41

30

10.00

35

13.25

40

17.00

Slope

1.25 times as
long

Twice as long

After downloading and unzipping the sample dataset, load City Boundary.lyr, Analysis
Area.lyr, Streets – Slope.lyr, and Fire Halls.lyr, and the JPEG image of a hillshade.

5 times as long

10 times as
long
Very steep

Table 1: Slope Adjustment Factors

Note the effects the field calculations have made on the symbolization of the
Streets – Slope layer.
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Continued from page 50
Table 1 shows the empirical slope factors in
1 percent intervals. Notice that it takes twice
as long to climb or descend a 10 percent
slope than it does to travel on flat street
segments.
2. Now, calculate the slope-adjusted travel time
in minutes. Right-click on the MINUTES_S
field header, choose Field Calculator,
remove the previous formula from the text
field, and input the following formula:
[Minutes_R] * [Slope_Adj1]
3. Calculate slope adjusted travel speed in
minutes. This calculation incorporates the
slope adjustments in Table 1 and generates
the equivalent speed for travel on each street
segment. Right-click on the [Speed_Adj1]
field header, choose Field Calculator,
remove the previous formula from the text
field, and input the following equation:
([Length_Km]/[Minutes_S])*60

Building the Street Network Dataset
Close ArcMap and open ArcCatalog. In the
Burnaby_Fire geodatabase, navigate to the
Transport_Model feature dataset and refresh
ArcCatalog. Select the Highways_Streets
feature geodatabase class, click on the Preview
tab, and choose Table from the drop-down.
Look at the ONE_WAY, F_ELEV, and T_ELEV
fields.
1. In ArcCatalog, choose Tools > Extensions
and check the box next to Network Analyst.
2. Right-click on Transport_Model, choose
New > Network Dataset, name the new
dataset Transport_Model_ND, and click
Next.
3. Check the box next to the Highways_Streets
feature class and click Next.
4. Click the Connectivity button and note that
End Point connectivity is checked. Click
Next.
5. Click to modify connectivity with the
elevation fields F_ELEV and T_ELEV.
Click Next.
6. Accept Global Turns and click Next.

Defining Network Attributes and Turn Rules
Network attributes for time and distance travel
must now be specified.
1. Click the Add button. In the wizard pane
to specify the attributes for the network
dataset, add the Length_KM, Minutes_R,
and Minutes_S fields and set the values as
shown in Table 2.
2. If Oneway is not already set as a default,
right-click on it and set it as a default.
3. In the same wizard pane, highlight
Minutes_S and click the Evaluators button.
4. Click the Default Values tab. Right-click
the element named Turn, choose Type, and
click VBScript.
5. With the Turn element still highlighted, look
for the Evaluator Properties button on the
right side of the wizard pane. Click on it.
6. In the Script Evaluators dialog box, make
sure Turn is set as type, and click the Load
button. Navigate to the \Burnaby\Utility
folder. Locate and load TurnTime.sev. Click
OK.

Loading Fire Hall Locations

Preparing Street Data

4. Save the map document.

Use the
absolute
value function
on SLOPE1
to obtain
absolute
slope values.

Use Calculate Geometry to calculate all the
street segments in kilometers.

Use the Field Calculator to generate
unadjusted travel time values for the
MINUTES_R field.

Load the fire hall
locations into the
network and set
the sort field as
INDEX and the
search tolerance at
200 meters.
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Once the fire hall
locations have
been loaded,
check that halls
1, 3, 4, 5, and 7
are listed in the
Network Analyst
window.
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Name

Usage Type

Units

Data Type

Set as Default

Length_KM

Cost

Kilometers

Double

No

Minutes_R

Cost

Minutes

Double

No

Minutes_S

Cost

Minutes

Double

Yes

Defining Attributes
and Turn Rules

Table 2: Values for new network dataset
7. Back in the previous dialog box, select
Minutes_R from the Attribute drop-down
box. Right-click the element named Turn,
choose Type, then click VBScript.
8. With the Turn element still highlighted, look
for the Evaluator Properties button on the
right side of the wizard pane. Click on it.
9. In the Script Evaluators dialog box, make
sure Turn is set as type and click the Load
button. Navigate to the \Burnaby\Utility
folder. Locate and load TurnTime.sev. Click
OK. Click Apply. Click OK.
10. Back in the New Network Dataset wizard
pane, click Next.
These 10 steps have established the turn
rules for the streets corrected for slope

In ArcCatalog, set the network attributes
for time and distance travel using the New
Network Dataset wizard.

and streets not corrected for slope. The
default turn rules in TurnTime.sev specify
a 10-second delay for left turns, a 5-second
delay for right turns, and a 2-second delay
for straight travel from one segment to the
next. A 30-second penalty is imposed on
U-turns. Table 3 lists the turn rules applied
for municipal areas.
11. In the next wizard pane, click Yes to establish
driving directions.
12. Review the summary page for the New
Network Dataset, select the text, copy it
to the Windows clipboard, and paste it
into a WordPad document. Save it as NW_
YYMMDD.rtf (i.e., year, month, day) in the
\Utility folder.

Under the default values for the Turn element
for the MINUTES_S Evaluator, attach a
VBScript.

Use an
expression
to label the
service areas
with the
area of each
in square
kilometers.

13. Click Finish and click Yes to build dataset.
Wait while the network dataset builds.
Adding the Network Dataset
The next steps add the network dataset to the
map document so travel can be modeled.
1. Close ArcCatalog and restart ArcMap and
open Burnaby1.mxd.
2. Add Transport_Model_ND from the
Transport_Model feature dataset in
the GDBFiles folder. Do not add other
participating feature classes. Move the
network dataset below Highways, Streets
and turn it off.
3. Right-click on the Streets - Slope layer and
choose Zoom to Layer.
4. Enable the Network Analyst extension.
Choose Tools > Extensions and check
Network Analyst. Add the Network Analyst
toolbar and dock it at the top of the map.
5. Make the Network Analyst Window visible
by clicking the Show/Hide Network Analyst
Window button on the Network Analyst
toolbar.
Continued on page 54

Apply TurnTime.sev to the Evaluator for
MINUTES_S.

In the
Optimized
Travel
Network, Slope
attribute table,
summarize
on the LABEL
field using the
Shape_Length
statistics.

After joining the fire hall attributes to the network
analysis layers, save these layers as feature classes so
they are permanent and can be shared. Store these
feature classes in the Transportation Model in the
Burnaby geodatabase.
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Setting Up Service Areas
The steps in this section create the service areas
and load fire hall locations.
1. On the Network Analyst toolbar, click the
Network Analyst drop-down and select New
Service Area. Click the Properties button on
the top of the Network Analyst Window and
name this service area Optimized Travel
NW, Slope.
2. Repeat this process to build a second
service area called Optimized Travel NW,
No Slope.
3. Create a new layer group, name it Optimized
Travel NW Group, and drag and drop both
service areas to add them to the group.
Move Optimized Travel NW Group to the
bottom of the TOC, above Slope, Percent,
Hillshade JPEG.
Loading Fire Hall Locations into the Network
The following steps will be applied to both the
no slope and slope network datasets to load the
fire hall locations.
1. Change the network dataset in the Network
Analyst Window drop-down to Optimized
Travel NW, No Slope. Right-click on
Facilities (0) and choose Load Locations.
In the Load Locations dialog box, add the
parameters shown in Table 4. Click OK.
Facilities now shows (5) items. Expand the
entry to see that fire halls 1, 3, 4, 5, and 7
have loaded.
2. Change the Network Analyst Window
drop-down to Optimized Travel NW, Slope.
Using the same procedure and parameters,
load fire hall locations into this dataset.
3. Save the map document.

Turn Rule

Right-Turn
Penalty

Left-Turn
Penalty

U-Turn
Penalty

Straight Line
Travel Penalty

(in seconds)

(in seconds)

(in seconds)

(in seconds)

No Penalty

0

0

0

0

Slight Penalty

1

2

10

0

Moderate Penalty

2

4

20

0.5

High Penalty

3

5

30

1

Very High Penalty

5

10

30

2

Turn Angle, Minimum

30

210

150

330

Turn Angle, Maximum

150

330

210

30

Turn Angle, Range

120

120

60

60

Table 3: Turn rule options
Tab and Parameters

Setting

Analysis Settings Tab
Impedance

Important: Use Minutes_S (Minutes) for Slope.
Use Minutes_R (Minutes) for No Slope.

Default Breaks

10

Oneway

check Restrictions

Polygon Generation Tab
Generate Polygons

Check

Detailed

Select

Trim Polygons

Check and Set Trim to 200 Meters

Multiple Facilities Options

Not Overlapping

Overlap Type

Disks
(Not essential but a good habit)

Line Generation Tab

Field

Value

Generate Lines

Check

Load From

Fire Halls

Include Network Source Fields

Check

Sort Field

Index

Overlap Options

Not Overlapping

Name

LABEL

Accumulation Tab

Search Tolerance

200 Meters

Minutes_S, Minutes_R, Length_Km

Check

Table 4: Fire hall location parameters

Table 5: Travel area parameters

Defining Travel Area Parameters
for No Slope and Slope
1. Right-click on the Optimized Travel NW,
No Slope layer in the TOC and choose
Properties.
2. Click on each tab listed in Table 5 and
change the settings as indicated. On the
Analysis Settings tab, make sure the
Impedance is set to Minutes_S (Minutes).
This is an important parameter and it is not a
default. Double-check these parameters and
click Apply and OK.
3. Save the project.
4. Repeat these analysis selections for
Optimized Travel NW, Slope service area.
5. Save the map document.

Solving
With all the parameters established for the
network datasets, the network solver can be
applied.
1. With the Optimized Travel NW, No Slope
selected in the Network Analyst Window
drop-down, click the Solve button on the
Network Analyst toolbar. When the process
is complete, five polygons will be added to
the Network Analyst Window. Save the map
document.
2. Change the drop-down to Optimized Travel
NW, Slope and use the same process as in
the previous step. Save the document again.
3. Turn off the Streets - Slope and Slope,
Percent, Hillshade JPEG layers and turn the

Optimized Travel NW, Slope and Optimized
Travel NW, No Slope layers on. Inspect both
network solutions to discern the differences
between them.
4. Save the map document.
Joining Attribute Tables
Right-click on Polygons in the Network Analyst
Window for either service area and open the
attribute table. Notice the table contains a
NAME field that lists the responding station
and the 10-minute maximum time. Open and
inspect the Line attributes table for one of the
service areas. Lines contain only a Facility ID
for the related fire hall but no fire hall name.
These network output file attribute tables will
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require tabular joins back to the Fire Halls layer
attribute table.
1. Join the Fire Halls table with the polygon
and line attribute tables to incorporate
this data. Right-click on Polygons in the
Optimized Travel NW, Slope layer in the
TOC and choose Joins > Joins and Relates.
Fill in values for the Join Data dialog box
using the parameters in Table 5. Click OK.
2. Repeat this process for the lines in Optimized
Travel NW, Slope and for polygons and lines
in Optimized Travel NW, No Slope. It is
clear now why the Fire Halls were indexed.
Open the attribute tables to ensure the joins
were made correctly. If not, right-click on
the layer and choose Joins and Relates >
Remove Joins.
3. Save the project.
Join Parameter

Value

Field in this layer that the join
will be based on

FacilityID

Table to join to this layer

Fire Halls

Field in the table to base the
join on

INDEX

Table 6: Join parameters
Exporting Travel Areas and
Travel Networks to New Feature Classes
The results of a service area solver are stored
in the ArcMap document. To share these results
with others, network solutions can be saved as
geodatabase feature classes or shapefiles.
1. Make sure ArcCatalog is closed. In the
ArcMap TOC, right-click on Lines in the
Optimized Travel NW, No Slope layer and
choose Data > Export Data.
2. Export All features using the layer’s
coordinate system. Click the folder icon
button to browse to Burnaby_Fire.gdb\
Transport_Model. Set Save as type to
Personal and File Geodatabase feature
classes. Name the file snetopt10_NS. Add
the feature class to the map document.
3. Save the map document.
Network Analysis Layer

Feature Class
Name

Optimized Travel NW,
No Slope, Lines

snetopt10_NS

Optimized Travel NW,
No Slope, Polygons

sareaopt10_NS

Optimized Travel NW,
Slope, Lines

snetopt10_SL

Optimized Travel NW,
Slope, Polygons

sareaopt10_SL

After setting the travel area properties, click the Solve button to generate the service area
polygons.

Masters of Science in GIS
at the University of Redlands

O

ur MS GIS Program is designed for an audience of professionals seeking to
improve their knowledge of the analysis and management of geographic

information. We offer both a full-time and a part-time residential program. Within the
University’s interdisciplinary learning environment, students have an unparalleled

opportunity to interact personally not only with University faculty, staff, and students
from other programs, but also with the many talented professionals at the world’s
leading GIS company, ESRI, located in close proximity to the University.
The University of Redlands, founded in 1907, is a fully-accredited, liberal arts and
sciences university. This intensive, international learning environment ensures a global
context of relevance to students from around the world. Graduates of this program
can become GIS practitioners prepared for positions such as project managers,
applications specialists, and applications software development team members.

Table 7: Names for exported feature classes
Continued on page 56

For information call (909) 748-8128 or visit
www.msgis.redlands.edu
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Organizing and Symbolizing
Travel Areas and Networks
After creating feature classes for the networks
and areas, grouping and symbolizing them will
make comparing them easier.
1. Minimize all layers and groups in the TOC.
Create a new group and name it Optimized
Travel Network Group. Place this group
below Fire Halls.
2. Rename snetopt10_SL to Optimized Travel
Network, Slope and drag it to the Optimized
Travel Network Group.
3. Rename snetopt10_NS to Optimized Travel
Network, No Slope and drag it to the
Optimized Travel Network Group.
4. Create another new group, call it Optimized
Travel Area Group, and place this group
above the Travel NW Group.
5. Rename sareaopt10_SL to Optimized Travel
Area, Slope and place it in the Optimized
Travel Area Group.
6. Rename sareaopt10_NS to Optimized
Travel Area, No Slope and place it in the
Optimized Travel Area Group.
7. Double-click on the Optimized Travel
Area, Slope layer. Click the Symbology
tab and click the Import button. Navigate
to Optimized Travel Area.lyr in E:\02_
TESTDRIVE\Burnaby_1\GDBFiles\
UTM83Z10 to import its thematic
symbology. Repeat this process for
Optimized Travel Area, No Slope.
8. Use the same procedure to import the
Optimized Travel Network.lyr symbology
for Optimized Travel Network, Slope and
Optimized Travel Network, No Slope.
Calculating Optimized Area for Each Fire Hall
Now summarize the characteristics of the
optimized travel areas.
1. Open the attribute table for Optimized
Travel Area, Slope and notice that each
fire station has only one footprint polygon.
The area is calculated in square meters. To
label each polygon with the area in square
kilometers requires only applying a simple
math function and rounding.
2. Right-click on the Optimized Travel Area,
Slope layer name in the TOC and click
Label Features. Right-click on this layer
again and select Properties. Click on the
Label tab. Change the text symbol color to
white, bold, and 12 points. Do not close this
dialog box.
3. Click the Expression button. Type
ROUND([Shape_Area]/1000000,2) &” Sq
Km” into the formula window. Click the
Verify button to check the calculation and
see a sample label. Click OK.
4. Looking at the service areas, new
Fire Hall 7 has the largest area (10.32 sq

After generating the service areas and networks, use the layer files in the sample dataset to
quickly symbolize these layers.

When complete, the map allows the service areas and fire hall locations to be easily compared
visually.
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km) and Fire Hall 4 has the smallest (6.21 sq
km). To effectively model response areas for
all Burnaby fire halls would require building
a complete three-dimensional street network
and adding the other stations located outside
of the study area.
Calculating Total Street Length
Traversed by Each Fire Hall
Open the Optimized Travel Network, Slope
attribute table. Note that each fire hall has
multiple street segments. The Label field

identifies which segments correspond with each
station. The next step will be to summarize this
data to assign total kilometers to each station.
1. Open the attribute table for Optimized
Travel Network, Slope.
2. Right-click on the Label field and choose
Summarize.
3. Summarize on LABEL. Under statistic
to summarize on, scroll to the bottom of
the list, expand Shape _Length, and check
Sum.

ESRI Is Your Total Solution Provider
Total solutions from ESRI can
provide technology you need at
prices you can afford. ESRI works
with leading hardware vendors
to provide bundled solutions that
include ArcGIS® Server, ArcGIS
Desktop, ArcPad®, and much more.

4. Name the table snetopt10_SL_Sum1,
specify that it is a File and Personal Database
Table, and store it inside Burnaby_Fire.gdb.
5. Add the summary table into the map and
open it. Notice that Fire Hall 5 protects nearly
98 km of streets while Fire Hall 4 protects
only a little more than 50 km. (Note that the
dataset was clipped for training purposes.)
The new Fire Hall 7 protects nearly 84 km
of streets including a significant portion of
Highway 1.
Conclusion
In this exercise, slope- and turn-adjusted timebased optimum response areas were used for
carefully defining primary response areas for
each fire hall and its neighboring stations.
Modeling coverage for existing and proposed
stations often requires running multiple
models and summarizing value, hazard, risk,
and protection within all station footprints for
multiple scenarios. This requires a bit of work,
but the results are very convincing.
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