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A Workflow for Creating 
and Sharing Maps
By Keith Mann, Esri

What You Will Need
Item Source

ArcGIS Online 
for Organizations 
subscription

Can use the 
free 30-day trial

ArcGIS 10.1 for Desktop 
(Any license level)

Can use the 
free 60-day trial 

ArcGIS Spatial Analyst 
extension

Can use the 
free 60-day trial 

ArcGIS mobile applica-
tion for smartphones 
and tablets running iOS, 
Android, or Windows 
Phone

Free from App 
Store, Google 
Play, Windows 
Phone 
Marketplace

As more organizations adopt the ArcGIS Online platform, the web 
map is becoming an essential communication tool that helps GIS 
professionals empower decision makers and other non-GIS staff. 
In this tutorial, you’ll learn basic workflows for generating web 
maps, analyzing a web map layer in ArcGIS for Desktop, publishing 
the analysis as a hosted service, and creating new web maps that 
can be shared in web map applications and with ArcGIS mobile 
applications.

Getting Started
If you do not already have an ArcGIS Online for Organization sub-
scription or ArcGIS 10.1 for Desktop and the ArcGIS Spatial Analyst 
extension, you can get evaluation copies from the Esri website. The 
free mobile application is available for iOS, Android, and Windows 
Phone platforms. In Windows Explorer, create a folder named 

Manhattan and leave Windows Explorer open. Next, visit the 
ArcUser website and download the sample dataset, WiFi.zip. Extract 
the files to the Manhattan folder. 

Create a Web Map from a GPX File
Creating a web map using ArcGIS Online is an easy way to visualize 
raw data on a map and share that information with others. In this 
scenario, suppose that you have some Wi-Fi hotspot location data 
for Manhattan that was collected using a smartphone GPS applica-
tion. The data is stored in the WiFi_HotSpots_NYC.gpx file in the 
sample dataset.
1.	 Sign in to your ArcGIS Online for Organizations account and 

click Map. Create a new folder for the group called Manhattan. 
2.	 In Windows Explorer, navigate to the Manhattanexercise folder, 

select the WiFi_HotSpots_NYC.gpx, and drag the file onto the map.

 After creating a new map on ArcGIS Online, drag WiFi_HotSpots_NYC.gpx onto the map. 
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3.	 To symbolize the hotspots, click the Details button, then the 
Show Contents of Map button. Click the arrow symbol next to 
the Wi-Fi_HotSpots_NYC layer and choose Change Symbols 
from the context menu. For Use, select Unique Symbols. For To 
Show, select type. 

4.	 Click Fee-based symbol. In the Change Label and Symbol dialog 
box, click Change Symbol. In the Change Symbol dialog box, 
choose a red symbol and make the symbol 12 pixels in size. Click 
Done and then click OK. 

5.	 Use the same process to change the symbol for the free hotspots 
to a black 12-pixel symbol. Click Apply in the Change Symbol 

dialog box to finalize these changes and close the dialog box.
6.	 Configure the pop-ups for the Wi-Fi hotspots by clicking the 

arrow symbol on the Wi-Fi_HotSpots_NYC layer and choosing 
Configure Pop-up from the context menu. Click the Configure 
Attributes button and, in the dialog box, confirm that the boxes 
next to name and type are checked. Click OK. Click the Save 
Pop-up button.

7.	 Save this web map by choosing Save As. Complete the Save Map 
dialog.  
Title: WiFi Hotspots in Manhattan 
Tags: New York City, Manhattan, WiFi 
Summary: Free and fee-based Wi-Fi hotspots in Manhattan. 
Save the map. 

8.	 Click My Content and choose Groups. Click Create a Group and 
complete this page as follows:  
Name: Manhattan Internet Access Project; Summary: Public 
Internet access in Manhattan interest group; Description: This 
group provides inventory and analysis of public Internet access 
in Manhattan. Make sure Status is Public. Add the following 
tags: NYC, Manhattan, WiFi, Internet. Complete the Description 
section. 

9.	 Click the thumbnail image area to the left of Name, click the 
Choose File button, navigate to the Manhattanexercise folder, 
and choose MIAP_logo.png. Select it and click Open. Click OK. 
Click Save.

10.	Click the Manhattan folder and then click WiFi Hotspots in 
Manhattan. Click the Edit button. Complete the description page 
as specified in Table 1. Click Save. 

Special Section: ArcGIS Online

 Change the symbology to indicate fee-
based and free Wi-Fi hot spots.

 Open the WiFi Hotspots in Manhattan 
map in ArcGIS 10.1 for Desktop. Create the 
WiFi_HotSpots_NYC feature class in the 
new Manhattan file geodatabase to enable 
spatial analysis on the hot spot locations. 
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11.	 Click the Share button. In the Share 
dialog box, check Everyone (public) and 
These groups. Check Manhattan Internet 
Access Project. Click OK. Leave ArcGIS 
Online open.

Use ArcGIS for Desktop to 
Analyze Wi-Fi Hotspots
In this next step, you’ll analyze the Wi-Fi 
hotspot locations in ArcGIS 10.1 for Desktop. 
You can use features in a web map as inputs 
for spatial analysis using ArcGIS for Desktop. 

1.	 On the WiFi Hotspots in Manhattan 
Details page in ArcGIS Online, click Open 
> Open in ArcGIS 10 for Desktop. This will 
create a map package and download it 
to your browser. Double-click the down-
loaded package to open it in ArcGIS 10 for 
Desktop.

2.	 In ArcMap, choose Customize > 
Extensions from the menu. Check Spatial 
Analyst and click Close.

3.	 In ArcMap, open the Catalog window and 

Title WiFi Hotspots in Manhattan

Summary Free and fee-based Wi-Fi 
hotspots in Manhattan

Description An inventory of Wi-Fi hotspots 
in Manhattan. This map is for 
testing purposes only.

Access and Use Constraints None

Credits New York City

 Table 1: WiFi Hotspots in Manhattan details

click Connect to Folder. Navigate to the location of the Manhattan 
folder created earlier and click OK. 

4.	In the Catalog window, select the Manhattan folder and choose 
New > File Geodatabase. Name the geodatabase Manhattan.

5.	Still in the Catalog window, expand Toolboxes and expand System 
Toolboxes, then Spatial Analyst Tools, then Density and double-
click the Kernel Density tool. Drag the WiFi_HotSpots layer from 
the ArcMap table of contents (TOC) and drop it on the Input point 

 Activate the ArcGIS Spatial Analyst extension and locate the 
Kernel Density tool in the Density toolset in the Spatial Analyst 
toolbox. 

 Place the raster created by the Kernel Density tool in the 
Manhattan file geodatabase.
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or polyline features field of the Kernel Density dialog box. Leave 
Population field as NONE. For Output raster, click the folder icon 
and navigate to the Manhattan geodatabase and name the output 
raster WiFi_density. For Output cell size, enter 10. For Search radius, 
enter 300. For Area units, choose SQUARE_METERS. Click OK.

6.	Once the WiFi_density raster is added to the map, right-click the 
layer and choose Properties. Click the Symbology tab, choose 
Classified, set the number of classes to 5, and choose the Slope 
(Green to Red) color ramp. Click Apply.

7.	 Double-click the symbol for the first value range, choose No 
Color, and click Apply. Click the Display 
tab. Click the Resample drop-down and 
choose Bilinear Interpolation. For trans-
parency, enter 30 percent and click OK.

8.	In the TOC, uncheck the WiFi_HotSpots_
NYC layer to turn it off so you can inspect 
the WiFi_density layer. Save the map and 
leave ArcGIS for Desktop open.

Publish Your Analysis to ArcGIS 
Online

1.	 In ArcMap, remove the WiFi_HotSpots_
NYC layer and any basemaps from the 
TOC, leaving only the WiFi_density layer.

2.	 Choose File > Sign In and log in to your 
organizational account if necessary.

3.	 Click File > Share As > Service and 
click Next. In the Publish a Service 
dialog box, your organizational ac-
count should be listed under Choose 
a connection. For Service name, enter 

WiFi_Hotspots_Analysis. Click Continue.
4.	In the Service Editor panel, click Sharing and check the name of 

your organization, Everyone (public), and the Manhattan Internet 
Access Project group.

5.	Click Analyze and review any messages. If you get an error that 
tells you that basemaps cannot be published, right-click the error 
and choose Remove layer, then analyze again. If you get a mes-
sage that the raster layer does not have pyramids, right-click the 
message and allow ArcGIS for Desktop to build pyramids. Click 
Analyze again. Click Publish.

Special Section: ArcGIS Online

 After using a green to red color ramp to 
symbolize the raster, remove all but the 
raster layer from the map and publish it to 
ArcGIS Online as a hosted service.

 Open the WiFi Hotspots in Manhattan 
map in the ArcGIS.com map viewer and the 
WiFi_Hotspots_Analysis service to the map. 
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6. Once the service is published, open ArcGIS Online. If your WiFi 
Hotspots in Manhattan map is still open, go to the next step. 
Otherwise, click the My Content drop-down and then My Content. 
Click the Manhattan folder and then click the WiFi Hotspots in 
Manhattan item to open the web map. Click Open > Open in 
ArcGIS.com map viewer. 

7. In the map viewer, click the Add drop-down and then Search for 
Layers from the web, and enter wifi . Click Go. Click Add to add 
WiFi_Hotspots_Analysis to the map. Zoom in to see both the 
layers. Choose Save As and complete the Save Map dialog box. 
Th e title is WiFi Hotspots in Manhattan and enter tags for New 
York City, Manhattan, WiFi. Under Summary, type in Free and 
fee-based Wi-Fi hotspots and Wi-Fi density analysis in Manhattan. 
Click Save Map.

Sharing Your Web Map Using a Template
1. Click Share and make sure that your map is shared with Everyone 

(public), your organization, and the Manhattan Interest Group.
2. In the Share dialog box, click the Make a Web Application button. 

Choose the Chrome Twitter map template, click the Publish drop-
down, and then click Preview to see what the map looks like in the 
template. Close the preview. 

3. Now click the Publish drop-down and choose Publish. Enter the 
title, WiFi Hotspots in Manhattan. For Save folder:, choose the 
MIAP folder. Click Save & Publish.

4. But wait…your new templatized web map application isn’t shared 
yet. Go back to My Content. Check the WiFi Hotspots in Manhattan 
web map that you just created. Click Share and share the item 
with Everyone, including the Manhattan Interest Group. Click OK. 
Note: You can confi gure the map application further by clicking on 
the item in My Content and then clicking Confi gure App.

 Make sure the 
map is shared 
with Everyone. 
Then create a web 
application  from 
the map and share 
the application with 
everyone.

 Open the map 
in the ArcGIS.com 
map viewer, click 
Share, and copy the 
shortened link to 
the map. Mail it to 
yourself and open 
it using the ArcGIS 
mobile application 
for smartphones.
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Share Your Web Map Using E-mail
This time, you’ll share the map so it can be used with the ArcGIS 
mobile application. 
1.	 Go back to the WiFi Hotspots in Manhattan Details page on 

ArcGIS Online and open the map in the ArcGIS.com map viewer. 
2.	Click Share. Under Link to this map, copy the shortened URL. 

Close the Share dialog box.
3.	Open your e-mail program. Paste the URL into the body of a new 

e-mail, enter a subject line, and send the e-mail to yourself.
4.	On your smartphone (iPhone, Android device, or Windows Phone), 

open the e-mail and click the URL. This will automatically open 
the ArcGIS application and display your map.

Conclusion
ArcGIS Online provides a new way to access 
GIS maps and analyses. Web maps can 
become an essential communication tool 
for you and your organization. Not only 
can you quickly create web maps without 
any programming or development, you can 
share them with everyone or with specific 
group members through application tem-
plates and the ArcGIS mobile application. 
You can use operational layers in the web 
map as inputs for analysis in ArcGIS for 
Desktop and then turn that analysis layer 
into a hosted service on ArcGIS Online. 

Special Section: ArcGIS Online




