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Create 3D buildings in SketchUp 
and position them in ArcScene

By David L. Miller and Derek Ziders, SUNY College, Cortland, New York

This article relates a simplified process for ex-
porting building models constructed in Sketch-
Up as 3DS format files, bringing them into 
ArcScene as 3D marker symbols, and position-
ing them accurately. Using SketchUp to create 
three-dimensional symbology is straightfor-
ward. Model exchange between SketchUp and 
ArcGIS can be accomplished by bringing geo-
referenced vector data and orthorectified imag-
ery into SketchUp. (For more information on 
this topic, see “Interoperable Three-Dimension 
GIS: Urban Modeling with ArcGIS 3D Analyst 
and SketchUp” in the January–March 2007 is-
sue of ArcUser.) The authors’ experience sug-
gests that this simplified approach is a good 
path to successful creation of three-dimensional 
objects for visualization in ArcScene. 
 The authors developed the approach outlined 
in this article as part of a project to model buildings 
along the historic Main Street in Cortland, New 
York. A concerted effort is being made to restore 
downtown buildings and the surrounding area. 
When the project is completed, the authors will 
have built 38 highly detailed three-dimensional 
building models in SketchUp, exported them 
to ArcScene as 3D marker symbols, positioned 
them accurately over high-resolution orthoim-
agery, and created animations that will assist 
visualization of the planned changes that are 
designed to attract businesses and customers to 
downtown Cortland. 

Bring It On!

Buildings and other images constructed in 
Google SketchUp Pro 6 can be exported as 
3DS files and used in ArcGIS 3D Analyst 
documents.

This ArcScene screen capture shows an orthophoto of Cortland’s historic Main Street overlaid 
with a shapefile indicating the location of the Food Mart building with a red star. Main Street 
runs north (top of image) to south. 

 This exercise assumes the reader is familiar 
with the ArcGIS Desktop applications and the 
ArcGIS 3D Analyst extension and one of its 
applications, ArcScene. While creating mod-
erately complex three-dimensional buildings 
in SketchUp requires a good understanding of 
basic SketchUp techniques and some practice, 
this exercise uses prebuilt SKP files and ex-
ports them to a format that can be used by the 
ArcGIS 3D Analyst extension. 

Getting Started
Before starting this exercise, download the 
sample dataset, 3DBuilding.zip, from the 
ArcUser Online Web site (www.esri.com/
arcuser) and unzip the archive. Extract-
ing the archive will generate a new folder 
called 3Dbuilding. To shorten the amount 
of time needed to complete this exercise, the 
downloaded material includes an orthophoto 
(NAD83/NY Central), three point shapefiles, 
and three SketchUp building (SKP) files. 
 Download and install the free trial version 
of SketchUp Pro 6 from the SketchUp Web 

site (www.sketchup.com). Approximately 
14 MB of space is required for the unzipped 
sample dataset. SketchUp 6, also available at 
no charge from this site, does not have the abil-
ity to export .skp files to .3ds format files for 
use in ArcGIS 3D Analyst. 

Exporting a SketchUp Model 
to an ArcScene 3D Marker Symbol
The 3Dbuilding folder includes a prebuilt 
SketchUp file called Food_Mart.skp and a brief 
Microsoft PowerPoint presentation (Food_
Mart.ppt) that reviews the steps that were used 
to create the Food Mart building in SketchUp. 
Additional .skp files are included in the folder 
that demonstrate the level of complexity that 
can be achieved. 
1. Start a SketchUp session, and open the file 

Food_Mart.skp from the 3Dbuilding folder. 
This is a relatively simple 3D building. 

2. Choose Tools > Tape Measure. Use the 
measuring tape to verify that the building’s 
footprint is 40 feet by 100 feet. The dis-
tance from the roof to the base of the build-
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A 3D symbol is a 2D symbol with extended properties that allows it to be viewed 
in three dimensions in an ArcGIS 3D Analyst application. There are two types of 3D 
symbols—geotypical and geospecific. A geotypical symbol models realistic properties 
of a certain style of 3D symbol such as a Cape Cod house. ArcGIS 3D Analyst comes 
with 3D styles for symbolizing points, lines, and polygons with generic 3D symbols 
such as typical houses or textured roads. These symbols create realism without im-
plying specific, actual objects. The FoodMart symbol is an example of a geotypical 
symbol. A geospecific symbol, in contrast, models a real-world object.The detailed 
State Farm and HSBC Bank models created for this exercise are examples of geospe-
cific symbols.

Types of 3D Symbols

What You Will Need
ArcGIS 9.2 (ArcInfo, ArcEditor, or ArcView license)•	
ArcGIS 3D Analyst 9.2 extension•	
SketchUp Pro 6 (free eight-hour trial version)•	

Use the Symbol Property Editor 
dialog box to change the marker to 
a 3D marker symbol and import the 
Food_Mart1.3ds file.

ing should measure 17 feet.
3. Export the file by choosing File > Export 

> 3D Model. In the Export Model window, 
navigate to 3Dbuilding and create a new 
folder named FoodMart. All elements of the 
SketchUp to .3ds export must reside in the 
same file. Name the export file Food_Mart1 
and set the Export Type to 3DS (*.3ds). Be-
fore clicking Export, make sure the destina-
tion is the FoodMart folder. 

 Repeat this process for the State_Farm.skp 

and HSBC_Bank.skp files. Create a separate 
folder for each output and save the 3DS file 
output in each.

3D Marker Symbol
Placement in ArcScene
Three processes are required to accurately place 
a custom 3D marker symbol in the ArcScene 
document. The symbol must be linked to a 
point at the building’s location, the symbol’s 
properties must be edited, and the symbol’s 

position must be adjusted. The following steps 
show how to place the SketchUp-generated 
3D marker symbol on a three-dimensional 
ArcScene representation of Main Street in 
Cortland. 
1. Start ArcScene and open a new document.
2. Load foodmartpoint.shp. This shape-

file contains one feature, the Food Mart. 
Double-click on the marker symbol in the 
Table of Contents to open the Symbol Se-
lector dialog box. Change the symbol point 
size to 6 and its color to one that is bright to 
make it more visible. Click OK. The point 
feature is located at the site of an actual 
similar building on Main Street. Because 
the shapefile includes projection informa-
tion, the Data Frame (Scene Layer) will 
adopt the NAD_1983_StatePlane_NY_
Central_FIPS_3102 coordinate system.

3. Load c_09270946_12_07200_col_2003.
sid file (orthophoto). Save the ArcScene 
document.

4. Reopen in the Symbol Selector dialog box 
for the Food Mart point feature. Set Symbol 
Selector Category to All, click Properties to 
open the Symbol Property Editor, and set 
Properties Type to 3D Marker Symbol. 

5. Still in the Symbol Selector dialog box, 
click the Import button and navigate to 
and open the Food_Mart1.3ds file in the 
FoodMart subfolder. Click OK to import 
the Food Mart building as a 3D marker 
symbol. The Food Mart building should 
appear in the approximate location of the 
point feature on the orthophoto. Refresh the 
orthophoto if necessary and zoom in a bit 
closer to the building. 

Fine-Tuning Building Placement
To adjust a building symbol to match its real-
world footprint requires changing the model’s 
orientation, size, and placement. The orthopho-
to will be used to guide modifications to the 
symbol. 

Continued on page 44
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1. Examine the scene. The building front is 
facing south but it needs to be turned to the 
east so it fronts on Main Street. 

2. Left-click on the Food Mart point symbol 
in the Scene Layer to open the Symbol 
Selector dialog box. Select Properties to 
open the Symbol Property Editor, left-click 
once on the Rotate Axis Z (blue) clockwise 
button to turn the symbol 90 degrees east, 
click OK to return to the Symbol Selector 
window, then click OK to set the change. 
If the orthophoto layer partially disappears, 
right-click on that layer in the Table of Con-
tents and choose Refresh. An alternate way 
to turn the building is to open the Symbol 
Selector dialog box and set Angle to 90.

3. Again examine the scene. Use the Navigate 
tool to view the building’s size from various 
perspectives. The building extends too far 
into the street and does not fit its footprint; 
it is too large. To correct this, left-click on 
the Food Mart point symbol and reduce the 
size to 7.0 points. Click OK to return to the 
scene, and examine the result. 

Note that the building is slightly off the foot-
print’s east–west (Y) axis. Return to the Sym-
bol Selector dialog box, click Properties, then 
click the 3D Placement tab. Set the Y (green) 
Offset to -4. Click OK to close each open win-
dow. If the orthophoto disappears, refresh it as 
before. 
 Finally, review the changes with the Navi-
gate tool. Some tweaking is often necessary. 
With practice, good placement is quickly 
accomplished.

Additional Practice with 
Real Building Models
The preceding instructions bring a relatively 
simple SketchUp 3D model into ArcScene. To 
provide readers with an opportunity for addi-
tional practice and demonstrate the utility of 
this approach, two additional SketchUp model 

Bring It On!
Continued from page 43

After importing the Food Mart building, it is 
shown facing south.

Some tweaking is usually necessary to precisely align a building symbol to its real-world 
footprint. In the Symbol Property Editor dialog box, click on Rotate Axis Z (blue) clockwise to 
turn building to face Main Street. 

A photograph of Cortland’s historic State Farm building and a highly detailed model of it  
constructed using Google SketchUp

buildings were included in the 3Dbuilding data-
set. Add the StateFarm.shp and HSBC.shp files 
to the ArcScene document. State_Farm.skp (in 
the StateFarm subfolder) and HSBC_Bank.skp 
(in the HSBC_Bank subfolder) are models that 
closely represent actual Main Street buildings. 
Export them from SketchUp as .3ds files and 
add them as 3D marker symbols. Fine tune 
their positions using the techniques learned in 
the previous section. Digital photos of the ac-
tual buildings are included for reference. 

Summary
Google SketchUp’s 3D modeling soft-
ware can be used to produce highly detailed 
three-dimensional models that can be easily 
imported into ArcScene as 3D marker sym-
bols. This article provided a relatively easy ap-
proach for bringing custom-built 3D structures 
into ArcScene. To successfully acomplish this, 
use care to keep exported file components or-
ganized and observe SketchUp conventions.  
Some experimentation and tweaking of the 
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To give readers more 
practice with the 
techniques described 
in this article, the 
sample data contains 
detailed models of the 
State Farm building 
and HSBC Bank and 
shapefiles to correctly 
locate these features.

First-time users of SketchUp should complete the introductory tutorial to master the 
basics of using SketchUp for creating 3D symbols for import in ArcGIS 3D Analyst. 
Many support materials for obtaining proficiency with the software can be found on 
the SketchUp Web site (www.sketchup.com). After becoming familiar with SketchUp, 
review the following suggestions before creating a building for import into ArcScene. 
1. Respect the real-life dimensions of the building. Measure the building footprint 

from an orthophoto or with a tape measure. Use these dimensions to create the 3D 
model. Also, visit the building and take digital photos for reference during virtual 
construction.

2. If some textures don’t show up after the custom 3D marker symbol is imported, 
don’t panic. In SketchUp, faces have two sides. If the backside of a face is on the 
outside of the model, the texture will not show when the model is exported to a 
.3ds-based marker symbol in ArcScene. To determine which faces are reversed in 
SketchUp, choose View > Face Style > Monochrome in SketchUp to temporarily 
remove all texture. The back of a face is blue and the front is white. All outside 
surfaces of building should be white or gray, depending on perspective. To reverse 
the orientation of a face, right-click on it and choose Reverse Faces. After correcting 
all reversed faces, click View > Face Style > Shaded With Textures to restore the 
texture. 

3. Export each SketchUp model as a 3DS file with its own folder. When exporting 
.skp files to 3Ds format, each texture style on the building becomes a .jpeg file that 
must be in the same folder as the 3DS file. All the parts—JPEG and 3DS files—have 
to be in the file for textures to show when a .3ds file is used to create a 3D marker 
symbol in ArcScene.

4. Complex models may require several exports (SketchUp 3D Model > .3ds > ArcScene 
3D Marker Symbol) to ensure that the finished 3D marker symbol is perfect. 

5. For SketchUp models that contain images, such as a photo-based sign, use an 
image in .jpeg format. This format seems to weather 3DS exports better than other 
formats. While in SketchUp, remove texture from beneath images. Otherwise, 
both textures will wrestle for the surface of the .3ds-based 3D marker symbol. For 
example, if the image is a sign on a wall, draw a rectangle surrounding the image 
and use the rotate tool to navigate to the backside of the wall the sign is on, select 
the reverse side of the rectangle, and press the Delete key. The backside of the sign 
will appear. The face side will correctly display the JPEG image.

Five Tips for Creating 
3D Building Models

final position of the marker symbol will be 
required. Nevertheless, with modest practice, 
users can quickly produce three-dimensional 
models useful for visualizing proposed chang-
es and create highly realistic animations. For 
more information, contact 
David L. Miller
Director, GIS Lab
SUNY College, Cortland, New York
E-mail: Millerd@cortland.edu
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