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Exercise 1: File Geodatabase Preparation 
 
A geodatabase is a collection of geographic datasets of various types 
and is a native data storage and management framework for ArcGIS. It 
acts as an organizational tool to store and manage large lidar datasets 
and terrains and is also the gateway into advanced GIS capabilities. It 
provides a central scalable data storage and management system with 
better data integrity, backup, recovery, and security. 
 
Esri CityEngine relies on three ingredients: feature geometry, feature 
attributes, and procedural rules. The more detail provided in each 
element, the greater the complexity and real-world accuracy of the 
generated 3D content. 
 
CityEngine uses the Esri file geodatabase (including textured 
multipatches) as its native storage format. This means that you can use any geo-spatial vector data, such 
as parcels, building footprints, and street networks, in CityEngine. 
 
In this exercise, you will: 
 

 Create a file geodatabase 
 

 Use the Clip tool to select data for the area of interest 
 

 License: This data has been provided by Esri and the City of Redlands 
 
 

Part 1: Open ArcMap and Create a Folder Connection 
 
Steps: 
 

1. In Windows Explorer, navigate to C:\3D_Workshop\Exercise1. 
 

2. Double-click Exercise1.mxd to open it. 
 

3. Click the Catalog button ( ) on the Standard toolbar. Drag the Catalog window and dock it at the 
right tab. Click the pin to keep it open. 

 

4. In the Catalog window, click the Connect to Folder button ( ). 
 

5. Navigate to C:\3D_Workshop\ and click OK. 
 
You now have access to all the data and exercise folders. 
 
 

Complexity: 
Beginner 

Data Requirement: 
Installed with software 

Data Path: 
C:\3D_Workshop\  

Goal: 
Learn how to prepare data for 
CityEngine 

Average length of time to complete: 
15 minutes 
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Part 2: Create a File Geodatabase 
 
The map document with Redlands data has been given to you. The map has an outline of an area of 
interest (AOI.) Your job is to prepare the data within the AOI for a CityEngine project. To do this, you will 
extract a subset of the original data with the Clip geoprocessing tool, and place the subset into a new file 
geodatabase. 
 
Steps: 
 

1. Make sure that the ArcGIS 3D Analyst extension is enabled. On the main menu, click 
Customize > Extensions and make sure that 3D Analyst is checked. Then click Close. 

 
2. In the Catalog window, navigate to C:\3D_Workshop\Exercise1. 

 
3. Right-click the Exercise1 folder and click New > File Geodatabase. 

 
4. Rename it to RedlandsFinal. 

 
5. Right-click the geodatabase and click Make Default Geodatabase. 

 
The default geodatabase is the home location for the spatial content of your map. This location is used for 
adding datasets and for saving resultant datasets created by various editing and geoprocessing 
operations. The default geodatabase is synchronized with Current Workspace of the Geoprocessing 
Environments; therefore, all output from tools or models will be saved to this default location. Access to 
the default geodatabase is available from the Catalog window menu, and as a shortcut in dialog boxes, 
so that you can quickly get back to the default geodatabase if you have navigated elsewhere in the 
system. 
 
 

Part 3: Vector Data Preparation 
 
To prepare the data for import into CityEngine, we're going to generate a subset that just covers our area 
of interest. We will use the Clip geoprocessing (gp) tool. 
 
Steps: 
 

1. Click the ArcToolbox button ( ) on the Standard toolbar. 
 

2. Drag and dock under the Table of Contents. 
 

3. Expand the Analysis toolbox and then the Extract toolbox. 
 

 
 

4. Double-click the Clip tool to open it. 
 

5. Click the dropdown arrow for Input Features and select Buildings. 
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6. Use the dropdown for Clip Features to select Area of Interest. 
 

7. Notice that the tool has entered the path to the default geodatabase and created a name for 
Output Feature Class. Change the name to just Buildings by backspacing over the name right 
in the text box. 

 
8. Check to see that your tool settings match the image below. If so, click OK. 

 

 
 

9. When the tool is finished, the new layer Buildings is added to the map. Turn off the Redlands 
original layer. Notice that all of the buildings are within the area of interest. 

 

 
 

10. Use the Clip tool to extract subsets for the other vector layers: Lights, Trees and Streets. 
 

Note: We are not going to clip the imagery in this exercise. We will wait and do that with 
the other raster preparation in Exercise 2. 

 
11. Click the ArcMap File menu button and select Save As. Save it into the Exercise1 folder and 

give it the name MyExercise1.mxd. 
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Exercise 2: Raster Data—Lidar and Imagery 
 
A fundamental component of any 3D map is a detailed model of the 
terrain. This provides "texture" for the city scene, but also determines 
the vertical placement of all the ground-based GIS data: buildings, 
land cover, street furniture, and other installations. To obtain the level 
of accuracy required for realistic terrain modeling and feature 
placement at the street-level, high resolution classified lidar data is 
required. 
 
For the purpose of terrain modeling and feature extraction, there are 
three basic surface types used in the 3D City models. These raster 
surfaces are created based on different return classifications in the 
lidar dataset: 
 

1. Digital Terrain Model (DTM)—A raster representing the elevation of the bare earth, with structures 
and vegetation removed. This is used as the base elevation surface in the 3D scenes (ArcGlobe, 
ArcScene, CityEngine). Ground return points are used. 

 
2. Digital Surface Model (DSM)—A raster representing the elevation of all structures and natural 

features on the earth. The same kind of surface you'd get if you "shrink-wrapped" the landscape. 
First return points are used. 

 
3. Normalized Digital Surface Model (nDSM)—This surface is used to model the height above the 

ground surface of structures and vegetation. The surface is derived by subtracting the DSM from 
the DTM. 

 
The nDSM is the difference between a DTM and a DSM: DTM – DSM = nDSM. 

 

  

Digital Terrain Model (left) and Digital Surface Model (right) along the riverfront with extruded building footprints 

 
In this exercise, you will: 
 

 Import ground lidar points into a multipoint feature class 

 Create a rasterized digital terrain model using the ground-based multipoints 

 Similarly, create a digital surface model 

 Use these models to determine elevation values for the Buildings feature class 
 
In this section of the course, you will learn how to create, visualize, and analyze raster datasets in 
ArcGIS. 
 
Using the LAS Dataset toolbar in ArcGIS 10.2, it is a simple process to convert high resolution LAS data 
into these 3 surfaces: DTM, DSM, and nDSM. 
 
 

Complexity: 
Beginner 

Data Requirement: 
Installed with software 

Data Path: 
C:\3D_Workshop\ 

Goal: 
Learn how to create a terrain 
dataset from lidar data. 

Average length of time to complete: 
60 minutes 
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Part 1: Add Lidar Ground Points Into the Map 
 
Lidar (light detection and ranging) is a relatively new remote sensing technology allowing us to collect 
very dense point samples of features in 3D. Lidar technology has evolved to become a common source of 
geographic data in GIS. These vast collections of real-world points are typically stored in LAS files. Each 
lidar point can have additional attributes such as intensity, class codes, and RGB color values, which can 
be leveraged inside ArcGIS. 
 
ArcGIS reads LAS files natively, providing immediate access to lidar data without the need for data 
conversion or import. LAS attributes can be used to filter out content and symbolize points in 2D and 3D. 
Also, as lidar data often comes as a group of files, ArcGIS provides the ability to define logical sets of LAS 
files for working in localized projects. 
 
Steps: 
 

1. In Windows Explorer, navigate to C:\3D_Workshop\Exercise2. 
 

2. Double-click Exercise2.mxd. 
 

3. If you did not do Exercise 1, make sure you have the 3D Analyst extension enabled. To do this, 
click the Customize menu, then Extensions. Make sure 3D Analyst is checked on. Then click 
Close. 

 
4. Enable the LAS Dataset toolbar. To do this, click the Customize menu and click on Toolbars. 

Select LAS Dataset from the list. 
 

5. Drag the LAS Dataset toolbar to the top next to the Tools menu. 
 

 
 

6. Open the Catalog (  ) window (if necessary) and dock it at the right. 
 

7. In the Catalog window, right-click on RedlandsFinal.gdb and select Make Default 
Geodatabase. 

 
8. Expand the 3D_Workshop\Exercise2\Lidar folder. 

 

 
 

9. Drag Redlands.lasd to the map. 
 

If you get a Geographic Coordinate Systems Warning, just click Close. 
 

If you don’t see the lidar points, but just the red LAS file extent outlines, right-click the Buildings 
layer in the TOC and choose Zoom To Layer. 

 

http://resources.arcgis.com/en/help/main/10.1/015w/015w00000041000000.htm
http://resources.arcgis.com/en/help/main/10.1/015w/015w00000054000000.htm
http://resources.arcgis.com/en/help/main/10.1/015w/015w00000041000000.htm#ESRI_SECTION1_DE9C4733D20A44F795EC43061106A3BE
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10. Turn off the Buildings layer. 
 

 
 

11. On the LAS Dataset toolbar, click Filters and select Ground. Now only the ground lidar points 
are displayed. Click the pin at the top-right of the Catalog window to hide it, so you can see more 
of the map. 
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Part 2: Create the Digital Terrain Model 
 
Steps: 
 

1. If not already, open the Toolbox window ( ) and dock it under the Table of Contents. 
 

2. In the ArcToolbox window, open Conversion Tools > To Raster.  
 

3. Double-click the LAS Dataset to Raster tool to open it. After the tool is open, you may need to 
resize it so you can see all the parameters. 

 

 
 

4. On the tool dialog, use the dropdown for Input LAS Dataset and select Redlands.lasd. 
 

5. For Output Raster, change the name provided to DTM. 
 

6. Ensure that the Value Field is set to ELEVATION. 
 

7. Click the radio button for Triangulation. 
 

8. Set Interpolation Method to NATURAL_NEIGHBOR. 
 

9. Point Thinning Type should be set to NO_THINNING. 
 

10. Change Sampling Value to 3. (This is approximately two times the point spacing of the data.) 
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11. If your tool looks like the graphic below, click OK to run the tool. 
 

*And please be patient, as it can take a couple minutes to complete. 
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12. When the tool has completed, the surface is added to the map. Turn off the Redlands.lasd layer 
so you can see the DTM layer. It should look like this: 

 

 
 

Note that you are viewing only the extent of the Buildings layer. To see the entire DTM, click the 

Full Extent button ( ). 
 

 
 

Now click the Go Back To Previous Extent button ( ). 
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Part 3: Create the Digital Surface Model 
 
Before creating the Digital Surface Model we need to change the display of the lidar on the map. We used 
ground points for the terrain; we will use the first returns (highest points) for the surface model. 
 
Steps: 
 

1. An easy way to turn on one layer and turn off all other layers in the TOC is as follows: while 
pressing the Alt key on your keyboard, click the check box next to the layer you want to be on. 
Do this now for the Redlands.lasd layer. 

 
2. On the LAS Dataset toolbar, click Filters and select First Return. 

 

 
 

Notice the difference in the display of the lidar? Open the 3D View ( ) window to look at the 
lidar. (Note: There are a few noise points that have not been tagged as such that will appear in 
the first return.) 

 
3. Open the LAS Dataset to Raster tool again. 
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4. Set the parameters of the tool as follows: 
 

Input LAS Dataset: Redlands.lasd 
 

Output Raster: C:\3D_Workshop\Scratch_Workspace\Scratch_Database.gdb\DSM 
 

Value Field: ELEVATION 
 

Binning: 
 

Cell Assignment Type: MAXIMUM 
Void Fill Method: NATURAL_NEIGHBOR 

 
Sampling Value: 3 

 

 
 

Note: if you want to know the difference between the Binning and Triangulation methods, 
click the Show Help button on the tool and click on Binning, or anywhere in the 
Interpolation Type section. 

 
5. Click OK to run the tool. 
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6. Turn off the lidar layer so you can see the DSM. 
 

 
 
 

Part 4: Create the Normalized Digital Surface Model 
 
The next step is to Subtract the Ground Terrain Model from the First Return Surface Model to create a 
Normalized Digital Surface Model (nDSM). 
 
Steps: 
 

1. The easiest way to find the Minus tool is to open the Search ( ) window, click the Tools link, 
type minus and then press the Enter key. 

 
2. Click the Minus (3D Analyst) tool. 
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3. Use the dropdown for Input raster or constant value 1 and select DSM. 
 

4. Use the dropdown for Input raster or constant value 2 and select DTM. 
 

5. Change the Output raster name to nDSM. 
 

6. Click OK to run 
 

 
 

The resulting raster should look like this: 
 

 
 

7. Save the map document (File > Save As) to 3D_Workshop\Exercise2\MyExercise2.mxd 
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Part 5: Determine the Elevation of the Buildings 
 
Now that you have an elevation layer, you will need to determine the elevation of your buildings by 
sampling at random locations. The first step is to generate a set of random sample points for each 
building footprint. We will use the Create Random Points geoprocessing tool to generate a set of random 
sample points in your building footprints. 
 
Steps: 
 

1. Turn off all layers except for Buildings. 
 

2. Find and open the create random points (data management) tool from the Search window.  
 

 
 

(Or locate the tool in the Data Management Tools > Feature Class toolbox.) 
 

3. Set the following tool parameters: 
 

Output Location: this should be set to the default database. 
 

Output Point Feature Class: Random_Points (type this directly into the box.) 
 

Constraining Feature Class: Buildings (use dropdown) 
 

Number of Points: 
 

Long radio button on, value = 100 
 

Minimum Allowed Distance: 
 

Linear unit button on, units set to Meters 
 

Note: When deciding how many random points to generate, remember that the more 
sample points you have, the more accurate your average height will be, but the longer 
your processing time is. 
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4. Click OK to run. 
 

The result is a new feature class containing groups of points, one group for each building. Note 
that each building may not have the total number of sample points you specified in the 
geoprocessing tool. The tool stops creating points when it cannot place a new point without 
violating your parameters. 
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5. Zoom into some buildings. 
 

 
 

Random point placement in each building might differ from illustrated. The key value we are 
capturing per point is the average elevation for each building, so a point's exact xy location on a 
building footprint is not as important. 

 
 

Part 6: Add Elevation Values to the Random Points 
 
Elevation information from your Normalized Digital Surface Model (nDSM) raster elevation surface can be 
added to each point as an attribute using the Add Surface Information geoprocessing tool. 
 
Steps: 
 

1. In the ArcToolbox window, navigate to 3D Analyst Tools > Functional Surface and double-click 
Add Surface Information. 
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2. Set the following parameters: 
 

Use the dropdown for Input Feature Class to select Random_Points. 
 

Use the Input Surface dropdown to select nDSM. 
 

Under Output Property, check on the box for Z. 
 

Leave the defaults for everything else and click OK to run. 
 

 
 

Now that all the random points in each building have an elevation, or Z value, we want to get the 
average, or mean elevation for each building. We'll use the Summary Statistics tool for that. 

 



ArcGIS 10.2 3D Workshop 

Copyright © 1995-2013 Esri. All rights reserved. 20 

3. From the ArcToolbox window, open Analysis Tools > Statistics > Summary Statistics. 
 

4. Set the following parameters: 
 

Use the dropdown for Input Table to select Random_Points. 
 

Use the Output Table browse button to navigate into the Exercise 2 folder. Type 
Summary_Statistics for Name. then click Save. 

 
For Statistics Fields, use the dropdown to select Z. Do not be alarmed when you get an error 
message! This will go away as soon as you set the Statistic Type to MEAN. 

 
Click in the white space below Statistic Type to enable the dropdown and select MEAN. 
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Use the dropdown for Case field to select CID. 
 

Click OK to run. 
 

 
 

5. When the tool is complete, it automatically changes the TOC view and highlights the table. Right-
click the table and select Open (resize if necessary.) It should look like this, but you will have 
different MEAN_Z values. 
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6. Close the table. 
 

Now we want to attach the Mean_Z values generated for the random points to the Buildings 
feature class. To do this we will use the Join function. Resize the windows if needed. 

 
7. In the TOC, right-click Buildings and select Open Attribute Table. Dock the table at the bottom. 

Scroll all the way to the right to see the fields. 
 

8. Right-click Buildings again, hover over Joins and Relates, and then select Join. 
 

9. Fill out the Join Data tool as in the following graphic and then run it: 
 

 
 



ArcGIS 10.2 3D Workshop 

Copyright © 1995-2013 Esri. All rights reserved. 23 

If you get this message, click No: 
 

 
 

You will see in the attribute table that the new fields were joined. 
 

To permanently join the new fields into the Buildings layer, we need to create a new feature class 
in the file geodatabase. 

 
10. In the TOC, right-click Buildings and then choose Data > Export Data. 

 
11. In the Export Data dialog, click the browse button for the Output feature class. 

 
12. In the Saving Data dialog, navigate into your RedlandsFinal.gdb if not already there. For Name, 

type BuildingsFinal, then click Save. 
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13. On the Export Data dialog, click OK. 
 

 
 

When asked if you want to add the exported data to the map as a layer, click No. 
 

Now that the Building footprint layer has an elevation field, we need to make two more changes to 
it so that it meets CityEngine's data requirements. The CityEngine rule that we will use to 
generate the 3D buildings expects a field named totalHeight with data values in metric units. We 
can simply change the name of the MEAN_Z field, then convert the units from feet to meters. 

 
14. In the Catalog window, open RedlandsFinal.gdb. Right-click the BuildingsFinal feature class 

and select Properties. 
 

15. On the Feature Class Properties dialog, click on the Fields tab. 
 

16. Find the MEAN_Z field name. Change it to totalHeight by highlighting the name with the cursor 
and typing. Click OK to dismiss the dialog. 
 

17. Drag BuildingsFinal from the Catalog window to the map. 
 

18. In the TOC, right-click BuildingsFinal and choose Open Attribute Table. 
 

19. In the Table window, click the Table Options menu ( ) If Show Field Aliases is checked on, 
click it to turn it off. 

 
20. Locate the totalHeight field in the BuildingsFinal table. Right-click the name and select Field 

Calculator. Click Yes on the dialog to continue. 
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21. On the Field Calculator, double-click the totalHeight field to add it to the equation. Then click the 
multiply symbol (*), then type in .3048. 

 

 
 

22. Save the map document into the Exercise2 folder as MyExercise2.mxd. 
 

Note: When you move on to Exercise 3, you will use a file geodatabase that has already 
been prepared in this manner. In that one, the BuildingsFinal feature class has been 
renamed to simply Buildings. 

 
 

Part 7: Clip the Raster Imagery to the Area of Interest and Save in .tif Format 
 
CityEngine requires (at version 2012.1) that imagery be formatted in either .tif or .jpg formats. When we 
created our surface models we placed them into a file geodatabase. Now we are going to reformat the 
DTM surface and clip it to the area of interest. This DTM will be used as the Heightmap when we create a 
terrain in CityEngine. Then we'll do the same with the Redlands orthoimagery that you saw in Exercise 1, 
and use it as the Texture file for the terrain. 
 
When clipped the vector data in Exercise 1 we placed the results into a file geodatabase. When we clip 
the imagery layers, we will create output files in the .tif format, not in the file geodatabase. 
 
We will use the raster version of the Clip tool. 
 
Steps: 
 

1. In the ArcToolbox window, expand the Data Management Tools > Raster > Raster Processing 
toolboxes. 
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2. Double-click the Clip tool. 
 

 
 

3. Use the dropdown for Input Raster and select DTM. 
 

4. Use the dropdown for Output Extent and select Buildings. 
 

5. The location for Output Raster Dataset will default to your default geodatabase. Because we 
want to create a .tif file, we don't want to put it into the geodatabase. For Output Raster Dataset, 
click the browse button. Make sure you are in the Exercise2 folder. Type the name DTM.tif and 
then click Save. 
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6. Compare your tool with the graphic below, then click OK. 
 

 
 

7. After the tool completes, the DTM.tif is added to the map. If you look at it with the Buildings layer 
on, it will look like this: 
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8. In the Catalog window, expand 3D_Workshop\Exercise1\RedlandsSourceData.gdb. Drag the 
redlands raster to the map. 

 

 
 

9. Open the Clip tool again. 
 

10. Use the dropdown for Input Raster and select redlands. 
 

11. Set the Output Extent to Buildings. 
 

12. Click the browse button, make sure you are in the Exercise2 folder, and type the name 
Redlands.tif. Click Save. 

 
13. Click OK to run the tool. 

 

 
 

14. Save the map document. 
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Exercise 3: Working with CityEngine 
 
CityEngine is a standalone software product that provides professional 
users in defense, entertainment, architecture, urban planning, GIS and 
general 3D content production with a unique conceptual design and 
modeling solution for the efficient creation and maintenance of 3D 
cities. 
 
More specifically, you can use CityEngine to: 
 

 Efficiently create 3D cities based on your existing 2D/3D GIS 
data 

 

 Maintain (modify / update) 3D city data 
 

 Do conceptual city design in 3D based on GIS data and urban planning rules 
 

 Share 3D CityEngine scenes via the CityEngine Web Viewer on ArcGIS Online (browser-based, 
no plugin required) 

 
 

Exercise 3a: Create a Scene and Apply Rules 
 

Part 1: Create a CityEngine Project 
 
The main component of CityEngine is the project. When you create a new project, CityEngine creates a 
set of folders that will contain all the data, rules, models and other information for the project.  
 
Steps: 
 

1. Open CityEngine. Click Launch to dismiss the Welcome Wizard and start the application. 
 

Note: It takes a while for the software to launch for the first time. If you get the Welcome 
Wizard again you can close it by clicking the x in the upper right corner. 

 
2. Click File and select New. 

 

 
 

Complexity: 
Beginner 

Data Requirement: 
Installed with software 

Data Path: 
C:\3D_Workshop\ 

Goal: 
Learn the basics of 3D mapping 
with CityEngine 

Average length of time to complete: 
60 minutes 
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3. In the Select a wizard dialog, open the CityEngine folder, click on CityEngine project, then 
Next. 

 

 
 

4. For Project name, type Redlands.  
 

5. Uncheck the box for Use default location. 
 

6. Click the Browse button and then open C:\3D_Workshop. Select CityEngine_Workspace and 
click OK. 

 

 
 

7. Click Finish to create the project. 
 

8. Look at the CityEngine Navigator window. You will see your new project with many folders 
under it. 

 

 
 

9. Now that you have a project, you need to create a scene. Right-click the scenes folder and select 
New > CityEngine scene. 

 
Note: you could also use File > New to open the wizard, but starting from the scenes 
folder saves you from browsing to the proper Project folder. 
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10. In the CityEngine Scene dialog box, change the File name: to Redlands.cej. It is important to 
keep the .cej extension in the name. 

 
11. Click Finish. 

 

 
 

12. Now look at your CityEngine Scene window. It has two layers, Scene Light and Panorama. 
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Part 2: Add Data to the Project 
 
If you worked through Exercises 1 and 2, your resulting data could be used here. But we have provided 
data for you that has already been clipped and formatted. The file geodatabase and the tiff files are in the 
C:\3D_Workshop\DataForCityEngineImport folder. You will add them to the scene in the following 
steps. 
 
Steps: 
 

1. In the Navigator window, right-click the Redlands folder and select Import. 
 

2. On the Import wizard, expand Files into Existing Project, highlight File System, then click Next. 
 

 
 

3. On the File system dialog, click the browse button for From directory: 
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4. On the Import from directory dialog box, open the C:\3D_Workshop folder, click on 
DataForCityEngineImport to select it and then click OK. 

 

 
 

5. On the File system dialog, click the arrow to the left of the checkbox to expand the folders. 
 

 
 

6. Check the top checkbox to check all the folders: assets, data, models, and rules. 
 

  
 

7. Into folder should be set to Redlands already; if not, browse to it. 
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8. The Import dialog should look like the graphic below. Click Finish. The import will take a minute 
or so. 
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Part 3: Add Terrain to the Scene 
 
Steps: 
 

1. Click File and select Import. 
 

2. On the Select dialog, open CityEngine Layers, select Terrain Import and click Next. 
 

 
 

3. On the Terrain dialog, click the browse button for Heightmap file. 
 

4. On the Select Heightmap file dialog, click the data folder in the left column, then in the right 
column click DTM.tif and then click Open. You will be presented with a coordinate system dialog. 
(Note: If you do not see two columns, click the toggle tree view button in the upper left.) 

 
5. Expand Projected Coordinate Systems > World and select WGS 1984 Web Mercator 

Esri:102113, then click OK. This will align the heightmap to the appropriate coordinate system. 
 

 
 

6. Back on the Terrain dialog, click the browse button for Texture file: 
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7. Select Redlands.tif from the data folder and click Open. Select the same coordinate system as 
in step 4, WGS 1984 Web Mercator Esri:102113. 

 
Notice how CityEngine's Terrain import wizard automatically detected elevation height from the 
heightmap. 

 
 

 
 

8. Leave all other settings and click Finish. 
 

Once the terrain is added, the layer becomes visible in the Scene window. 
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9. To see the terrain in the Viewport window, right-click on the Terrain DTM layer and select Frame 
Layer. 
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Part 4: Add Data from the File Geodatabase to the Scene 
 
The data folder that you imported in Part 2 contains a file geodatabase. You will now add that data to the 
scene. 
 
Steps: 
 

1. In the Navigator window, expand the data folder. 
 

2. Drag and drop RedlandsFinal.gdb into the Viewport window. This will bring up the File 
Geodatabase Import wizard. 

 
3. In the wizard: 

 
These layers should be checked on: Lights, Trees, Streets, and Buildings. 

 
Ensure that the following options are checked: 

 
Run Graph Cleanup Tool after Import 
Create Street/Intersection Shapes from Graph 
Map Shape File Attributes 

 
Click Finish. 
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4. You will get a dialog asking you to choose the coordinate system for each layer. The dialog 
should have WGS 1984 Web Mercator ESRI:102113 already selected, so you can just click OK 
(four times.) If not already selected, choose Projected Coordinate Systems > World > WGS 
1984 Web Mercator ESRI:102113, then click OK. 

 

 
 

This will align the layers to the appropriate coordinate system. 
 

5. In the Scene window, right-click Streets and select Align Graph to Terrain. 
 

 
 

6. In the Align Graph to Terrain dialog box: 
 

Use the dropdown for Align function and select Project All (if not already selected). 
 

For Heightmap, use the dropdown and select Terrain DTM. 
 

Click Finish. 
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7. In the Scene window, click the eye ( ) next to Streets to turn off the layer, then click again turn 
it back on. 

 
Notice how CityEngine automatically drapes the road data on top of the terrain file. 

 

 
 

8. Click the Tumble/Rotate (  ) tool, then click in the Viewport window. Hold the left mouse button 
down and move the cursor to rotate. You can zoom in and out with the mouse wheel. 

 
9. Back in the Viewport, navigate to an edge where a road is going down to the unaligned Buildings 

layer. 
 

 
 

10. Click the Select tool, then click on the black point at the bottom of the road. When selected it 
becomes blue. 

 

 
 

11. Click Edit > Delete (or use the Delete key on your keyboard.) The point and the incorrect street 
are removed from the scene. 
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12. Delete the other stray points in the same manner. Remember to enable the Tumble/Rotate tool 
after you've used the Select tool. 

 
Tip: you can also rotate and zoom in the Viewport by holding down the keyboard Alt key 
while pressing the left mouse button and moving the cursor. 

 
13. The next step is to align all other vector data to the terrain. Holding down the Ctrl key, in the 

Scene window, select all of the following: Buildings, Trees, and Lights. 
 

14. Right-click the selected layers and choose Align Shapes to Terrain. 
 

15. In the Align Shapes dialog box: 
 

Set Align function to Translate to Average. 
 

Set Heightmap to Terrain DTM. 
 

Click Finish. 
 

 
 

16. If you have shapes that are still below the terrain, select them and run Align Shapes to Terrain, 
this time setting Align function to Translate to Maximum. 

 
The vector data is now draped on top of the terrain. 

 
The next steps will cover how to apply Rule files to GIS data and extrude the imported files into a 
Smart 3D City Model. 
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Part 5: Assign CityEngine Rules 
 
Steps: 
 

1. In the Scene window, right-click Buildings and choose Assign Rule File. 
 

2. The Assign Rule File dialog box opens to the Redlands/rules folder, with the available rules 
listed at the right. click on Customizable_City_MASTER.cga and then click Open. 

 

 
 

3. Look for the Generate button ( ) on the toolbars at the top of CityEngine. Click it to 
generate the buildings. Alternatively, you can right-click Buildings and choose Generate from the 
context menu. Be patient, and watch the buildings grow. 
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4. In the same manner, right-click Streets, Assign Rule File and choose StreetConstruction.cga. 
 

5. Click Generate to create the streets. 
 

6. Assign the trees.cga to the Trees layer and generate. 
 

7. Assign Light_Post.cga to the Lights layer and generate. 
 

8. If your trees or other layers have wireframes: 
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You can turn them off by clicking the Settings dropdown and clicking on Wireframe on 
Shaded/Textured. 
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Exercise 3b: Create a New Building 
 
CityEngine has editing tools for the quick sketching and texturing of 3D (mulitpatch) data. This exercise 
demonstrates basic shape creation and texturing options. 
 
Four tools will be used: 
 

 
 
 

Part 1: Draw a Basic Mass 
 
Steps: 
 

1. Find an empty lot where you'd like to sketch a building. 
 

2. Choose the Rectangular Shape Creation tool. 
 

3. Click once to begin shape creation, and click again at opposite corner to complete shape. 
 

4. After completing rectangle, hover over shape to find the orange "grip". 
 

5. Click the grip and pull upwards to create a 3D rectangular mass. 
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Part 2: Add a Roof 
 
Steps: 
 

1. Choose the Polygonal Shape Creation tool, since it will allow center snap on edges. 
 

2. Hover over one edge of your building to locate its center – an orange X will appear when it is 
snapped. 

 

 
 

3. Click once and then move towards the opposite edge –orange guidelines appear if parallel to 
edge. 

 
4. Find the center snap (orange X) and click to complete the ridge line of the roof 
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5. Hover over the ridge line until the orange dot appears. Put the cursor on the dot  
 

 
 

and then press-drag upwards to create a gable roof shape. 
 

 
 

6. Now, use either of the Shape Creation tools to draw a door. 
 

7. Hover over the door shape and use the grip to push it into the house slightly. 
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Part 3: Add Texture to the Building 
 
Steps: 
 

1. Choose the Selection ( ) tool and click on the building to select it. 
 

2. Choose the Texture Shapes ( ) tool, which will open the Shape Texturing Tool. 
 

3. On the Shape Texturing Tool, General section, click the Browse/pick button. 
 

4. On the left side of the Select texture dialog box, expand Redlands\assets. Click on the textures 
folder. 

 
On the right side of Select texture, click wall_stones.png. Then click Open. 

 

 
 

5. On the Shape Texturing Tool, click Assign to apply the wall texture. This happens immediately, 
so make sure your tool dialog is not covering up your building. 
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6. Under Texture Coordinates Mapping, change the Mode setting to Dimension so that all walls 
will use the same texture mapping regardless of their differently sized faces. 

 
Adjust Absolute texture width and Absolute texture height if the texture is not sized 
appropriately. When you click next to the numbers for these attributes, a scrollbar appears that 
you can use to change the sizes. 

 

 
 

7. Leave the tool open for the next part of the exercise. 
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Part 4: Add Texture to the Roof and Door 
 
Steps: 
 

1. With the Shape Texturing Tool open, click the dropdown for the Selection tool and choose 
Select. 

 

 
 

2. Click one side of the roof. This will deselect the entire building, and select only the roof. 
 

3. Select the other roof face by holding down the Ctrl or Shift key while clicking. 
 

Note: the Ctrl key toggles the selection, while Shift adds to the selection. 
 

4. Click the Browse/pick button and then click the roof.jpg texture. Click Open. 
 

5. Click Assign and follow the same process from Part 3 to adjust the roof texture. 
 

6. Select the door, and use Browse/pick to open the door.png texture, then Assign it. 
 

7. Change the door texture Mode to Stretch to polygon. This will match the edges of the door 
texture to any size door shape. 

 

 
 

8. Click Select > Deselect All if your door is still selected. 
 

 
 

9. Rotate in the Viewport to admire your new building! 
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Exercise 3c: Fun with Rules (Introduction to Procedural 
Modeling) 

 

Quick Introduction to Procedural Modeling with CityEngine 
 
This is a short demonstration of how CityEngine generates architecture using rules. Procedural rules are 
driven by inputs, which can come from GIS data, such as attributes and raster images. For this demo, we 
will alter these inputs and watch CityEngine regenerate buildings in real time. 
 
 

Part 1: Import the NYC 2259 Example Project 
 
Steps: 
 

1. In CityEngine, click File > Import. 
 

2. Select Existing Projects into Workspace and then click Next. 
 

3. Click the radio button for Select archive file and then click Browse. 
 

4. Navigate to C:\3D_Workshop\Exercise3c, click on Example_NYC2259__2012_1.zip and then 
click Open. 

 
(Note: If you don't have this project you can find it on the CityEngine web site) 

 
5. On the Import dialog, click Finish. You will see the Example_NYC2259_2012_1 project in the 

Navigator window. 
 
 

Part 2: Preview the NYC Building Rule 
 
Steps: 
 

1. In the Navigator window, expand the NYC project by double-clicking the project name, and then 
expand the rules folder similarly. 

 
2. Single click the buildings.cga rule file, and you will see a preview of the model. 

 
(Note: If preview pane is hidden, use the button highlighted in upper right of below image.) 

 

 
 
 

http://resources.arcgis.com/en/communities/city-engine/01w90000000r000000.htm#s=0&n=30&d=1&md=cte-resource-type:0000001000
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Part 3: Assign this Rule to Some Shapes 
 
Steps: 
 

1. Create new shapes with the Rectangular Shape Creation tool or the Polygonal Shape Creation 
tool. 

 
2. Click the Select tool and then select your shapes. 

 
3. Drag the buildings.cga rule file onto the selected shapes until they turn orange, then release the 

mouse button to assign the rule. 
 

4. Wait a moment for the buildings to generate, then you will see buildings from the future! 
 

 
 
 

Part 4: Alter Building Parameters 
 
Steps: 
 

1. Click the side of one building to select it. 
 

2. Optional: Click the Isolate button ( ) on the Viewport to show only this building. 
 

3. Open the Inspector window. 
 

 
 

4. You will see the attributes for the selected building. (Widen the window if necessary.) 
 

5. Alter the Building_Height attribute by sliding the button or by typing a new number, and the 
building will regenerate with the new height. 
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6. Now try altering any of the attributes to see how they affect the model. 
 

 
 
 

Part 5: Change the Random "Seed" 
 
These buildings have randomly determined attributes – we can re-seed this randomness. 
 
Steps: 
 

1. With one or more buildings selected, click the Update Seed and Generate Models button ( ). 
 

2. You will see the building regenerate with new random variations. 
 

 
 
Now you can see the power of procedural modeling. Combine this with real-world GIS data and you can 
create geo-typical city models very quickly. 
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Exercise 4: CityEngine Web Scenes 
 
A CityEngine Web Scene is a custom, web-optimized format. It can be 
viewed from CityEngine or it can be shared to ArcGIS Online. 
 
If there are specific locations in the scene that you would like a viewer 
to see, you can create bookmarks for these places. The viewer can go 
to the bookmarks individually, or can press a "Play" button which 
makes the scene move itself through the bookmarked locations. 
 
In this exercise you will create three bookmarks, create a web scene 
and then view it. 
 
 

Part 1: Create Bookmarks in CityEngine 
 
Find three places where you want to create bookmarks. 
 
Steps: 
 

1. Navigate to the first place that you want your web scene to show. 
 

2. On the Viewport window, click the Bookmarks ( ) menu button. 
 

3. On the New Bookmark dialog box, type a name for your bookmark, then click OK. 
 

 
 

4. Navigate to the next place for a bookmark, and create another one in the same manner. 
 

5. Create at least one more bookmark so that you have at least three; create more if you have time. 
 
 

Part 2: Create the Web Scene 
 
To create a web scene, you select features and export them to the CityEngine Web Scene format. 
 

1. Click Select > Select All. 
 

 
 

Dive-in: The Ctrl+A to the right means that you could alternatively press those two keys 
to select all the geometries currently in CityEngine. If you use CityEngine a lot you will 
probably want to learn its shortcuts. 

 

Complexity: 
Beginner 

Data Requirement: 
Installed with software 

Data Path: 
C:\3D_Workshop\ 

Goal: 
Learn the basics of creating a 
web scene and using ArcGIS 
Online 

Average length of time to complete: 
30 minutes 
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2. Click File > Export Models. 
 

3. In the Choose format for model export dialog box, choose CityEngine Web Scene, then click 
Next. 

 

 
 

4. In the CityEngine Web Scene dialog box, set the following parameters: 
 

Location: should be set to C:\3D_Workshop\CityEngine_Workspace\models 
 

Name: should be set to Redlands; add California 
 

Exported Content: use dropdown to choose Export generatable models 
 

Terrain Layers: should be set to Export all visible terrain layers 
 

 
 

5. Click Next. 
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6. Verify that you have the same layer settings as in the next graphic; if so, click Finish. 
 

 
 
Be patient while CityEngine generates the web scene. 
 
 

Part 2: View the Web Scene 
 
After the scene is generated, you can view it in a browser opened directly from CityEngine. You must be 
sure that your default browser supports WebGL. 
 

1. First you must click File > Refresh Workspace. 
 

2. Ensure that the default browser is Firefox. Open a Firefox browser and click Firefox > Options. 
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On the Options dialog box, go to the Advanced tab. Click the Make Firefox the default 
browser button, then OK to dismiss. 

 

 
 

Alternatively, you can use the Google Chrome browser. Click the Customize button ( ) and go to 
Settings. Click the button at the bottom of the page. 

 

 
 

3. Go to the Navigator window and expand the Redlands\models folder. 
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4. Right-click your Redlands California.3ws file, hover over Open With and choose 3D Web 
Scene Viewer (offline). 

 

 
 

5. When the web scene opens, experiment with it by turning off and on the different layers, going to 

the bookmarks ( ) and going to the Settings ( ) and other buttons on the toolbar at the top 
right column. 

 
 

Part 3: (Optional) Share the Web Scene to ArcGIS Online 
 
If you have an ArcGIS Online account, you can share the web scene and view it from there. 
 

1. In the Navigator window, right-click Redlands California.3ws and select Share As 
 

2. Ensure that you select Upload package to my ArcGIS Online account 
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3. Click the Item Description tab and enter a Summary, Tags, and Description. 
 

 
 

4. Click Share. The ArcGIS Online sign in dialog will appear (unless you are already signed in.) After 
you sign in, the upload will begin. 

 
5. When complete you will get a message; click OK. 
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6. Open a Firefox browser and log in to ArcGIS Online. Go to your web scene's Details page and 
click Open > View Application. 

 

 
 

7. When the web scene opens, notice the play button in the lower left corner. Click it to have 
CityEngine fly through the bookmarks you created for your web scene. 

 

 
 

8. Press the button again (which now looks like this: ) to stop flying. 
 
You have now completed the last exercise and can close CityEngine without saving. 
 
 


